Skip to content

Commit

Permalink
security/libgcrypt: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Apr 23, 2016
1 parent 1ee709f commit 6ea7e7e
Show file tree
Hide file tree
Showing 7 changed files with 296 additions and 100 deletions.
3 changes: 1 addition & 2 deletions security/libgcrypt/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $FreeBSD$

PORTNAME= libgcrypt
PORTVERSION= 1.6.5
PORTREVISION= 1
PORTVERSION= 1.7.0
CATEGORIES= security
MASTER_SITES= GNUPG

Expand Down
4 changes: 2 additions & 2 deletions security/libgcrypt/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (libgcrypt-1.6.5.tar.bz2) = f49ebc5842d455ae7019def33eb5a014a0f07a2a8353dc3aa50a76fd1dafa924
SIZE (libgcrypt-1.6.5.tar.bz2) = 2549601
SHA256 (libgcrypt-1.7.0.tar.bz2) = b0e67ea74474939913c4d9d9ef4ef5ec378efbe2bebe36389dee319c79bffa92
SIZE (libgcrypt-1.7.0.tar.bz2) = 2840453
279 changes: 279 additions & 0 deletions security/libgcrypt/files/patch-cipher_crc-intel-pclmul.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,279 @@
--- cipher/crc-intel-pclmul.c.orig 2016-04-07 15:30:08 UTC
+++ cipher/crc-intel-pclmul.c
@@ -143,7 +143,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
[inbuf_2] "m" (inbuf[2 * 16]),
[inbuf_3] "m" (inbuf[3 * 16]),
[crc] "m" (*pcrc)
- : );
+ );

inbuf += 4 * 16;
inlen -= 4 * 16;
@@ -151,7 +151,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
asm volatile ("movdqa %[k1k2], %%xmm4\n\t"
:
: [k1k2] "m" (consts->k[1 - 1])
- : );
+ );

/* Fold by 4. */
while (inlen >= 4 * 16)
@@ -188,7 +188,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
[inbuf_1] "m" (inbuf[1 * 16]),
[inbuf_2] "m" (inbuf[2 * 16]),
[inbuf_3] "m" (inbuf[3 * 16])
- : );
+ );

inbuf += 4 * 16;
inlen -= 4 * 16;
@@ -199,7 +199,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
:
: [k3k4] "m" (consts->k[3 - 1]),
[my_p] "m" (consts->my_p[0])
- : );
+ );

/* Fold 4 to 1. */

@@ -222,7 +222,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
"pxor %%xmm4, %%xmm0\n\t"
:
:
- : );
+ );
}
else
{
@@ -236,7 +236,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
[crc] "m" (*pcrc),
[k3k4] "m" (consts->k[3 - 1]),
[my_p] "m" (consts->my_p[0])
- : );
+ );

inbuf += 16;
inlen -= 16;
@@ -256,7 +256,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
"pxor %%xmm1, %%xmm0\n\t"
:
: [inbuf] "m" (*inbuf)
- : );
+ );

inbuf += 16;
inlen -= 16;
@@ -288,7 +288,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
[mask] "m" (crc32_partial_fold_input_mask[inlen]),
[shl_shuf] "m" (crc32_refl_shuf_shift[inlen]),
[shr_shuf] "m" (crc32_refl_shuf_shift[inlen + 16])
- : );
+ );

inbuf += inlen;
inlen -= inlen;
@@ -318,7 +318,7 @@ crc32_reflected_bulk (u32 *pcrc, const b
"pextrd $2, %%xmm0, %[out]\n\t"
: [out] "=m" (*pcrc)
: [k5] "m" (consts->k[5 - 1])
- : );
+ );
}

static inline void
@@ -333,7 +333,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
asm volatile ("movdqa %[my_p], %%xmm5\n\t"
:
: [my_p] "m" (consts->my_p[0])
- : );
+ );

if (inlen == 1)
{
@@ -372,7 +372,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
: [out] "=m" (*pcrc)
: [in] "rm" (data),
[crc] "rm" (crc)
- : );
+ );
}
else if (inlen == 4)
{
@@ -391,7 +391,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
: [in] "m" (*inbuf),
[crc] "m" (*pcrc),
[my_p] "m" (consts->my_p[0])
- : );
+ );
}
else
{
@@ -404,14 +404,14 @@ crc32_reflected_less_than_16 (u32 *pcrc,
[crc] "m" (*pcrc),
[my_p] "m" (consts->my_p[0]),
[k3k4] "m" (consts->k[3 - 1])
- : );
+ );

if (inlen >= 8)
{
asm volatile ("movq %[inbuf], %%xmm0\n\t"
:
: [inbuf] "m" (*inbuf)
- : );
+ );
if (inlen > 8)
{
asm volatile (/*"pinsrq $1, %[inbuf_tail], %%xmm0\n\t"*/
@@ -422,7 +422,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
: [inbuf_tail] "m" (inbuf[inlen - 8]),
[merge_shuf] "m"
(*crc32_merge9to15_shuf[inlen - 9])
- : );
+ );
}
}
else
@@ -435,7 +435,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
[inbuf_tail] "m" (inbuf[inlen - 4]),
[merge_shuf] "m"
(*crc32_merge5to7_shuf[inlen - 5])
- : );
+ );
}

/* Final fold. */
@@ -465,7 +465,7 @@ crc32_reflected_less_than_16 (u32 *pcrc,
"pextrd $2, %%xmm0, %[out]\n\t"
: [out] "=m" (*pcrc)
: [k5] "m" (consts->k[5 - 1])
- : );
+ );
}
}

@@ -477,7 +477,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
asm volatile ("movdqa %[bswap], %%xmm7\n\t"
:
: [bswap] "m" (*crc32_bswap_shuf)
- : );
+ );

if (inlen >= 8 * 16)
{
@@ -497,7 +497,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
[inbuf_2] "m" (inbuf[2 * 16]),
[inbuf_3] "m" (inbuf[3 * 16]),
[crc] "m" (*pcrc)
- : );
+ );

inbuf += 4 * 16;
inlen -= 4 * 16;
@@ -505,7 +505,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
asm volatile ("movdqa %[k1k2], %%xmm4\n\t"
:
: [k1k2] "m" (consts->k[1 - 1])
- : );
+ );

/* Fold by 4. */
while (inlen >= 4 * 16)
@@ -546,7 +546,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
[inbuf_1] "m" (inbuf[1 * 16]),
[inbuf_2] "m" (inbuf[2 * 16]),
[inbuf_3] "m" (inbuf[3 * 16])
- : );
+ );

inbuf += 4 * 16;
inlen -= 4 * 16;
@@ -557,7 +557,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
:
: [k3k4] "m" (consts->k[3 - 1]),
[my_p] "m" (consts->my_p[0])
- : );
+ );

/* Fold 4 to 1. */

@@ -580,7 +580,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
"pxor %%xmm4, %%xmm0\n\t"
:
:
- : );
+ );
}
else
{
@@ -595,7 +595,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
[crc] "m" (*pcrc),
[k3k4] "m" (consts->k[3 - 1]),
[my_p] "m" (consts->my_p[0])
- : );
+ );

inbuf += 16;
inlen -= 16;
@@ -616,7 +616,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
"pxor %%xmm1, %%xmm0\n\t"
:
: [inbuf] "m" (*inbuf)
- : );
+ );

inbuf += 16;
inlen -= 16;
@@ -650,7 +650,7 @@ crc32_bulk (u32 *pcrc, const byte *inbuf
[mask] "m" (crc32_partial_fold_input_mask[inlen]),
[shl_shuf] "m" (crc32_refl_shuf_shift[32 - inlen]),
[shr_shuf] "m" (crc32_shuf_shift[inlen + 16])
- : );
+ );

inbuf += inlen;
inlen -= inlen;
@@ -697,7 +697,7 @@ crc32_less_than_16 (u32 *pcrc, const byt
asm volatile ("movdqa %[my_p], %%xmm5\n\t"
:
: [my_p] "m" (consts->my_p[0])
- : );
+ );

if (inlen == 1)
{
@@ -774,14 +774,14 @@ crc32_less_than_16 (u32 *pcrc, const byt
[crc] "m" (*pcrc),
[my_p] "m" (consts->my_p[0]),
[k3k4] "m" (consts->k[3 - 1])
- : );
+ );

if (inlen >= 8)
{
asm volatile ("movq %[inbuf], %%xmm0\n\t"
:
: [inbuf] "m" (*inbuf)
- : );
+ );
if (inlen > 8)
{
asm volatile (/*"pinsrq $1, %[inbuf_tail], %%xmm0\n\t"*/
@@ -792,7 +792,7 @@ crc32_less_than_16 (u32 *pcrc, const byt
: [inbuf_tail] "m" (inbuf[inlen - 8]),
[merge_shuf] "m"
(*crc32_merge9to15_shuf[inlen - 9])
- : );
+ );
}
}
else
@@ -805,7 +805,7 @@ crc32_less_than_16 (u32 *pcrc, const byt
[inbuf_tail] "m" (inbuf[inlen - 4]),
[merge_shuf] "m"
(*crc32_merge5to7_shuf[inlen - 5])
- : );
+ );
}

/* Final fold. */
62 changes: 0 additions & 62 deletions security/libgcrypt/files/patch-cipher_salsa20.c

This file was deleted.

26 changes: 13 additions & 13 deletions security/libgcrypt/files/patch-mpi_longlong.h
Original file line number Diff line number Diff line change
@@ -1,27 +1,27 @@
--- mpi/longlong.h.orig 2016-03-23 17:33:08 UTC
--- mpi/longlong.h.orig 2016-04-18 19:16:10 UTC
+++ mpi/longlong.h
@@ -170,6 +170,7 @@ MA 02111-1307, USA. */
@@ -174,6 +174,7 @@ MA 02111-1307, USA. */
(pl) = __m0 * __m1; \
} while (0)
#define UMUL_TIME 46
+#if 0
#ifndef LONGLONG_STANDALONE
#define udiv_qrnnd(q, r, n1, n0, d) \
# define UMUL_TIME 46
+# if 0
# ifndef LONGLONG_STANDALONE
# define udiv_qrnnd(q, r, n1, n0, d) \
do { UDItype __r; \
@@ -179,6 +180,7 @@ MA 02111-1307, USA. */
@@ -183,6 +184,7 @@ MA 02111-1307, USA. */
extern UDItype __udiv_qrnnd ();
#define UDIV_TIME 220
#endif /* LONGLONG_STANDALONE */
+#endif /* 0 */
# define UDIV_TIME 220
# endif /* !LONGLONG_STANDALONE */
+# endif /* 0 */
#endif /* __alpha */

/***************************************
@@ -1287,7 +1289,7 @@ typedef unsigned int UTItype __attribute
@@ -1293,7 +1295,7 @@ typedef unsigned int UTItype __attribute
"rJ" ((USItype)(al)), \
"rI" ((USItype)(bl)) \
__CLOBBER_CC)
-#if defined (__sparc_v8__) || defined(__sparcv8)
+#if defined (__sparc_v8__) || defined(__sparcv8) || defined (__sparc__)
-# if defined (__sparc_v8__)
+# if defined (__sparc_v8__) || defined (__sparc__)
/* Don't match immediate range because, 1) it is not often useful,
2) the 'I' flag thinks of the range as a 13 bit signed interval,
while we want to match a 13 bit interval, sign extended to 32 bits,
Loading

0 comments on commit 6ea7e7e

Please sign in to comment.