Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Jun 3, 2015
1 parent 627cbf9 commit 75ca77b
Show file tree
Hide file tree
Showing 262 changed files with 4,408 additions and 11,353 deletions.
1 change: 1 addition & 0 deletions audio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -51,6 +51,7 @@
SUBDIR += baudline
SUBDIR += bcg729
SUBDIR += beast
SUBDIR += beep
SUBDIR += beets
SUBDIR += blop
SUBDIR += boodler
Expand Down
24 changes: 24 additions & 0 deletions audio/beep/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,24 @@
# Created by: Tyler Spivey
# $FreeBSD$

PORTNAME= beep
PORTVERSION= 1.0
CATEGORIES= audio
MASTER_SITES= LOCAL/garga/${PORTNAME}

MAINTAINER= [email protected]
COMMENT= Beeps a certain duration and pitch out of the PC Speaker

LICENSE= BSD4CLAUSE

WRKSRC= ${WRKDIR}/${PORTNAME}

ONLY_FOR_ARCHS= i386 amd64 pc98

PLIST_FILES= bin/beep man/man1/beep.1.gz

post-patch:
${REINPLACE_CMD} 's|machine/speaker\.h|dev/speaker/speaker.h|' \
${WRKSRC}/beep.c

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions audio/beep/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (beep-1.0.tar.gz) = c25d2044d37adad08076d9d87543331650defaaaf1e13a144d4597d9c86ec80c
SIZE (beep-1.0.tar.gz) = 3537
2 changes: 2 additions & 0 deletions audio/beep/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
This program will beep, using a
duration and pitch specified on the command line or the program's defaults.
2 changes: 2 additions & 0 deletions audio/slv2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@

PORTNAME= slv2
PORTVERSION= 0.6.6
PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= http://download.drobilla.net/

Expand Down Expand Up @@ -34,6 +35,7 @@ post-patch:
's|^#define _XOPEN_SOURCE .*||' ${WRKSRC}/src/plugin.c

post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libslv2.so
.for file in lv2_inspect lv2_jack_host lv2_list lv2_simple_jack_host
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${file}
.endfor
Expand Down
3 changes: 2 additions & 1 deletion audio/streamtuner/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= streamtuner
PORTVERSION= 0.99.99
PORTREVISION= 20
PORTREVISION= 21
CATEGORIES= audio www
MASTER_SITES= SAVANNAH

Expand All @@ -20,6 +20,7 @@ INSTALLS_OMF= yes
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip

OPTIONS_DEFINE= SHOUTCAST LIVE365 XIPH LOCAL LOCAL_METADATA PYTHON
OPTIONS_DEFAULT= SHOUTCAST LIVE365 XIPH LOCAL LOCAL_METADATA
Expand Down
2 changes: 1 addition & 1 deletion benchmarks/wrk/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= wrk
PORTVERSION= 4.0.1
PORTREVISION= 2
PORTREVISION= 3
CATEGORIES= benchmarks www
DISTNAME= ${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
Expand Down
4 changes: 2 additions & 2 deletions benchmarks/wrk/files/patch-Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- Makefile.orig 2015-03-24 13:03:52.000000000 +0300
+++ Makefile 2015-05-31 22:58:26.276469000 +0300
+++ Makefile 2015-06-02 22:37:10.831330000 +0300
@@ -1,5 +1,5 @@
-CFLAGS := -std=c99 -Wall -O2 -D_REENTRANT
-LIBS := -lpthread -lm -lcrypto -lssl
Expand Down Expand Up @@ -38,7 +38,7 @@
$(ODIR)/bytecode.o: src/wrk.lua
@echo LUAJIT $<
- @$(SHELL) -c 'cd $(LDIR) && ./luajit -b $(CURDIR)/$< $(CURDIR)/$@'
+ $(SHELL) -c 'cd $(LDIR) && ${PREFIX}/bin/luajit -b $(CURDIR)/$< $(CURDIR)/$@'
+ $(SHELL) -c '${PREFIX}/bin/luajit -b $(CURDIR)/$< $(CURDIR)/$@'

$(ODIR)/%.o : %.c
@echo CC $<
Expand Down
6 changes: 3 additions & 3 deletions cad/ghdl/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,6 +3,7 @@

PORTNAME= ghdl
PORTVERSION= 0.32
PORTREVISION= 1
CATEGORIES= cad
DISTFILES= ${SRCDISTFILE} ${GCCDISTFILE}

Expand All @@ -20,7 +21,7 @@ USES= ada gmake
USE_GITHUB= yes
GH_ACCOUNT= hanzer
GH_PROJECT= GHDL
GH_TAGNAME= a88ac1c
GH_TAGNAME= 47ee186

GNU_CONFIGURE= yes
GCCVER= 4.9.2
Expand Down Expand Up @@ -93,7 +94,7 @@ EXTRA_CONFIG+= --with-as=${AS_COMMAND}

.if ${PORT_OPTIONS:MGCC}
GCCDISTFILE= gcc-${GCCVER}.tar.bz2
USES+= iconv libtool perl5
USES+= iconv libtool makeinfo perl5
USE_PERL5= build
INFO= ghdl
PLIST_SUB+= GLEX=ghdl/libexec/gcc/${BLD_TARGET}/${GCCVER} \
Expand All @@ -110,7 +111,6 @@ BUILD_DEPENDS+= llvm-config${LLVMVER}:${PORTSDIR}/devel/llvm${LLVMVER} \
RUN_DEPENDS+= llc${LLVMVER}:${PORTSDIR}/devel/llvm${LLVMVER}
PLIST= ${.CURDIR}/llvm-plist
PLIST_SUB+= GLIB=ghdl/lib/ghdl/
MAKE_JOBS_UNSAFE= yes
.endif

post-patch:
Expand Down
4 changes: 2 additions & 2 deletions cad/ghdl/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
SHA256 (hanzer-GHDL-0.32-a88ac1c_GH0.tar.gz) = 8f2d7f953ee6e0a34ec1f51308ce2fa694ce6776a3154184591ebe690d45eed9
SIZE (hanzer-GHDL-0.32-a88ac1c_GH0.tar.gz) = 3081221
SHA256 (hanzer-GHDL-0.32-47ee186_GH0.tar.gz) = e552f340223ad7cd9680d91bd8caff611950382364f5eb098de0a65d58ea6911
SIZE (hanzer-GHDL-0.32-47ee186_GH0.tar.gz) = 3081814
SHA256 (gcc-4.9.2.tar.bz2) = 2020c98295856aa13fda0f2f3a4794490757fc24bcca918d52cc8b4917b972dd
SIZE (gcc-4.9.2.tar.bz2) = 89939747
14 changes: 14 additions & 0 deletions cad/ghdl/files/patch-src_grt_Makefile.inc
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
--- src/grt/Makefile.inc.orig 2015-06-01 05:56:40 UTC
+++ src/grt/Makefile.inc
@@ -71,6 +71,11 @@ ifeq ($(filter-out x86_64 freebsd%,$(arc
GRT_EXTRA_LIB=-lm $(GRT_ELF_OPTS)
ADAC=ada
endif
+ifeq ($(filter-out x86_64 dragonfly%,$(arch) $(osys)),)
+ GRT_TARGET_OBJS=amd64.o linux.o times.o
+ GRT_EXTRA_LIB=-lm $(GRT_ELF_OPTS)
+ ADAC=ada
+endif
ifeq ($(filter-out i%86 darwin%,$(arch) $(osys)),)
GRT_TARGET_OBJS=i386.o linux.o times.o
GRT_EXTRA_LIB=
4 changes: 2 additions & 2 deletions converters/p5-Net-IDN-Nameprep/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,7 @@
# $FreeBSD$

PORTNAME= Net-IDN-Nameprep
PORTVERSION= 1.101
PORTREVISION= 1
PORTVERSION= 1.102
CATEGORIES= converters perl5
MASTER_SITES= CPAN
PKGNAMEPREFIX= p5-
Expand All @@ -17,5 +16,6 @@ BUILD_DEPENDS:= ${RUN_DEPENDS} \

USES= perl5
USE_PERL5= modbuild
NO_ARCH= yes

.include <bsd.port.mk>
4 changes: 2 additions & 2 deletions converters/p5-Net-IDN-Nameprep/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (Net-IDN-Nameprep-1.101.tar.gz) = 2861058143a8b26fb06b691ad289e3c6a0b0ae093f32769089f2a7c5fae4d4f8
SIZE (Net-IDN-Nameprep-1.101.tar.gz) = 15063
SHA256 (Net-IDN-Nameprep-1.102.tar.gz) = c4a21dc1ca8a35a612415eb8027d9407142f2b27b5fa9e67917a88f388947726
SIZE (Net-IDN-Nameprep-1.102.tar.gz) = 15379
2 changes: 2 additions & 0 deletions databases/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -408,6 +408,8 @@
SUBDIR += p5-Exception-Class-DBI
SUBDIR += p5-GDBM
SUBDIR += p5-Genezzo
SUBDIR += p5-GitDDL
SUBDIR += p5-GitDDL-Migrator
SUBDIR += p5-GraphViz-DBI
SUBDIR += p5-HTML-FormHandler-Model-DBIC
SUBDIR += p5-Ima-DBI
Expand Down
2 changes: 1 addition & 1 deletion databases/freetds/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ LICENSE= GPLv2

LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt

PORTSCOUT= skipv:0.92.48,0.92.49,0.92,51,0.92.52,0.92.53,0.92.54,0.92.55,0.92.59,0.92.63,0.92.79,0.92.405
PORTSCOUT= skipv:0.92.48,0.92.49,0.92.51,0.92.52,0.92.53,0.92.54,0.92.55,0.92.59,0.92.63,0.92.79,0.92.405
TDS_VER?= 5.0

USES= autoreconf iconv gmake pkgconfig libtool:keepla tar:bzip2
Expand Down
26 changes: 26 additions & 0 deletions databases/p5-GitDDL-Migrator/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,26 @@
# $FreeBSD$

PORTNAME= GitDDL-Migrator
PORTVERSION= 0.07
CATEGORIES= databases perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:SONGMU
PKGNAMEPREFIX= p5-

MAINTAINER= [email protected]
COMMENT= Perl extension to extended p5-GitDDL

LICENSE= ART10 GPLv1
LICENSE_COMB= dual

RUN_DEPENDS= \
p5-GitDDL>=0.03:${PORTSDIR}/databases/p5-GitDDL \
p5-Mouse>0:${PORTSDIR}/devel/p5-Mouse \
p5-SQL-Translator>0:${PORTSDIR}/databases/p5-SQL-Translator
BUILD_DEPENDS= ${RUN_DEPENDS}

USES= perl5
USE_PERL5= modbuild
NO_ARCH= YES

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions databases/p5-GitDDL-Migrator/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (GitDDL-Migrator-0.07.tar.gz) = b78ed88c042f1fa6a1221ad8393c1cef4ef88c27fcb10d6b81429703a4adf8ff
SIZE (GitDDL-Migrator-0.07.tar.gz) = 13631
11 changes: 11 additions & 0 deletions databases/p5-GitDDL-Migrator/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
GitDDL::Migrator is database migration utility extended GitDDL.

Extended features are:

- save migration history
- rollback to previous version
- specify version
- specify SQL (sometimes SQL::Translator's output is wrong)
- check differences from versioned SQL and real database

WWW: http://search.cpan.org/dist/GitDDL-Migrator/
2 changes: 2 additions & 0 deletions databases/p5-GitDDL-Migrator/pkg-plist
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
%%PERL5_MAN3%%/GitDDL::Migrator.3.gz
%%SITE_PERL%%/GitDDL/Migrator.pm
27 changes: 27 additions & 0 deletions databases/p5-GitDDL/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
# $FreeBSD$

PORTNAME= GitDDL
PORTVERSION= 0.03
CATEGORIES= databases perl5
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= CPAN:TYPESTER
PKGNAMEPREFIX= p5-

MAINTAINER= [email protected]
COMMENT= Perl extension for database migration utility by git managed sql

LICENSE= ART10 GPLv1
LICENSE_COMB= dual

RUN_DEPENDS= \
p5-DBI>0:${PORTSDIR}/databases/p5-DBI \
p5-Git-Repository>0:${PORTSDIR}/devel/p5-Git-Repository \
p5-Mouse>0:${PORTSDIR}/devel/p5-Mouse \
p5-SQL-Translator>=0.11016:${PORTSDIR}/databases/p5-SQL-Translator
BUILD_DEPENDS= ${RUN_DEPENDS}

USES= perl5
USE_PERL5= configure
NO_ARCH= YES

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions databases/p5-GitDDL/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (GitDDL-0.03.tar.gz) = 0dc3f088f06a0259b4ec866f44b050ea7315649a4af5e0901f0d53238f13949a
SIZE (GitDDL-0.03.tar.gz) = 32182
8 changes: 8 additions & 0 deletions databases/p5-GitDDL/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
This is database migration helper module for users who manage database
schema version by single .sql file in git repository.

By using this module, you can deploy .sql to database, check sql
version between database and .sql file, make diff between them, and
apply alter table to database.

WWW: http://search.cpan.org/dist/GitDDL/
2 changes: 2 additions & 0 deletions databases/p5-GitDDL/pkg-plist
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
%%PERL5_MAN3%%/GitDDL.3.gz
%%SITE_PERL%%/GitDDL.pm
2 changes: 1 addition & 1 deletion databases/pgadmin3/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@ LICENSE= PostgreSQL
BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx

IGNORE_WITH_PGSQL= 8.2 8.3 8.4
USES= gettext gmake #pgsql:9.0+
USES= gettext gmake pgsql #:9.0+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-wx-version=${USE_WX} --enable-databasedesigner
USE_GNOME= libxml2 libxslt
Expand Down
2 changes: 1 addition & 1 deletion databases/postgresql_autodoc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ DIST_SUBDIR= postgresql
MAINTAINER= [email protected]
COMMENT= Automatic documentation generator for postgresql databases

BUILD_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
RUN_DEPENDS= p5-HTML-Template>=0:${PORTSDIR}/www/p5-HTML-Template \
p5-Term-ReadKey>=0:${PORTSDIR}/devel/p5-Term-ReadKey \
p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg

Expand Down
6 changes: 5 additions & 1 deletion databases/tokyotyrant/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= tokyotyrant
PORTVERSION= 1.1.41
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= databases
MASTER_SITES= http://fallabs.com/${PORTNAME}/

Expand Down Expand Up @@ -36,4 +36,8 @@ post-patch:
${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's|llua|llua-${LUA_VER}|g' ${WRKSRC}/configure

post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/*.so

.include <bsd.port.mk>
8 changes: 7 additions & 1 deletion devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -411,12 +411,15 @@
SUBDIR += eric4
SUBDIR += eric6
SUBDIR += eris
SUBDIR += erlang-gen_leader
SUBDIR += erlang-gen_smtp
SUBDIR += erlang-getopt
SUBDIR += erlang-gproc
SUBDIR += erlang-ibrowse
SUBDIR += erlang-msgpack
SUBDIR += erlang-mustache
SUBDIR += erlang-protobuffs
SUBDIR += erlang-recon
SUBDIR += erlang-syslog
SUBDIR += esdl
SUBDIR += etcd
Expand Down Expand Up @@ -3737,7 +3740,6 @@
SUBDIR += py-Products.validation
SUBDIR += py-RPyC
SUBDIR += py-Record
SUBDIR += py-ScriptTest
SUBDIR += py-SymbolType
SUBDIR += py-TGScheduler
SUBDIR += py-ToscaWidgets
Expand Down Expand Up @@ -3864,6 +3866,7 @@
SUBDIR += py-foolscap
SUBDIR += py-fortran
SUBDIR += py-freebsd
SUBDIR += py-freezegun
SUBDIR += py-fs
SUBDIR += py-fsm
SUBDIR += py-fudge
Expand Down Expand Up @@ -4004,6 +4007,7 @@
SUBDIR += py-posix_ipc
SUBDIR += py-pp
SUBDIR += py-pqueue
SUBDIR += py-pretend
SUBDIR += py-prettytable
SUBDIR += py-prioritized_methods
SUBDIR += py-prompt_toolkit
Expand Down Expand Up @@ -4038,6 +4042,7 @@
SUBDIR += py-pyshapelib
SUBDIR += py-pytemplate
SUBDIR += py-pytest
SUBDIR += py-pytest-capturelog
SUBDIR += py-pytest-runner
SUBDIR += py-pytest-timeout
SUBDIR += py-python-jenkins
Expand Down Expand Up @@ -4087,6 +4092,7 @@
SUBDIR += py-rtree
SUBDIR += py-ruledispatch
SUBDIR += py-sanetime
SUBDIR += py-scripttest
SUBDIR += py-sdl2
SUBDIR += py-serpent
SUBDIR += py-setproctitle
Expand Down
2 changes: 1 addition & 1 deletion devel/coccinelle/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -6,7 +6,7 @@ DISTVERSION= 1.0.0-rc22
CATEGORIES= devel
MASTER_SITES= http://coccinelle.lip6.fr/distrib/

MAINTAINER= [email protected]
MAINTAINER= [email protected]
COMMENT= Program matching and transformation engine

LICENSE= GPLv2
Expand Down
Loading

0 comments on commit 75ca77b

Please sign in to comment.