Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Oct 8, 2016
1 parent 1c2735f commit 7c0780c
Show file tree
Hide file tree
Showing 128 changed files with 592 additions and 312 deletions.
42 changes: 21 additions & 21 deletions audio/gbsplay/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,42 +2,45 @@
# $FreeBSD$

PORTNAME= gbsplay
PORTVERSION= 0.0.8
PORTREVISION= 7
PORTVERSION= 0.0.93
CATEGORIES= audio
MASTER_SITES= LOCAL/ehaupt
PKGNAMEPREFIX?=

MAINTAINER= [email protected]
COMMENT?= Emulates the sound hardware of the Nintendo Game Boy(TM)
COMMENT= Emulates the sound hardware of the Nintendo Game Boy(TM)

LICENSE= GPLv2

USE_GITHUB= yes
GH_ACCOUNT= mmitch

HAS_CONFIGURE= yes
USES= gettext gmake
USES= gmake compiler:gcc-c++11-lib
USE_CSTD= gnu89

CONFIGURE_ARGS+= --prefix=${PREFIX}

.if ${PKGNAMEPREFIX} == ""

CONFIGURE_ARGS+= --without-xmmsplugin

MANPAGE1= gbsplay.1 gbsinfo.1
MANPAGE5= gbsplayrc.5
PORTDOCS= COPYRIGHT HISTORY README

OPTIONS_DEFINE= NAS DOCS

.endif

.if ${PKGNAMEPREFIX} == ""
OPTIONS_DEFINE= DOCS NAS NLS
OPTIONS_SUB= yes

NAS_LIB_DEPENDS= libaudio.so:audio/nas
NAS_CONFIGURE_ENABLE= nas
NLS_CONFIGURE_OFF= --disable-i18n
NLS_USES= gettext
NLS_LDFLAGS= -lintl

.endif
.include <bsd.port.options.mk>

post-patch: gbsplay-post-patch
@${REINPLACE_CMD} -e 's|^\(default.*\)test|\1|' ${WRKSRC}/${MAKEFILE}
post-patch:
@${REINPLACE_CMD} \
-e 's|^\(default.*\)test|\1|' \
-e 's#md5sum | cut -f1 -d..#md5 -q#' \
${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e \
'/^need_include\ /d; \
468s|char argc|int argc|; \
Expand All @@ -50,10 +53,6 @@ post-patch: gbsplay-post-patch
s|-Os||; s|-pipe||; s|-fomit-frame-pointer||; \
s|-march=$$ARCH||' \
${WRKSRC}/configure

.if ${PKGNAMEPREFIX} == ""

gbsplay-post-patch:
@${REINPLACE_CMD} -e 's|/\(etc/gbsplayrc\)|${PREFIX}/\1|' \
${WRKSRC}/gbsplay.c \
${WRKSRC}/gbsplay.in.1 \
Expand All @@ -79,14 +78,15 @@ do-install:
${STAGEDIR}${PREFIX}/etc/gbsplayrc
.endif

.if ${PORT_OPTIONS:MNLS}
.for l in de en
${INSTALL_DATA} ${WRKSRC}/po/${l}.mo \
${STAGEDIR}${PREFIX}/share/locale/${l}/LC_MESSAGES/gbsplay.mo
.endfor
.endif
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for f in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${f} ${STAGEDIR}${DOCSDIR}
.endfor
.endif

.include <bsd.port.mk>
5 changes: 3 additions & 2 deletions audio/gbsplay/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
SHA256 (gbsplay-0.0.8.tar.gz) = 9bd95118741315e991dfe4f5108128817725c924ba81bb4938de45290e8f0926
SIZE (gbsplay-0.0.8.tar.gz) = 57033
TIMESTAMP = 1475758315
SHA256 (mmitch-gbsplay-0.0.93_GH0.tar.gz) = 49a4545b51b91d3c01100b7f99d7c00f981f60d2bade7389255076078deef4ef
SIZE (mmitch-gbsplay-0.0.93_GH0.tar.gz) = 66683
2 changes: 1 addition & 1 deletion audio/gbsplay/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,4 @@ gbsplay emulates the sound hardware of the Nintendo Game Boy(TM). It is able
to play the sounds from a Game Boy(TM) module dump (.GBS format) through
/dev/dsp, standard output or NAS.

WWW: http://gbsplay.berlios.de/
WWW: https://github.com/mmitch/gbsplay
4 changes: 2 additions & 2 deletions audio/gbsplay/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
bin/gbsplay
bin/gbsinfo
@sample etc/gbsplayrc.sample
share/locale/de/LC_MESSAGES/gbsplay.mo
share/locale/en/LC_MESSAGES/gbsplay.mo
%%NLS%%share/locale/de/LC_MESSAGES/gbsplay.mo
%%NLS%%share/locale/en/LC_MESSAGES/gbsplay.mo
man/man1/gbsinfo.1.gz
man/man1/gbsplay.1.gz
man/man5/gbsplayrc.5.gz
Expand Down
39 changes: 31 additions & 8 deletions audio/xmms-gbsplay/Makefile
Original file line number Diff line number Diff line change
@@ -1,30 +1,40 @@
# Created by: Emanuel Haupt <[email protected]>
# $FreeBSD$

PORTNAME= gbsplay
PORTVERSION= 0.0.8
PORTREVISION= 8
CATEGORIES= audio
MASTER_SITES= LOCAL/ehaupt
PKGNAMEPREFIX= xmms-

MAINTAINER= [email protected]
COMMENT= XMMS plugin for playing Nintendo Game Boy(TM) audio

MASTERDIR= ${.CURDIR}/../gbsplay
LICENSE= GPLv2

BUILD_DEPENDS= xmms:multimedia/xmms
RUN_DEPENDS= xmms:multimedia/xmms \
gbsplay:audio/gbsplay
RUN_DEPENDS= xmms:multimedia/xmms

USE_GNOME= glib12
USE_GCC= any
HAS_CONFIGURE= yes
USES= gmake
USE_CSTD= gnu89

CONFIGURE_ARGS= --disable-nas
OPTIONS_DEFINE= NLS

DESCR= ${.CURDIR}/pkg-descr
PLIST= ${.CURDIR}/pkg-plist
NLS_CONFIGURE_OFF= --disable-i18n
NLS_USES= gettext-runtime

CONFIGURE_ARGS= --disable-nas --prefix=${PREFIX}

PLIST_FILES= lib/xmms/Input/gbsxmms.so

post-extract:
@${RM} -f ${WRKSRC}/po/subdir.mk

gbsplay-post-patch:
post-patch:
@${REINPLACE_CMD} -e \
's|`which xmms-config`||; \
s|\(xmms-config\)|${LOCALBASE}/bin/\1|g; \
Expand All @@ -36,10 +46,23 @@ gbsplay-post-patch:
's|^objs += $$(objs_gbsplay) $$(objs_gbsinfo)||; \
s|^dsts += gbsplay gbsinfo||; \
/^default:/ s|$$(mans)||' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e 's|^\(default.*\)test|\1|' ${WRKSRC}/${MAKEFILE}
@${REINPLACE_CMD} -e \
'/^need_include\ /d; \
468s|char argc|int argc|; \
s|/usr/local/include|${LOCALBASE}/include|; \
s|/usr/local/lib|${LOCALBASE}/lib|; \
s|/usr/X11R6/include||; \
s|/usr/X11R6/lib||; \
s|/usr/X11/lib|${LOCALBASE}/lib|; \
s|/usr/lib/X11|${LOCALBASE}/lib/X11|; \
s|-Os||; s|-pipe||; s|-fomit-frame-pointer||; \
s|-march=$$ARCH||' \
${WRKSRC}/configure

do-install:
@${MKDIR} ${STAGEDIR}${PREFIX}/lib/xmms/Input
${INSTALL_PROGRAM} ${WRKSRC}/gbsxmms.so \
${STAGEDIR}${PREFIX}/lib/xmms/Input

.include "${MASTERDIR}/Makefile"
.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions audio/xmms-gbsplay/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1475768149
SHA256 (gbsplay-0.0.8.tar.gz) = 9bd95118741315e991dfe4f5108128817725c924ba81bb4938de45290e8f0926
SIZE (gbsplay-0.0.8.tar.gz) = 57033
2 changes: 1 addition & 1 deletion audio/xmms-gbsplay/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,4 @@ xmms-gbsplay is a XMMS input plugin which emulates the sound hardware of the
Nintendo Game Boy(TM). It is able to play the sounds from a Game Boy(TM)
module dump (.GBS format) in XMMS.

WWW: http://gbsplay.berlios.de/
WWW: https://www.cgarbs.de/gbsplay.en.html
27 changes: 14 additions & 13 deletions databases/db5/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -15,11 +15,15 @@ DIST_SUBDIR= bdb
MAINTAINER= [email protected]
COMMENT= Oracle Berkeley DB, revision ${BDBVER}

LICENSE_NAME= Sleepycat
LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
LICENSE_FILE= ${WRKSRC}/../LICENSE
LICENSE_GROUPS= FSF GPL OSI

BDBVER= ${PORTVERSION:R}
BDBMAJ= ${BDBVER:R}
CONFIGURE_ARGS= --enable-cxx --enable-stl \
--enable-compat185 --enable-dump185 \
--disable-tcl \
--includedir=${PREFIX}/include/${PORTNAME} \
--libdir=${PREFIX}/lib/${PORTNAME} \
--bindir=${PREFIX}/bin/${PORTNAME}
Expand All @@ -34,11 +38,7 @@ PLIST_SUB= BDBMAJ=${BDBMAJ} BDBVER=${BDBVER}
MAKE_ARGS+= docdir=${DOCSDIR}
CFLAGS+= -Wall -Wextra

OPTIONS_DEFINE= CRYPTO L10N SQL JAVA DOCS TCL
# WARNING: DO NOT ADD TCL TO OPTIONS:
# On FreeBSD 10.3 this causes a heap of warnings of the following kind
# and is deemed unsafe.
# ./lang/tcl/tcl_*.c:*:*: warning: the value of the size argument in 'strncat' is too large, might lead to a buffer overflow [-Wstrncat-size]
OPTIONS_DEFINE= CRYPTO L10N SQL JAVA TCL DOCS
OPTIONS_DEFAULT=CRYPTO
OPTIONS_SUB= yes
CRYPTO_DESC= Cryptography support
Expand Down Expand Up @@ -91,23 +91,24 @@ post-install:
cd ${STAGEDIR}${PREFIX}/bin/${PORTNAME}; \
for i in *; do ${LN} -s -f ${PORTNAME}/$$i ../$$i-${BDBVER} ; \
${LN} -s -f ${PORTNAME}/$$i ../$$i-${BDBMAJ} ; done
.if empty(PORT_OPTIONS:MJAVA)

post-install-JAVA-off:
${RM} -r -f ${STAGEDIR}${DOCSDIR}/java
.for i in gsg gsg_db_rep gsg_txn
${RM} -r -f ${STAGEDIR}${DOCSDIR}/${i}/JAVA
.endfor
.endif
.if empty(PORT_OPTIONS:MSQL)

post-install-SQL-off:
${RM} -r -f ${STAGEDIR}${DOCSDIR}/bdb-sql
.endif
.if !empty(PORT_OPTIONS:MTCL)

post-install-TCL-on:
echo "package ifneeded Db_tcl ${BDBVER} \
[list load [file join $$dir libdb_tcl-${BDBVER}.so]] \
" > ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/pkgIndex.tcl
.else

post-install-TCL-off:
.for i in api_reference/TCL
${RM} -r -f ${STAGEDIR}${DOCSDIR}/${i}
.endfor
.endif

.include <bsd.port.mk>
4 changes: 2 additions & 2 deletions databases/db6/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -93,12 +93,12 @@ post-install-SQL-on:
${INSTALL_SCRIPT} ${WRKSRC}/../lang/sql/upgrade61.sh \
${STAGEDIR}${PREFIX}/bin/${PORTNAME}-upgrade61.sh

post-install-TCL-off:
post-install-TCL-on:
echo "package ifneeded Db_tcl ${BDBVER} \
[list load [file join $$dir libdb_tcl-${BDBVER}.so]] \
" > ${STAGEDIR}${PREFIX}/lib/${PORTNAME}/pkgIndex.tcl

post-install-TCL-on:
post-install-TCL-off:
.for i in api_reference/TCL
${RM} -r -f ${STAGEDIR}${DOCSDIR}/${i}
.endfor
Expand Down
2 changes: 2 additions & 0 deletions databases/hbase/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -15,6 +15,8 @@ COMMENT= Hadoop database, a distributed, scalable, big data store

LICENSE= APACHE20

BROKEN= fails to build

BUILD_DEPENDS= bash:shells/bash \
cmake:devel/cmake \
${LOCALBASE}/share/java/maven3/bin/mvn:devel/maven3
Expand Down
4 changes: 1 addition & 3 deletions databases/libcouchbase/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= libcouchbase
DISTVERSION= 2.6.2
DISTVERSION= 2.6.3
CATEGORIES= databases
MASTER_SITES= http://packages.couchbase.com/clients/c/

Expand All @@ -14,8 +14,6 @@ LIB_DEPENDS= libevent.so:devel/libevent2 \
libev.so:devel/libev \
libuv.so:devel/libuv

BUILDDIR= ${WRKDIR}/${DISTNAME}/build

CMAKE_ARGS+= -DLCB_NO_TESTS=1

USES= cmake perl5
Expand Down
6 changes: 3 additions & 3 deletions databases/libcouchbase/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1472883834
SHA256 (libcouchbase-2.6.2.tar.gz) = 28f9218aea0bd0b390bb8129aa6ac2724b7444c0e0c62e21df8d3aabdb896b18
SIZE (libcouchbase-2.6.2.tar.gz) = 1118419
TIMESTAMP = 1475022835
SHA256 (libcouchbase-2.6.3.tar.gz) = 4010a10d8204ce4bb0b05b3cc24a727f88e303633639b3d9649d4d2ab03ebf6b
SIZE (libcouchbase-2.6.3.tar.gz) = 1119550
2 changes: 1 addition & 1 deletion databases/libcouchbase/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -2,4 +2,4 @@ This is the C client library for Couchbase. It communicates with the cluster
and speaks the relevant protocols necessary to connect to the cluster and
execute data operations.

https://github.com/couchbase/libcouchbase/
WWW: http://developer.couchbase.com/documentation/server/current/sdk/c/start-using-sdk.html
2 changes: 1 addition & 1 deletion databases/libcouchbase/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -59,7 +59,7 @@ include/libcouchbase/views.h
include/libcouchbase/visibility.h
lib/libcouchbase.so
lib/libcouchbase.so.2
lib/libcouchbase.so.2.0.37
lib/libcouchbase.so.2.0.38
lib/libcouchbase_libev.so
lib/libcouchbase_libevent.so
lib/libcouchbase_libuv.so
Expand Down
2 changes: 1 addition & 1 deletion devel/autoconf-archive/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,7 @@ MAINTAINER= [email protected]
COMMENT= Set of useful GNU Autoconf macros

USES= makeinfo tar:xz
DISTDATE= 2016.03.20
DISTDATE= 2016.09.16
GNU_CONFIGURE= yes
INFO= ${PORTNAME}

Expand Down
6 changes: 3 additions & 3 deletions devel/autoconf-archive/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1463940662
SHA256 (autoconf-archive-2016.03.20.tar.xz) = 88fb2efff640eddd28a52ae550ff5561bca3bd2bba09e1d7b0580e719875e437
SIZE (autoconf-archive-2016.03.20.tar.xz) = 613612
TIMESTAMP = 1475851931
SHA256 (autoconf-archive-2016.09.16.tar.xz) = e8f2efd235f842bad2f6938bf4a72240a5e5fcd248e8444335e63beb60fabd82
SIZE (autoconf-archive-2016.09.16.tar.xz) = 624536
7 changes: 7 additions & 0 deletions devel/autoconf-archive/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -45,6 +45,7 @@
%%MACRODIR%%/ax_boost_unit_test_framework.m4
%%MACRODIR%%/ax_boost_wave.m4
%%MACRODIR%%/ax_boost_wserialization.m4
%%MACRODIR%%/ax_build_date_epoch.m4
%%MACRODIR%%/ax_c99_inline.m4
%%MACRODIR%%/ax_c___attribute__.m4
%%MACRODIR%%/ax_c_arithmetic_rshift.m4
Expand Down Expand Up @@ -171,6 +172,7 @@
%%MACRODIR%%/ax_check_uname_syscall.m4
%%MACRODIR%%/ax_check_user.m4
%%MACRODIR%%/ax_check_vscript.m4
%%MACRODIR%%/ax_check_x86_features.m4
%%MACRODIR%%/ax_check_zlib.m4
%%MACRODIR%%/ax_code_coverage.m4
%%MACRODIR%%/ax_compare_version.m4
Expand Down Expand Up @@ -340,6 +342,7 @@
%%MACRODIR%%/ax_gcc_version.m4
%%MACRODIR%%/ax_gcc_warn_unused_result.m4
%%MACRODIR%%/ax_gcc_x86_avx_xgetbv.m4
%%MACRODIR%%/ax_gcc_x86_cpu_supports.m4
%%MACRODIR%%/ax_gcc_x86_cpuid.m4
%%MACRODIR%%/ax_generate_changelog.m4
%%MACRODIR%%/ax_gnu_autotest.m4
Expand Down Expand Up @@ -394,6 +397,7 @@
%%MACRODIR%%/ax_libtoolize_cflags.m4
%%MACRODIR%%/ax_llvm.m4
%%MACRODIR%%/ax_lua.m4
%%MACRODIR%%/ax_luarocks_rock.m4
%%MACRODIR%%/ax_maintainer_mode_auto_silent.m4
%%MACRODIR%%/ax_missing_prog.m4
%%MACRODIR%%/ax_mpi.m4
Expand All @@ -402,6 +406,9 @@
%%MACRODIR%%/ax_normalize_path.m4
%%MACRODIR%%/ax_not_enable_frame_pointer.m4
%%MACRODIR%%/ax_numeric_namedlevel.m4
%%MACRODIR%%/ax_open62541_check_h.m4
%%MACRODIR%%/ax_open62541_check_lib.m4
%%MACRODIR%%/ax_open62541_path.m4
%%MACRODIR%%/ax_openmp.m4
%%MACRODIR%%/ax_patch_libtool_changing_cmds_ifs.m4
%%MACRODIR%%/ax_path_bdb.m4
Expand Down
2 changes: 1 addition & 1 deletion devel/erlang-gen_rpc/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= gen_rpc
PORTVERSION= 2.0.0
PORTVERSION= 2.0.1
CATEGORIES= devel
PKGNAMEPREFIX= erlang-

Expand Down
6 changes: 3 additions & 3 deletions devel/erlang-gen_rpc/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1475605255
SHA256 (priestjim-gen_rpc-2.0.0_GH0.tar.gz) = dab4d0a8fd8b110380f0bd99f626815da4e7c7276b3235f7db682273d7d6fe72
SIZE (priestjim-gen_rpc-2.0.0_GH0.tar.gz) = 51380
TIMESTAMP = 1475825194
SHA256 (priestjim-gen_rpc-2.0.1_GH0.tar.gz) = 6d62546814777f844d81c50203f7cc9389a373614adc2fb0f562563926669d53
SIZE (priestjim-gen_rpc-2.0.1_GH0.tar.gz) = 52126
Loading

0 comments on commit 7c0780c

Please sign in to comment.