forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
13 changed files
with
74 additions
and
883 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -10,6 +10,26 @@ in the release notes and/or placed into UPDATING. | |
|
||
All ports committers are allowed to commit to this file. | ||
|
||
20150408: | ||
AUTHOR: [email protected] | ||
|
||
Add a new USES=waf to handle the waf building system, allowing to factorise | ||
code. Plug waf into MAKE_CMD and CONFIGURE_CMD so the regular defined targets | ||
can be reused. | ||
|
||
Always define _MAKE_JOBS so that when bsd.port.mk will stop overwritting | ||
_MAKE_JOBS when parallel jobs are disabled we can enforce -j1 (which is needed | ||
to really disable parallelisation with waf | ||
|
||
WAF_CMD has been created to allow one to override the location of the waf | ||
script relatively to WRKSRC | ||
|
||
CONFIGURE_TARGET is by default defined to "configure" | ||
ALL_TARGET is by default defined to "build" | ||
INSTALL_TARGET is by default defined to "install" | ||
|
||
USES=waf is by default stagedir safe | ||
|
||
20150407: | ||
AUTHOR: [email protected] | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
# $FreeBSD$ | ||
# | ||
# Provide support to use the waf building system | ||
# | ||
# Feature: waf | ||
# Usage: USES=waf | ||
# | ||
# It implies USES=python:build automatically is no USES=python has been | ||
# specified yet | ||
# | ||
# WAF_CMD can be specified in the ports if the waf script is not | ||
# in WRKSRC/waf | ||
# CONFIGURE_TARGET default to 'configure' | ||
# ALL_TARGET default to 'build' | ||
# INSTALL_TARGET= default to 'install' | ||
|
||
.if !defined(_INCLUDE_USES_WAF_MK) | ||
_INCLUDE_USES_WAF_MK= yes | ||
|
||
.if !empty(waf_ARGS) | ||
IGNORE= Incorrect 'USES+= waf:${waf_ARGS}' waf takes no arguments | ||
.endif | ||
|
||
.if !${USES:Mpython*} | ||
python_ARGS= 2,build | ||
.include "${USESDIR}/python.mk" | ||
.endif | ||
|
||
MAKEFILE= # | ||
MAKE_FLAGS= # | ||
ALL_TARGET= # | ||
HAS_CONFIGURE= yes | ||
WAF_CMD?= ./waf | ||
|
||
CONFIGURE_TARGET?= configure | ||
ALL_TARGET?= build | ||
INSTALL_TARGET?= install | ||
|
||
CONFIGURE_CMD= ${PYTHON_CMD} ${WAF_CMD} ${CONFIGURE_TARGET} | ||
MAKE_CMD= ${PYTHON_CMD} ${WAF_CMD} | ||
CONFIGURE_ARGS+= --prefix=${PREFIX} \ | ||
${_MAKE_JOBS} | ||
|
||
DESTDIRNAME= --destdir | ||
|
||
# Set a minimal job of 1 | ||
_MAKE_JOBS= -j${MAKE_JOBS_NUMBER} | ||
|
||
.endif |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file was deleted.
Oops, something went wrong.
This file was deleted.
Oops, something went wrong.
Oops, something went wrong.