Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Jun 30, 2015
1 parent 4758c2a commit addc4f1
Show file tree
Hide file tree
Showing 268 changed files with 1,261 additions and 2,399 deletions.
41 changes: 27 additions & 14 deletions accessibility/speech-dispatcher/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@
# $FreeBSD$

PORTNAME= speech-dispatcher
PORTVERSION= 0.8
PORTREVISION= 2
PORTVERSION= 0.8.3
CATEGORIES= accessibility audio
MASTER_SITES= http://devel.freebsoft.org/pub/projects/speechd/

Expand All @@ -17,28 +16,27 @@ LIB_DEPENDS= libdotconf.so:${PORTSDIR}/devel/dotconf \
libsndfile.so:${PORTSDIR}/audio/libsndfile

USE_GNOME= glib20 intltool
USES= alias gettext gmake pathfix pkgconfig libtool
USES= alias gmake pathfix pkgconfig libtool
GNU_CONFIGURE= yes
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip

ETCFILES= clients/emacs.conf clients/gnome-speech.conf \
ETCFILES= clients/emacs.conf modules/pico-generic.conf \
modules/cicero.conf modules/dtk-generic.conf \
modules/epos-generic.conf modules/espeak-generic.conf \
modules/espeak-mbrola-generic.conf modules/espeak.conf \
modules/festival.conf modules/flite.conf modules/ibmtts.conf \
modules/ivona.conf modules/llia_phon-generic.conf \
modules/swift-generic.conf speechd.conf

PLIST_SUB+= ETCFILES="${ETCFILES}"

PORTDOCS= AUTHORS ChangeLog FAQ INSTALL NEWS README TODO
PORTDOCS= ANNOUNCE AUTHORS ChangeLog FAQ NEWS README TODO

INFO= spd-say speech-dispatcher ssip

OPTIONS_DEFINE= ALSA AO DOCS ESPEAK FESTIVAL FLITE NAS PULSEAUDIO #PYTHON
OPTIONS_DEFINE= ALSA AO DOCS ESPEAK FESTIVAL FLITE NAS NLS \
PULSEAUDIO PYTHON
OPTIONS_DEFAULT=ESPEAK
OPTIONS_SUB= yes

Expand All @@ -63,25 +61,40 @@ FLITE_CONFIGURE_WITH= flite
NAS_LIB_DEPENDS= libaudio.so:${PORTSDIR}/audio/nas
NAS_CONFIGURE_WITH= nas

NLS_USES= gettext

PULSEAUDIO_LIB_DEPENDS= libpulse.so:${PORTSDIR}/audio/pulseaudio
PULSEAUDIO_CONFIGURE_WITH=pulse

# devel/py-xdg doesn't support Python 3.
CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= PYTHON="@comment "
#PYTHON_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py-xdg
#PYTHON_USE= PYTHON=3
#PYTHON_CONFIGURE_ENABLE=python
PYTHON_RUN_DEPENDS= ${PYTHON_SITELIBDIR}/xdg/__init__.py:${PORTSDIR}/devel/py3-xdg
PYTHON_USES= python:3
PYTHON_USE= PYTHON=py3kplist
PYTHON_CONFIGURE_ENABLE=python

.include <bsd.port.options.mk>

.if ${PORT_OPTIONS:MNLS}
INFO+= speech-dispatcher-cs
.endif

post-patch:
@${REINPLACE_CMD} -e '/SUBDIRS/ s/tests//' \
${WRKSRC}/src/Makefile.in
.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e '/SUBDIRS/ s/po//' \
${WRKSRC}/Makefile.in
.endif

post-install:
.for f in ${ETCFILES}
@${MV} ${STAGEDIR}${ETCDIR}/${f} ${STAGEDIR}${ETCDIR}/${f}.sample
.endfor
@${RM} -rf ${STAGEDIR}${DATADIR}/conf
@${RMDIR} ${STAGEDIR}${DATADIR} || ${TRUE}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
.if ! ${PORT_OPTIONS:MNLS}
@${RM} -f ${STAGEDIR}${PREFIX}/${INFO_PATH}/speech-dispatcher-cs.info
.endif

.include <bsd.port.mk>
4 changes: 2 additions & 2 deletions accessibility/speech-dispatcher/distinfo
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
SHA256 (speech-dispatcher-0.8.tar.gz) = 0a6ce544cfbac8592a8ea08e3ab24c389153904ea51c6fd68756cea52de9efa2
SIZE (speech-dispatcher-0.8.tar.gz) = 1229312
SHA256 (speech-dispatcher-0.8.3.tar.gz) = 96a293b2ba1e2498f1280c75a9607891a9990947a8d87e9855c2a642c93f1e4f
SIZE (speech-dispatcher-0.8.3.tar.gz) = 1292321
11 changes: 0 additions & 11 deletions accessibility/speech-dispatcher/files/patch-include__spd_utils.h

This file was deleted.

This file was deleted.

21 changes: 0 additions & 21 deletions accessibility/speech-dispatcher/files/patch-src__modules__cicero.c

This file was deleted.

25 changes: 0 additions & 25 deletions accessibility/speech-dispatcher/files/patch-src__server__output.c

This file was deleted.

This file was deleted.

This file was deleted.

Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
--- ./src/server/speechd.h.orig 2012-07-11 11:05:06.000000000 +0200
+++ ./src/server/speechd.h 2013-11-15 08:44:05.115355454 +0100
--- src/server/speechd.h.orig 2015-06-04 01:52:14 UTC
+++ src/server/speechd.h
@@ -56,7 +56,7 @@
/* TODO: This fixes compilation for Mac OS X but might not be a correct
solution for other platforms. A better check is needed, possibly including
_POSIX_C_SOURCE and friends*/
-#if (defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)) || defined(__APPLE__)
+#if (defined(__GNU_LIBRARY__) && !defined(_SEM_SEMUN_UNDEFINED)) || defined(__APPLE__) || defined(__FreeBSD__)
/* union semun is defined by including <sys/sem.h> */
/* union semun is defined by including <sys/sem.h> */
#else
/* according to X/OPEN we have to define it ourselves */
/* according to X/OPEN we have to define it ourselves */
25 changes: 6 additions & 19 deletions accessibility/speech-dispatcher/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,6 @@ bin/spd-say
bin/spdsend
bin/speech-dispatcher
@sample %%ETCDIR%%/clients/emacs.conf.sample
@sample %%ETCDIR%%/clients/gnome-speech.conf.sample
@sample %%ETCDIR%%/modules/cicero.conf.sample
@sample %%ETCDIR%%/modules/dtk-generic.conf.sample
@sample %%ETCDIR%%/modules/epos-generic.conf.sample
Expand All @@ -15,15 +14,18 @@ bin/speech-dispatcher
@sample %%ETCDIR%%/modules/ibmtts.conf.sample
@sample %%ETCDIR%%/modules/ivona.conf.sample
@sample %%ETCDIR%%/modules/llia_phon-generic.conf.sample
@sample %%ETCDIR%%/modules/pico-generic.conf.sample
@sample %%ETCDIR%%/modules/swift-generic.conf.sample
@sample %%ETCDIR%%/speechd.conf.sample
include/speech-dispatcher/libspeechd.h
include/speech-dispatcher/libspeechd_version.h
include/speech-dispatcher/spd_audio_plugin.h
include/speech-dispatcher/speechd_defines.h
include/speech-dispatcher/speechd_types.h
lib/libspeechd.a
lib/libspeechd.so
lib/libspeechd.so.2
lib/libspeechd.so.2.4.0
lib/libspeechd.so.2.6.0
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.py
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.pyc
%%PYTHON%%%%PYTHON_SITELIBDIR%%/speechd/__init__.pyo
Expand Down Expand Up @@ -62,22 +64,7 @@ lib/speech-dispatcher/spd_oss.so
%%PULSEAUDIO%%lib/speech-dispatcher/spd_pulse.a
%%PULSEAUDIO%%lib/speech-dispatcher/spd_pulse.so
libdata/pkgconfig/speech-dispatcher.pc
share/locale/cs/LC_MESSAGES/speech-dispatcher.mo
share/locale/hu/LC_MESSAGES/speech-dispatcher.mo
%%NLS%%share/locale/cs/LC_MESSAGES/speech-dispatcher.mo
%%NLS%%share/locale/hu/LC_MESSAGES/speech-dispatcher.mo
share/sounds/speech-dispatcher/dummy-message.wav
%%PYTHON%%share/sounds/speech-dispatcher/test.wav
%%DATADIR%%/conf/clients/emacs.conf
%%DATADIR%%/conf/clients/gnome-speech.conf
%%DATADIR%%/conf/modules/cicero.conf
%%DATADIR%%/conf/modules/dtk-generic.conf
%%DATADIR%%/conf/modules/epos-generic.conf
%%DATADIR%%/conf/modules/espeak-generic.conf
%%DATADIR%%/conf/modules/espeak-mbrola-generic.conf
%%DATADIR%%/conf/modules/espeak.conf
%%DATADIR%%/conf/modules/festival.conf
%%DATADIR%%/conf/modules/flite.conf
%%DATADIR%%/conf/modules/ibmtts.conf
%%DATADIR%%/conf/modules/ivona.conf
%%DATADIR%%/conf/modules/llia_phon-generic.conf
%%DATADIR%%/conf/modules/swift-generic.conf
%%DATADIR%%/conf/speechd.conf
2 changes: 0 additions & 2 deletions archivers/p5-Archive-Extract-Libarchive/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -24,8 +24,6 @@ USE_PERL5= modbuild
USES= perl5

post-install:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Archive/Extract/Libarchive/Libarchive.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Archive/Extract/Libarchive/Libarchive.so
${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Archive/Extract/Libarchive/Libarchive.so

.include <bsd.port.mk>
2 changes: 0 additions & 2 deletions archivers/p5-Compress-LZ4/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -16,8 +16,6 @@ USES= perl5
USE_PERL5= configure

post-stage:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/LZ4/LZ4.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/LZ4/LZ4.so
${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/LZ4/LZ4.so

.include <bsd.port.mk>
2 changes: 0 additions & 2 deletions archivers/p5-Compress-Raw-Bzip2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -21,8 +21,6 @@ USE_PERL5= configure
USES= perl5

post-install:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Bzip2/Bzip2.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Bzip2/Bzip2.so
${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Bzip2/Bzip2.so

.include <bsd.port.mk>
2 changes: 0 additions & 2 deletions archivers/p5-Compress-Raw-Lzma/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -26,8 +26,6 @@ USES= perl5
LZMALIB_LIB_DEPENDS= liblzma.so.1:${PORTSDIR}/archivers/lzmalib

post-install:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Lzma/Lzma.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Lzma/Lzma.so
${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Lzma/Lzma.so

.include <bsd.port.mk>
2 changes: 0 additions & 2 deletions archivers/p5-Compress-Raw-Zlib/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -24,8 +24,6 @@ post-patch:
@${REINPLACE_CMD} -e '/^BUILD_ZLIB/ s|True|False|; /^INCLUDE/ s|= .*$$|= ${INCLUDEDIR}|; /^LIB/ s|= .*$$|= ${LIBDIR}|' ${WRKSRC}/config.in

post-install:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Zlib/Zlib.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Zlib/Zlib.so
${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Raw/Zlib/Zlib.so

.include <bsd.port.mk>
2 changes: 0 additions & 2 deletions archivers/p5-Compress-Snappy/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -20,8 +20,6 @@ USE_PERL5= configure
USES= perl5

post-install:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Snappy/Snappy.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Snappy/Snappy.so
${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Compress/Snappy/Snappy.so

.include <bsd.port.mk>
1 change: 0 additions & 1 deletion audio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -573,7 +573,6 @@
SUBDIR += p5-tagged
SUBDIR += p5-xmms2
SUBDIR += pacpl
SUBDIR += padevchooser
SUBDIR += paman
SUBDIR += paprefs
SUBDIR += patchage
Expand Down
2 changes: 1 addition & 1 deletion audio/icecast2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= icecast2
PORTVERSION= 2.4.1
PORTVERSION= 2.4.2
PORTEPOCH= 1
CATEGORIES= audio net ipv6
MASTER_SITES= http://downloads.xiph.org/releases/icecast/:source \
Expand Down
4 changes: 2 additions & 2 deletions audio/icecast2/distinfo
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
SHA256 (icecast/icecast-2.4.1.tar.gz) = 43f89ec301db1652740d1069bbc2c2e5244611fb86743dd5de90ce97a9a7454b
SIZE (icecast/icecast-2.4.1.tar.gz) = 2392650
SHA256 (icecast/icecast-2.4.2.tar.gz) = aa1ae2fa364454ccec61a9247949d19959cb0ce1b044a79151bf8657fd673f4f
SIZE (icecast/icecast-2.4.2.tar.gz) = 2388381
SHA256 (icecast/favicon.ico) = 6e22f7e26d2f97e9c1b7840458bcd29a81a6ad3433248506f56cdc305ec7487e
SIZE (icecast/favicon.ico) = 1406
2 changes: 0 additions & 2 deletions audio/p5-Audio-CD/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -19,8 +19,6 @@ CONFIGURE_ARGS= INC="-I${LOCALBASE}/include " \
LIBS="-L${LOCALBASE}/lib -lcdaudio"

post-install:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/CD/CD.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/CD/CD.so
${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/CD/CD.so

.include <bsd.port.mk>
2 changes: 0 additions & 2 deletions audio/p5-Audio-Mixer/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -19,8 +19,6 @@ USES= perl5 shebangfix
SHEBANG_FILES= volume.pl

post-install:
${CHMOD} u+w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/Mixer/Mixer.so
${STRIP_CMD} ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/Mixer/Mixer.so
${CHMOD} u-w ${STAGEDIR}${PREFIX}/${SITE_ARCH_REL}/auto/Audio/Mixer/Mixer.so

.include <bsd.port.mk>
Loading

0 comments on commit addc4f1

Please sign in to comment.