forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: FreeBSD
- Loading branch information
Showing
291 changed files
with
4,888 additions
and
1,653 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
SHA256 (maptools_0.8-39.tar.gz) = 4b81e313e45dbb75e0fbb180b02985d1c34aaa5669e483283b632788e6a67dd2 | ||
SIZE (maptools_0.8-39.tar.gz) = 1582435 | ||
TIMESTAMP = 1481025150 | ||
SHA256 (maptools_0.8-40.tar.gz) = 7875a45886f72cdd4d1601c89717c3d2868b5379183f618d753a3f7a25b6e713 | ||
SIZE (maptools_0.8-40.tar.gz) = 1576590 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,85 @@ | ||
# Fix build with FFmpeg 3.x; obtained from https://git.reviewboard.kde.org/r/126682 | ||
# | ||
--- src/musicbrainz/MusicDNSAudioDecoder.cpp | ||
+++ src/musicbrainz/MusicDNSAudioDecoder.cpp | ||
@@ -243,7 +243,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
{ | ||
if( !decodedFrame ) | ||
{ | ||
- decodedFrame = avcodec_alloc_frame(); | ||
+ decodedFrame = av_frame_alloc(); | ||
if( !decodedFrame ) | ||
{ | ||
warning() << "Unable to allocate enough memory to decode file."; | ||
@@ -251,7 +251,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
break; | ||
} | ||
else | ||
- avcodec_get_frame_defaults( decodedFrame ); | ||
+ av_frame_unref( decodedFrame ); | ||
} | ||
|
||
decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt ); | ||
@@ -287,7 +287,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
|
||
avcodec_close( pCodecCtx ); | ||
avformat_close_input( &pFormatCtx ); | ||
- av_free( decodedFrame ); | ||
+ av_frame_free( &decodedFrame ); | ||
|
||
return data->duration(); | ||
} | ||
@@ -361,7 +361,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
{ | ||
if( !decodedFrame ) | ||
{ | ||
- decodedFrame = avcodec_alloc_frame(); | ||
+ decodedFrame = av_frame_alloc(); | ||
if( !decodedFrame ) | ||
{ | ||
warning() << "Unable to allocate enough memory to decode file."; | ||
@@ -369,7 +369,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
break; | ||
} | ||
else | ||
- avcodec_get_frame_defaults( decodedFrame ); | ||
+ av_frame_unref( decodedFrame ); | ||
} | ||
|
||
decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt ); | ||
@@ -405,7 +405,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
|
||
avcodec_close( pCodecCtx ); | ||
avformat_close_input( &pFormatCtx ); | ||
- av_free( decodedFrame ); | ||
+ av_frame_free( &decodedFrame ); | ||
|
||
return data->duration(); | ||
} | ||
@@ -479,7 +479,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
{ | ||
if( !decodedFrame ) | ||
{ | ||
- decodedFrame = avcodec_alloc_frame(); | ||
+ decodedFrame = av_frame_alloc(); | ||
if( !decodedFrame ) | ||
{ | ||
warning() << "Unable to allocate enough memory to decode file."; | ||
@@ -487,7 +487,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
break; | ||
} | ||
else | ||
- avcodec_get_frame_defaults( decodedFrame ); | ||
+ av_frame_unref( decodedFrame ); | ||
} | ||
|
||
decoderRet = avcodec_decode_audio4( pCodecCtx, decodedFrame, &gotFrame, &avpkt ); | ||
@@ -523,7 +523,7 @@ MusicDNSAudioDecoder::decode( const QString &fileName, DecodedAudioData *data, c | ||
|
||
avcodec_close( pCodecCtx ); | ||
av_close_input_file( pFormatCtx ); | ||
- av_free( decodedFrame ); | ||
+ av_frame_free( &decodedFrame ); | ||
|
||
return data->duration(); | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,29 +2,26 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= flowgrind | ||
PORTVERSION= 0.7.5 | ||
PORTREVISION= 1 | ||
PORTVERSION= 0.8.0 | ||
DISTVERSIONPREFIX= ${PORTNAME}- | ||
CATEGORIES= benchmarks | ||
|
||
MAINTAINER= [email protected] | ||
MAINTAINER= [email protected] | ||
COMMENT= Measure throughput and other metrics for TCP | ||
|
||
LICENSE= GPLv3+ | ||
LICENSE_FILE= ${WRKSRC}/COPYING | ||
|
||
LIB_DEPENDS= libgsl.so:math/gsl \ | ||
libxmlrpc.so:net/xmlrpc-c | ||
libxmlrpc.so:net/xmlrpc-c \ | ||
libcurl.so:ftp/curl \ | ||
libwwwxml.so:www/libwww \ | ||
libuuid.so:misc/e2fsprogs-libuuid | ||
|
||
USE_GITHUB= yes | ||
|
||
USES= autoreconf | ||
USES= autoreconf ssl | ||
GNU_CONFIGURE= yes | ||
CONFIGURE_ARGS= --enable-pcap --enable-gsl | ||
CONFIGURE_ENV= LIBS="${LIBS} -lpcap" | ||
|
||
post-patch: | ||
@${RM} -r ${WRKSRC}/build-aux | ||
@${REINPLACE_CMD} -e 's|AC_LIB_RPATH||g' ${WRKSRC}/configure.ac | ||
CONFIGURE_ENV= LIBS="${LIBS} -lpcap" | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
SHA256 (flowgrind-flowgrind-flowgrind-0.7.5_GH0.tar.gz) = 714d958340ac89339404fd0b2acd42dcb67277c7e9e4443903a9f85ab6c6342b | ||
SIZE (flowgrind-flowgrind-flowgrind-0.7.5_GH0.tar.gz) = 146499 | ||
TIMESTAMP = 1478561627 | ||
SHA256 (flowgrind-flowgrind-flowgrind-0.8.0_GH0.tar.gz) = 1b0c6c571f11430e170ee5d654ff10ba095f627f50509b6c678681566ead8cb6 | ||
SIZE (flowgrind-flowgrind-flowgrind-0.8.0_GH0.tar.gz) = 152977 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1480362125 | ||
SHA256 (phpMyAdmin-4.6.5.1-all-languages.tar.xz) = e163b08b6d1137fd7c48ea97e8e53be415b1937f5e5f7e070936a60c3b9a3df0 | ||
SIZE (phpMyAdmin-4.6.5.1-all-languages.tar.xz) = 6162164 | ||
TIMESTAMP = 1481008881 | ||
SHA256 (phpMyAdmin-4.6.5.2-all-languages.tar.xz) = 8cb549c0cd04ecaa3b2a8d9315e7c88528603fa6fe91057b13173f6afba80894 | ||
SIZE (phpMyAdmin-4.6.5.2-all-languages.tar.xz) = 6136880 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,7 @@ | ||
# $FreeBSD$ | ||
|
||
MASTERDIR= ${.CURDIR}/../py-mysqlclient | ||
|
||
PYTHON_VERSION= python3.5 | ||
|
||
.include "${MASTERDIR}/Makefile" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,10 +2,12 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= redis | ||
DISTVERSION= 3.2.5 | ||
DISTVERSION= 4.0-rc1 | ||
CATEGORIES= databases | ||
MASTER_SITES= http://download.redis.io/releases/ | ||
MASTER_SITES= https://github.com/antirez/redis/archive/ | ||
PKGNAMESUFFIX= -devel | ||
DISTNAME= ${DISTVERSION} | ||
DIST_SUBDIR= ${PORTNAME} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Persistent key-value database with built-in net interface | ||
|
@@ -23,6 +25,8 @@ LUAJIT_DESC= Use lang/luajit instead of builtin lua | |
TESTS_DESC= Install lang/tcl for redis unit tests | ||
TRIB_DESC= Install redis-trib.rb (lang/ruby req.) | ||
|
||
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION} | ||
|
||
.include <bsd.port.options.mk> | ||
|
||
.if ${PORT_OPTIONS:MTRIB} | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1480441490 | ||
SHA256 (redis-3.2.5.tar.gz) = 8509ceb1efd849d6b2346a72a8e926b5a4f6ed3cc7c3cd8d9f36b2e9ba085315 | ||
SIZE (redis-3.2.5.tar.gz) = 1544040 | ||
TIMESTAMP = 1480898940 | ||
SHA256 (redis/4.0-rc1.tar.gz) = 4a7f8daafd5ca6d65a077d0bb8d4b6cc4ba5a2e6da2281fd45acebd327db941c | ||
SIZE (redis/4.0-rc1.tar.gz) = 1683841 |
Oops, something went wrong.