Skip to content

Commit

Permalink
Merge pull request openwrt#784 from micmac1/kam562
Browse files Browse the repository at this point in the history
kamailio: bump to 5.6.2
  • Loading branch information
micmac1 authored Oct 19, 2022
2 parents fa14037 + 7163789 commit 33e6dea
Show file tree
Hide file tree
Showing 5 changed files with 69 additions and 395 deletions.
17 changes: 14 additions & 3 deletions net/kamailio/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,12 +9,12 @@
include $(TOPDIR)/rules.mk

PKG_NAME:=kamailio
PKG_VERSION:=5.5.2
PKG_VERSION:=5.6.2
PKG_RELEASE:=$(AUTORELEASE)

PKG_SOURCE_URL:=https://www.kamailio.org/pub/kamailio/$(PKG_VERSION)/src
PKG_SOURCE:=kamailio-$(PKG_VERSION)_src.tar.gz
PKG_HASH:=998f337d0561b5d814ebb5c59b160e0c856e7c9f3e53bcee0f3285d003d1c05c
PKG_HASH:=ea3cd5d688c34208b92072c3844c8276b693e0ca2c688168ea0357978c76b32d
PKG_USE_MIPS16:=0

PKG_LICENSE:=GPL-2.0+
Expand Down Expand Up @@ -125,6 +125,7 @@ MODULES_AVAILABLE:= \
matrix \
maxfwd \
mediaproxy \
misctest \
mohqueue \
mqueue \
msilo \
Expand All @@ -142,6 +143,7 @@ MODULES_AVAILABLE:= \
permissions \
pike \
pipelimit \
posops \
prefix_route \
presence \
presence_conference \
Expand Down Expand Up @@ -178,10 +180,12 @@ MODULES_AVAILABLE:= \
secfilter \
sipcapture \
sipdump \
siprepo \
sipt \
siptrace \
siputils \
sl \
slack \
sms \
smsops \
snmpstats \
Expand Down Expand Up @@ -370,6 +374,9 @@ define BuildKamailioModule
endef
define Package/kamailio-mod-$(subst _,-,$(1))/conffiles
$(subst $(space),$(newline),$(foreach c,$(6),/etc/kamailio/$(c)))
endef
define Package/kamailio-mod-$(subst _,-,$(1))/description
$(subst \n,$(newline),$(3))
endef
define Package/kamailio-mod-$(subst _,-,$(1))/install
$(call Package/kamailio/install/module,$$(1),$(1))
Expand Down Expand Up @@ -552,7 +559,7 @@ $(eval $(call BuildKamailioModule,jansson,Access to JSON attributes,,+jansson))
$(eval $(call BuildKamailioModule,janssonrpcc,Alternative JSONRPC server,,+kamailio-mod-jansson +libevent2))
$(eval $(call BuildKamailioModule,json,Access to JSON document attributes,,+libjson-c))
$(eval $(call BuildKamailioModule,jsonrpcs,JSONRPC server over HTTP,,+libevent2))
$(eval $(call BuildKamailioModule,keepalive,SIP keepalive monitoring,+kamailio-mod-tm,))
$(eval $(call BuildKamailioModule,keepalive,SIP keepalive monitoring,,+kamailio-mod-tm,,))
$(eval $(call BuildKamailioModule,kemix,KEMI extensions,,,))
$(eval $(call BuildKamailioModule,kex,Core extensions,,))
$(eval $(call BuildKamailioModule,lcr,Least Cost Routing,,+kamailio-mod-tm +libpcre))
Expand All @@ -564,6 +571,7 @@ $(eval $(call BuildKamailioModule,mangler,SDP mangling,,))
$(eval $(call BuildKamailioModule,matrix,Matrix operations,,))
$(eval $(call BuildKamailioModule,maxfwd,Max-Forward processor,,))
$(eval $(call BuildKamailioModule,mediaproxy,Automatic NAT traversal,,+kamailio-mod-dialog))
$(eval $(call BuildKamailioModule,misctest,Debugging/testing,This is a debugging/test module. It implements functions (both script\nand rpcs) that can be used to stress the memory allocator or force\nmemory leaks.\n\nWarning: This module should never be used in a production environment.,,,))
$(eval $(call BuildKamailioModule,mohqueue,Music on hold queuing system,,+kamailio-mod-rtpproxy +kamailio-mod-sl +kamailio-mod-tm))
$(eval $(call BuildKamailioModule,mqueue,Generic message queue system,,))
$(eval $(call BuildKamailioModule,msilo,SIP message silo,,+kamailio-mod-tm))
Expand All @@ -581,6 +589,7 @@ $(eval $(call BuildKamailioModule,pdt,Prefix-to-Domain translator,,))
$(eval $(call BuildKamailioModule,permissions,Permissions control,,))
$(eval $(call BuildKamailioModule,pike,Flood detector,,))
$(eval $(call BuildKamailioModule,pipelimit,Traffic shaping policies,,+kamailio-mod-sl))
$(eval $(call BuildKamailioModule,posops,Position SIP message buffer ops,The module exports utility functions to work with the position inside the SIP\nmessage buffer. Among them are function to add or remove content at\na specific position.,,,))
$(eval $(call BuildKamailioModule,prefix_route,Execute based on prefix,,))
$(eval $(call BuildKamailioModule,presence,Presence server,,+kamailio-mod-sl +kamailio-mod-tm,))
$(eval $(call BuildKamailioModule,presence_conference,Conference events,,+kamailio-mod-presence))
Expand Down Expand Up @@ -617,10 +626,12 @@ $(eval $(call BuildKamailioModule,seas,Sip Express Application Server,,+kamailio
$(eval $(call BuildKamailioModule,secfilter,Allow/block filters,,,))
$(eval $(call BuildKamailioModule,sipcapture,SIP capture,,))
$(eval $(call BuildKamailioModule,sipdump,Save SIP traffic,,))
$(eval $(call BuildKamailioModule,siprepo,SIP Repo,This module can store and fetch SIP message content in an in-memory hash\ntable.,,,))
$(eval $(call BuildKamailioModule,sipt,SIP-T and SIP-I operations,,))
$(eval $(call BuildKamailioModule,siptrace,SIP trace,,))
$(eval $(call BuildKamailioModule,siputils,SIP utilities,,+kamailio-mod-sl))
$(eval $(call BuildKamailioModule,sl,Stateless replier,,))
$(eval $(call BuildKamailioModule,slack,Slack integration,This module provides integration with Slack over webhooks.,+libcurl,,))
$(eval $(call BuildKamailioModule,sms,SIP-to-SMS IM gateway,,+kamailio-mod-tm))
$(eval $(call BuildKamailioModule,smsops,Handle SMS packets in SIP,,))
$(eval $(call BuildKamailioModule,snmpstats,SNMP interface for statistics,,+libnetsnmp))
Expand Down
8 changes: 6 additions & 2 deletions net/kamailio/patches/140-redis_use_pkg-config.patch
Original file line number Diff line number Diff line change
Expand Up @@ -15,19 +15,23 @@
HIREDISDEFS=-I$(LOCALBASE)/include
--- a/src/modules/db_redis/Makefile
+++ b/src/modules/db_redis/Makefile
@@ -5,12 +5,10 @@ include ../../Makefile.defs
@@ -5,7 +5,6 @@ include ../../Makefile.defs
auto_gen=
NAME=db_redis.so

-ifeq ($(CROSS_COMPILE),)
HIREDIS_BUILDER = $(shell \
if pkg-config --exists hiredis; then \
echo 'pkg-config hiredis'; \
@@ -16,8 +15,6 @@ HIREDIS_CLUSTER_BUILDER = $(shell \
echo 'pkg-config hiredis_cluster'; \
fi)
-endif

-endif
-
ifeq ($(HIREDIS_BUILDER),)
HIREDISDEFS=-I$(LOCALBASE)/include -I$(LOCALBASE)/include/hiredis -I/usr/include/hiredis
HIREDISLIBS=-L$(LOCALBASE)/lib -lhiredis
--- a/src/modules/ndb_redis/Makefile
+++ b/src/modules/ndb_redis/Makefile
@@ -5,12 +5,10 @@ include ../../Makefile.defs
Expand Down

This file was deleted.

Original file line number Diff line number Diff line change
@@ -0,0 +1,49 @@
From f32e1d9c96f6ba9df3c27178c689ccd27eabaafc Mon Sep 17 00:00:00 2001
From: Sebastian Kemper <[email protected]>
Date: Sun, 16 Oct 2022 16:51:41 +0200
Subject: [PATCH] siputils: fix time_t warning and a typo

Fix the below warning one gets when compiling siputils for a 32 bit
target against a time64 libc (musl).

Also fix a spelling mistake on the same line ("autdated" -> "outdated").

siputils.c: In function 'ki_hdr_date_check':
../../core/parser/../dprint.h:321:73: warning: format '%ld' expects argument of type 'long int', but argument 11 has type 'time_t' {aka 'long long int'} [-Wformat=]
321 | fprintf(stderr, "%2d(%d) %s: %.*s%s%s%s" fmt, \
| ^~~~~~~~~~~~~~~~~~~~~~~~
../../core/parser/../dprint.h:345:25: note: in expansion of macro 'LOG_FX'
345 | LOG_FX(facility, level, lname, prefix, _FUNC_NAME_, fmt, ## args)
| ^~~~~~
../../core/parser/../dprint.h:351:25: note: in expansion of macro 'LOG_FL'
351 | LOG_FL(facility, level, NULL, prefix, fmt, ## args)
| ^~~~~~
../../core/parser/../dprint.h:354:25: note: in expansion of macro 'LOG_FP'
354 | LOG_FP(DEFAULT_FACILITY, (level), LOC_INFO, fmt, ## args)
| ^~~~~~
../../core/parser/../dprint.h:392:37: note: in expansion of macro 'LOG'
392 | # define ERR(fmt, args...) LOG(L_ERR, fmt , ## args)
| ^~~
../../core/parser/../dprint.h:418:16: note: in expansion of macro 'ERR'
418 | #define LM_ERR ERR
| ^~~
siputils.c:562:17: note: in expansion of macro 'LM_ERR'
562 | LM_ERR("autdated date header value (%ld sec)\n", tnow - tmsg + tdiff);
| ^~~~~~

Signed-off-by: Sebastian Kemper <[email protected]>
---
src/modules/siputils/siputils.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

--- a/src/modules/siputils/siputils.c
+++ b/src/modules/siputils/siputils.c
@@ -559,7 +559,7 @@ static int ki_hdr_date_check(sip_msg_t*
}

if (tnow > tmsg + tdiff) {
- LM_ERR("autdated date header value (%ld sec)\n", tnow - tmsg + tdiff);
+ LM_ERR("outdated date header value (%" TIME_T_FMT " sec)\n", TIME_T_CAST(tnow - tmsg + tdiff));
return -4;
} else {
LM_ERR("Date header value OK\n");
Loading

0 comments on commit 33e6dea

Please sign in to comment.