forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
app-emacs/nxml-libvirt-schemas: Version bump to 7.10.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Ulrich Müller <[email protected]>
- Loading branch information
Showing
2 changed files
with
35 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1 +1,2 @@ | ||
DIST libvirt-5.8.0.tar.xz 13129328 BLAKE2B ff49b0b6dca86f35c68edfb880677c88e0aed8021ed01ebd145922821914edd70c355ca777fe470e2b0e4baf36f2813c1100be9377344f81c9df374068307da1 SHA512 73d18fdf307b8029921a9f1a0c84ca31c50c662a3c0339e3850d6d2f31574168807a6f34943b286ed86a44031decbbc1339f27366da7269e29d38c7094503113 | ||
DIST libvirt-7.10.0.tar.xz 8798000 BLAKE2B 6cb2ab5913d382b11d24b46154dc3250355050cd3038f64ba571b35f33ae5bd0a322d4b96469bd6c78fd848c87f2e6fc7213c33e5bdb9d375a9b81d2a40899bb SHA512 c7eecc9538b68852a8cc67565566d64ec7b087b6f009858b2eb524bc3ef0f6ca3c0da67edf801e6a3ae3fcc0364e65e108fa92bcb01ee810c85fa5f37785aa32 |
34 changes: 34 additions & 0 deletions
34
app-emacs/nxml-libvirt-schemas/nxml-libvirt-schemas-7.10.0.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,34 @@ | ||
# Copyright 1999-2022 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=8 | ||
|
||
inherit elisp | ||
|
||
MY_P="libvirt-${PV}" | ||
DESCRIPTION="Extension for nxml-mode with libvirt schemas" | ||
HOMEPAGE="http://www.libvirt.org/" | ||
SRC_URI="http://libvirt.org/sources/${MY_P}.tar.xz" | ||
S="${WORKDIR}/${MY_P%-rc*}/docs/schemas" | ||
|
||
# This is the license of the package, but the schema files are | ||
# provided without license, maybe it's bad. | ||
LICENSE="LGPL-2.1+" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
# Yes this requires Java, but I'd rather not repackage this, if you | ||
# know something better in C, I'll be glad to use that. | ||
BDEPEND="app-text/trang" | ||
|
||
SITEFILE="60${PN}-gentoo.el" | ||
|
||
src_compile() { | ||
emake -f "${FILESDIR}"/Makefile-trang | ||
} | ||
|
||
src_install() { | ||
insinto "${SITEETC}/${PN}" | ||
doins "${FILESDIR}"/schemas.xml *.rnc | ||
elisp-site-file-install "${FILESDIR}/${SITEFILE}" | ||
} |