Skip to content

Commit

Permalink
net-misc/proxytunnel: add 1.12.1
Browse files Browse the repository at this point in the history
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Feb 6, 2024
1 parent da83df6 commit 6c452e6
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-misc/proxytunnel/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST proxytunnel-1.12.0.tar.gz 57664 BLAKE2B 3d5090a7f8f38fc928d68222e703913fcaade652c4d3cbf28b68682923c3558a7b3e17f00893a60b0cea4e27af185b50cf1ab52064e5125922c50716d5d9c0b7 SHA512 1a448728f49b34a3c6de2a876bfbd57b0f328f9f901db70cf8e6570eef81d2c26a0e0dbdfd566f683cea2d1b4816c01abc7049e5688b0335078034ec3f102b83
DIST proxytunnel-1.12.1.tar.gz 58464 BLAKE2B c2aac8c8eaed6003a5bc56cf07a9ccd47536f75069937d35794029abe36c9037e4363401d6208bbdcf1e50fb8cbed295e3d01e6c8afebb9c4bf00cb269746412 SHA512 e39ff2b623f468e885f173e70de2d6c89eb34e39ce951cbc63f306dacf58bae86af21e92bec27c5b5f777ed95e9eff10f07e2f912e2270c6e49c32487f449ede
45 changes: 45 additions & 0 deletions net-misc/proxytunnel/proxytunnel-1.12.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit flag-o-matic toolchain-funcs

DESCRIPTION="Connect stdin and stdout to a server via an HTTPS proxy"
HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ https://proxytunnel.sourceforge.net/"

LICENSE="GPL-2"
SLOT="0"
IUSE="static"

RDEPEND="dev-libs/openssl:="
DEPEND="${RDEPEND}
app-text/asciidoc
app-text/xmlto
"
BDEPEND="virtual/pkgconfig"

DOCS=( CHANGES CREDITS INSTALL.md KNOWN_ISSUES LICENSE.txt README.md RELNOTES TODO )

if [[ ${PV} == *9999 ]] ; then
EGIT_REPO_URI="https://github.com/${PN}/${PN}.git"
inherit git-r3
else
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
fi

src_prepare() {
default
sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
}

src_compile() {
use static && append-ldflags -static
emake CC="$(tc-getCC)"
}

src_install() {
emake install prefix="${EPREFIX}"/usr DESTDIR="${D}"
einstalldocs
}

0 comments on commit 6c452e6

Please sign in to comment.