forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
games-simulation/flightgear: Version bump 2017.1.3
- Loading branch information
Showing
6 changed files
with
224 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST simgear-2016.4.4.tar.bz2 1200320 SHA256 5514fd0006bbfcdbdc0e2dab7da41eae491ea03a6246cc6a009590032b2fc1dc SHA512 f7b9124e40dba347cd73304fc1b20a5b6d09eb476bc41949d5be615be968a6a66f64141b87819bfa357bd1fd376b2e1fc18334eb1d4df2d4f1e3f95ef4a1928d WHIRLPOOL 3fb4d580d84633a6a852f6a8ab5e708afde9616b636bb5b49d30b56ed232d9938606f602d473e51855605d2544b364691ae362ec974f56b34e32507a37752221 | ||
DIST simgear-2017.1.2.tar.bz2 1235662 SHA256 69c8223051b039b00038aabbb8660cecce1866e3f854dadd9543db824d232f6b SHA512 5746262873f9ca9183bf5bcfbff1493637faa68c8d070a5683f991b414b69b0e432f181394db0c39c939b3d6e433288a143eb3489a407c38f3d26c9033027404 WHIRLPOOL a6b18db36078e1e26c8915ef72a5bb890bcef7433c6c641f314533c637cbcd3a626e4146ddbf7551fc179b9b07989baba04559a0f1684c4b00e94760ddace2cb | ||
DIST simgear-2017.1.3.tar.bz2 1235062 SHA256 85304d985b4fc0dc00d9f7603b02d096e3c24ca4c98adc18dc9af1e2d0e3c310 SHA512 600f883ad92d37bf76d5e6beb066da340c7af927b0f2d51ce290cccaf23d1f3289b1aa31d3aa6cc17a4b9bc57c7180f03e234e08601e4169f26624678bf551aa WHIRLPOOL 377caa9327be22f10e0c45a64db7747d66dc7498b425ae5cf330544e727248b84f907b9eebb7c6b8e6a3272d1929a2b2ae1eaf8a4a542469d1e3615e9a2b7966 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,51 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit eutils cmake-utils | ||
|
||
DESCRIPTION="Development library for simulation games" | ||
HOMEPAGE="http://www.simgear.org/" | ||
SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
KEYWORDS="~amd64 ~x86" | ||
SLOT="0" | ||
IUSE="+dns debug subversion test" | ||
|
||
COMMON_DEPEND=" | ||
dev-libs/expat | ||
>=dev-games/openscenegraph-3.2.0 | ||
media-libs/openal | ||
net-misc/curl | ||
sys-libs/zlib | ||
virtual/opengl | ||
dns? ( net-libs/udns ) | ||
" | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-libs/boost-1.44 | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
subversion? ( dev-vcs/subversion ) | ||
" | ||
|
||
DOCS=(AUTHORS ChangeLog NEWS README Thanks) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DENABLE_DNS=$(usex dns) | ||
-DENABLE_PKGUTIL=ON | ||
-DENABLE_RTI=OFF | ||
-DENABLE_SIMD=ON | ||
-DENABLE_SOUND=ON | ||
-DENABLE_TESTS=$(usex test) | ||
-DSIMGEAR_HEADLESS=OFF | ||
-DSIMGEAR_SHARED=ON | ||
-DSYSTEM_EXPAT=ON | ||
-DSYSTEM_UDNS=ON | ||
-DUSE_AEONWAVE=OFF | ||
-DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO perhaps track it | ||
) | ||
cmake-utils_src_configure | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST FlightGear-2016.4.4-data.tar.bz2 1654119067 SHA256 3dfd4b82c99a8bf4b81dd31846efce52ed417be180eaa71020ccc914f9a49668 SHA512 e9a8dfb17c03fb2961e4d031ef63d56c580f029a7ceee816e67c3944a3a79f476ee1c6ad40ce8af530c8551497d9e1329b00805499ad85c4610c07bfaf22d3aa WHIRLPOOL 249ba21e7ad58c885a92094ec403d99bc8879e9c6638b8ebc2e48053c5524c62383c95ddb9bac3039ddbcd50a90b4a690676df642125e4219fc3c7e94f793717 | ||
DIST FlightGear-2017.1.2-data.tar.bz2 1460657435 SHA256 99d38d0478a8c8031f59376112bd54a6f996e1d363807b3bb45786384cfb2753 SHA512 0498b662a26c03dd08a1861d63e982adeded1a01db34ccf09d2acd9420a0b0343242216c58fa2a2ce215806690eb4d1796114f15f3adbd391fa18421629d4f97 WHIRLPOOL 45a1898ed0ca108d501f3bd35153a2107c4e4f682e3b49a7e8f49015fa5a6b6468d5177cc79458e23f5ae9b3ee2744540ab82a48561d9ba994cb147adc898650 | ||
DIST FlightGear-2017.1.3-data.tar.bz2 1460527272 SHA256 bf35d9a15be9e7bd1c286eee879251e0907a3fb5cca4e7d1fdfbe67690345365 SHA512 eb6140612920b190cec7f2879e4789cfb1ab41ab3c2d463948c592347bfd8f042bb62b499abf94d51e550bc472afe334c77ad750930d954067dc1f6bab66efac WHIRLPOOL c2de9906a0d4f88bafd85edb9b217b1ee766f128c0b6e95f82a6c6a98313c63e26113e5798b5be7e8714831db94bb5c95afc0cbdd570b0c2313dcf856e944523 |
26 changes: 26 additions & 0 deletions
26
games-simulation/flightgear-data/flightgear-data-2017.1.3.ebuild
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
DESCRIPTION="FlightGear data files" | ||
HOMEPAGE="http://www.flightgear.org/" | ||
SRC_URI="mirror://sourceforge/flightgear/FlightGear-${PV}-data.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="" | ||
|
||
# data files split to separate package since 2.10.0 | ||
RDEPEND=" | ||
!<games-simulation/flightgear-2.10.0 | ||
" | ||
|
||
S=${WORKDIR}/fgdata | ||
|
||
src_install() { | ||
insinto /usr/share/flightgear | ||
rm -fr .git | ||
doins -r * | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST flightgear-2016.4.4.tar.bz2 7560911 SHA256 d51992cbe40f1812f9821ab27b838d52e04c10551772d57fc2e815f4444dfafc SHA512 3f3d5a72adea9cb9a22b7b355a18492c1c58634e6203d6ae364d7a89f1af0fcc3df446c72c3c83ac9a1f51e05a6cd83c7d7af5f7bc3a5e8e75e3b80f709394a0 WHIRLPOOL 0a3fc48c5ec440cdcc7f2a99b860c51310fd9f256e5577458ccd9fa5202c26751b982918752326c68b5c6d9554eb902c4789df4a6221752870d3eaf263756226 | ||
DIST flightgear-2017.1.2.tar.bz2 8056697 SHA256 41fe2a4ab0c14ed10436026c2edbb83148bf603691487976aaf2a5314f524659 SHA512 26466d6bd567c06cec7744dccba5c4a70d01c5169153c3c660175e9b400b9d1b5cc0d067e4d53d102ba5c20ceffb2217afcc54a0e86bf8aa7b3e7ee5a60aaf07 WHIRLPOOL f7b8a7884d4738a6e803a27b0dd3a5ad7bfc65d25b6c19baca0b0244222b967963ff3663298a8659ff01fd6aa52c4d7ed91f29792c8b77dded36ec6ba687200c | ||
DIST flightgear-2017.1.3.tar.bz2 8056402 SHA256 3d7cb2b4b1d60b80b0613222b1fc7b6db665eddaf68d7080c07cdedcb544b0ad SHA512 93aa27a976bcdd79c76eb9751ba90a79a6146d8f3961c3bdf1db136a99cb9a0ab644c7409a26267181be0476fa455bf739b78cb7028e3e12d5509f96a1d3f303 WHIRLPOOL 55592116f730eaefb57f1d1eb684629c3cfa4e4167ed4f3a17203b1ce7eacb9885f389cb934a4e3f9d10230ce45410ec09dd2b81220a5077f4c4c545dd8a116c |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,144 @@ | ||
# Copyright 1999-2017 Gentoo Foundation | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=6 | ||
|
||
inherit cmake-utils bash-completion-r1 | ||
|
||
DESCRIPTION="Open Source Flight Simulator" | ||
HOMEPAGE="http://www.flightgear.org/" | ||
SRC_URI="mirror://sourceforge/flightgear/${P}.tar.bz2" | ||
|
||
LICENSE="GPL-2" | ||
SLOT="0" | ||
KEYWORDS="~amd64 ~x86" | ||
IUSE="dbus debug examples qt5 test +udev +utils vim-syntax" | ||
|
||
# zlib is some strange auto-dep from simgear | ||
COMMON_DEPEND=" | ||
dev-db/sqlite:3 | ||
>=dev-games/openscenegraph-3.2.0[png] | ||
~dev-games/simgear-${PV} | ||
media-libs/openal | ||
>=media-libs/speex-1.2.0:0 | ||
media-libs/speexdsp:0 | ||
media-sound/gsm | ||
sys-libs/zlib | ||
virtual/glu | ||
x11-libs/libX11 | ||
dbus? ( >=sys-apps/dbus-1.6.18-r1 ) | ||
qt5? ( | ||
>=dev-qt/qtcore-5.4.1:5 | ||
>=dev-qt/qtgui-5.4.1:5 | ||
>=dev-qt/qtwidgets-5.4.1:5 | ||
) | ||
udev? ( virtual/udev ) | ||
utils? ( | ||
media-libs/freeglut | ||
media-libs/freetype:2 | ||
media-libs/glew:0 | ||
media-libs/libpng:0 | ||
virtual/opengl | ||
qt5? ( >=dev-qt/qtwebsockets-5.4.1:5 ) | ||
) | ||
" | ||
# libXi and libXmu are build-only-deps according to FindGLUT.cmake | ||
DEPEND="${COMMON_DEPEND} | ||
>=dev-libs/boost-1.44 | ||
>=media-libs/plib-1.8.5 | ||
utils? ( | ||
x11-libs/libXi | ||
x11-libs/libXmu | ||
) | ||
" | ||
RDEPEND="${COMMON_DEPEND} | ||
~games-simulation/${PN}-data-${PV} | ||
" | ||
|
||
DOCS=(AUTHORS ChangeLog NEWS README Thanks) | ||
|
||
src_configure() { | ||
local mycmakeargs=( | ||
-DENABLE_FGCOM=$(usex utils) | ||
-DENABLE_FGELEV=$(usex utils) | ||
-DENABLE_FGJS=$(usex utils) | ||
-DENABLE_FGQCANVAS=$(usex qt5 && usex utils) | ||
-DENABLE_FGVIEWER=$(usex utils) | ||
-DENABLE_FLITE=OFF | ||
-DENABLE_GPSSMOOTH=$(usex utils) | ||
-DENABLE_JS_DEMO=$(usex utils) | ||
-DENABLE_JSBSIM=ON | ||
-DENABLE_LARCSIM=ON | ||
-DENABLE_LOGGING=$(usex test) | ||
-DENABLE_METAR=$(usex utils) | ||
-DENABLE_PROFILE=OFF | ||
-DENABLE_QT=$(usex qt5) | ||
-DENABLE_RTI=OFF | ||
-DENABLE_TERRASYNC=$(usex utils) | ||
-DENABLE_TESTS=$(usex test) | ||
-DENABLE_TRAFFIC=$(usex utils) | ||
-DENABLE_UIUC_MODEL=ON | ||
-DENABLE_YASIM=ON | ||
-DEVENT_INPUT=$(usex udev) | ||
-DFG_DATA_DIR=/usr/share/${PN} | ||
-DJSBSIM_TERRAIN=ON | ||
-DOSG_FSTREAM_EXPORT_FIXED=OFF # TODO also see simgear | ||
-DSP_FDMS=ON | ||
-DSYSTEM_FLITE=ON | ||
-DSYSTEM_HTS_ENGINE=ON | ||
-DSYSTEM_SPEEX=ON | ||
-DSYSTEM_GSM=ON | ||
-DSYSTEM_SQLITE=ON | ||
-DUSE_AEONWAVE=OFF | ||
-DUSE_DBUS=$(usex dbus) | ||
-DWITH_FGPANEL=$(usex utils) | ||
) | ||
|
||
cmake-utils_src_configure | ||
} | ||
|
||
src_install() { | ||
cmake-utils_src_install | ||
|
||
# Install icons and menu entry | ||
local s | ||
for s in 16 22 24 32 48 64 128; do | ||
doicon -s ${s} icons/${s}x${s}/apps/${PN}.png | ||
use utils && doicon -s ${s} icons/${s}x${s}/apps/fgcom.png | ||
done | ||
doicon -s scalable icons/scalable/${PN}.svg | ||
use utils && doicon -s scalable icons/scalable/fgcom.svg | ||
|
||
newmenu package/${PN}.desktop ${PN}.desktop | ||
|
||
# Install bash completion (TODO zsh) | ||
# Uncomment below when scripts stops writing files... | ||
# sed -e "s|/usr/local/share/FlightGear|${GAMES_DATADIR}/${PN}|" \ | ||
# -i scripts/completion/fg-completion.bash || die 'unable to replace FG_ROOT' | ||
# newbashcomp scripts/completion/fg-completion.bash ${PN} | ||
|
||
# Install examples and other misc files | ||
if use examples; then | ||
insinto /usr/share/doc/"${PF}"/examples | ||
doins -r scripts/java scripts/perl scripts/python | ||
insinto /usr/share/doc/"${PF}"/examples/c++ | ||
doins -r scripts/example/* | ||
insinto /usr/share/doc/"${PF}"/tools | ||
doins -r scripts/atis scripts/tools/* | ||
fi | ||
|
||
# Install nasal script syntax | ||
if use vim-syntax; then | ||
insinto /usr/share/vim/vimfiles/syntax | ||
doins scripts/syntax/{ac3d,nasal}.vim | ||
insinto /usr/share/vim/vimfiles/ftdetect/ | ||
doins "${FILESDIR}"/{ac3d,nasal}.vim | ||
fi | ||
} | ||
|
||
pkg_postinst() { | ||
einfo "Please note that data files location changed to /usr/share/flightgear" | ||
if use qt5; then | ||
einfo "To use launcher, run fgfs with '--launcher' parameter" | ||
fi | ||
} |