Skip to content

Commit

Permalink
games-util/xboxdrv: add 0.8.11
Browse files Browse the repository at this point in the history
  • Loading branch information
ceamac committed Jul 16, 2024
1 parent 286138c commit 8758330
Show file tree
Hide file tree
Showing 2 changed files with 75 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-util/xboxdrv/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST xboxdrv-0.8.11.tar.gz 323870 BLAKE2B 3cfc5441496e72226a00a82874b580dd7113ff52317cc63afeca94d53c0c20d0d2bd8c458adabdd0e2358746d43de8a2815788d9fd82b21c4e733638a07379f8 SHA512 d6503ee3a4b0388214dd866e479205d37fc9dcd4aa8e8a10edae5db7368d755e2dcc1e4217ecde234c5dd4d0aec3548fd1eea980aa7d6150895ed6dfa3673e5a
DIST xboxdrv-v0.8.8.tar.bz2 268046 BLAKE2B 3092a0e1e1cf1ee351879e791212445c567772f4115eb09eeb0c28bc1692b1951837ae7f6488091eb57d06cd38edae4e964502524606370f1ccd8fc39b307db8 SHA512 9b90f866ab322aaf3223215c78120a7aeacb56970fedf2e603f14704bd517b8316a3e28edb6a75e1a47729e9ced4cde5cac3a2f7a95d8514b83219b8821eb9db
74 changes: 74 additions & 0 deletions games-util/xboxdrv/xboxdrv-0.8.11.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,74 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..13} )

inherit linux-info python-any-r1 scons-utils toolchain-funcs systemd udev

DESCRIPTION="Userspace Xbox 360 Controller driver"
HOMEPAGE="https://github.com/xiota/xboxdrv https://xboxdrv.gitlab.io"
SRC_URI="https://github.com/xiota/xboxdrv/archive/v$(ver_cut 1-3).tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"

RDEPEND="
dev-libs/dbus-glib
dev-libs/glib:2
sys-apps/dbus
virtual/libudev:=
virtual/libusb:1
x11-libs/libX11
"

DEPEND="
${RDEPEND}
"

BDEPEND="
dev-util/glib-utils
virtual/pkgconfig
"

CONFIG_CHECK="~INPUT_EVDEV ~INPUT_JOYDEV ~INPUT_UINPUT ~!JOYSTICK_XPAD"

pkg_setup() {
linux-info_pkg_setup
python-any-r1_pkg_setup
}

src_compile() {
escons \
BUILD=custom \
CXX="$(tc-getCXX)" \
AR="$(tc-getAR)" \
RANLIB="$(tc-getRANLIB)" \
CXXFLAGS="-Wall ${CXXFLAGS}" \
LINKFLAGS="${LDFLAGS}"
}

src_install() {
dobin xboxdrv
doman doc/xboxdrv.1
dodoc AUTHORS NEWS PROTOCOL README.md TODO

newinitd "${FILESDIR}"/xboxdrv.initd xboxdrv
newconfd "${FILESDIR}"/xboxdrv.confd xboxdrv

insinto /etc/dbus-1/system.d
doins "${FILESDIR}"/org.seul.Xboxdrv.conf

udev_newrules "${FILESDIR}"/xboxdrv.udev-rules 99-xbox-controller.rules
systemd_dounit "${FILESDIR}"/xboxdrv.service
}

pkg_postinst() {
udev_reload
}

pkg_postrm() {
udev_reload
}

0 comments on commit 8758330

Please sign in to comment.