forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
dev-libs/libzia: Fix detection of strerror_r return type
Closes: https://bugs.gentoo.org/942789 Signed-off-by: Thomas Beierlein <[email protected]>
- Loading branch information
Showing
2 changed files
with
17 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,14 @@ | ||
# fix detecxtion of return type of strerror_r (bug #942789) | ||
diff --git a/configure.ac b/configure.ac | ||
index 0f4efac..2f4526e 100644 | ||
--- a/configure.ac | ||
+++ b/configure.ac | ||
@@ -511,7 +511,7 @@ fi | ||
|
||
OLDCFLAGS=$CFLAGS | ||
CFLAGS="$CFLAGS -Werror" | ||
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <string.h> ]], [[ int i = strerror_r(1);]])],[ AC_DEFINE([Z_STRERROR_R_RETURNS_INT], [], [strerror_r returns int not char*])],[]) | ||
+AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[ #include <string.h> ]], [[ int i = strerror_r(1, NULL, 1);]])],[ AC_DEFINE([STRERROR_R_RETURNS_INT], [], [strerror_r returns int not char*])],[]) | ||
CFLAGS=$OLDCFLAGS | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters