forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Refreshed all patches. Compile-tested on: cns3xxx, imx6 Runtime-tested on: cns3xxx, imx6 Signed-off-by: Koen Vandeputte <[email protected]>
- Loading branch information
Koen Vandeputte
committed
Jun 12, 2019
1 parent
a7e6892
commit 11b4d29
Showing
10 changed files
with
14 additions
and
49 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -208,7 +208,7 @@ Signed-off-by: John Crispin <[email protected]> | |
|
||
#include <asm/bootinfo.h> | ||
#include <asm/idle.h> | ||
@@ -305,6 +306,11 @@ void __init plat_time_init(void) | ||
@@ -311,6 +312,11 @@ void __init plat_time_init(void) | ||
mips_hpt_frequency = cpu_clk_rate / 2; | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -944,7 +944,7 @@ Signed-off-by: John Crispin <[email protected]> | |
|
||
#define ATH79_SYS_TYPE_LEN 64 | ||
|
||
@@ -230,25 +229,21 @@ void __init plat_mem_setup(void) | ||
@@ -236,25 +235,21 @@ void __init plat_mem_setup(void) | ||
else if (fw_passed_dtb) | ||
__dt_setup_arch((void *)KSEG0ADDR(fw_passed_dtb)); | ||
|
||
|
@@ -979,7 +979,7 @@ Signed-off-by: John Crispin <[email protected]> | |
{ | ||
struct device_node *np; | ||
struct clk *clk; | ||
@@ -278,66 +273,12 @@ static void __init ath79_of_plat_time_in | ||
@@ -284,66 +279,12 @@ static void __init ath79_of_plat_time_in | ||
clk_put(clk); | ||
} | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -71,9 +71,6 @@ Signed-off-by: Kevin Darbyshire-Bryant <[email protected]> | |
create mode 100644 include/uapi/linux/tc_act/tc_ctinfo.h | ||
create mode 100644 net/sched/act_ctinfo.c | ||
|
||
diff --git a/include/net/tc_act/tc_ctinfo.h b/include/net/tc_act/tc_ctinfo.h | ||
new file mode 100644 | ||
index 000000000000..d6a688571672 | ||
--- /dev/null | ||
+++ b/include/net/tc_act/tc_ctinfo.h | ||
@@ -0,0 +1,28 @@ | ||
|
@@ -105,8 +102,6 @@ index 000000000000..d6a688571672 | |
+#define to_ctinfo(a) ((struct tcf_ctinfo *)a) | ||
+ | ||
+#endif /* __NET_TC_CTINFO_H */ | ||
diff --git a/include/uapi/linux/pkt_cls.h b/include/uapi/linux/pkt_cls.h | ||
index be382fb0592d..71e10c5a96a0 100644 | ||
--- a/include/uapi/linux/pkt_cls.h | ||
+++ b/include/uapi/linux/pkt_cls.h | ||
@@ -68,7 +68,8 @@ enum { | ||
|
@@ -119,9 +114,6 @@ index be382fb0592d..71e10c5a96a0 100644 | |
}; | ||
|
||
#define TCA_ID_MAX __TCA_ID_MAX | ||
diff --git a/include/uapi/linux/tc_act/tc_ctinfo.h b/include/uapi/linux/tc_act/tc_ctinfo.h | ||
new file mode 100644 | ||
index 000000000000..da803e05a89b | ||
--- /dev/null | ||
+++ b/include/uapi/linux/tc_act/tc_ctinfo.h | ||
@@ -0,0 +1,34 @@ | ||
|
@@ -159,8 +151,6 @@ index 000000000000..da803e05a89b | |
+}; | ||
+ | ||
+#endif | ||
diff --git a/net/sched/Kconfig b/net/sched/Kconfig | ||
index e95741388311..1d79d5dba6e4 100644 | ||
--- a/net/sched/Kconfig | ||
+++ b/net/sched/Kconfig | ||
@@ -866,6 +866,23 @@ config NET_ACT_CONNMARK | ||
|
@@ -187,8 +177,6 @@ index e95741388311..1d79d5dba6e4 100644 | |
config NET_ACT_SKBMOD | ||
tristate "skb data modification action" | ||
depends on NET_CLS_ACT | ||
diff --git a/net/sched/Makefile b/net/sched/Makefile | ||
index f0403f49edcb..bb3c2bc44af7 100644 | ||
--- a/net/sched/Makefile | ||
+++ b/net/sched/Makefile | ||
@@ -21,6 +21,7 @@ obj-$(CONFIG_NET_ACT_CSUM) += act_csum.o | ||
|
@@ -199,9 +187,6 @@ index f0403f49edcb..bb3c2bc44af7 100644 | |
obj-$(CONFIG_NET_ACT_SKBMOD) += act_skbmod.o | ||
obj-$(CONFIG_NET_ACT_IFE) += act_ife.o | ||
obj-$(CONFIG_NET_IFE_SKBMARK) += act_meta_mark.o | ||
diff --git a/net/sched/act_ctinfo.c b/net/sched/act_ctinfo.c | ||
new file mode 100644 | ||
index 000000000000..8975cb4976aa | ||
--- /dev/null | ||
+++ b/net/sched/act_ctinfo.c | ||
@@ -0,0 +1,395 @@ | ||
|
@@ -600,8 +585,6 @@ index 000000000000..8975cb4976aa | |
+MODULE_AUTHOR("Kevin Darbyshire-Bryant <[email protected]>"); | ||
+MODULE_DESCRIPTION("Connection tracking mark actions"); | ||
+MODULE_LICENSE("GPL"); | ||
diff --git a/tools/testing/selftests/tc-testing/config b/tools/testing/selftests/tc-testing/config | ||
index 203302065458..9d1fddcfb887 100644 | ||
--- a/tools/testing/selftests/tc-testing/config | ||
+++ b/tools/testing/selftests/tc-testing/config | ||
@@ -37,6 +37,7 @@ CONFIG_NET_ACT_SKBEDIT=m | ||
|
@@ -612,6 +595,3 @@ index 203302065458..9d1fddcfb887 100644 | |
CONFIG_NET_ACT_CONNMARK=m | ||
CONFIG_NET_ACT_SKBMOD=m | ||
CONFIG_NET_ACT_IFE=m | ||
-- | ||
2.20.1 (Apple Git-117) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -12,8 +12,6 @@ Signed-off-by: Pawel Dembicki <[email protected]> | |
arch/powerpc/Kconfig | 2 +- | ||
1 file changed, 1 insertion(+), 1 deletion(-) | ||
|
||
diff --git a/arch/powerpc/Kconfig b/arch/powerpc/Kconfig | ||
index a80669209155..f1e9f31ee3b0 100644 | ||
--- a/arch/powerpc/Kconfig | ||
+++ b/arch/powerpc/Kconfig | ||
@@ -197,7 +197,7 @@ config PPC | ||
|
@@ -25,6 +23,3 @@ index a80669209155..f1e9f31ee3b0 100644 | |
select HAVE_KPROBES | ||
select HAVE_KPROBES_ON_FTRACE | ||
select HAVE_KRETPROBES | ||
-- | ||
2.20.1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -17,19 +17,17 @@ Signed-off-by: Pawel Dembicki <[email protected]> | |
arch/powerpc/platforms/85xx/Makefile | 1 + | ||
4 files changed, 20 insertions(+), 1 deletion(-) | ||
|
||
diff --git a/arch/powerpc/boot/Makefile b/arch/powerpc/boot/Makefile | ||
index 25e3184f11f7..0826346fd97c 100644 | ||
--- a/arch/powerpc/boot/Makefile | ||
+++ b/arch/powerpc/boot/Makefile | ||
@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pseries-head.S | ||
@@ -164,6 +164,7 @@ src-plat-$(CONFIG_PPC_PSERIES) += pserie | ||
src-plat-$(CONFIG_PPC_POWERNV) += pseries-head.S | ||
src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S | ||
src-plat-$(CONFIG_MVME7100) += motload-head.S mvme7100.c | ||
+src-plat-$(CONFIG_TL_WDR4900_V1) += simpleboot.c fixed-head.S | ||
|
||
src-wlib := $(sort $(src-wlib-y)) | ||
src-plat := $(sort $(src-plat-y)) | ||
@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm8555 | ||
@@ -343,7 +344,7 @@ image-$(CONFIG_TQM8555) += cuImage.tqm | ||
image-$(CONFIG_TQM8560) += cuImage.tqm8560 | ||
image-$(CONFIG_SBC8548) += cuImage.sbc8548 | ||
image-$(CONFIG_KSI8560) += cuImage.ksi8560 | ||
|
@@ -38,8 +36,6 @@ index 25e3184f11f7..0826346fd97c 100644 | |
# Board ports in arch/powerpc/platform/86xx/Kconfig | ||
image-$(CONFIG_MVME7100) += dtbImage.mvme7100 | ||
|
||
diff --git a/arch/powerpc/boot/wrapper b/arch/powerpc/boot/wrapper | ||
index f9141eaec6ff..bd55094d9899 100755 | ||
--- a/arch/powerpc/boot/wrapper | ||
+++ b/arch/powerpc/boot/wrapper | ||
@@ -302,6 +302,11 @@ adder875-redboot) | ||
|
@@ -54,8 +50,6 @@ index f9141eaec6ff..bd55094d9899 100755 | |
simpleboot-virtex405-*) | ||
platformo="$object/virtex405-head.o $object/simpleboot.o $object/virtex.o" | ||
binary=y | ||
diff --git a/arch/powerpc/platforms/85xx/Kconfig b/arch/powerpc/platforms/85xx/Kconfig | ||
index 68920d42b4bc..2bf6533ce023 100644 | ||
--- a/arch/powerpc/platforms/85xx/Kconfig | ||
+++ b/arch/powerpc/platforms/85xx/Kconfig | ||
@@ -170,6 +170,18 @@ config STX_GP3 | ||
|
@@ -77,18 +71,13 @@ index 68920d42b4bc..2bf6533ce023 100644 | |
config TQM8540 | ||
bool "TQ Components TQM8540" | ||
help | ||
diff --git a/arch/powerpc/platforms/85xx/Makefile b/arch/powerpc/platforms/85xx/Makefile | ||
index d1dd0dca5ebf..d0dab29a33eb 100644 | ||
--- a/arch/powerpc/platforms/85xx/Makefile | ||
+++ b/arch/powerpc/platforms/85xx/Makefile | ||
@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += corenet_generic.o | ||
@@ -26,6 +26,7 @@ obj-$(CONFIG_CORENET_GENERIC) += coren | ||
obj-$(CONFIG_FB_FSL_DIU) += t1042rdb_diu.o | ||
obj-$(CONFIG_STX_GP3) += stx_gp3.o | ||
obj-$(CONFIG_TQM85xx) += tqm85xx.o | ||
+obj-$(CONFIG_TL_WDR4900_V1) += tl_wdr4900_v1.o | ||
obj-$(CONFIG_SBC8548) += sbc8548.o | ||
obj-$(CONFIG_PPA8548) += ppa8548.o | ||
obj-$(CONFIG_SOCRATES) += socrates.o socrates_fpga_pic.o | ||
-- | ||
2.20.1 | ||
|