Skip to content

Commit

Permalink
ath10k-ct: switch to version 5.2
Browse files Browse the repository at this point in the history
Signed-off-by: Hauke Mehrtens <[email protected]>
  • Loading branch information
hauke authored and ynezz committed Jul 17, 2019
1 parent 10fe5ca commit bc5b2bc
Show file tree
Hide file tree
Showing 5 changed files with 606 additions and 3 deletions.
6 changes: 3 additions & 3 deletions package/kernel/ath10k-ct/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,10 +12,10 @@ PKG_SOURCE_DATE:=2019-06-13
PKG_SOURCE_VERSION:=f0aa81302b2286715fa2fa5a2f4ebe2faf17694c
PKG_MIRROR_HASH:=a6d418dfec02842529a53b3c48236e7a375a654a03e199fbc5178bdb269b7d64

# Build the 4.19 ath10k-ct driver version. Other options are "-4.16", or
# leave un-defined for 4.7 kernel. Probably this should match as closely as
# Build the 5.2 ath10k-ct driver version. Other option is "-4.19".
# Probably this should match as closely as
# possible to whatever mac80211 backports version is being used.
CT_KVER="-4.19"
CT_KVER="-5.2"

PKG_MAINTAINER:=Ben Greear <[email protected]>
PKG_BUILD_PARALLEL:=1
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -41,3 +41,29 @@ Origin: other, https://patchwork.kernel.org/patch/10723033/

if (ar->phy_capability & WHAL_WLAN_11A_CAPABILITY)
rateidx += ATH10K_MAC_FIRST_OFDM_RATE_IDX;
--- a/ath10k-5.2/mac.c
+++ b/ath10k-5.2/mac.c
@@ -6518,8 +6518,8 @@ static void ath10k_bss_info_changed(stru
struct cfg80211_chan_def def;
u32 vdev_param, pdev_param, slottime, preamble;
u16 bitrate, hw_value;
- u8 rate, basic_rate_idx;
- int rateidx, ret = 0, hw_rate_code;
+ u8 rate, basic_rate_idx, rateidx;
+ int ret = 0, hw_rate_code, mcast_rate;
enum nl80211_band band;
const struct ieee80211_supported_band *sband;

@@ -6706,7 +6706,11 @@ static void ath10k_bss_info_changed(stru
if (changed & BSS_CHANGED_MCAST_RATE &&
!ath10k_mac_vif_chan(arvif->vif, &def)) {
band = def.chan->band;
- rateidx = vif->bss_conf.mcast_rate[band] - 1;
+ mcast_rate = vif->bss_conf.mcast_rate[band];
+ if (mcast_rate > 0)
+ rateidx = mcast_rate - 1;
+ else
+ rateidx = ffs(vif->bss_conf.basic_rates) - 1;

if (ar->phy_capability & WHAL_WLAN_11A_CAPABILITY)
rateidx += ATH10K_MAC_FIRST_OFDM_RATE_IDX;
Original file line number Diff line number Diff line change
Expand Up @@ -35,3 +35,29 @@ Signed-off-by: Sven Eckelmann <[email protected]>
vdev_param = ar->wmi.vdev_param->mgmt_rate;
ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id, vdev_param,
hw_rate_code);
--- a/ath10k-5.2/mac.c
+++ b/ath10k-5.2/mac.c
@@ -6728,6 +6728,7 @@ static void ath10k_bss_info_changed(stru
"mac vdev %d mcast_rate %x\n",
arvif->vdev_id, rate);

+ arvif->mcast_rate[band] = rate;
vdev_param = ar->wmi.vdev_param->mcast_data_rate;
ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
vdev_param, rate);
@@ -6736,6 +6737,7 @@ static void ath10k_bss_info_changed(stru
"failed to set mcast rate on vdev %i: %d\n",
arvif->vdev_id, ret);

+ arvif->bcast_rate[band] = rate;
vdev_param = ar->wmi.vdev_param->bcast_data_rate;
ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
vdev_param, rate);
@@ -6762,6 +6764,7 @@ static void ath10k_bss_info_changed(stru
return;
}

+ arvif->mgt_rate[def.chan->band] = hw_rate_code;
vdev_param = ar->wmi.vdev_param->mgmt_rate;
ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id, vdev_param,
hw_rate_code);
Loading

0 comments on commit bc5b2bc

Please sign in to comment.