Skip to content

Commit

Permalink
Respect CC and CFLAGS
Browse files Browse the repository at this point in the history
  • Loading branch information
vanillahsu committed Apr 2, 2000
1 parent 8be9691 commit 6ed7761
Show file tree
Hide file tree
Showing 9 changed files with 101 additions and 39 deletions.
6 changes: 3 additions & 3 deletions chinese/autoconvert/files/patch-aa
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
--- Makefile.orig Sat Mar 11 14:41:18 2000
+++ Makefile Sat Mar 11 14:41:24 2000
--- Makefile.orig Wed Jan 5 13:50:05 2000
+++ Makefile Sun Apr 2 11:37:04 2000
@@ -1,6 +1,6 @@

CC=gcc
-CFLAG=-O2 -g -Iinclude
+CFLAG+=-O2 -g -Iinclude
+CFLAG+=-Iinclude


all: autob5 autogb hzlib
6 changes: 3 additions & 3 deletions chinese/autoconvert/files/patch-ab
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
--- hzconvert/Makefile.orig Wed Jan 5 13:12:31 2000
+++ hzconvert/Makefile Sun Mar 12 18:39:46 2000
@@ -1,12 +1,12 @@
+++ hzconvert/Makefile Sun Apr 2 11:37:24 2000
@@ -1,12 +1,11 @@
CC=gcc -I../include
CFLAGS=-O2
-CFLAGS=-O2
OBJS=b2g.o b2u.o g2u.o hz2gb.o b2g_tables.o b2u_tables.o g2u_tables.o io.o unicode.o judge.o
+all:libhzconvert
%.o:%c
Expand Down
13 changes: 10 additions & 3 deletions chinese/c2t/files/patch-01
Original file line number Diff line number Diff line change
@@ -1,8 +1,15 @@
--- Makefile.orig Tue Feb 23 22:21:39 1993
+++ Makefile Tue Feb 4 02:10:15 1997
@@ -1,4 +1,4 @@
--- Makefile.orig Wed Feb 24 14:21:39 1993
+++ Makefile Sun Apr 2 11:42:44 2000
@@ -1,9 +1,9 @@
-CC=cc
+CC=cc -DCHINDICT=\"$(PREFIX)/share/chinese/gb/TONEPY.tit\"

all: c2t

c2t: c2t.o
- $(CC) -O -o c2t c2t.o
+ $(CC) $(CFLAGS) -o c2t c2t.o

c2t.o: c2t.c
- $(CC) -O -c c2t.c
+ $(CC) $(CFLAGS) -c c2t.c
6 changes: 3 additions & 3 deletions chinese/celvis/files/patch-aa
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
--- Makefile.orig Wed May 15 12:09:50 1991
+++ Makefile Thu Aug 15 04:47:32 1996
--- Makefile.orig Thu May 16 03:09:50 1991
+++ Makefile Sun Apr 2 11:44:47 2000
@@ -22,7 +22,7 @@
SRC5= regexp.c regexp.h regsub.c sysdos.c system.c tinytcap.c tio.c tmp.c
SRC6= vars.c vcmd.c vi.c vi.h ctags.c ref.c virec.c wildcard.c shell.c
EXTRA=
-CFLAGS= -O
+CFLAGS= -O -D_HAVE_PARAM_H
+CFLAGS+= -D_HAVE_PARAM_H
LIBS= -ltermcap

all: $(PROGS)
11 changes: 7 additions & 4 deletions chinese/gb2ps/files/patch-01
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- Makefile.orig Sun Aug 16 22:34:14 1992
+++ Makefile Wed Feb 5 00:03:39 1997
@@ -5,9 +5,9 @@
--- Makefile.orig Mon Aug 17 13:34:14 1992
+++ Makefile Sun Apr 2 11:40:36 2000
@@ -5,11 +5,11 @@
# COVERPAGE -- the absolute path and name of coverpage PS file
# -- default is current directory

Expand All @@ -10,5 +10,8 @@
-COVERPAGE=./cover.ps
+COVERPAGE=${PREFIX}/share/chinese/cover.ps

CFLAGS = -DCFONT=\"${CFONT}\" -DCOVERPAGE=\"${COVERPAGE}\"
-CFLAGS = -DCFONT=\"${CFONT}\" -DCOVERPAGE=\"${COVERPAGE}\"
+CFLAGS += -DCFONT=\"${CFONT}\" -DCOVERPAGE=\"${COVERPAGE}\"

all: gb2ps

48 changes: 28 additions & 20 deletions chinese/hztty/files/patch-aa
Original file line number Diff line number Diff line change
@@ -1,20 +1,28 @@
*** Makefile.dist Thu Sep 25 00:26:00 1997
--- Makefile Thu Sep 25 00:47:01 1997
***************
*** 132,138 ****


bsd:
! miniconf.sh $(CPP)
${MAKE} ${MFLAGS} DEFINES='-DBSD' ${PROG}

posix:
--- 134,140 ----


bsd:
! ./miniconf.sh $(CPP)
${MAKE} ${MFLAGS} DEFINES='-DBSD' ${PROG}

posix:

--- Makefile.orig Sun Jan 29 16:39:19 1995
+++ Makefile Sun Apr 2 11:16:03 2000
@@ -19,7 +19,6 @@

CC=cc
CPP=$(CC) -E
-CDEBUGFLAGS= -O
MAKE=make
RM=rm -f

@@ -31,7 +30,7 @@
${OBJ_GB_BIG5} ${OBJ_UNICODE_GB} ${OBJ_UNICODE_BIG5}

DEFINES=
-CFLAGS=${CDEBUGFLAGS} ${DEFINES} ${MODULES_DEF} -I.
+CFLAGS+=${CDEBUGFLAGS} ${DEFINES} ${MODULES_DEF} -I.

PROG = hztty
LIBS=
@@ -132,7 +131,7 @@


bsd:
- miniconf.sh $(CPP)
+ ./miniconf.sh $(CPP)
${MAKE} ${MFLAGS} DEFINES='-DBSD' ${PROG}

posix:
2 changes: 1 addition & 1 deletion chinese/lunar/files/patch-01
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
# Makefile of LUNAR

-CFLAGS= -O
+CFLAGS= -O -DBITMAPFILE=\"$(BITMAPFILE)\"
+CFLAGS+= -DBITMAPFILE=\"$(BITMAPFILE)\"
+
+BITMAPFILE= $(PREFIX)/share/chinese/lunar.bitmap

Expand Down
13 changes: 11 additions & 2 deletions chinese/pine4/files/patch-aa
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
--- imap/src/osdep/unix/Makefile.orig Thu Sep 30 13:54:13 1999
+++ imap/src/osdep/unix/Makefile Thu Oct 14 10:53:41 1999
--- imap/src/osdep/unix/Makefile.orig Wed Nov 17 10:26:06 1999
+++ imap/src/osdep/unix/Makefile Sun Apr 2 12:22:00 2000
@@ -86,7 +86,7 @@
# Commands possibly overriden by the individual port

Expand All @@ -18,3 +18,12 @@
MAKE=make
MV=mv
RM=rm -rf
@@ -194,7 +194,7 @@
SPOOLDIR=/var \
ACTIVEFILE=/usr/local/news/lib/active \
RSHPATH=/usr/bin/rsh \
- BASECFLAGS="-g -O -pipe -DNFSKLUDGE" \
+ BASECFLAGS="-pipe -DNFSKLUDGE" \
BASELDFLAGS="-lcrypt"

bsi: # BSD/i386
35 changes: 35 additions & 0 deletions chinese/pine4/files/patch-bx
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
--- pico/makefile.bsf.orig Wed Aug 19 01:57:03 1998
+++ pico/makefile.bsf Sun Apr 2 12:19:40 2000
@@ -34,10 +34,10 @@
MAKE= make
OPTIMIZE= # -O
PROFILE= # -pg
-DEBUG= -DDEBUG # -g
+###DEBUG= -DDEBUG # -g

STDCFLAGS= -DBSDI -DBSDI2 -DPOSIX -DJOB_CONTROL -DMOUSE
-CFLAGS= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(STDCFLAGS)
+CFLAGS+= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(STDCFLAGS)

# switches for library building
LIBCMD= ar
--- pine/makefile.bsf.orig Fri Aug 28 00:49:51 1998
+++ pine/makefile.bsf Sun Apr 2 12:20:02 2000
@@ -48,7 +48,7 @@
MAKE= make
OPTIMIZE= # -O
PROFILE= # -pg
-DEBUG= -DDEBUG # -g
+#DEBUG= -DDEBUG # -g

CCLIENTDIR= ../c-client
PICODIR= ../pico
@@ -67,7 +67,7 @@
`cat $(CCLIENTDIR)/LDFLAGS`

STDCFLAGS= -DBSDI -DSYSTYPE=\"BSF\" -DMOUSE
-CFLAGS= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(LDAPCFLAGS) \
+CFLAGS+= $(OPTIMIZE) $(PROFILE) $(DEBUG) $(EXTRACFLAGS) $(LDAPCFLAGS) \
$(STDCFLAGS)

OFILES= addrbook.o adrbkcmd.o adrbklib.o args.o bldaddr.o context.o filter.o \

0 comments on commit 6ed7761

Please sign in to comment.