Skip to content

Commit

Permalink
mac80211: Update to version 5.8.18-1
Browse files Browse the repository at this point in the history
The removed patches were applied upstream.

Signed-off-by: Hauke Mehrtens <[email protected]>
  • Loading branch information
hauke committed Dec 16, 2020
1 parent c9c7cdb commit 6cdc21b
Show file tree
Hide file tree
Showing 19 changed files with 38 additions and 218 deletions.
8 changes: 4 additions & 4 deletions package/kernel/mac80211/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,10 +10,10 @@ include $(INCLUDE_DIR)/kernel.mk

PKG_NAME:=mac80211

PKG_VERSION:=5.8-1
PKG_RELEASE:=2
PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.8/
PKG_HASH:=19b4174d89bf11ee221458e11f1e8dace26558498774b823051156f522d2036b
PKG_VERSION:=5.8.18-1
PKG_RELEASE:=1
PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.8.18/
PKG_HASH:=f04a8172423c6a945fc7d9844b04f33fda9ae574e552f8f18ee3bdfcfb494563

PKG_SOURCE:=backports-$(PKG_VERSION).tar.xz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/backports-$(PKG_VERSION)
Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/net/wireless/reg.c
+++ b/net/wireless/reg.c
@@ -3042,6 +3042,8 @@ void regulatory_hint_country_ie(struct w
@@ -3045,6 +3045,8 @@ void regulatory_hint_country_ie(struct w
enum environment_cap env = ENVIRON_ANY;
struct regulatory_request *request = NULL, *lr;

Expand All @@ -9,7 +9,7 @@
/* IE len must be evenly divisible by 2 */
if (country_ie_len & 0x01)
return;
@@ -3293,6 +3295,7 @@ static bool is_wiphy_all_set_reg_flag(en
@@ -3296,6 +3298,7 @@ static bool is_wiphy_all_set_reg_flag(en

void regulatory_hint_disconnect(void)
{
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ Signed-off-by: Rafał Miłecki <[email protected]>

--- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
+++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
@@ -712,8 +712,36 @@ static struct wireless_dev *brcmf_cfg802
@@ -714,8 +714,36 @@ static struct wireless_dev *brcmf_cfg802
struct brcmf_cfg80211_info *cfg = wiphy_to_cfg(wiphy);
struct brcmf_pub *drvr = cfg->pub;
struct wireless_dev *wdev;
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ Signed-off-by: Phil Elwell <[email protected]>

--- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
+++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
@@ -2953,6 +2953,10 @@ brcmf_cfg80211_set_power_mgmt(struct wip
@@ -2955,6 +2955,10 @@ brcmf_cfg80211_set_power_mgmt(struct wip
* preference in cfg struct to apply this to
* FW later while initializing the dongle
*/
Expand Down
8 changes: 4 additions & 4 deletions package/kernel/mac80211/patches/brcm/998-survey.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
+++ b/drivers/net/wireless/broadcom/brcm80211/brcmfmac/cfg80211.c
@@ -2905,6 +2905,63 @@ done:
@@ -2907,6 +2907,63 @@ done:
}

static int
Expand Down Expand Up @@ -64,15 +64,15 @@
brcmf_cfg80211_dump_station(struct wiphy *wiphy, struct net_device *ndev,
int idx, u8 *mac, struct station_info *sinfo)
{
@@ -2994,6 +3051,7 @@ static s32 brcmf_inform_single_bss(struc
@@ -3002,6 +3059,7 @@ static s32 brcmf_inform_single_bss(struc
struct brcmu_chan ch;
u16 channel;
u32 freq;
+ int i;
u16 notify_capability;
u16 notify_interval;
u8 *notify_ie;
@@ -3018,6 +3076,17 @@ static s32 brcmf_inform_single_bss(struc
@@ -3026,6 +3084,17 @@ static s32 brcmf_inform_single_bss(struc
band = NL80211_BAND_5GHZ;

freq = ieee80211_channel_to_frequency(channel, band);
Expand All @@ -90,7 +90,7 @@
bss_data.chan = ieee80211_get_channel(wiphy, freq);
bss_data.scan_width = NL80211_BSS_CHAN_WIDTH_20;
bss_data.boottime_ns = ktime_to_ns(ktime_get_boottime());
@@ -5470,6 +5539,7 @@ static struct cfg80211_ops brcmf_cfg8021
@@ -5478,6 +5547,7 @@ static struct cfg80211_ops brcmf_cfg8021
.leave_ibss = brcmf_cfg80211_leave_ibss,
.get_station = brcmf_cfg80211_get_station,
.dump_station = brcmf_cfg80211_dump_station,
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@
depends on m
default n
help
@@ -197,18 +197,18 @@ config LIB80211
@@ -197,19 +197,19 @@ config LIB80211
Drivers should select this themselves if needed.

config LIB80211_CRYPT_WEP
Expand All @@ -22,6 +22,7 @@
- tristate
+ tristate "lib80211 CCMP support"
depends on m
depends on CRYPTO
depends on CRYPTO_AES
depends on CRYPTO_CCM

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@ Used for AP+STA support in OpenWrt - preserve AP mode keys across STA reconnects

--- a/net/mac80211/cfg.c
+++ b/net/mac80211/cfg.c
@@ -1197,7 +1197,6 @@ static int ieee80211_stop_ap(struct wiph
@@ -1198,7 +1198,6 @@ static int ieee80211_stop_ap(struct wiph
sdata->vif.bss_conf.ftmr_params = NULL;

__sta_info_flush(sdata, true);
Expand Down
2 changes: 1 addition & 1 deletion package/kernel/mac80211/patches/subsys/210-ap_scan.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
--- a/net/mac80211/cfg.c
+++ b/net/mac80211/cfg.c
@@ -2345,7 +2345,7 @@ static int ieee80211_scan(struct wiphy *
@@ -2346,7 +2346,7 @@ static int ieee80211_scan(struct wiphy *
* the frames sent while scanning on other channel will be
* lost)
*/
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
void ieee80211_apply_htcap_overrides(struct ieee80211_sub_if_data *sdata,
--- a/net/mac80211/status.c
+++ b/net/mac80211/status.c
@@ -843,6 +843,11 @@ void ieee80211_tx_monitor(struct ieee802
@@ -846,6 +846,11 @@ void ieee80211_tx_monitor(struct ieee802
struct net_device *prev_dev = NULL;
int rtap_len;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -58,7 +58,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
struct ieee80211_sub_if_data *sdata;
--- a/net/mac80211/rx.c
+++ b/net/mac80211/rx.c
@@ -2578,8 +2578,8 @@ static void ieee80211_deliver_skb_to_loc
@@ -2579,8 +2579,8 @@ static void ieee80211_deliver_skb_to_loc
memset(skb->cb, 0, sizeof(skb->cb));

/* deliver to local stack */
Expand All @@ -69,15 +69,15 @@ Signed-off-by: Felix Fietkau <[email protected]>
else
netif_receive_skb(skb);
}
@@ -3869,7 +3869,6 @@ void ieee80211_release_reorder_timeout(s
@@ -3870,7 +3870,6 @@ void ieee80211_release_reorder_timeout(s
/* This is OK -- must be QoS data frame */
.security_idx = tid,
.seqno_idx = tid,
- .napi = NULL, /* must be NULL to not have races */
};
struct tid_ampdu_rx *tid_agg_rx;

@@ -4479,8 +4478,8 @@ static bool ieee80211_invoke_fast_rx(str
@@ -4480,8 +4479,8 @@ static bool ieee80211_invoke_fast_rx(str
/* deliver to local stack */
skb->protocol = eth_type_trans(skb, fast_rx->dev);
memset(skb->cb, 0, sizeof(skb->cb));
Expand All @@ -88,7 +88,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
else
netif_receive_skb(skb);

@@ -4547,7 +4546,7 @@ static bool ieee80211_prepare_and_rx_han
@@ -4548,7 +4547,7 @@ static bool ieee80211_prepare_and_rx_han
static void __ieee80211_rx_handle_packet(struct ieee80211_hw *hw,
struct ieee80211_sta *pubsta,
struct sk_buff *skb,
Expand All @@ -97,7 +97,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
{
struct ieee80211_local *local = hw_to_local(hw);
struct ieee80211_sub_if_data *sdata;
@@ -4562,7 +4561,7 @@ static void __ieee80211_rx_handle_packet
@@ -4563,7 +4562,7 @@ static void __ieee80211_rx_handle_packet
memset(&rx, 0, sizeof(rx));
rx.skb = skb;
rx.local = local;
Expand All @@ -106,7 +106,7 @@ Signed-off-by: Felix Fietkau <[email protected]>

if (ieee80211_is_data(fc) || ieee80211_is_mgmt(fc))
I802_DEBUG_INC(local->dot11ReceivedFragmentCount);
@@ -4670,8 +4669,8 @@ static void __ieee80211_rx_handle_packet
@@ -4671,8 +4670,8 @@ static void __ieee80211_rx_handle_packet
* This is the receive path handler. It is called by a low level driver when an
* 802.11 MPDU is received from the hardware.
*/
Expand All @@ -117,7 +117,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
{
struct ieee80211_local *local = hw_to_local(hw);
struct ieee80211_rate *rate = NULL;
@@ -4763,36 +4762,53 @@ void ieee80211_rx_napi(struct ieee80211_
@@ -4764,36 +4763,53 @@ void ieee80211_rx_napi(struct ieee80211_
status->rx_flags = 0;

/*
Expand Down

This file was deleted.

Original file line number Diff line number Diff line change
Expand Up @@ -55,12 +55,12 @@ Signed-off-by: Felix Fietkau <[email protected]>
+ agg_shift = 3;
+ else
+ agg_shift = 4;

- return airtime;
+
+ duration *= len;
+ duration /= AVG_PKT_SIZE;
+ duration /= 1024;
+

- return airtime;
+ return duration + (overhead >> agg_shift);
}

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -67,12 +67,12 @@ Signed-off-by: Felix Fietkau <[email protected]>
if (!acked && !noack_success)
- sta->status_stats.retry_failed++;
- sta->status_stats.retry_count += retry_count;
-
+ sta->status_stats.msdu_failed[tid]++;

- if (ieee80211_is_data_present(fc)) {
- if (!acked && !noack_success)
- sta->status_stats.msdu_failed[tid]++;
+ sta->status_stats.msdu_failed[tid]++;

-
- sta->status_stats.msdu_retries[tid] +=
- retry_count;
- }
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <[email protected]>

--- a/net/mac80211/rx.c
+++ b/net/mac80211/rx.c
@@ -1811,9 +1811,6 @@ ieee80211_rx_h_sta_process(struct ieee80
@@ -1812,9 +1812,6 @@ ieee80211_rx_h_sta_process(struct ieee80
sta->rx_stats.last_rate = sta_stats_encode_rate(status);
}

Expand All @@ -122,15 +122,15 @@ Signed-off-by: Felix Fietkau <[email protected]>
sta->rx_stats.fragments++;

u64_stats_update_begin(&rx->sta->rx_stats.syncp);
@@ -4148,7 +4145,6 @@ void ieee80211_check_fast_rx(struct sta_
@@ -4149,7 +4146,6 @@ void ieee80211_check_fast_rx(struct sta_
fastrx.sa_offs = offsetof(struct ieee80211_hdr, addr2);
fastrx.expected_ds_bits = 0;
} else {
- fastrx.sta_notify = sdata->u.mgd.probe_send_count > 0;
fastrx.da_offs = offsetof(struct ieee80211_hdr, addr1);
fastrx.sa_offs = offsetof(struct ieee80211_hdr, addr3);
fastrx.expected_ds_bits =
@@ -4378,11 +4374,6 @@ static bool ieee80211_invoke_fast_rx(str
@@ -4379,11 +4375,6 @@ static bool ieee80211_invoke_fast_rx(str
pskb_trim(skb, skb->len - fast_rx->icv_len))
goto drop;

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -129,7 +129,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
}
--- a/net/mac80211/rx.c
+++ b/net/mac80211/rx.c
@@ -2896,7 +2896,7 @@ ieee80211_rx_h_mesh_fwding(struct ieee80
@@ -2897,7 +2897,7 @@ ieee80211_rx_h_mesh_fwding(struct ieee80
fwd_hdr->frame_control &= ~cpu_to_le16(IEEE80211_FCTL_RETRY);
info = IEEE80211_SKB_CB(fwd_skb);
memset(info, 0, sizeof(*info));
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -30,7 +30,7 @@ Signed-off-by: Felix Fietkau <[email protected]>
/**
--- a/net/mac80211/cfg.c
+++ b/net/mac80211/cfg.c
@@ -1693,6 +1693,7 @@ static int ieee80211_change_station(stru
@@ -1694,6 +1694,7 @@ static int ieee80211_change_station(stru

rcu_assign_pointer(vlansdata->u.vlan.sta, sta);
__ieee80211_check_fast_rx_iface(vlansdata);
Expand Down
Loading

0 comments on commit 6cdc21b

Please sign in to comment.