Skip to content

Commit

Permalink
Revert "ccache: update to 4.1"
Browse files Browse the repository at this point in the history
This reverts commit b1952dc as it's
causing issues on the buildbot which uses some kind of ccache wrapper
and so the breakage needs to be investigated further:

 bash: cmake: command not found
 time: tools/ccache/compile#0.05#0.03#0.15
     ERROR: tools/ccache failed to build.

Signed-off-by: Petr Štetiar <[email protected]>
  • Loading branch information
ynezz committed Dec 22, 2020
1 parent d3c8881 commit 67790f5
Show file tree
Hide file tree
Showing 2 changed files with 18 additions and 15 deletions.
13 changes: 8 additions & 5 deletions tools/ccache/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,22 +8,25 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/target.mk

PKG_NAME:=ccache
PKG_VERSION:=4.1
PKG_VERSION:=3.7.11

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
PKG_HASH:=5fdc804056632d722a1182e15386696f0ea6c59cb4ab4d65a54f0b269ae86f99

HOST_BUILD_PARALLEL:=1
PKG_HASH:=8d450208099a4d202bd7df87caaec81baee20ce9dd62da91e9ea7b95a9072f68

include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk

HOST_CONFIGURE_VARS += CC="$(HOSTCC_NOCACHE)"

define Host/Install/ccache
$(INSTALL_DIR) $(STAGING_DIR_HOST)/bin/
$(CP) ./files/* $(STAGING_DIR_HOST)/bin/
endef

define Host/Clean
-$(MAKE) -C $(HOST_BUILD_DIR) uninstall
$(call Host/Clean/Default)
endef
define Host/Install
$(call Host/Install/Default)
$(call Host/Install/ccache)
Expand Down
20 changes: 10 additions & 10 deletions tools/ccache/patches/100-honour-copts.patch
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
--- a/src/ccache.cpp
+++ b/src/ccache.cpp
@@ -1654,6 +1654,7 @@ calculate_result_name(Context& ctx,
"CPLUS_INCLUDE_PATH",
"OBJC_INCLUDE_PATH",
"OBJCPLUS_INCLUDE_PATH", // clang
+ "GCC_HONOUR_COPTS",
nullptr};
for (const char** p = envvars; *p; ++p) {
const char* v = getenv(*p);
--- a/src/ccache.c
+++ b/src/ccache.c
@@ -2277,6 +2277,7 @@ calculate_object_hash(struct args *args,
"CPLUS_INCLUDE_PATH",
"OBJC_INCLUDE_PATH",
"OBJCPLUS_INCLUDE_PATH", // clang
+ "GCC_HONOUR_COPTS",
NULL
};
for (const char **p = envvars; *p; ++p) {

0 comments on commit 67790f5

Please sign in to comment.