Skip to content

Commit

Permalink
tools: add tar host build, required for --sort=name which was only ad…
Browse files Browse the repository at this point in the history
…ded in the latest version

Signed-off-by: Felix Fietkau <[email protected]>

SVN-Revision: 46876
  • Loading branch information
Felix Fietkau committed Sep 11, 2015
1 parent accc5e3 commit caddbf5
Show file tree
Hide file tree
Showing 3 changed files with 50 additions and 0 deletions.
3 changes: 3 additions & 0 deletions tools/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -81,6 +81,9 @@ endif
# dependency for tools which have patches directory
$(foreach tool, $(tools-y), $(if $(wildcard $(curdir)/$(tool)/patches),$(eval $(curdir)/$(tool)/compile += $(curdir)/patch/install)))

$(foreach tool, $(tools-y), $(eval $(curdir)/$(tool)/compile += $(curdir)/tar/install))
tools-y += tar

$(curdir)/builddirs := $(tools-y) $(tools-dep) $(tools-)
$(curdir)/builddirs-default := $(tools-y)

Expand Down
30 changes: 30 additions & 0 deletions tools/tar/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,30 @@
#
# Copyright (C) 2015 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk

PKG_NAME:=tar
PKG_VERSION:=1.28

PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=@GNU/tar
PKG_MD5SUM:=49b6306167724fe48f419a33a5beb857

HOST_BUILD_PARALLEL := 1

include $(INCLUDE_DIR)/host-build.mk

HOSTCC := $(HOSTCC_NOCACHE)
HOSTCXX := $(HOSTCXX_NOCACHE)

HOST_CONFIGURE_ARGS += \
--without-posix-acls \
--without-selinux \
--without-xattrs \
--disable-acl \
--disable-nls

$(eval $(call HostBuild))
17 changes: 17 additions & 0 deletions tools/tar/patches/100-fix_xattr_disable.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
--- a/lib/xattr-at.c
+++ b/lib/xattr-at.c
@@ -18,6 +18,8 @@

#include <config.h>

+#ifdef HAVE_XATTRS
+
#include "xattr-at.h"
#include "openat.h"

@@ -108,3 +110,5 @@
#undef AT_FUNC_RESULT
#undef AT_FUNC_POST_FILE_PARAM_DECLS
#undef AT_FUNC_POST_FILE_ARGS
+
+#endif

0 comments on commit caddbf5

Please sign in to comment.