forked from archlinux/svntogit-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
archrelease: copy trunk to staging-x86_64
git-svn-id: file:///srv/repos/svn-packages/svn@438286 eb2447ed-0c53-47e4-bac8-5bc4a241df78
- Loading branch information
1 parent
9c06083
commit 49cf2ed
Showing
6 changed files
with
343 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,72 @@ | ||
From 068cd9aec11052733e393976142516d2190e4564 Mon Sep 17 00:00:00 2001 | ||
From: Pierre Ducroquet <[email protected]> | ||
Date: Sun, 28 Feb 2021 23:23:02 +0100 | ||
Subject: [PATCH] Fix some more warnings | ||
|
||
diff --git a/filters/words/msword-odf/wv2/src/styles.cpp b/filters/words/msword-odf/wv2/src/styles.cpp | ||
index f47c3dd8d51..d2c96e3d92b 100644 | ||
--- a/filters/words/msword-odf/wv2/src/styles.cpp | ||
+++ b/filters/words/msword-odf/wv2/src/styles.cpp | ||
@@ -42,7 +42,6 @@ STD::STD() | ||
} | ||
|
||
STD::STD( U16 baseSize, U16 totalSize, OLEStreamReader* stream, bool preservePos ) | ||
-throw(InvalidFormatException) | ||
{ | ||
clearInternal(); | ||
if (!read( baseSize, totalSize, stream, preservePos )) { | ||
@@ -112,7 +111,6 @@ STD& STD::operator=( const STD& rhs ) | ||
} | ||
|
||
bool STD::read( const U16 cbStd, const U16 stdfSize, OLEStreamReader* stream, bool preservePos ) | ||
-throw(InvalidFormatException) | ||
{ | ||
U16 shifterU16; | ||
S32 startOffset=stream->tell(); // address where the STD starts | ||
@@ -938,7 +936,7 @@ void Style::mergeUpechpx( const Style* parentStyle, WordVersion version ) | ||
} | ||
|
||
|
||
-StyleSheet::StyleSheet( OLEStreamReader* tableStream, U32 fcStshf, U32 lcbStshf ) throw(InvalidFormatException) | ||
+StyleSheet::StyleSheet( OLEStreamReader* tableStream, U32 fcStshf, U32 lcbStshf ) | ||
: m_udsNum(0) | ||
{ | ||
WordVersion version = Word8; | ||
diff --git a/filters/words/msword-odf/wv2/src/styles.h b/filters/words/msword-odf/wv2/src/styles.h | ||
index ba02def6845..41c8278dd21 100644 | ||
--- a/filters/words/msword-odf/wv2/src/styles.h | ||
+++ b/filters/words/msword-odf/wv2/src/styles.h | ||
@@ -58,8 +58,9 @@ struct STD | ||
STD(); | ||
/** | ||
* Simply calls read(...) | ||
+ * @throw InvalidFormatException | ||
*/ | ||
- STD( U16 stdfSize, U16 totalSize, OLEStreamReader* stream, bool preservePos = false ) throw(InvalidFormatException); | ||
+ STD( U16 stdfSize, U16 totalSize, OLEStreamReader* stream, bool preservePos = false ); | ||
/** | ||
* Attention: This struct allocates memory on the heap | ||
*/ | ||
@@ -74,8 +75,9 @@ struct STD | ||
* false the state of stream will be changed! | ||
* | ||
* @return true - success, false - failed | ||
+ * @throw InvalidFormatException | ||
*/ | ||
- bool read( const U16 cbStd, const U16 stdfSize, OLEStreamReader* stream, bool preservePos = false ) throw(InvalidFormatException); | ||
+ bool read( const U16 cbStd, const U16 stdfSize, OLEStreamReader* stream, bool preservePos = false ); | ||
|
||
/** | ||
* Same as reading :) | ||
@@ -365,7 +367,10 @@ class WV2_EXPORT Style | ||
class WV2_EXPORT StyleSheet | ||
{ | ||
public: | ||
- StyleSheet( OLEStreamReader* tableStream, U32 fcStshf, U32 lcbStshf ) throw(InvalidFormatException); | ||
+ /** | ||
+ * @throw InvalidFormatException | ||
+ */ | ||
+ StyleSheet( OLEStreamReader* tableStream, U32 fcStshf, U32 lcbStshf ); | ||
~StyleSheet(); | ||
|
||
/** |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
From 2ac46db52c6ad401f67ae5b5fcd859a5872f0311 Mon Sep 17 00:00:00 2001 | ||
From: Pierre Ducroquet <[email protected]> | ||
Date: Sat, 1 May 2021 15:08:57 +0200 | ||
Subject: [PATCH] Small CMake modernization | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index fe6502493ed..b237f68fcb6 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -105,11 +90,7 @@ endif() | ||
message(STATUS "Release build: ${RELEASE_BUILD}") | ||
|
||
# use CPP-11 | ||
-if (CMAKE_VERSION VERSION_LESS "3.1") | ||
- set (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11") | ||
-else () | ||
- set (CMAKE_CXX_STANDARD 11) | ||
-endif () | ||
+set (CMAKE_CXX_STANDARD 11) | ||
|
||
############ | ||
############# |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,50 @@ | ||
From 62f510702ef9c34ac50f8d8601a4290ab558464c Mon Sep 17 00:00:00 2001 | ||
From: =?UTF-8?q?=C3=96mer=20Fad=C4=B1l=20Usta?= <[email protected]> | ||
Date: Sun, 6 Jun 2021 08:41:05 +0000 | ||
Subject: [PATCH] Update Cmake and deps, Fix Freetype and FontConfig Linkage | ||
|
||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index b237f68fcb6..cdcc02f0236 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -89,9 +89,6 @@ if(NOT DEFINED RELEASE_BUILD) | ||
endif() | ||
message(STATUS "Release build: ${RELEASE_BUILD}") | ||
|
||
-# use CPP-11 | ||
-set (CMAKE_CXX_STANDARD 11) | ||
- | ||
############ | ||
############# | ||
## Options ## | ||
@@ -599,8 +593,8 @@ if(NOT WIN32 AND NOT APPLE) | ||
) | ||
endif() | ||
|
||
-if(NOT FONTCONFIG_FOUND OR NOT FREETYPE_FOUND) | ||
- set(FONTCONFIG_INCLUDE_DIR "") | ||
+if(NOT Fontconfig_FOUND OR NOT FREETYPE_FOUND) | ||
+ set(Fontconfig_INCLUDE_DIRS "") | ||
set(FREETYPE_INCLUDE_DIRS "") | ||
else() | ||
add_definitions( -DSHOULD_BUILD_FONT_CONVERSION ) | ||
diff --git a/libs/text/CMakeLists.txt b/libs/text/CMakeLists.txt | ||
index 16d7e066fa2..429afe79704 100644 | ||
--- a/libs/text/CMakeLists.txt | ||
+++ b/libs/text/CMakeLists.txt | ||
@@ -152,11 +152,11 @@ if( SHOULD_BUILD_FEATURE_RDF ) | ||
endif() | ||
|
||
if( FONTCONFIG_FOUND ) | ||
- target_link_libraries(kotext PRIVATE ${FONTCONFIG_LIBRARIES}) | ||
+ target_link_libraries(kotext PRIVATE Fontconfig::Fontconfig) | ||
endif() | ||
|
||
if( FREETYPE_FOUND ) | ||
- target_link_libraries(kotext PRIVATE ${FREETYPE_LIBRARIES}) | ||
+ target_link_libraries(kotext PRIVATE Freetype::Freetype) | ||
endif() | ||
|
||
|
||
-- | ||
GitLab |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
# Maintainer: Felix Yan <[email protected]> | ||
# Maintainer: Antonio Rojas <[email protected]> | ||
# Contributor: Andrea Scarpino <[email protected]> | ||
# Contributor: Ronald van Haren <ronald.archlinux.org> | ||
|
||
pkgname=calligra | ||
pkgdesc='A set of applications for productivity and creative usage' | ||
pkgver=3.2.1 | ||
pkgrel=31 | ||
arch=(x86_64) | ||
url='https://www.calligra-suite.org/' | ||
license=(FDL1.2 GPL2 LGPL) | ||
depends=(kcmutils knotifyconfig kross kactivities kdiagram libspnav kdelibs4support | ||
gsl imath kcontacts qca-qt5 poppler-qt5 libodfgen khtml kinit cauchy) | ||
makedepends=(extra-cmake-modules kdoctools kdesignerplugin libwpg okular eigen marble-common | ||
boost pstoedit libvisio libetonyek libwps vc libgit2 kcalendarcore akonadi) | ||
optdepends=('libwpg: Corel WordPerfect Graphics image importer' | ||
'libwps: Microsoft Works file word processor format import' | ||
'libvisio: Microsoft Visio import filter' | ||
'libetonyek: Apple Keynote import filter' | ||
'pstoedit: EPS to SVG filter' | ||
'poppler: PDF to SVG filter' | ||
'libgit2: Calligra Gemini git plugin' | ||
'kirigami2: for Calligra Gemini' | ||
'qt5-quickcontrols: for Calligra Gemini' | ||
'qt5-webengine: for Calligra Gemini') | ||
source=(https://download.kde.org/stable/$pkgname/$pkgver/$pkgname-$pkgver.tar.xz{,.sig} | ||
calligra-openexr3.patch | ||
poppler-22.03.0.patch | ||
068cd9ae.patch | ||
2ac46db5.patch | ||
62f51070.patch) | ||
sha256sums=('b1f8a6eb8208543a2f908caa83d089075fcd1e530d00e19f5362b2f9cc371147' | ||
'SKIP' | ||
'96fbe4f06bf184e60ff653a1574f0f0523af5b4672ced2a501cd54642961dffe' | ||
'92593726793577e314ba25359450ee8c3f84b75fb4e99d9cd6baf4ca5df6d2d0' | ||
'4516d15421209e5d8c8b5008140dbcb1eefa96b0e96e0da49b343e1799a8cefd' | ||
'c88e6d7a1f67c1b5413b624aa67fca2841205fdf4201f6682f69bae737582922' | ||
'8a94e076c09887ff0741da3276ce4652063351b884c66d4c9ba0cde431dbb867') | ||
validpgpkeys=(05D00A8B73A686789E0A156858B9596C722EA3BD # Boudewijn Rempt <[email protected]> | ||
42A60D06F449E895F40F09C01638B8A616108B8A) # Dag Andersen <[email protected]> | ||
options=(debug) | ||
|
||
prepare() { | ||
patch -d $pkgname-$pkgver -p1 < calligra-openexr3.patch # Fix build with OpenEXR 3 | ||
patch -d $pkgname-$pkgver -p1 < poppler-22.03.0.patch # Fix build with poppler 22.03.0 | ||
patch -d $pkgname-$pkgver -p1 < 068cd9ae.patch # Remove dynamic exception specifications | ||
patch -d $pkgname-$pkgver -p1 < 2ac46db5.patch # Prerequisite for the following patch | ||
patch -d $pkgname-$pkgver -p1 < 62f51070.patch # Fix fontconfig linking | ||
} | ||
|
||
build() { | ||
cmake -B build -S $pkgname-$pkgver \ | ||
-DCMAKE_CXX_STANDARD=17 \ | ||
-DBUILD_TESTING=OFF | ||
cmake --build build | ||
} | ||
|
||
package() { | ||
DESTDIR="$pkgdir" cmake --install build | ||
|
||
# Remove utterly broken thumbnailers | ||
rm "$pkgdir"/usr/lib/qt/plugins/calligra*thumbnail.so | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,89 @@ | ||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 8955357ff97..ea56c84bb11 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -363,8 +363,13 @@ endif () | ||
## Check for OpenEXR | ||
## | ||
|
||
-macro_optional_find_package(OpenEXR) | ||
-macro_bool_to_01(OPENEXR_FOUND HAVE_OPENEXR) | ||
+macro_optional_find_package(Imath 3.0 CONFIG QUIET) | ||
+if(TARGET Imath::Imath) | ||
+ set(OPENEXR_LIBRARIES Imath::Imath) | ||
+else() | ||
+ macro_optional_find_package(OpenEXR) | ||
+endif() | ||
+macro_bool_to_01(OpenEXR_FOUND HAVE_OPENEXR) | ||
|
||
## | ||
## Test for GNU Scientific Library | ||
diff --git a/libs/pigment/CMakeLists.txt b/libs/pigment/CMakeLists.txt | ||
index a039251e2ad..6eb6a8e70b6 100644 | ||
--- a/libs/pigment/CMakeLists.txt | ||
+++ b/libs/pigment/CMakeLists.txt | ||
@@ -12,7 +12,7 @@ include_directories( ${PIGMENT_INCLUDES} ${Boost_INCLUDE_DIR}) | ||
|
||
set(FILE_OPENEXR_SOURCES) | ||
set(LINK_OPENEXR_LIB) | ||
-if(OPENEXR_FOUND) | ||
+if(OpenEXR_FOUND) | ||
include_directories(${OPENEXR_INCLUDE_DIR}) | ||
set(LINK_OPENEXR_LIB ${OPENEXR_LIBRARIES}) | ||
add_definitions(${OPENEXR_DEFINITIONS}) | ||
diff --git a/plugins/colorengines/lcms2/CMakeLists.txt b/plugins/colorengines/lcms2/CMakeLists.txt | ||
index 77807ff9702..920adbeaf87 100644 | ||
--- a/plugins/colorengines/lcms2/CMakeLists.txt | ||
+++ b/plugins/colorengines/lcms2/CMakeLists.txt | ||
@@ -31,7 +31,7 @@ include_directories( | ||
${CMAKE_CURRENT_SOURCE_DIR}/colorprofiles | ||
) | ||
|
||
-if (HAVE_LCMS24 AND OPENEXR_FOUND) | ||
+if (HAVE_LCMS24 AND OpenEXR_FOUND) | ||
include_directories( | ||
${CMAKE_CURRENT_SOURCE_DIR}/colorspaces/gray_f16 | ||
${CMAKE_CURRENT_SOURCE_DIR}/colorspaces/rgb_f16 | ||
@@ -41,7 +41,7 @@ endif () | ||
|
||
set(FILE_OPENEXR_SOURCES) | ||
set(LINK_OPENEXR_LIB) | ||
-if(OPENEXR_FOUND) | ||
+if(OpenEXR_FOUND) | ||
include_directories(${OPENEXR_INCLUDE_DIR}) | ||
set(LINK_OPENEXR_LIB ${OPENEXR_LIBRARIES}) | ||
add_definitions(${OPENEXR_DEFINITIONS}) | ||
@@ -80,7 +80,7 @@ set ( lcmsengine_SRCS | ||
LcmsEnginePlugin.cpp | ||
) | ||
|
||
-if (HAVE_LCMS24 AND OPENEXR_FOUND) | ||
+if (HAVE_LCMS24 AND OpenEXR_FOUND) | ||
set ( lcmsengine_SRCS | ||
${lcmsengine_SRCS} | ||
colorspaces/gray_f16/GrayF16ColorSpace.cpp | ||
diff --git a/plugins/colorengines/lcms2/tests/CMakeLists.txt b/plugins/colorengines/lcms2/tests/CMakeLists.txt | ||
index 2540acc834c..77bd0b3fe4a 100644 | ||
--- a/plugins/colorengines/lcms2/tests/CMakeLists.txt | ||
+++ b/plugins/colorengines/lcms2/tests/CMakeLists.txt | ||
@@ -12,7 +12,7 @@ include_directories( ../colorspaces/cmyk_u16 | ||
../colorprofiles | ||
.. | ||
) | ||
-if(OPENEXR_FOUND) | ||
+if(OpenEXR_FOUND) | ||
include_directories(${OPENEXR_INCLUDE_DIR}) | ||
endif() | ||
include_directories( ${PIGMENT_INCLUDES} ${LCMS2_INCLUDE_DIR} ) | ||
diff --git a/CMakeLists.txt b/CMakeLists.txt | ||
index 4a77c4be50b..89636205c2b 100644 | ||
--- a/CMakeLists.txt | ||
+++ b/CMakeLists.txt | ||
@@ -341,6 +341,7 @@ endif () | ||
macro_optional_find_package(Imath 3.0 CONFIG QUIET) | ||
if(TARGET Imath::Imath) | ||
set(OPENEXR_LIBRARIES Imath::Imath) | ||
+ set(OpenEXR_FOUND TRUE) | ||
else() | ||
macro_optional_find_package(OpenEXR) | ||
endif() |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
diff -uprw calligra-3.2.1.orig/filters/karbon/pdf/CMakeLists.txt calligra-3.2.1/filters/karbon/pdf/CMakeLists.txt | ||
--- calligra-3.2.1.orig/filters/karbon/pdf/CMakeLists.txt 2020-05-14 09:51:30.000000000 +0300 | ||
+++ calligra-3.2.1/filters/karbon/pdf/CMakeLists.txt 2022-03-02 12:19:08.039939530 +0200 | ||
@@ -14,6 +14,10 @@ if(Poppler_VERSION VERSION_LESS "0.83.0" | ||
add_definitions("-DHAVE_POPPLER_PRE_0_83") | ||
endif() | ||
|
||
+if(Poppler_VERSION VERSION_LESS "22.3.0") | ||
+ add_definitions("-DHAVE_POPPLER_PRE_22_3") | ||
+endif() | ||
+ | ||
set(pdf2svg_PART_SRCS PdfImportDebug.cpp PdfImport.cpp SvgOutputDev.cpp ) | ||
|
||
add_library(calligra_filter_pdf2svg MODULE ${pdf2svg_PART_SRCS}) | ||
diff -uprw calligra-3.2.1.orig/filters/karbon/pdf/Pdf2OdgImport.cpp calligra-3.2.1/filters/karbon/pdf/Pdf2OdgImport.cpp | ||
--- calligra-3.2.1.orig/filters/karbon/pdf/Pdf2OdgImport.cpp 2020-05-14 09:51:30.000000000 +0300 | ||
+++ calligra-3.2.1/filters/karbon/pdf/Pdf2OdgImport.cpp 2022-03-02 12:20:35.125605950 +0200 | ||
@@ -86,8 +86,12 @@ KoFilter::ConversionStatus Pdf2OdgImport | ||
if (! globalParams) | ||
return KoFilter::NotImplemented; | ||
|
||
+#ifdef HAVE_POPPLER_PRE_22_3 | ||
GooString * fname = new GooString(QFile::encodeName(m_chain->inputFile()).data()); | ||
PDFDoc * pdfDoc = new PDFDoc(fname, 0, 0, 0); | ||
+#else | ||
+ PDFDoc * pdfDoc = new PDFDoc(std::make_unique<GooString>(QFile::encodeName(m_chain->inputFile()).data())); | ||
+#endif | ||
if (! pdfDoc) { | ||
#ifdef HAVE_POPPLER_PRE_0_83 | ||
delete globalParams; | ||
diff -uprw calligra-3.2.1.orig/filters/karbon/pdf/PdfImport.cpp calligra-3.2.1/filters/karbon/pdf/PdfImport.cpp | ||
--- calligra-3.2.1.orig/filters/karbon/pdf/PdfImport.cpp 2020-05-14 09:51:30.000000000 +0300 | ||
+++ calligra-3.2.1/filters/karbon/pdf/PdfImport.cpp 2022-03-02 12:21:46.197510028 +0200 | ||
@@ -73,8 +73,12 @@ KoFilter::ConversionStatus PdfImport::co | ||
if (! globalParams) | ||
return KoFilter::NotImplemented; | ||
|
||
+#ifdef HAVE_POPPLER_PRE_22_3 | ||
GooString * fname = new GooString(QFile::encodeName(m_chain->inputFile()).data()); | ||
PDFDoc * pdfDoc = new PDFDoc(fname, 0, 0, 0); | ||
+#else | ||
+ PDFDoc * pdfDoc = new PDFDoc(std::make_unique<GooString>(QFile::encodeName(m_chain->inputFile()).data())); | ||
+#endif | ||
if (! pdfDoc) { | ||
#ifdef HAVE_POPPLER_PRE_0_83 | ||
delete globalParams; |