Skip to content

Commit

Permalink
fixed svn conflict
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@26279 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
eric committed Feb 5, 2009
1 parent 0b93e70 commit 5193171
Show file tree
Hide file tree
Showing 2 changed files with 24 additions and 16 deletions.
30 changes: 14 additions & 16 deletions alsaplayer/repos/extra-i686/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,28 +1,26 @@
# $Id$
# Maintainer: dorphell <dorphell@archlinux.org>
# Maintainer: Eric Belanger <eric@archlinux.org>
# Contributor: Jochem Kossen <[email protected]>

pkgname=alsaplayer
pkgver=0.99.80
pkgrel=1
pkgdesc="A heavily multi-threaded PCM player that tries to excercise the ALSA library and driver quite a bit."
license=('GPL')
url="http://www.alsaplayer.org/"
arch=('i686' 'x86_64')
depends=('gtk' 'libid3tag' 'libvorbis' 'libmad' 'libmikmod' 'jack-audio-connection-kit>=0.102.20-2' 'esd' 'gcc-libs')
source=(http://www.alsaplayer.org/${pkgname}-${pkgver}.tar.bz2) # flac_patch.diff)
md5sums=('04f8c2321a37d15f40f9ee21251c6202')
url="http://www.alsaplayer.org/"
license=('GPL')
depends=('gtk' 'libid3tag' 'libvorbis' 'libmad' 'libmikmod' 'jack-audio-connection-kit>=0.102.20-2' 'esound' 'gcc-libs')
options=('!libtool')
source=(http://www.alsaplayer.org/${pkgname}-${pkgver}.tar.bz2 gcc.diff)
md5sums=('04f8c2321a37d15f40f9ee21251c6202' '0c1790e4744d9b085208436f5442efe0')
sha1sums=('883d590b01371840024b5a8bf0fe95b464a2ccd1' '684ac4ea9f58e63da7f4c9518196128714575066')

build() {
cd ${startdir}/src/${pkgname}-${pkgver}
autoconf
#fix compilation with flac support on x86_64
# [ "$CARCH" = "x86_64" ] && patch -Np1 -i $startdir/flac_patch.diff
./configure --prefix=/usr --enable-esd \
--disable-opengl --enable-gtk --enable-jack \
--disable-gtk2 --enable-audiofile
make || return 1
make DESTDIR=${startdir}/pkg install
cd ${startdir}/src/${pkgname}-${pkgver}
patch -p0 < ../gcc.diff || return 1
./configure --prefix=/usr --enable-esd \
--disable-opengl --enable-gtk --enable-jack \
--disable-gtk2 --enable-audiofile || return 1
make || return 1
make DESTDIR=${startdir}/pkg install || return 1
}

10 changes: 10 additions & 0 deletions alsaplayer/repos/extra-i686/gcc.diff
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- app/ControlSocket.cpp.orig 2008-07-04 22:34:38.000000000 +0200
+++ app/ControlSocket.cpp 2008-07-04 22:35:53.000000000 +0200
@@ -28,6 +28,7 @@
#include <sys/un.h>
#include <csignal>
#include <pwd.h>
+#include <climits>
#include "control.h"
#include "message.h"
#include "Playlist.h"

0 comments on commit 5193171

Please sign in to comment.