forked from archlinux/svntogit-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
archrelease: copy trunk to gnome-unstable-i686, gnome-unstable-x86_64
git-svn-id: file:///srv/repos/svn-packages/svn@261860 eb2447ed-0c53-47e4-bac8-5bc4a241df78
- Loading branch information
jgc
committed
Mar 16, 2016
1 parent
f8fbe3f
commit 998999e
Showing
2 changed files
with
66 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# $Id$ | ||
# Maintainer: Ionut Biru <[email protected]> | ||
|
||
pkgname=at-spi2-atk | ||
pkgver=2.19.92 | ||
pkgrel=1 | ||
pkgdesc="A GTK+ module that bridges ATK to D-Bus at-spi" | ||
arch=('i686' 'x86_64') | ||
url="https://wiki.gnome.org/Accessibility" | ||
license=('GPL2') | ||
depends=('at-spi2-core' 'libx11' 'atk') | ||
makedepends=('intltool') | ||
source=(http://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz) | ||
sha256sums=('ca14964ae08a2e57d28ec4f9c9e3edb0507f4e032bef00b27c44e71df1a25fe1') | ||
|
||
build() { | ||
cd $pkgname-$pkgver | ||
|
||
sed -i -e '/AC_PATH_XTRA/d' configure.ac | ||
autoreconf --force --install | ||
|
||
./configure --prefix=/usr --sysconfdir=/etc \ | ||
--disable-schemas-compile | ||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool | ||
make | ||
} | ||
|
||
package() { | ||
cd $pkgname-$pkgver | ||
make DESTDIR="$pkgdir" install | ||
} | ||
|
||
# vim:set ts=2 sw=2 et: |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,33 @@ | ||
# $Id$ | ||
# Maintainer: Ionut Biru <[email protected]> | ||
|
||
pkgname=at-spi2-atk | ||
pkgver=2.19.92 | ||
pkgrel=1 | ||
pkgdesc="A GTK+ module that bridges ATK to D-Bus at-spi" | ||
arch=('i686' 'x86_64') | ||
url="https://wiki.gnome.org/Accessibility" | ||
license=('GPL2') | ||
depends=('at-spi2-core' 'libx11' 'atk') | ||
makedepends=('intltool') | ||
source=(http://download.gnome.org/sources/$pkgname/${pkgver:0:4}/$pkgname-$pkgver.tar.xz) | ||
sha256sums=('ca14964ae08a2e57d28ec4f9c9e3edb0507f4e032bef00b27c44e71df1a25fe1') | ||
|
||
build() { | ||
cd $pkgname-$pkgver | ||
|
||
sed -i -e '/AC_PATH_XTRA/d' configure.ac | ||
autoreconf --force --install | ||
|
||
./configure --prefix=/usr --sysconfdir=/etc \ | ||
--disable-schemas-compile | ||
sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool | ||
make | ||
} | ||
|
||
package() { | ||
cd $pkgname-$pkgver | ||
make DESTDIR="$pkgdir" install | ||
} | ||
|
||
# vim:set ts=2 sw=2 et: |