Skip to content

Commit

Permalink
archrelease: copy trunk to testing-x86_64
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@403278 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
antonio-rojas committed Dec 10, 2020
1 parent b08bff1 commit a87eff2
Showing 1 changed file with 41 additions and 0 deletions.
41 changes: 41 additions & 0 deletions akonadi/repos/testing-x86_64/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>
# Contributor: Pierre Schmitz <[email protected]>

pkgbase=akonadi
pkgname=(akonadi libakonadi)
pkgver=20.12.0
pkgrel=1
pkgdesc="PIM layer, which provides an asynchronous API to access all kind of PIM data"
arch=(x86_64)
url='https://kontact.kde.org'
license=(LGPL)
makedepends=(extra-cmake-modules postgresql qt5-tools boost kitemmodels kaccounts-integration)
source=("https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('37318b79992264e996d8afa14fa332e984a60e3a31de36f6da03ca395c2e6813'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

build() {
cmake -B build -S $pkgname-$pkgver \
-DBUILD_TESTING=OFF
cmake --build build
}

package_libakonadi() {
pkgdesc='Libraries used by applications based on Akonadi'
depends=(kitemmodels kaccounts-integration)

DESTDIR="$pkgdir" cmake --install build
rm -r "$pkgdir"/usr/bin # Provided by akonadi
}

package_akonadi() {
depends=(libakonadi mariadb)
optdepends=('postgresql: PostgreSQL backend')

DESTDIR="$pkgdir" cmake --install build
rm -r "$pkgdir"/{etc,usr/{include,lib,share}} # Provided by libakonadi
}

0 comments on commit a87eff2

Please sign in to comment.