Skip to content

Commit

Permalink
adding kdelibs version 3 for some old applications
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@6416 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
pierre committed Jul 24, 2008
1 parent be6a3e7 commit df3a7a1
Show file tree
Hide file tree
Showing 2 changed files with 67 additions and 0 deletions.
52 changes: 52 additions & 0 deletions kdelibs3/trunk/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# $ Id: $
# Maintainer: Pierre Schmitz <[email protected]>
# Contributor: Tobias Powalowski <[email protected]>

pkgname=kdelibs3
pkgver=3.5.9
pkgrel=1
pkgdesc="KDE3 Core Libraries"
arch=('i686' 'x86_64')
url="http://www.kde.org"
license=('GPL' 'LGPL')
depends=('db>=4.7' 'libxslt' 'pcre' 'libart-lgpl' 'openexr' 'alsa-lib' 'libcups'
'avahi>=0.6.9' 'jasper>=1.900.1' 'bzip2' 'openssl' 'libidn' 'perl'
'aspell' 'heimdal>=1.0.1' 'acl' 'libtiff' 'qt3>=3.3.7' 'ca-certificates')
makedepends=('pkgconfig' 'cups' 'lua')
options=('libtool')
source=("http://download.kde.org/stable/${pkgver}/src/kdelibs-${pkgver}.tar.bz2" 'kde3.profile')
md5sums=('55e5f00874933d1a7ba7c95e369a205e' '3c49828eb8985cfb25af8e1495f7800a')

build() {
cd $srcdir/kdelibs-$pkgver

. /etc/profile.d/qt3.sh
. $srcdir/kde3.profile

# install KDE3 profile
install -D -m755 $srcdir/kde3.profile $pkgdir/etc/profile.d/kde3.sh

./configure --prefix=/opt/kde \
--with-distribution='Arch Linux' \
--with-alsa \
--disable-dependency-tracking \
--disable-debug \
--disable-dnssd \
--disable-dnotify \
--enable-inotify \
--enable-sendfile \
--without-lua \
--without-hspell \
--enable-gcc-hidden-visibility \
--enable-final \
--enable-new-ldflags LDFLAGS="${LDFLAGS} -L/opt/qt/lib" \
--without-arts \
--disable-libfam || return 1
make || return 1
make DESTDIR=$pkgdir install || return 1

# cert bundle seems to be hardcoded
# link it to the one from ca-certificates
rm -f $pkgdir/opt/kde/share/apps/kssl/ca-bundle.crt
ln -sf /etc/ssl/certs/ca-certificates.crt $pkgdir/opt/kde/share/apps/kssl/ca-bundle.crt
}
15 changes: 15 additions & 0 deletions kdelibs3/trunk/kde3.profile
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
export KDE3DIR=/opt/kde
export KDEDIRS=/usr:$KDE3DIR
export PATH=$PATH:$KDE3DIR/bin
export PKG_CONFIG_PATH=$PKG_CONFIG_PATH:$KDE3DIR/lib/pkgconfig
if [ ! -z $XDG_DATA_DIRS ]; then
export XDG_DATA_DIRS=$XDG_DATA_DIRS:$KDE3DIR/share
else
export XDG_DATA_DIRS=$KDE3DIR/share
fi
if [ ! -z $XDG_CONFIG_DIRS ]; then
export XDG_CONFIG_DIRS=$XDG_CONFIG_DIRS:$KDE3DIR/etc/xdg
else
export XDG_CONFIG_DIRS=$KDE3DIR/etc/xdg
fi
unset KDE3DIR

0 comments on commit df3a7a1

Please sign in to comment.