Skip to content

Commit

Permalink
ath79: Add support for OpenMesh MR900 v2
Browse files Browse the repository at this point in the history
Device specifications:
======================

* Qualcomm/Atheros QCA9558 ver 1 rev 0
* 720/600/240 MHz (CPU/DDR/AHB)
* 128 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 3T3R 2.4 GHz Wi-Fi
* 3T3R 5 GHz Wi-Fi
* 6x GPIO-LEDs (2x wifi, 2x status, 1x lan, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default))
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 1x ethernet
  - AR8035 ethernet PHY (RGMII)
  - 10/100/1000 Mbps Ethernet
  - 802.3af POE
  - used as LAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin [email protected]:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <[email protected]>
[rebase, add LED migration]
Signed-off-by: Adrian Schmutzler <[email protected]>
  • Loading branch information
ecsv authored and adschm committed Jan 19, 2021
1 parent e06c9ee commit 31172e5
Show file tree
Hide file tree
Showing 8 changed files with 23 additions and 3 deletions.
2 changes: 1 addition & 1 deletion package/boot/uboot-envtools/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=uboot-envtools
PKG_DISTNAME:=u-boot
PKG_VERSION:=2020.04
PKG_RELEASE:=18
PKG_RELEASE:=19

PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:= \
Expand Down
1 change: 1 addition & 0 deletions package/boot/uboot-envtools/files/ath79
Original file line number Diff line number Diff line change
Expand Up @@ -51,6 +51,7 @@ ocedo,raccoon|\
openmesh,mr600-v1|\
openmesh,mr600-v2|\
openmesh,mr900-v1|\
openmesh,mr900-v2|\
openmesh,om5p|\
openmesh,om5p-ac-v2|\
samsung,wam250|\
Expand Down
8 changes: 8 additions & 0 deletions target/linux/ath79/dts/qca9558_openmesh_mr900-v2.dts
Original file line number Diff line number Diff line change
@@ -0,0 +1,8 @@
// SPDX-License-Identifier: GPL-2.0-or-later OR MIT

#include "qca9558_openmesh_mr900.dtsi"

/ {
compatible = "openmesh,mr900-v2", "qca,qca9558";
model = "OpenMesh MR900 v2";
};
3 changes: 2 additions & 1 deletion target/linux/ath79/generic/base-files/etc/board.d/01_leds
Original file line number Diff line number Diff line change
Expand Up @@ -158,7 +158,8 @@ telco,t1)
comfast,cf-wr752ac-v1|\
engenius,eap300-v2|\
enterasys,ws-ap3705i|\
openmesh,mr900-v1)
openmesh,mr900-v1|\
openmesh,mr900-v2)
ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
;;
compex,wpj344-16m|\
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -49,6 +49,7 @@ ath79_setup_interfaces()
openmesh,mr600-v1|\
openmesh,mr600-v2|\
openmesh,mr900-v1|\
openmesh,mr900-v2|\
pcs,cap324|\
pisen,ts-d084|\
pisen,wmb001n|\
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -23,7 +23,8 @@ openmesh,mr600-v1)
openmesh,mr600-v2)
migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
;;
openmesh,mr900-v1)
openmesh,mr900-v1|\
openmesh,mr900-v2)
migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
;;
pcs,cap324)
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -53,6 +53,7 @@ platform_do_upgrade() {
openmesh,mr600-v1|\
openmesh,mr600-v2|\
openmesh,mr900-v1|\
openmesh,mr900-v2|\
openmesh,om2p-v2|\
openmesh,om2p-v4|\
openmesh,om2p-hs-v1|\
Expand Down
7 changes: 7 additions & 0 deletions target/linux/ath79/image/generic.mk
Original file line number Diff line number Diff line change
Expand Up @@ -1572,6 +1572,13 @@ define Device/openmesh_mr900-v1
endef
TARGET_DEVICES += openmesh_mr900-v1

define Device/openmesh_mr900-v2
$(Device/openmesh_mr900-common)
DEVICE_VARIANT := v2
SUPPORTED_DEVICES += mr900v2
endef
TARGET_DEVICES += openmesh_mr900-v2

define Device/openmesh_om2p-common
DEVICE_VENDOR := OpenMesh
DEVICE_PACKAGES := uboot-envtools
Expand Down

0 comments on commit 31172e5

Please sign in to comment.