Skip to content

Commit

Permalink
games-strategy/0ad: Bump to version 0.0.22_alpha
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.3
  • Loading branch information
Lars Wendler committed Jul 27, 2017
1 parent c9f9ad2 commit 644a4c6
Show file tree
Hide file tree
Showing 2 changed files with 147 additions and 0 deletions.
146 changes: 146 additions & 0 deletions games-strategy/0ad/0ad-0.0.22_alpha.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,146 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6

WX_GTK_VER="3.0"

PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="threads,ssl"

inherit eutils wxwidgets toolchain-funcs gnome2-utils python-any-r1

MY_P=0ad-${PV/_/-}
DESCRIPTION="A free, real-time strategy game"
HOMEPAGE="https://play0ad.com/"
SRC_URI="http://releases.wildfiregames.com/${MY_P}-unix-build.tar.xz"

LICENSE="GPL-2 LGPL-2.1 MIT CC-BY-SA-3.0 ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="editor +lobby nvtt pch sound test"
RESTRICT="test"

RDEPEND="
dev-libs/boost:=
dev-libs/icu:=
dev-libs/libxml2
dev-libs/nspr
~games-strategy/0ad-data-${PV}
media-libs/libpng:0
media-libs/libsdl2[X,opengl,video]
net-libs/enet:1.3
net-libs/miniupnpc:=
net-misc/curl
sys-libs/zlib
virtual/jpeg:0
virtual/opengl
x11-libs/libX11
x11-libs/libXcursor
editor? ( x11-libs/wxGTK:${WX_GTK_VER}[X,opengl] )
lobby? ( net-libs/gloox )
nvtt? ( media-gfx/nvidia-texture-tools )
sound? ( media-libs/libvorbis
media-libs/openal )"
DEPEND="${RDEPEND}
${PYTHON_DEPS}
virtual/pkgconfig
test? ( dev-lang/perl )"

S="${WORKDIR}/${MY_P}"

pkg_setup() {
python-any-r1_pkg_setup
}

PATCHES=(
"${FILESDIR}"/${PN}-0.0.21_alpha-gentoo.patch
)

src_configure() {
local myconf=(
--with-system-nvtt
--with-system-miniupnpc
--minimal-flags
$(usex nvtt "" "--without-nvtt")
$(usex pch "" "--without-pch")
$(usex test "" "--without-tests")
$(usex sound "" "--without-audio")
$(usex editor "--atlas" "")
$(usex lobby "" "--without-lobby")
--collada
--bindir="/usr/bin"
--libdir="/usr/$(get_libdir)"/${PN}
--datadir="/usr/share/${PN}"
)

# stock premake4 does not work, use the shipped one
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# regenerate scripts.c so our patch applies
cd "${S}"/build/premake/premake4 || die
"${S}"/build/premake/premake4/bin/release/premake4 embed || die

# rebuild premake again... this is the most stupid build system
emake -C "${S}"/build/premake/premake4/build/gmake.unix clean
emake -C "${S}"/build/premake/premake4/build/gmake.unix

# run premake to create build scripts
cd "${S}"/build/premake || die
"${S}"/build/premake/premake4/bin/release/premake4 \
--file="premake4.lua" \
--outpath="../workspaces/gcc/" \
--platform=$(usex amd64 "x64" "x32") \
--os=linux \
"${myconf[@]}" \
gmake || die "Premake failed"
}

src_compile() {
tc-export AR

# build bundled and patched spidermonkey
cd libraries/source/spidermonkey || die
JOBS="${MAKEOPTS}" ./build.sh || die
cd "${S}" || die

# build 3rd party fcollada
emake -C libraries/source/fcollada/src

# build 0ad
emake -C build/workspaces/gcc verbose=1
}

src_test() {
cd binaries/system || die
./test -libdir "${S}/binaries/system" || die "test phase failed"
}

src_install() {
newbin binaries/system/pyrogenesis 0ad
use editor && newbin binaries/system/ActorEditor 0ad-ActorEditor

insinto /usr/share/${PN}
doins -r binaries/data/l10n

exeinto /usr/$(get_libdir)/${PN}
doexe binaries/system/libCollada.so
doexe libraries/source/spidermonkey/lib/*.so
use editor && doexe binaries/system/libAtlasUI.so

dodoc binaries/system/readme.txt
doicon -s 128 build/resources/${PN}.png
make_desktop_entry ${PN}
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
gnome2_icon_cache_update
}

pkg_postrm() {
gnome2_icon_cache_update
}
1 change: 1 addition & 0 deletions games-strategy/0ad/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST 0ad-0.0.20-alpha-unix-build.tar.xz 25610932 SHA256 a396d5cb37057ddd3cd523434f70c56be21588a2228443e7508d2b2d610fc68e SHA512 786f92b74c2e0c64c07ef2f5578dcb5c753fb4fed7238d385bca23549805fcfaeecb9bfbfae809a2ac09a7dfc804455237346588099db347c28a3ff0ae284c43 WHIRLPOOL 2d4b4e96dcb80e265cbbbddfe3b52e72110a419713f6644a68d2a9d499ffc57f03d5b68e612d00ccd889ec9a19609b968af450b228ef586d9567bd16cbc76fcb
DIST 0ad-0.0.21-alpha-unix-build.tar.xz 29196476 SHA256 96be23e4284a3931ef9536f988f2517040bde1f8700ee048bff18c932d8683cf SHA512 68f3586375f7dcbf3dfb6476040b8b43da8e2ea1e74947223ff5c9936b54a93caef919d8982d78c6f4ad01ee8f707b38a2c37cdab88ea5c5408544364cff4c37 WHIRLPOOL 8e72c2c3311169eabab5a8a028ffc90b8d6838f72d23ebbac3e5331a7f9434bbe7cae8cf0f5a97bf30b913f7f7f737d264aaf86298f8f65c81a270b0c4e5f871
DIST 0ad-0.0.22-alpha-unix-build.tar.xz 29199308 SHA256 fddd36df4fd32b5b31fd8871bc5ed3ec71a921de79517fb6199ba7571ec9f5b1 SHA512 3f917e77c6cc1d3fb585c98950db6eab3f5895ba3db41a8737f8172c769b5582689b436cab31eeafecce0e9639ee456afc7b78ebb03435b06512eb9fe7393771 WHIRLPOOL ae33f4f77cb981a0e8f00969c6b1ee05a2f06bacb70f79bfac74fda383bffedd4c6027370d5003e3d7815d5c68e13308b3553d8810bc69eebee143231968e95c

0 comments on commit 644a4c6

Please sign in to comment.