forked from archlinux/svntogit-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Fix FS#38602 git-svn-id: file:///srv/repos/svn-packages/svn@269280 eb2447ed-0c53-47e4-bac8-5bc4a241df78
- Loading branch information
jgc
committed
Jun 10, 2016
1 parent
7134520
commit 71058fd
Showing
2 changed files
with
25 additions
and
4 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,24 +1,28 @@ | ||
# $Id$ | ||
# Maintainer: | ||
# Maintainer: Jan de Groot <[email protected]> | ||
# Maintainer: Tom Gundersen <[email protected]> | ||
# Contributor: Thomas Baechler <[email protected]> | ||
# Contributor: Sarah Hay <[email protected]> | ||
|
||
pkgname=a52dec | ||
pkgver=0.7.4 | ||
pkgrel=8 | ||
pkgrel=9 | ||
pkgdesc="A free library for decoding ATSC A/52 streams" | ||
url="http://liba52.sourceforge.net/" | ||
arch=('i686' 'x86_64') | ||
license=('GPL2') | ||
depends=('glibc') | ||
source=("http://liba52.sourceforge.net/files/${pkgname}-${pkgver}.tar.gz" | ||
'a52dec-0.7.4-build.patch') | ||
'a52dec-0.7.4-build.patch' | ||
'stderr.patch') | ||
md5sums=('caa9f5bc44232dc8aeea773fea56be80' | ||
'fa16f224a7dceb7613824380abef0052') | ||
'fa16f224a7dceb7613824380abef0052' | ||
'52f57e003259a24516eaab08b64ae703') | ||
|
||
prepare() { | ||
cd "${pkgname}-${pkgver}" | ||
patch -Np1 -i ../a52dec-0.7.4-build.patch | ||
patch -Np1 -i ../stderr.patch | ||
sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.in | ||
mv configure.in configure.ac | ||
./bootstrap | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,17 @@ | ||
diff -aur a52dec-0.7.4.orig/liba52/imdct.c a52dec-0.7.4/liba52/imdct.c | ||
--- a52dec-0.7.4.orig/liba52/imdct.c 2016-06-10 02:39:52.984345055 -0700 | ||
+++ a52dec-0.7.4/liba52/imdct.c 2016-06-10 02:41:08.304633486 -0700 | ||
@@ -419,13 +419,11 @@ | ||
|
||
#ifdef LIBA52_DJBFFT | ||
if (mm_accel & MM_ACCEL_DJBFFT) { | ||
- fprintf (stderr, "Using djbfft for IMDCT transform\n"); | ||
ifft128 = (void (*) (complex_t *)) fftc4_un128; | ||
ifft64 = (void (*) (complex_t *)) fftc4_un64; | ||
} else | ||
#endif | ||
{ | ||
- fprintf (stderr, "No accelerated IMDCT transform found\n"); | ||
ifft128 = ifft128_c; | ||
ifft64 = ifft64_c; | ||
} |