forked from archlinux/svntogit-packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
git-svn-id: file:///srv/repos/svn-packages/svn@5601 eb2447ed-0c53-47e4-bac8-5bc4a241df78
- Loading branch information
jgc
committed
Jul 18, 2008
1 parent
b2853e5
commit dad5520
Showing
2 changed files
with
43 additions
and
11 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,21 +1,26 @@ | ||
# $Id$ | ||
# Maintainer: arjan <arjan@archlinux.org> | ||
#contributor Sarah Hay <[email protected]> | ||
# Maintainer: Thomas Baechler <thomas@archlinux.org> | ||
# contributor: Sarah Hay <[email protected]> | ||
|
||
pkgname=a52dec | ||
pkgver=0.7.4 | ||
pkgrel=3 | ||
pkgrel=4 | ||
pkgdesc="liba52 is a free library for decoding ATSC A/52 streams." | ||
depends=(glibc) | ||
source=(http://liba52.sourceforge.net/files/$pkgname-$pkgver.tar.gz) | ||
arch=('i686' 'x86_64') | ||
license=('GPL2') | ||
depends=('glibc') | ||
options=(!libtool) | ||
source=(http://liba52.sourceforge.net/files/${pkgname}-${pkgver}.tar.gz | ||
a52dec-0.7.4-build.patch) | ||
url="http://liba52.sourceforge.net/" | ||
md5sums=('caa9f5bc44232dc8aeea773fea56be80') | ||
md5sums=('caa9f5bc44232dc8aeea773fea56be80' 'fa16f224a7dceb7613824380abef0052') | ||
|
||
build() { | ||
cd $startdir/src/$pkgname-$pkgver | ||
./configure --prefix=/usr --enable-shared | ||
cd ${srcdir}/${pkgname}-${pkgver} | ||
patch -Np1 -i ${srcdir}/a52dec-0.7.4-build.patch || return 1 | ||
./bootstrap || return 1 | ||
./configure --prefix=/usr --enable-shared || return 1 | ||
make || return 1 | ||
make DESTDIR=$startdir/pkg install | ||
install -m644 liba52/a52_internal.h $startdir/pkg/usr/include/a52dec/ | ||
find $startdir/pkg -name '*.la' -exec rm {} \; | ||
make DESTDIR=${pkgdir} install || return 1 | ||
install -m644 liba52/a52_internal.h $startdir/pkg/usr/include/a52dec/ || return 1 | ||
} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,27 @@ | ||
diff -Naur a52dec-0.7.4.orig/liba52/Makefile.am a52dec-0.7.4/liba52/Makefile.am | ||
--- a52dec-0.7.4.orig/liba52/Makefile.am 2002-01-27 20:36:48.000000000 -0800 | ||
+++ a52dec-0.7.4/liba52/Makefile.am 2004-11-05 01:10:21.317401872 -0800 | ||
@@ -1,4 +1,3 @@ | ||
-CFLAGS = @CFLAGS@ @LIBA52_CFLAGS@ | ||
|
||
lib_LTLIBRARIES = liba52.la | ||
|
||
diff -Naur a52dec-0.7.4.orig/liba52/configure.incl a52dec-0.7.4/liba52/configure.incl | ||
--- a52dec-0.7.4.orig/liba52/configure.incl 2002-01-27 20:36:48.000000000 -0800 | ||
+++ a52dec-0.7.4/liba52/configure.incl 2004-11-05 01:11:38.172672216 -0800 | ||
@@ -2,7 +2,6 @@ | ||
AC_SUBST([LIBA52_LIBS]) | ||
|
||
dnl avoid -fPIC when possible | ||
-LIBA52_CFLAGS="$LIBA52_CFLAGS -prefer-non-pic" | ||
|
||
AC_ARG_ENABLE([double], | ||
[ --enable-double use double-precision samples]) | ||
diff -Naur a52dec-0.7.4.orig/src/Makefile.am a52dec-0.7.4/src/Makefile.am | ||
--- a52dec-0.7.4.orig/src/Makefile.am 2002-06-22 18:51:57.000000000 -0700 | ||
+++ a52dec-0.7.4/src/Makefile.am 2004-11-05 01:10:21.320401375 -0800 | ||
@@ -1,4 +1,3 @@ | ||
-CFLAGS = @A52DEC_CFLAGS@ | ||
|
||
bin_PROGRAMS = a52dec extract_a52 | ||
a52dec_SOURCES = a52dec.c getopt.c gettimeofday.c |