Skip to content

Commit

Permalink
KDE Applications 17.12 beta
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@310087 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
antonio-rojas committed Nov 17, 2017
1 parent 9547d52 commit fbae67c
Show file tree
Hide file tree
Showing 213 changed files with 8,268 additions and 0 deletions.
39 changes: 39 additions & 0 deletions akonadi-calendar-tools/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadi-calendar-tools
pkgver=17.11.80
pkgrel=1
pkgdesc="CLI tools to manage akonadi calendars"
arch=(x86_64)
url="https://community.kde.org/KDE_PIM"
license=(GPL2)
depends=(hicolor-icon-theme calendarsupport)
makedepends=(extra-cmake-modules kdoctools kdesignerplugin boost python)
conflicts=(konsolekalendar)
replaces=(konsolekalendar)
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('d872b9685bd9de57e6a860884dd70040efd26aab3d6221452f4c8b8f12bed3b9'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
35 changes: 35 additions & 0 deletions akonadi-calendar/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-calendar
pkgver=17.11.80
pkgrel=1
pkgdesc="Akonadi calendar integration"
arch=(x86_64)
url="https://community.kde.org/KDE_PIM"
license=(LGPL)
depends=(kmailtransport kcalutils akonadi-contacts)
makedepends=(extra-cmake-modules kdoctools boost python kdesignerplugin)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('548ff783964cbc52d020d8ea39318d4a324ba3b8649e0e561f63a31971f0ce40'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
37 changes: 37 additions & 0 deletions akonadi-contacts/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-contacts
pkgver=17.11.80
pkgrel=1
pkgdesc="Libraries and daemons to implement Contact Management in Akonadi"
arch=(x86_64)
url="https://community.kde.org/KDE_PIM"
license=(LGPL)
depends=(akonadi kcontacts kmime prison)
makedepends=(extra-cmake-modules kdoctools python boost akonadi-mime kcalcore kdesignerplugin)
conflicts=(akonadi-contact)
replaces=(akonadi-contact)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('00239fca6d584c047fb05e27ac9e1853ec535c84cc9d1f48b930512d36d597c0'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
39 changes: 39 additions & 0 deletions akonadi-import-wizard/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadi-import-wizard
pkgver=17.11.80
pkgrel=1
pkgdesc="Import data from other mail clients to KMail"
arch=(x86_64)
url="https://community.kde.org/KDE_PIM"
license=(GPL2)
depends=(mailcommon)
makedepends=(extra-cmake-modules boost kdoctools python)
optdepends=('kdepim-addons: additional import plugins')
conflicts=('kmail<16.11')
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('b77ab6ee15000936ce7906be6d38c71efd4c18ae3e58de99195114aa22655415'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
35 changes: 35 additions & 0 deletions akonadi-mime/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-mime
pkgver=17.11.80
pkgrel=1
pkgdesc="Libraries and daemons to implement basic email handling"
arch=(x86_64)
url="https://community.kde.org/KDE_PIM"
license=(LGPL)
depends=(akonadi kmime)
makedepends=(extra-cmake-modules python kdoctools boost)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('badb30466bd1e453b55a5ef80b7b8af6b13268a4aa4f2c9e1dd4ba06ecc3a59e'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
35 changes: 35 additions & 0 deletions akonadi-notes/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Maintainer: Antonio Rojas <[email protected]>

pkgname=akonadi-notes
pkgver=17.11.80
pkgrel=1
pkgdesc="Libraries and daemons to implement management of notes in Akonadi"
arch=(x86_64)
url="https://community.kde.org/KDE_PIM"
license=(LGPL)
depends=(kmime)
makedepends=(extra-cmake-modules python akonadi boost)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('4924fdbb0c305686d0b1267dd6167fa009596074343cb2e416f6eefd4350cd76'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
36 changes: 36 additions & 0 deletions akonadi-search/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
# Maintainer: Antonio Rojas <[email protected]>
# Contributor: Gustavo Alvarez <[email protected]>

pkgname=akonadi-search
pkgver=17.11.80
pkgrel=1
pkgdesc="Libraries and daemons to implement searching in Akonadi"
url='https://community.kde.org/KDE_PIM'
arch=(x86_64)
license=(GPL LGPL FDL)
depends=(xapian-core akonadi-mime kcontacts kcalcore krunner kcmutils)
makedepends=(extra-cmake-modules kdoctools boost python kdesignerplugin)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('a63e80805737ab934e9fbd0f06f380b17b3ce0aa7382f4d0ae5f389d3303c376'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
42 changes: 42 additions & 0 deletions akonadi/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,42 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>
# Contributor: Andrea Scarpino <[email protected]>
# Contributor: Pierre Schmitz <[email protected]>

pkgname=akonadi
pkgver=17.11.80
pkgrel=1
pkgdesc="PIM layer, which provides an asynchronous API to access all kind of PIM data"
arch=(x86_64)
url='https://community.kde.org/KDE_PIM/Akonadi'
license=(LGPL)
depends=(kio kitemmodels mariadb hicolor-icon-theme)
makedepends=(extra-cmake-modules postgresql qt5-tools boost python kdesignerplugin)
optdepends=('postgresql: PostgreSQL backend')
conflicts=(akonadi-client)
provides=(akonadi-client)
replaces=(akonadi-client)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('274aba7f428559e283521463033a860ba1339f31e39fde8832211637f50e8bf3'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
37 changes: 37 additions & 0 deletions akonadiconsole/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akonadiconsole
pkgver=17.11.80
pkgrel=1
pkgdesc="Akonadi management and debugging console"
arch=(x86_64)
url="https://community.kde.org/KDE_PIM"
license=(GPL2)
depends=(hicolor-icon-theme calendarsupport messagelib)
makedepends=(extra-cmake-modules kdoctools kdesignerplugin boost python)
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('13b733b22b08efcc1afc110f64241d2480003b8d28b0b6b812c7cc31c5a80d4d'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
38 changes: 38 additions & 0 deletions akregator/kde-unstable/PKGBUILD
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
# Maintainer: Antonio Rojas <[email protected]>
# Maintainer: Felix Yan <[email protected]>

pkgname=akregator
pkgver=17.11.80
pkgrel=1
pkgdesc="A Feed Reader by KDE"
arch=(x86_64)
url="https://community.kde.org/KDE_PIM"
license=(GPL2)
depends=(kontactinterface messagelib knotifyconfig ktexteditor kde-syndication)
makedepends=(extra-cmake-modules boost kdoctools python)
optdepends=('kdepim-addons: additional plugins')
groups=(kde-applications kdepim)
source=("https://download.kde.org/unstable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"{,.sig})
sha256sums=('721ff28a6f1719608a584e0a401ad37394c663c9ffcfa63fa95e4b8f69c73279'
'SKIP')
validpgpkeys=(CA262C6C83DE4D2FB28A332A3A6A4DB839EAA6D7 # Albert Astals Cid <[email protected]>
F23275E4BF10AFC1DF6914A6DBD2CE893E2D1C87) # Christoph Feck <[email protected]>

prepare() {
mkdir -p build
}

build() {
cd build
cmake ../$pkgname-$pkgver \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_TESTING=OFF
make
}

package() {
cd build
make DESTDIR="$pkgdir" install
}
Loading

0 comments on commit fbae67c

Please sign in to comment.