forked from freebsd/freebsd-ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
py-tftpy is a Pure Python TFTP Implementation.
PR: ports/146480 Submitted by: Ju Pengfei <[email protected]>
- Loading branch information
Showing
5 changed files
with
52 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
# New ports collection makefile for: py-tftpy | ||
# Date created: 11 May 2010 | ||
# Whom: Ju Pengfei <[email protected]> | ||
# | ||
# $FreeBSD$ | ||
# | ||
|
||
PORTNAME= tftpy | ||
PORTVERSION= 0.5.0 | ||
CATEGORIES= ftp python | ||
MASTER_SITES= SF \ | ||
CHEESESHOP | ||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= A Pure Python TFTP Implementation | ||
|
||
USE_PYTHON= yes | ||
USE_PYDISTUTILS= yes | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
MD5 (tftpy-0.5.0.tar.gz) = eebb8c9e3e874702d9f75bc25e65a4ad | ||
SHA256 (tftpy-0.5.0.tar.gz) = c8e797ee9f49153759f578211854f6cf62a8032c42c5c9f3905c03258cd3855e | ||
SIZE (tftpy-0.5.0.tar.gz) = 20614 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
TFTPy is a Pure Python TFTP Implementation. | ||
|
||
WWW: http://tftpy.sourceforge.net/ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,24 @@ | ||
bin/tftpy_client.py | ||
bin/tftpy_server.py | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpServer.py | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpPacketTypes.py | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpStates.py | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpShared.py | ||
%%PYTHON_SITELIBDIR%%/tftpy/__init__.py | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpClient.py | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpPacketFactory.py | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpServer.pyc | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpPacketTypes.pyc | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpStates.pyc | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpShared.pyc | ||
%%PYTHON_SITELIBDIR%%/tftpy/__init__.pyc | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpClient.pyc | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpPacketFactory.pyc | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpServer.pyo | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpPacketTypes.pyo | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpStates.pyo | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpShared.pyo | ||
%%PYTHON_SITELIBDIR%%/tftpy/__init__.pyo | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpClient.pyo | ||
%%PYTHON_SITELIBDIR%%/tftpy/TftpPacketFactory.pyo | ||
@dirrm %%PYTHON_SITELIBDIR%%/tftpy |