Skip to content
/ gentoo Public
forked from gentoo/gentoo

Commit

Permalink
dev-db/rqlite: add 8.36.8
Browse files Browse the repository at this point in the history
Signed-off-by: Zac Medico <[email protected]>
  • Loading branch information
zmedico committed Jan 24, 2025
1 parent 3f16cb9 commit 5fceeac
Show file tree
Hide file tree
Showing 2 changed files with 47 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-db/rqlite/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,5 @@ DIST rqlite-8.36.5-deps.tar.xz 4081984 BLAKE2B a607643062279a256729687b1bbc821b2
DIST rqlite-8.36.5.tar.gz 749309 BLAKE2B 43bb5740cb153c6971d9a8dee598078969aa93bcd5d81d06baa8ddd83ab0c28737056d7442689c8907e288bdcb0d34475a6e7db96ca2d45d4b41d6e719a97487 SHA512 07eff0135ca8685fd6d48b13ba991232b515f0eaa9aa61b3f5d4ba6e38252f2430342cdbe89ecc96a09abf36c1f85511fcb08a34c0adf75f7f292c023e3d9927
DIST rqlite-8.36.6-deps.tar.xz 4082040 BLAKE2B 1ec6bb86f0daa2bcc3e4d723215e06e2ba06d5f8961c367afa688cf988a186dcbaaaf3905e37f358f05f4a8367e62c9cf2287425f782e0cd2135881ed25dc14c SHA512 9f9be57a9c2f0d01b987ec48775d3acbea23daee92be463ce8248e8022b7811a9bcd347da25847ef3c600b6e8df5160982614387574a4088216fc879babdc399
DIST rqlite-8.36.6.tar.gz 770581 BLAKE2B a55017838601bde4bd1a424fd161272c4fbc821e899c10fd9af66da6c83691d634558fdf08d2896070c4d16ce477013462826edc254297385ac4ddff232ed0cf SHA512 b61986724c8967820985abe209a20357f652ec92e88069ed763896b35354fd318a00f6928c682e0d03ce942428cc9e3fcb06511eec5d453a634cf51d360fe0fa
DIST rqlite-8.36.8-deps.tar.xz 4079916 BLAKE2B d8c34b7c9ec0b172af7f551093e811a5c829ab9c26430ec30ac0e9f5984d8fd9f49d50fb15c9fd8fed9c576a26fa5232854dcb7b2c49b226f74f210233246fee SHA512 3f6f1ecd7fb9f638535f4a19ac88a7b39a16f42ae16d2afbfc33ed3eadfd8b22facaf4693c1eeb810765a2e0caf845ee60a9d2f492adc0df75ca7249a69058b3
DIST rqlite-8.36.8.tar.gz 776252 BLAKE2B c4375d64bc6558782f1835a1968d211cd7b8d662ea6c5951ac4abc4a008a018172f644ed9af437e61efd09f7e2568341e24dad991c07a6105c17caba81aa03f1 SHA512 8008dc190146b27bde6b0e7660bd290c70f26d2cf087a4a1d9faf1ea557c10cfecaa8660d1bf0d21c36fde57a07f8dd021a1eed9b141bf25a8763120592a0da0
45 changes: 45 additions & 0 deletions dev-db/rqlite/rqlite-8.36.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,45 @@
# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8
inherit go-module
EGIT_COMMIT=768eafc309ff05a57d041d2b19f67994ce83a5c5

DESCRIPTION="Replicated SQLite using the Raft consensus protocol"
HOMEPAGE="https://github.com/rqlite/rqlite https://www.philipotoole.com/tag/rqlite/"
SRC_URI="https://github.com/rqlite/rqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz
https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"

LICENSE="MIT"
LICENSE+=" Apache-2.0 BSD CC0-1.0 MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"

src_unpack() {
default
}

src_prepare() {
ln -sv ../vendor ./ || die
default
}

src_compile() {
GOBIN="${S}/bin" \
ego install \
-ldflags="-X main.version=v${PV}
-X main.branch=master
-X main.commit=${EGIT_COMMIT}
-X main.buildtime=$(date +%Y-%m-%dT%T%z)" \
./cmd/... || die
}

src_test() {
GOBIN="${S}/bin" \
ego test ./... || die
}

src_install() {
dobin bin/*
dodoc -r *.md DOC
}

0 comments on commit 5fceeac

Please sign in to comment.