Skip to content
/ gentoo Public
forked from gentoo/gentoo

Commit

Permalink
sci-mathematics/petsc: add 3.21.3
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/929795
Signed-off-by: Matthias Maier <[email protected]>
  • Loading branch information
tamiko committed Jul 3, 2024
1 parent 770e748 commit b27eaf5
Show file tree
Hide file tree
Showing 4 changed files with 276 additions and 0 deletions.
1 change: 1 addition & 0 deletions sci-mathematics/petsc/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -6,3 +6,4 @@ DIST petsc-3.19.1.tar.gz 16659061 BLAKE2B 8c7b22e5f97756261a5d0e8b707670d55db53e
DIST petsc-3.19.2.tar.gz 16627765 BLAKE2B 1267db717989c3819f32ac6a62642054af2ac49d9e9276ffd4f0846d73e31ae4a5dcca4ad794b91cdb29463b7ec68040baa4e1cad99aaef8ab910ff7b64d7478 SHA512 f8feeb66fa8bd2406227be0e2cc2946485238362270d40e3f07dc89491177751f6bf680f51b70696bc30b677624c0e525c3fa9784eabdeb2337697ec56f63fc1
DIST petsc-3.19.4.tar.gz 16630006 BLAKE2B 577655fff12f9f54570393b2023d3386e66c7d4351ef20922f4b8100cbc54eeec0fb6ce249774cb54d2d06062a610c7d755e3b44994a3e053c0c02889810adc8 SHA512 b32b8cf72ea6bf3d976067ce0b722a6fb2ede525bc2293b72daf5693de48c6256e50f3968c0464a5e0d3bb067b936e1d78b66b51626fd27bbef2f57322509564
DIST petsc-3.20.5.tar.gz 17077395 BLAKE2B e76ff83572f7f0fcfa85b80f36301e0378d240e60726f07ab78a66b87591434bda6a96758037580370965f91c03341d95f60cfb961c2ab6707eeaafd5a7b1e1d SHA512 1e0ebdacbcc9db22dbe3803cbc13f5e0138d0412c328ff49cab024c839527c73b28983717104daf0858d482a8804b931c5c2bf20363c6b801d2be7d27219692f
DIST petsc-3.21.3.tar.gz 17334266 BLAKE2B 6a34ae9f57b6f6c9ece4d411da8374d0b5675539f4041b8aa872c639084c7d38b7ddcf27889e7b835df453a8725869d04b4515615dba5998fb00fe28074043ec SHA512 699bbf3ddfc8fe8ebd4a1cb51a04108c10cafb65d30e7a74a9bf1b1ddd0f4350f0b893b256ea8a835e076e0a2f982189902bff30a9e301b3e04b539d2d2b6f99
18 changes: 18 additions & 0 deletions sci-mathematics/petsc/files/petsc-3.21.3-disable-rpath.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,18 @@
diff --git a/config/BuildSystem/config/setCompilers.py b/config/BuildSystem/config/setCompilers.py
index bcf0181..a56bf8a 100644
--- a/config/BuildSystem/config/setCompilers.py
+++ b/config/BuildSystem/config/setCompilers.py
@@ -2543,12 +2543,7 @@ class Configure(config.base.Configure):
if Configure.isCygwin(self.log):
self.logPrint('Cygwin detected! disabling -rpath test.')
testFlags = []
- # test '-R' before '-rpath' as sun compilers [c,fortran] don't give proper errors with wrong options.
- elif not Configure.isDarwin(self.log):
- testFlags = ['-Wl,-rpath,', '-R','-rpath ' , '-Wl,-R,']
- else:
- testFlags = ['-Wl,-rpath,']
- # test '-R' before '-Wl,-rpath' for SUN compilers [as cc on linux accepts -Wl,-rpath, but f90 & CC do not.
+ testFlags = []
if self.isSun(self.framework.getCompiler(), self.log):
testFlags.insert(0,'-R')
for testFlag in testFlags:
Original file line number Diff line number Diff line change
@@ -0,0 +1,17 @@
diff --git a/config/PETSc/options/installDir.py b/config/PETSc/options/installDir.py
index 0ef7ecd..be21ec8 100755
--- a/config/PETSc/options/installDir.py
+++ b/config/PETSc/options/installDir.py
@@ -36,12 +36,6 @@ class Configure(config.base.Configure):
self.dir = os.path.abspath(os.path.expanduser(self.framework.argDB['prefix']))
self.petscDir = self.dir
self.petscArch = ''
- try:
- os.makedirs(os.path.join(self.dir,'PETScTestDirectory'))
- os.rmdir(os.path.join(self.dir,'PETScTestDirectory'))
- except Exception as e:
- self.logPrint('Error trying to test write permissions on directory '+str(e))
- self.installSudo = 'sudo '
else:
self.dir = os.path.abspath(os.path.join(self.petscdir.dir, self.arch.arch))
self.petscDir = self.petscdir.dir
240 changes: 240 additions & 0 deletions sci-mathematics/petsc/petsc-3.21.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,240 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

PYTHON_COMPAT=( python3_{10..12} pypy3 )

inherit flag-o-matic fortran-2 python-any-r1 toolchain-funcs

DESCRIPTION="Portable, Extensible Toolkit for Scientific Computation"
HOMEPAGE="https://petsc.org/release/"
SRC_URI="https://web.cels.anl.gov/projects/petsc/download/release-snapshots/${P}.tar.gz"

LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="afterimage boost complex-scalars debug +examples fftw
fortran hdf5 hypre int64 mpi metis mumps scotch superlu threads X"

# readd sparse when suitesparse-5.6.0 is in tree
# sparse? ( >=sci-libs/suitesparse-5.6.0 >=sci-libs/cholmod-1.7.0 )
# $(use_with sparse suitesparse) \
RDEPEND="
virtual/blas
virtual/lapack
afterimage? ( media-libs/libafterimage )
boost? ( dev-libs/boost )
fftw? ( sci-libs/fftw:3.0[mpi?] )
hdf5? ( sci-libs/hdf5:=[mpi?] )
hypre? ( >=sci-libs/hypre-2.18.0[int64?,mpi?] )
metis? ( >=sci-libs/parmetis-4 )
mpi? ( virtual/mpi[fortran?] )
mumps? ( sci-libs/mumps[mpi?] sci-libs/scalapack )
scotch? ( sci-libs/scotch[int64?,mpi?] )
superlu? ( >=sci-libs/superlu-5 )
X? ( x11-libs/libX11 )
"
DEPEND="
${RDEPEND}
${PYTHON_DEPS}
"
BDEPEND="
dev-build/cmake
virtual/pkgconfig
"

# hypre and superlu curretly exclude each other due to missing linking to hypre
# if both are enabled
REQUIRED_USE="
afterimage? ( X )
complex-scalars? ( !hypre !superlu )
fftw? ( mpi )
hdf5? ( mpi )
hypre? ( mpi !superlu )
mumps? ( mpi scotch )
scotch? ( mpi )
superlu? ( !hypre )
"
PATCHES=(
"${FILESDIR}/${P}-disable-rpath.patch"
"${FILESDIR}"/${P}-fix_sandbox_violation.patch
)

# petsc uses --with-blah=1 and --with-blah=0 to en/disable options
petsc_enable() {
use "$1" && echo "--with-${2:-$1}=1" || echo "--with-${2:-$1}=0"
}
# add external library:
# petsc_with use_flag libname libdir
# petsc_with use_flag libname include linking_libs
petsc_with() {
local myuse p=${2:-${1}}
if use ${1}; then
myuse="--with-${p}=1"
if [[ $# -ge 4 ]]; then
myuse="${myuse} --with-${p}-include=${EPREFIX}${3}"
shift 3
myuse="${myuse} --with-${p}-lib=$@"
else
myuse="${myuse} --with-${p}-dir=${EPREFIX}${3:-/usr}"
fi
else
myuse="--with-${p}=0"
fi
echo ${myuse}
}

# select between configure options depending on use flag
petsc_select() {
use "$1" && echo "--with-$2=$3" || echo "--with-$2=$4"
}

src_configure() {
# -Werror=lto-type-mismatch
# https://bugs.gentoo.org/863260
# https://gitlab.com/petsc/petsc/-/issues/1560
filter-lto

# bug 548498
# PETSc runs mpi processes during configure that result in a sandbox
# violation by trying to open /proc/mtrr rw. This is not easy to
# mitigate because it happens in libpciaccess.so called by libhwloc.so,
# which is used by libmpi.so.
addpredict /proc/mtrr
# if mpi is built with knem support it needs /dev/knem too
addpredict /dev/knem

# configureMPITypes with openmpi-2* insists on accessing the scaling
# governor rw.
addpredict /sys/devices/system/cpu/

# bug 771711
# configureMPIEXEC and configureMPITypes access /dev/nvidiactl
addpredict /dev/nvidiactl

# bug 810841
addpredict /dev/kfd

local myopt

use debug && myopt="debug" || myopt="opt"

# environmental variables expected by petsc during build

export PETSC_DIR="${S}"
export PETSC_ARCH="linux-gnu-c-${myopt}"

if use debug; then
strip-flags
filter-flags -O*
fi

tc-export AR RANLIB

# C Support on CXX builds is enabled if possible i.e. when not using
# complex scalars (no complex type for both available at the same time)

econf \
scrollOutput=1 \
AR="${AR}" \
CFLAGS="${CFLAGS} -fPIC" \
CPPFLAGS="${CPPFLAGS}" \
CXXFLAGS="${CXXFLAGS} -fPIC" \
CXXOPTFLAGS="${CXXFLAGS} -fPIC" \
FCFLAGS="${FCFLAGS} -fPIC" \
FFLAGS="${FFLAGS} -fPIC" \
LDFLAGS="${LDFLAGS}" \
MAKEFLAGS="${MAKEFLAGS}" \
RANLIB="${RANLIB}" \
--prefix="${EPREFIX}/usr/$(get_libdir)/petscdir/" \
--with-blas-lapack-lib="$($(tc-getPKG_CONFIG) --libs blas lapack)" \
--with-cmake:BOOL=1 \
--with-gnu-compilers \
--with-imagemagick=0 \
--with-petsc-arch="${PETSC_ARCH}" \
--with-precision=double \
--with-python=0 \
--with-shared-libraries \
--with-single-library \
--with-windows-graphics=0 \
$(petsc_enable debug debugging) \
$(petsc_enable fortran) \
$(petsc_enable mpi) \
$(petsc_enable mpi mpi-compilers) \
$(petsc_enable threads pthread) \
$(petsc_select complex-scalars scalar-type complex real) \
$(petsc_select mpi cc mpicc $(tc-getCC)) \
$(petsc_select mpi cxx mpicxx $(tc-getCXX)) \
$(petsc_with afterimage afterimage /usr/include/libAfterImage -lAfterImage) \
$(petsc_with hypre hypre /usr/include/hypre -lHYPRE) \
$(petsc_with superlu superlu /usr/include/superlu -lsuperlu) \
$(petsc_with scotch ptscotch /usr/include/scotch [-lptesmumps,-lptscotch,-lptscotcherr,-lscotch,-lscotcherr]) \
$(petsc_with mumps scalapack /usr/include/scalapack -lscalapack) \
$(petsc_with mumps mumps /usr/include [-lcmumps,-ldmumps,-lsmumps,-lzmumps,-lmumps_common,-lpord]) \
$(use fortran && echo "$(petsc_select mpi fc mpif77 $(tc-getF77))") \
$(use int64 && echo "--with-index-size=64") \
$(use_with boost) \
$(use_with fftw) \
$(use_with hdf5) \
$(use_with X x) \
$(use_with X x11)
}

src_install() {
emake DESTDIR="${ED}" install

#
# Clean up the mess:
#

# put all include directories under a proper subdirectory
mkdir "${ED}"/usr/include || die "mkdir failed (include)"
mv "${ED}"/usr/{$(get_libdir)/petscdir/include,include/petsc} || die "mv failed (include)"

# put libraries and pkconfig file into proper place
mv "${ED}"/usr/$(get_libdir)/petscdir/lib/{libpetsc*,pkgconfig} \
"${ED}/usr/$(get_libdir)" || die "mv failed (lib)"

# move share to proper location
mv "${ED}"/usr/{$(get_libdir)/petscdir/share,share} || die "mv failed (share)"

# fix pc files:
sed -i \
-e 's#include$#include/petsc#' \
-e "s#lib\$#$(get_libdir)#" \
-e "s#^prefix=.*petscdir\$#prefix=${EPREFIX}/usr#" \
"${ED}"/usr/$(get_libdir)/pkgconfig/*.pc || die "sed failed (pkgconfig)"

# recreate a "valid" petscdir:
for i in "${ED}"/usr/$(get_libdir)/*; do
[ $(basename $i) = petscdir ] && continue
ln -s "${EPREFIX}/usr/$(get_libdir)/$(basename $i)" \
"${ED}/usr/$(get_libdir)/petscdir/lib/$(basename $i)" || die "ln failed (petscdir)"
done
ln -s "${EPREFIX}"/usr/include/petsc/ \
"${ED}/usr/$(get_libdir)/petscdir/include" || die "ln failed (petscdir)"
mkdir "${ED}/usr/$(get_libdir)/petscdir/share" || die "mkdir fialed (petscdir)"
ln -s "${EPREFIX}"/usr/share/petsc/ \
"${ED}/usr/$(get_libdir)/petscdir/share/petsc" || die "ln failed (petscdir)"

# automatically symlink petsc matlab modules:
mkdir -p "${ED}"/usr/share/octave/site/m/
ln -s "${EPREFIX}"/usr/share/petsc/matlab "${ED}"/usr/share/octave/site/m/petsc || die "ln failed (matlab)"

if use examples; then
mkdir -p "${ED}"/usr/share/doc/${PF} || die "mkdir failed (examples)"
mv "${ED}"/usr/share/petsc/examples "${ED}"/usr/share/doc/${PF} || die "mv failed (examples)"
ln -s "${EPREFIX}"/usr/share/doc/${PF}/examples "${ED}"/usr/share/petsc/examples || die "ln failed (examples)"
docompress -x /usr/share/doc/${PF}/examples
else
rm -r "${ED}"/usr/share/petsc/examples || die "rm failed (examples)"
fi

# add PETSC_DIR to environmental variables
cat >> 99petsc <<- EOF
PETSC_DIR=${EPREFIX}/usr/$(get_libdir)/petscdir
EOF
doenvd 99petsc
}

0 comments on commit b27eaf5

Please sign in to comment.