Skip to content

Commit

Permalink
Merge remote-tracking branch 'op/main' into test
Browse files Browse the repository at this point in the history
  • Loading branch information
tiffany-929 committed Sep 2, 2024
2 parents 80d3d4a + 85f0128 commit 576387f
Show file tree
Hide file tree
Showing 225 changed files with 8,397 additions and 3,225 deletions.
2 changes: 1 addition & 1 deletion include/autotools.mk
Original file line number Diff line number Diff line change
Expand Up @@ -44,7 +44,7 @@ define autoreconf
touch NEWS AUTHORS COPYING ABOUT-NLS ChangeLog; \
$(AM_TOOL_PATHS) \
LIBTOOLIZE='$(STAGING_DIR_HOST)/bin/libtoolize --install' \
$(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
$(STAGING_DIR_HOST)/bin/autoreconf -v -f -i \
$(if $(word 2,$(3)),--no-recursive) \
-B $(STAGING_DIR_HOST)/share/aclocal \
$(patsubst %,-I %,$(5)) \
Expand Down
4 changes: 4 additions & 0 deletions include/cmake.mk
Original file line number Diff line number Diff line change
Expand Up @@ -68,6 +68,8 @@ ifeq ($(HOST_USE_NINJA),1)
define Host/Uninstall/Default
+$(NINJA) -C $(HOST_CMAKE_BINARY_DIR) uninstall
endef
else
CMAKE_HOST_OPTIONS += -DCMAKE_GENERATOR="Unix Makefiles"
endif

ifeq ($(PKG_USE_NINJA),1)
Expand All @@ -80,6 +82,8 @@ ifeq ($(PKG_USE_NINJA),1)
define Build/Install/Default
+DESTDIR="$(PKG_INSTALL_DIR)" $(NINJA) -C $(CMAKE_BINARY_DIR) install
endef
else
CMAKE_OPTIONS += -DCMAKE_GENERATOR="Unix Makefiles"
endif

define Build/Configure/Default
Expand Down
4 changes: 2 additions & 2 deletions include/kernel-6.1
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-6.1 = .106
LINUX_KERNEL_HASH-6.1.106 = 3773c9052c7ba7432e8337ca84bee115c1a94ccef9d62b72b99ae30c4cd5f80f
LINUX_VERSION-6.1 = .107
LINUX_KERNEL_HASH-6.1.107 = f43229d1d73011fa0a37400320a26972946f8ff295c404c31c0dd0407228b0e8
4 changes: 2 additions & 2 deletions include/kernel-6.6
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-6.6 = .47
LINUX_KERNEL_HASH-6.6.47 = d43376c9e9eaa92bb1b926054bd160d329c58a62d64bd65fe1222c11c6564f50
LINUX_VERSION-6.6 = .48
LINUX_KERNEL_HASH-6.6.48 = 6b16df7b2aba3116b78fdfd8aea0b6cd7abe8f0cb699b04a66d3169141772029
2 changes: 2 additions & 0 deletions include/netfilter.mk
Original file line number Diff line number Diff line change
Expand Up @@ -207,6 +207,8 @@ $(eval $(call nf_add,NF_NATHELPER,CONFIG_NF_NAT_FTP, $(P_XT)nf_nat_ftp))
# nathelper-extra

$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CONNTRACK_BROADCAST, $(P_XT)nf_conntrack_broadcast))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CONNTRACK_NETBIOS_NS, $(P_XT)nf_conntrack_netbios_ns))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CONNTRACK_SANE, $(P_XT)nf_conntrack_sane))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CONNTRACK_AMANDA, $(P_XT)nf_conntrack_amanda))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_NAT_AMANDA, $(P_XT)nf_nat_amanda))
$(eval $(call nf_add,NF_NATHELPER_EXTRA,CONFIG_NF_CONNTRACK_H323, $(P_XT)nf_conntrack_h323))
Expand Down
2 changes: 1 addition & 1 deletion package/base-files/files/lib/preinit/80_mount_root
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ missing_lines() {
IFS=":"
while read line; do
set -- $line
grep -q "^$1:" "$file2" || echo "$*"
grep -q "^$1:" "$file2" || echo "$line"
done < "$file1"
IFS="$oIFS"
}
Expand Down
2 changes: 2 additions & 0 deletions package/boot/uboot-envtools/files/ath79
Original file line number Diff line number Diff line change
Expand Up @@ -89,6 +89,8 @@ zyxel,nbg6616)
aruba,ap-105|\
aruba,ap-115|\
aruba,ap-175|\
belkin,f9j1108-v2|\
belkin,f9k1115-v2|\
dongwon,dw02-412h-64m|\
dongwon,dw02-412h-128m|\
glinet,gl-ar300m-lite|\
Expand Down
Original file line number Diff line number Diff line change
@@ -1,9 +1,9 @@

arm: kirkwood: add ZyXEL NSA310 device
arm: kirkwood: add Zyxel NSA310 device

This patch add ZyXEL NSA310 1-Bay Media Server
This patch add Zyxel NSA310 1-Bay Media Server

The ZyXEL NSA310 device is a Kirkwood based NAS:
The Zyxel NSA310 device is a Kirkwood based NAS:

- SoC: Marvell 88F6702 1200Mhz
- SDRAM memory: 256MB DDR2 400Mhz
Expand Down Expand Up @@ -512,7 +512,7 @@ NOTE: this patch is ready for upstream, LEDE-specific parts are in
+CONFIG_KIRKWOOD=y
+CONFIG_SYS_TEXT_BASE=0x600000
+CONFIG_TARGET_NSA310=y
+CONFIG_IDENT_STRING="\nZyXEL NSA310 1-Bay Power Media Server"
+CONFIG_IDENT_STRING="\nZyxel NSA310 1-Bay Power Media Server"
+CONFIG_NR_DRAM_BANKS=2
+CONFIG_BOOTDELAY=3
+CONFIG_SYS_PROMPT="NSA310> "
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -297,7 +297,7 @@
+ /* reset the phy */
+ miiphy_reset(name, devadr);
+
+ /* The ZyXEL NSA325 uses the 88E1310S Alaska (interface identical to 88E1318) */
+ /* The Zyxel NSA325 uses the 88E1310S Alaska (interface identical to 88E1318) */
+ /* and has an MCU attached to the LED[2] via tristate interrupt */
+ reg = 0;
+
Expand Down Expand Up @@ -496,7 +496,7 @@
+CONFIG_KIRKWOOD=y
+CONFIG_SYS_TEXT_BASE=0x600000
+CONFIG_TARGET_NSA325=y
+CONFIG_IDENT_STRING="\nZyXEL NSA325 2-Bay Power Media Server"
+CONFIG_IDENT_STRING="\nZyxel NSA325 2-Bay Power Media Server"
+CONFIG_NR_DRAM_BANKS=2
+CONFIG_BOOTDELAY=3
+CONFIG_SYS_PROMPT="NSA325> "
Expand Down
4 changes: 2 additions & 2 deletions package/boot/uboot-lantiq/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -280,14 +280,14 @@ define U-Boot/fb3370_sfspl
endef

define U-Boot/p2812hnufx_ram
NAME:=ZyXEL P-2812HNU-Fx (RAM)
NAME:=Zyxel P-2812HNU-Fx (RAM)
BUILD_SUBTARGET:=xrx200
BUILD_DEVICES:=zyxel_p-2812hnu-f1
DDR_SETTINGS:=board/zyxel/p2812hnufx/ddr_settings.h
endef

define U-Boot/p2812hnufx_nandspl
NAME:=ZyXEL P-2812HNU-Fx (NAND SPL)
NAME:=Zyxel P-2812HNU-Fx (NAND SPL)
BUILD_SUBTARGET:=xrx200
BUILD_DEVICES:=zyxel_p-2812hnu-f1
UBOOT_IMAGE:=u-boot.ltq.lzo.nandspl
Expand Down
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
From 3f7be04a148d23cdb5fd320e0e2923983f8bd1f4 Mon Sep 17 00:00:00 2001
From: Luka Perkov <[email protected]>
Date: Tue, 6 Aug 2013 22:51:00 +0200
Subject: MIPS: add board support for ZyXEL P-2812HNU-Fx
Subject: MIPS: add board support for Zyxel P-2812HNU-Fx

Signed-off-by: Luka Perkov <[email protected]>

Expand Down Expand Up @@ -51,7 +51,7 @@ Signed-off-by: Luka Perkov <[email protected]>
+/*
+ * Copyright (C) 2013 Luka Perkov <[email protected]>
+ *
+ * The values have been extracted from original ZyXEL U-Boot.
+ * The values have been extracted from original Zyxel U-Boot.
+ *
+ * SPDX-License-Identifier: GPL-2.0+
+ */
Expand Down Expand Up @@ -243,7 +243,7 @@ Signed-off-by: Luka Perkov <[email protected]>
+
+#define CONFIG_MACH_TYPE "P-2812HNU-Fx"
+#define CONFIG_IDENT_STRING " "CONFIG_MACH_TYPE
+#define CONFIG_BOARD_NAME "ZyXEL P-2812HNU-Fx"
+#define CONFIG_BOARD_NAME "Zyxel P-2812HNU-Fx"
+
+/* Configure SoC */
+#define CONFIG_LTQ_SUPPORT_UART /* Enable ASC and UART */
Expand Down
102 changes: 102 additions & 0 deletions package/boot/uboot-mediatek/patches/314-mt7981-select-rootdisk.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,102 @@
--- a/board/mediatek/mt7981/mt7981_rfb.c
+++ b/board/mediatek/mt7981/mt7981_rfb.c
@@ -11,7 +11,9 @@
#include <env.h>
#include <init.h>
#include <asm/global_data.h>
+#include <asm/io.h>
#include <linux/delay.h>
+#include <linux/libfdt.h>

#ifndef CONFIG_RESET_BUTTON_LABEL
#define CONFIG_RESET_BUTTON_LABEL "reset"
@@ -81,3 +83,54 @@ int board_nmbm_init(void)

return 0;
}
+
+#define MT7981_BOOT_NOR 0
+#define MT7981_BOOT_SPIM_NAND 1 /* ToDo: fallback to SD */
+#define MT7981_BOOT_EMMC 2
+#define MT7981_BOOT_SNFI_NAND 3 /* ToDo (treated as SD) */
+
+int ft_system_setup(void *blob, struct bd_info *bd)
+{
+ const u32 *media_handle_p;
+ int chosen, len, ret;
+ const char *media;
+ u32 media_handle;
+
+ switch ((readl(0x11d006f0) & 0xc0) >> 6) {
+ case MT7981_BOOT_NOR:
+ media = "rootdisk-nor";
+ break
+ ;;
+ case MT7981_BOOT_SPIM_NAND:
+ media = "rootdisk-spim-nand";
+ break
+ ;;
+ case MT7981_BOOT_EMMC:
+ media = "rootdisk-emmc";
+ break
+ ;;
+ case MT7981_BOOT_SNFI_NAND:
+ media = "rootdisk-sd";
+ break
+ ;;
+ }
+
+ chosen = fdt_path_offset(blob, "/chosen");
+ if (chosen <= 0)
+ return 0;
+
+ media_handle_p = fdt_getprop(blob, chosen, media, &len);
+ if (media_handle_p <= 0 || len != 4)
+ return 0;
+
+ media_handle = *media_handle_p;
+ ret = fdt_setprop(blob, chosen, "rootdisk", &media_handle, sizeof(media_handle));
+ if (ret) {
+ printf("cannot set media phandle %s as rootdisk /chosen node\n", media);
+ return ret;
+ }
+
+ printf("set /chosen/rootdisk to bootrom media: %s (phandle 0x%08x)\n", media, fdt32_to_cpu(media_handle));
+
+ return 0;
+}
--- a/configs/mt7981_emmc_rfb_defconfig
+++ b/configs/mt7981_emmc_rfb_defconfig
@@ -114,3 +114,4 @@ CONFIG_FAT_WRITE=y
CONFIG_HEXDUMP=y
# CONFIG_EFI_LOADER is not set
CONFIG_LMB_MAX_REGIONS=64
+CONFIG_OF_SYSTEM_SETUP=y
--- a/configs/mt7981_nor_rfb_defconfig
+++ b/configs/mt7981_nor_rfb_defconfig
@@ -126,3 +126,4 @@ CONFIG_DM_SPI=y
CONFIG_MTK_SPIM=y
CONFIG_HEXDUMP=y
CONFIG_LMB_MAX_REGIONS=64
+CONFIG_OF_SYSTEM_SETUP=y
--- a/configs/mt7981_rfb_defconfig
+++ b/configs/mt7981_rfb_defconfig
@@ -135,3 +135,4 @@ CONFIG_DM_SPI=y
CONFIG_MTK_SPIM=y
CONFIG_HEXDUMP=y
CONFIG_LMB_MAX_REGIONS=64
+CONFIG_OF_SYSTEM_SETUP=y
--- a/configs/mt7981_sd_rfb_defconfig
+++ b/configs/mt7981_sd_rfb_defconfig
@@ -114,3 +114,4 @@ CONFIG_FAT_WRITE=y
CONFIG_HEXDUMP=y
# CONFIG_EFI_LOADER is not set
CONFIG_LMB_MAX_REGIONS=64
+CONFIG_OF_SYSTEM_SETUP=y
--- a/configs/mt7981_snfi_nand_rfb_defconfig
+++ b/configs/mt7981_snfi_nand_rfb_defconfig
@@ -120,3 +120,4 @@ CONFIG_DM_SERIAL=y
CONFIG_MTK_SERIAL=y
CONFIG_HEXDUMP=y
CONFIG_LMB_MAX_REGIONS=64
+CONFIG_OF_SYSTEM_SETUP=y
33 changes: 33 additions & 0 deletions package/boot/uboot-rockchip/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -167,6 +167,21 @@ define U-Boot/radxa-cm3-io-rk3566
radxa_cm3-io
endef

define U-Boot/radxa-zero-3-rk3566
$(U-Boot/rk3566/Default)
NAME:=ZERO 3E/3W
BUILD_DEVICES:= \
radxa_zero-3e \
radxa_zero-3w
endef

define U-Boot/rock-3c-rk3566
$(U-Boot/rk3566/Default)
NAME:=ROCK 3C
BUILD_DEVICES:= \
radxa_rock-3c
endef

# RK3568 boards

define U-Boot/rk3568/Default
Expand Down Expand Up @@ -213,6 +228,13 @@ define U-Boot/rock-3a-rk3568
radxa_rock-3a
endef

define U-Boot/rock-3b-rk3568
$(U-Boot/rk3568/Default)
NAME:=ROCK 3B
BUILD_DEVICES:= \
radxa_rock-3b
endef


# RK3588 boards

Expand All @@ -230,6 +252,13 @@ define U-Boot/rock5b-rk3588
radxa_rock-5b
endef

define U-Boot/nanopc-t6-rk3588
$(U-Boot/rk3588/Default)
NAME:=NanoPC T6
BUILD_DEVICES:= \
friendlyarm_nanopc-t6
endef


# RK3588S boards

Expand Down Expand Up @@ -263,12 +292,16 @@ UBOOT_TARGETS := \
rock-pi-e-rk3328 \
rock-pi-e-v3-rk3328 \
radxa-cm3-io-rk3566 \
radxa-zero-3-rk3566 \
rock-3c-rk3566 \
bpi-r2-pro-rk3568 \
nanopi-r5c-rk3568 \
nanopi-r5s-rk3568 \
radxa-e25-rk3568 \
rock-3a-rk3568 \
rock-3b-rk3568 \
rock5b-rk3588 \
nanopc-t6-rk3588 \
nanopi-r6s-rk3588s \
rock5a-rk3588s

Expand Down
Loading

0 comments on commit 576387f

Please sign in to comment.