Skip to content

Commit

Permalink
Merge remote-tracking branch 'op/main' into test
Browse files Browse the repository at this point in the history
  • Loading branch information
tiffany-929 committed Sep 9, 2024
2 parents 571be8c + 1528031 commit d24c76b
Show file tree
Hide file tree
Showing 106 changed files with 2,392 additions and 1,548 deletions.
12 changes: 10 additions & 2 deletions config/Config-kernel.in
Original file line number Diff line number Diff line change
Expand Up @@ -1247,10 +1247,11 @@ config KERNEL_BTRFS_FS
menu "Filesystem ACL and attr support options"
config USE_FS_ACL_ATTR
bool "Use filesystem ACL and attr support by default"
default y if !SMALL_FLASH
help
Make using ACLs (e.g. POSIX ACL, NFSv4 ACL) the default
for kernel and packages, except tmpfs, flash filesystems,
and old NFS. Also enable userspace extended attribute support
for kernel and packages, except old NFS.
Also enable userspace extended attribute support
by default. (OpenWrt already has an expection it will be
present in the kernel).

Expand All @@ -1271,14 +1272,17 @@ menu "Filesystem ACL and attr support options"
config KERNEL_F2FS_FS_POSIX_ACL
bool "Enable POSIX ACL for F2FS Filesystems"
select KERNEL_FS_POSIX_ACL
default y if USE_FS_ACL_ATTR

config KERNEL_JFFS2_FS_POSIX_ACL
bool "Enable POSIX ACL for JFFS2 Filesystems"
select KERNEL_FS_POSIX_ACL
default y if USE_FS_ACL_ATTR

config KERNEL_TMPFS_POSIX_ACL
bool "Enable POSIX ACL for TMPFS Filesystems"
select KERNEL_FS_POSIX_ACL
default y if USE_FS_ACL_ATTR

config KERNEL_CIFS_ACL
bool "Enable CIFS ACLs"
Expand Down Expand Up @@ -1415,15 +1419,19 @@ config KERNEL_LSM

config KERNEL_EXT4_FS_SECURITY
bool "Ext4 Security Labels"
default y if !SMALL_FLASH

config KERNEL_F2FS_FS_SECURITY
bool "F2FS Security Labels"
default y if !SMALL_FLASH

config KERNEL_UBIFS_FS_SECURITY
bool "UBIFS Security Labels"
default y if !SMALL_FLASH

config KERNEL_JFFS2_FS_SECURITY
bool "JFFS2 Security Labels"
default y if !SMALL_FLASH

config KERNEL_WERROR
bool "Compile the kernel with warnings as errors"
Expand Down
4 changes: 2 additions & 2 deletions include/kernel-6.1
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-6.1 = .107
LINUX_KERNEL_HASH-6.1.107 = f43229d1d73011fa0a37400320a26972946f8ff295c404c31c0dd0407228b0e8
LINUX_VERSION-6.1 = .109
LINUX_KERNEL_HASH-6.1.109 = 732ff40ac63642c5ddbb7d65c24c90ed08b95af0e8c92df4739e9703eec01ac1
4 changes: 2 additions & 2 deletions include/kernel-6.6
Original file line number Diff line number Diff line change
@@ -1,2 +1,2 @@
LINUX_VERSION-6.6 = .48
LINUX_KERNEL_HASH-6.6.48 = 6b16df7b2aba3116b78fdfd8aea0b6cd7abe8f0cb699b04a66d3169141772029
LINUX_VERSION-6.6 = .50
LINUX_KERNEL_HASH-6.6.50 = c065e36daf28210060c91a37ef3e92ac5814784e634577e04e406297ead2e86e
1 change: 1 addition & 0 deletions package/boot/uboot-envtools/files/mediatek_mt7622
Original file line number Diff line number Diff line change
Expand Up @@ -62,6 +62,7 @@ ubnt,unifi-6-lr-v3)
;;
xiaomi,redmi-router-ax6s)
ubootenv_add_uci_config "/dev/mtd3" "0x0" "0x10000" "0x40000"
ubootenv_add_uci_sys_config "/dev/mtd4" "0x0" "0x10000" "0x40000"
;;
esac

Expand Down
3 changes: 2 additions & 1 deletion package/boot/uboot-envtools/files/qualcommax_ipq807x
Original file line number Diff line number Diff line change
Expand Up @@ -38,7 +38,8 @@ linksys,mx8500)
ubootenv_add_uci_config "/dev/mtd$idx" "0x0" "0x40000" "0x20000" "2"
;;
netgear,sxr80|\
netgear,sxs80)
netgear,sxs80|\
tplink,eap660hd-v1)
idx="$(find_mtd_index 0:appsblenv)"
[ -n "$idx" ] && \
ubootenv_add_uci_config "/dev/mtd$idx" "0x0" "0x40000" "0x20000"
Expand Down
2 changes: 1 addition & 1 deletion package/boot/uboot-lantiq/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk

PKG_NAME:=u-boot
PKG_VERSION:=2013.10
PKG_RELEASE:=66
PKG_RELEASE:=67

PKG_HASH:=0d71e62beb952b41ebafb20a7ee4df2f960db64c31b054721ceb79ff14014c55

Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -95,7 +95,7 @@
+void show_boot_progress(int arg)
+{
+ if (!do_gpio_init)
+ return 0;
+ return;
+
+ if (arg >= 0) {
+ /* Success - turn off the red power LED and turn on the green power LED */
Expand All @@ -107,7 +107,7 @@
+ gpio_set_value(GPIO_POWER_RED, 0);
+ }
+
+ return 0;
+ return;
+}
+
+static const struct ltq_eth_port_config eth_port_config[] = {
Expand Down
Original file line number Diff line number Diff line change
Expand Up @@ -107,7 +107,7 @@
+void show_boot_progress(int arg)
+{
+ if (!do_gpio_init)
+ return 0;
+ return;
+
+ if (arg >= 0) {
+ /* Success - turn off the red power LED and turn on the green power LED */
Expand All @@ -119,7 +119,7 @@
+ gpio_set_value(GPIO_POWER_RED, 0);
+ }
+
+ return 0;
+ return;
+}
+
+static const struct ltq_eth_port_config eth_port_config[] = {
Expand Down
14 changes: 7 additions & 7 deletions package/boot/uboot-rockchip/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -245,18 +245,18 @@ define U-Boot/rk3588/Default
TPL:=rk3588_ddr_lp4_2112MHz_lp5_2400MHz_v1.16.bin
endef

define U-Boot/rock5b-rk3588
define U-Boot/nanopc-t6-rk3588
$(U-Boot/rk3588/Default)
NAME:=ROCK 5B
NAME:=NanoPC T6
BUILD_DEVICES:= \
radxa_rock-5b
friendlyarm_nanopc-t6
endef

define U-Boot/nanopc-t6-rk3588
define U-Boot/rock5b-rk3588
$(U-Boot/rk3588/Default)
NAME:=NanoPC T6
NAME:=ROCK 5B
BUILD_DEVICES:= \
friendlyarm_nanopc-t6
radxa_rock-5b
endef


Expand Down Expand Up @@ -300,8 +300,8 @@ UBOOT_TARGETS := \
radxa-e25-rk3568 \
rock-3a-rk3568 \
rock-3b-rk3568 \
rock5b-rk3588 \
nanopc-t6-rk3588 \
rock5b-rk3588 \
nanopi-r6s-rk3588s \
rock5a-rk3588s

Expand Down
2 changes: 2 additions & 0 deletions package/firmware/ipq-wifi/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -62,6 +62,7 @@ ALLWIFIBOARDS:= \
redmi_ax5-jdcloud \
redmi_ax6 \
spectrum_sax1v1k \
tplink_eap660hd-v1 \
wallys_dr40x9 \
xiaomi_ax1800 \
xiaomi_ax3600 \
Expand Down Expand Up @@ -204,6 +205,7 @@ $(eval $(call generate-ipq-wifi-package,redmi_ax5,Redmi AX5))
$(eval $(call generate-ipq-wifi-package,redmi_ax5-jdcloud,Redmi AX5 JDCloud))
$(eval $(call generate-ipq-wifi-package,redmi_ax6,Redmi AX6))
$(eval $(call generate-ipq-wifi-package,spectrum_sax1v1k,Spectrum SAX1V1K))
$(eval $(call generate-ipq-wifi-package,tplink_eap660hd-v1,TP-Link EAP660 HD v1))
$(eval $(call generate-ipq-wifi-package,wallys_dr40x9,Wallys DR40X9))
$(eval $(call generate-ipq-wifi-package,xiaomi_ax1800,Xiaomi AX1800))
$(eval $(call generate-ipq-wifi-package,xiaomi_ax3600,Xiaomi AX3600))
Expand Down
4 changes: 3 additions & 1 deletion package/kernel/lantiq/ltq-atm/src/ifxmips_atm_amazon_se.c
Original file line number Diff line number Diff line change
Expand Up @@ -263,7 +263,7 @@ extern void ase_fw_ver(unsigned int *major, unsigned int *minor)
*minor = FW_VER_ID->minor;
}

void ase_init(struct platform_device *pdev)
int ase_init(struct platform_device *pdev)
{
init_pmu();

Expand All @@ -276,6 +276,8 @@ void ase_init(struct platform_device *pdev)
init_atm_tc();

clear_share_buffer();

return 0;
}

void ase_shutdown(void)
Expand Down
4 changes: 3 additions & 1 deletion package/kernel/lantiq/ltq-atm/src/ifxmips_atm_ar9.c
Original file line number Diff line number Diff line change
Expand Up @@ -194,13 +194,15 @@ void ar9_fw_ver(unsigned int *major, unsigned int *minor)
*minor = FW_VER_ID->minor;
}

void ar9_init(struct platform_device *pdev)
int ar9_init(struct platform_device *pdev)
{
init_pmu();
reset_ppe(pdev);
init_ema();
init_mailbox();
clear_share_buffer();

return 0;
}

void ar9_shutdown(void)
Expand Down
2 changes: 1 addition & 1 deletion package/kernel/lantiq/ltq-atm/src/ifxmips_atm_core.h
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,7 @@
#define SET_BITS(x, msb, lsb, value) (((x) & ~(((1 << ((msb) + 1)) - 1) ^ ((1 << (lsb)) - 1))) | (((value) & ((1 << (1 + (msb) - (lsb))) - 1)) << (lsb)))

struct ltq_atm_ops {
void (*init)(struct platform_device *pdev);
int (*init)(struct platform_device *pdev);
void (*shutdown)(void);

int (*start)(int pp32);
Expand Down
4 changes: 3 additions & 1 deletion package/kernel/lantiq/ltq-atm/src/ifxmips_atm_danube.c
Original file line number Diff line number Diff line change
Expand Up @@ -141,7 +141,7 @@ static void danube_fw_ver(unsigned int *major, unsigned int *minor)
*minor = FW_VER_ID->minor;
}

static void danube_init(struct platform_device *pdev)
static int danube_init(struct platform_device *pdev)
{
volatile u32 *p = SB_RAM0_ADDR(0);
unsigned int i;
Expand Down Expand Up @@ -190,6 +190,8 @@ static void danube_init(struct platform_device *pdev)

for ( i = 0; i < SB_RAM0_DWLEN + SB_RAM1_DWLEN + SB_RAM2_DWLEN + SB_RAM3_DWLEN; i++ )
IFX_REG_W32(0, p++);

return 0;
}

static void danube_shutdown(void)
Expand Down
34 changes: 16 additions & 18 deletions package/kernel/lantiq/ltq-atm/src/ifxmips_atm_vr9.c
Original file line number Diff line number Diff line change
Expand Up @@ -58,33 +58,24 @@
#define IFX_PMU_MODULE_AHBS BIT(13)
#define IFX_PMU_MODULE_DSL_DFE BIT(9)

static inline void vr9_reset_ppe(struct platform_device *pdev)
static inline int vr9_reset_ppe(struct platform_device *pdev)
{
struct device *dev = &pdev->dev;
struct reset_control *dsp;
struct reset_control *dfe;
struct reset_control *tc;

dsp = devm_reset_control_get(dev, "dsp");
if (IS_ERR(dsp)) {
if (PTR_ERR(dsp) != -EPROBE_DEFER)
dev_err(dev, "Failed to lookup dsp reset\n");
// return PTR_ERR(dsp);
}
if (IS_ERR(dsp))
return dev_err_probe(dev, PTR_ERR(dsp), "Failed to lookup dsp reset");

dfe = devm_reset_control_get(dev, "dfe");
if (IS_ERR(dfe)) {
if (PTR_ERR(dfe) != -EPROBE_DEFER)
dev_err(dev, "Failed to lookup dfe reset\n");
// return PTR_ERR(dfe);
}
if (IS_ERR(dfe))
return dev_err_probe(dev, PTR_ERR(dfe), "Failed to lookup dfe reset");

tc = devm_reset_control_get(dev, "tc");
if (IS_ERR(tc)) {
if (PTR_ERR(tc) != -EPROBE_DEFER)
dev_err(dev, "Failed to lookup tc reset\n");
// return PTR_ERR(tc);
}
if (IS_ERR(tc))
return dev_err_probe(dev, PTR_ERR(tc), "Failed to lookup tc reset");

reset_control_assert(dsp);
udelay(1000);
Expand All @@ -96,6 +87,8 @@ static inline void vr9_reset_ppe(struct platform_device *pdev)
udelay(1000);
*PP32_SRST |= 0x000303CF;
udelay(1000);

return 0;
}

static inline int vr9_pp32_download_code(int pp32, u32 *code_src, unsigned int code_dword_len, u32 *data_src, unsigned int data_dword_len)
Expand Down Expand Up @@ -132,10 +125,11 @@ static void vr9_fw_ver(unsigned int *major, unsigned int *minor)
*minor = FW_VER_ID->minor;
}

static void vr9_init(struct platform_device *pdev)
static int vr9_init(struct platform_device *pdev)
{
volatile u32 *p;
unsigned int i;
int ret;

/* setup pmu */
ltq_pmu_enable(IFX_PMU_MODULE_PPE_SLL01 |
Expand All @@ -145,7 +139,9 @@ static void vr9_init(struct platform_device *pdev)
IFX_PMU_MODULE_AHBS |
IFX_PMU_MODULE_DSL_DFE);

vr9_reset_ppe(pdev);
ret = vr9_reset_ppe(pdev);
if (ret)
return ret;

/* pdma init */
IFX_REG_W32(0x08, PDMA_CFG);
Expand All @@ -170,6 +166,8 @@ static void vr9_init(struct platform_device *pdev)
p = SB_RAM6_ADDR(0);
for ( i = 0; i < SB_RAM6_DWLEN; i++ )
IFX_REG_W32(0, p++);

return 0;
}

static void vr9_shutdown(void)
Expand Down
5 changes: 4 additions & 1 deletion package/kernel/lantiq/ltq-atm/src/ltq_atm.c
Original file line number Diff line number Diff line change
Expand Up @@ -1782,7 +1782,10 @@ static int ltq_atm_probe(struct platform_device *pdev)
goto INIT_PRIV_DATA_FAIL;
}

ops->init(pdev);
ret = ops->init(pdev);
if (ret)
return ret;

init_rx_tables();
init_tx_tables();

Expand Down
2 changes: 1 addition & 1 deletion package/kernel/lantiq/ltq-ptm/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk

PKG_NAME:=ltq-ptm
PKG_RELEASE:=3
PKG_RELEASE:=4

PKG_MAINTAINER:=John Crispin <[email protected]>
PKG_LICENSE:=GPL-2.0+
Expand Down
4 changes: 3 additions & 1 deletion package/kernel/lantiq/ltq-ptm/src/ifxmips_ptm_vdsl.c
Original file line number Diff line number Diff line change
Expand Up @@ -993,7 +993,9 @@ static int ltq_ptm_probe(struct platform_device *pdev)
goto INIT_PRIV_DATA_FAIL;
}

ifx_ptm_init_chip(pdev);
ret = ifx_ptm_init_chip(pdev);
if (ret)
goto INIT_PRIV_DATA_FAIL;
ret = init_tables();
if ( ret != 0 ) {
err("INIT_TABLES_FAIL");
Expand Down
2 changes: 1 addition & 1 deletion package/kernel/lantiq/ltq-ptm/src/ifxmips_ptm_vdsl.h
Original file line number Diff line number Diff line change
Expand Up @@ -112,7 +112,7 @@ extern unsigned int ifx_ptm_dbg_enable;

extern void ifx_ptm_get_fw_ver(unsigned int *major, unsigned int *mid, unsigned int *minor);

extern void ifx_ptm_init_chip(struct platform_device *pdev);
extern int ifx_ptm_init_chip(struct platform_device *pdev);
extern void ifx_ptm_uninit_chip(void);

extern int ifx_pp32_start(int pp32);
Expand Down
Loading

0 comments on commit d24c76b

Please sign in to comment.