forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request openwrt#5048 from diizzyy/patch-104
sound/lame: Add optional experimental optimization
- Loading branch information
Showing
2 changed files
with
23 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
menu "Configuration" | ||
depends on PACKAGE_lame-lib | ||
|
||
config LAME-LIB_OPTIMIZE_SPEED | ||
bool "Optimize for speed" | ||
default n | ||
help | ||
This enables additional experimental | ||
optmization and increases performance | ||
considerably at the expense of binary size. | ||
|
||
endmenu |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -22,6 +22,8 @@ PKG_MAINTAINER:=Ted Hess <[email protected]> | |
PKG_LICENSE:=LGPL-2.0 | ||
PKG_LICENSE_FILES:=COPYING LICENSE | ||
|
||
PKG_CONFIG_DEPENDS:= CONFIG_LAME-LIB_OPTIMIZE_SPEED | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
|
||
PKG_INSTALL=1 | ||
|
@@ -43,6 +45,10 @@ define Package/lame/description | |
lame mp3 encoder | ||
endef | ||
|
||
define Package/lame-lib/config | ||
source "$(SOURCE)/Config.in" | ||
endef | ||
|
||
define Package/lame-lib | ||
$(call Package/lame/Default) | ||
TITLE:=lame-lib | ||
|
@@ -56,6 +62,11 @@ ifeq ($(ARCH),i386) | |
TARGET_CFLAGS+=-msse | ||
endif | ||
|
||
ifeq ($(CONFIG_LAME-LIB_OPTIMIZE_SPEED),y) | ||
TARGET_CFLAGS += $(TARGET_CFLAGS) -O3 -fomit-frame-pointer -ffast-math -fschedule-insns2 | ||
TARGET_CFLAGS := $(filter-out -Os,$(TARGET_CFLAGS)) | ||
endif | ||
|
||
CONFIGURE_ARGS += --disable-gtktest --disable-static | ||
|
||
define Package/lame/install | ||
|