forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
debian-archive-keyring: add new package
Grab debian-archive-keyring from debian.org to easy use of debootstrap. Signed-off-by: Daniel Golle <[email protected]>
- Loading branch information
Showing
1 changed file
with
42 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
include $(TOPDIR)/rules.mk | ||
include $(INCLUDE_DIR)/kernel.mk | ||
|
||
PKG_NAME:=debian-archive-keyring | ||
PKG_VERSION:=2019.1 | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE:=debian-archive-keyring_2019.1_all.deb | ||
PKG_SOURCE_URL:=http://ftp.debian.org/debian/pool/main/d/debian-archive-keyring/ | ||
PKG_HASH:=9cefd8917f3d97a999c136aa87f04a3024408b5bc1de470de7d6dfa5e4bd4361 | ||
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) | ||
|
||
PKG_MAINTAINER:=Daniel Golle <[email protected]> | ||
PKG_LICENSE:=Unique | ||
PKG_LICENSE_FILES:=usr/share/doc/debian-archive-keyring/copyright | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
|
||
define Package/debian-archive-keyring | ||
SECTION:=admin | ||
CATEGORY:=Administration | ||
TITLE:=Debian Archive keyring | ||
URL:=https://salsa.debian.org/release-team/debian-archive-keyring | ||
PKGARCH:=all | ||
endef | ||
|
||
define Build/Prepare | ||
$(AR) p $(DL_DIR)/$(PKG_SOURCE) data.tar.xz | $(TAR) -xJC $(PKG_BUILD_DIR) | ||
endef | ||
|
||
define Build/Configure | ||
endef | ||
|
||
define Build/Compile | ||
endef | ||
|
||
define Package/debian-archive-keyring/install | ||
$(INSTALL_DIR) $(1)/usr/share/keyring | ||
$(INSTALL_DATA) $(PKG_BUILD_DIR)/usr/share/keyrings/*.gpg $(1)/usr/share/keyring | ||
endef | ||
|
||
$(eval $(call BuildPackage,debian-archive-keyring)) |