Skip to content

Commit

Permalink
Fix FS#71138
Browse files Browse the repository at this point in the history
git-svn-id: file:///srv/repos/svn-packages/svn@417303 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
jelly committed Jun 7, 2021
1 parent b5146c2 commit 3b2d0b5
Show file tree
Hide file tree
Showing 2 changed files with 46 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,36 @@
From 02f295d4c4c1b401cdb589df5bef2645c7f83813 Mon Sep 17 00:00:00 2001
From: Hans Verkuil <[email protected]>
Date: Mon, 15 Mar 2021 08:13:14 +0100
Subject: [PATCH] v4l2-tpg.patch: rename min/max defines to tpg_min/max

With gcc 11 the min/max defines clash with what gcc provides,
so rename these defines. They are only used in the min3/max3
defines, so the change it kept to a minimum.

Signed-off-by: Hans Verkuil <[email protected]>
Reported-by: Gregor Jasny <[email protected]>
---
utils/common/v4l2-tpg.h | 10 ++++------
utils/common/v4l2-tpg.patch | 12 +++++-------
2 files changed, 9 insertions(+), 13 deletions(-)

diff --git a/utils/common/v4l2-tpg.h b/utils/common/v4l2-tpg.h
index caf7b1a1..ecdb6eba 100644
--- a/utils/common/v4l2-tpg.h
+++ b/utils/common/v4l2-tpg.h
@@ -28,12 +28,10 @@ typedef __s8 s8;
#define pr_info printf
#define noinline

-#ifndef min
-#define min(a,b) ((a) < (b) ? (a) : (b))
-#define max(a,b) ((a) > (b) ? (a) : (b))
-#endif /* !min */
-#define min3(x, y, z) min((typeof(x))min(x, y), z)
-#define max3(x, y, z) max((typeof(x))max(x, y), z)
+#define tpg_min(a,b) ((a) < (b) ? (a) : (b))
+#define tpg_max(a,b) ((a) > (b) ? (a) : (b))
+#define min3(x, y, z) tpg_min((typeof(x))tpg_min(x, y), z)
+#define max3(x, y, z) tpg_max((typeof(x))tpg_max(x, y), z)
#define array_size(a, b) ((a) * (b))
#define array3_size(a, b, c) ((a) * (b) * (c))
13 changes: 10 additions & 3 deletions v4l-utils/trunk/PKGBUILD
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Maintainer: Thomas Bächler <[email protected]>
pkgname=v4l-utils
pkgver=1.20.0
pkgrel=1
pkgrel=2
pkgdesc="Userspace tools and conversion library for Video 4 Linux"
arch=('x86_64')
url="https://linuxtv.org/"
Expand All @@ -13,11 +13,18 @@ license=('LGPL')
makedepends=('qt5-base' 'alsa-lib')
optdepends=('qt5-base: for qv4l2' 'alsa-lib: for qv4l2')
depends=('hicolor-icon-theme' 'gcc-libs' 'sysfsutils' 'libjpeg-turbo')
source=(https://linuxtv.org/downloads/v4l-utils/${pkgname}-${pkgver}.tar.bz2{,.asc})
source=(https://linuxtv.org/downloads/v4l-utils/${pkgname}-${pkgver}.tar.bz2{,.asc}
0001-v4l2-tpg.patch-rename-min-max-defines-to-tpg_min-max.patch)
sha256sums=('956118713f7ccb405c55c7088a6a2490c32d54300dd9a30d8d5008c28d3726f7'
'SKIP')
'SKIP'
'b824c14b63208259069dfa52102993602a727a14ca4016eeea4ea726409e5d20')
validpgpkeys=('05D0169C26E41593418129DF199A64FADFB500FF') # Gregor Jasny <[email protected]>

prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
patch -Np1 -i ${srcdir}/0001-v4l2-tpg.patch-rename-min-max-defines-to-tpg_min-max.patch
}

build() {
cd "${srcdir}/${pkgname}-${pkgver}"

Expand Down

0 comments on commit 3b2d0b5

Please sign in to comment.