Skip to content

Commit

Permalink
upgpkg: mariadb 10.3.13-2
Browse files Browse the repository at this point in the history
MDEV-18605: Loss of column aliases by using view and group


git-svn-id: file:///srv/repos/svn-packages/svn@346965 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
eworm committed Mar 1, 2019
1 parent ce27766 commit 5a973e8
Show file tree
Hide file tree
Showing 2 changed files with 30 additions and 3 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,21 @@
From 82da98556cf58f0fbb43c82e9c6ae1a887b6cf3d Mon Sep 17 00:00:00 2001
From: Oleksandr Byelkin <[email protected]>
Date: Mon, 25 Feb 2019 15:57:08 +0100
Subject: [PATCH 2/2] MDEV-18605: Loss of column aliases by using view and
group

Preserv column name with copy fields even if it is function and Co.
diff --git a/sql/sql_select.cc b/sql/sql_select.cc
index 439853c2f66..0bc27f18d47 100644
--- a/sql/sql_select.cc
+++ b/sql/sql_select.cc
@@ -23914,7 +23914,9 @@ setup_copy_fields(THD *thd, TMP_TABLE_PARAM *param,
real_pos->type() == Item::COND_ITEM) &&
!real_pos->with_sum_func)
{ // Save for send fields
+ LEX_CSTRING real_name= pos->name;
pos= real_pos;
+ pos->name= real_name;
/* TODO:
In most cases this result will be sent to the user.
This should be changed to use copy_int or copy_real depending
12 changes: 9 additions & 3 deletions mariadb/trunk/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ pkgbase=mariadb
pkgname=('mariadb-libs' 'mariadb-clients' 'mariadb' 'mytop')
pkgdesc='Fast SQL database server, derived from MySQL'
pkgver=10.3.13
pkgrel=1
pkgrel=2
arch=('x86_64')
license=('GPL')
url='https://mariadb.org/'
Expand All @@ -16,13 +16,15 @@ source=("https://mirrors.n-ix.net/mariadb/mariadb-$pkgver/source/mariadb-$pkgver
'0001-arch-specific.patch'
'0002-systemd-sysusers-tmpfiles.patch'
'0004-do-not-break-main-configuration-with-instantiated-one.patch'
'0005-fix-galera_recovery-with-fs.protected_regular-enabled.patch')
'0005-fix-galera_recovery-with-fs.protected_regular-enabled.patch'
'0007-MDEV-18605-Loss-of-column-aliases-by-using-view-and-.patch')
sha256sums=('b2aa857ef5b84f85a7ea60a1eac7b34c0ca5151c71a0d44ce2d7fb028d71459a'
'SKIP'
'5a443a403821931ce35759e9583d23cd809b3b5a5df5b8293ac8e33b9c0cbc0f'
'1cd009b473d5965c7cbe6d48fff272030a2ccdd9c7e67b4f837d03252786a09a'
'd12806e4f90cc0fc081205dd4c0a5e0e7c455844f04276811b61b57fd24f5545'
'66e0acac7436fd8925710ef5cc66ba1a8f63a385ce374f01ae83096cc33d97a0')
'66e0acac7436fd8925710ef5cc66ba1a8f63a385ce374f01ae83096cc33d97a0'
'98f0bd85e1729133d236831e934a3dd0c9bc6deebbff6aebe8a4bda17e457ac4')

prepare() {
cd $pkgbase-$pkgver/
Expand All @@ -46,6 +48,10 @@ prepare() {
# fix galera_recovery with fs.protected_regular enabled
# https://github.com/MariaDB/server/pull/1137
patch -Np1 < ../0005-fix-galera_recovery-with-fs.protected_regular-enabled.patch

# MDEV-18605: Loss of column aliases by using view and group
# https://jira.mariadb.org/browse/MDEV-18605
patch -Np1 < ../0007-MDEV-18605-Loss-of-column-aliases-by-using-view-and-.patch
}

build() {
Expand Down

0 comments on commit 5a973e8

Please sign in to comment.