forked from freebsd/freebsd-ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Update the upstream and the references
PR: 230063 Submitted by: Yasuhiro KIMURA
- Loading branch information
Showing
4 changed files
with
14 additions
and
8 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -4,26 +4,32 @@ | |
PORTNAME= php-mode.el | ||
PORTVERSION= 1.19.1 | ||
DISTVERSIONPREFIX= v | ||
PORTREVISION= 1 | ||
CATEGORIES= lang elisp | ||
PKGNAMESUFFIX= ${EMACS_PKGNAMESUFFIX} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= PHP mode for GNU Emacs | ||
|
||
LICENSE= GPLv3 | ||
|
||
USES= emacs gmake | ||
USE_GITHUB= yes | ||
GH_ACCOUNT= ejmr | ||
GH_ACCOUNT= emacs-php | ||
GH_PROJECT= ${PORTNAME:S/.el$//} | ||
|
||
NO_BUILD= yes | ||
NO_ARCH= yes | ||
PLIST_FILES= share/emacs/site-lisp/php-mode.el \ | ||
share/emacs/site-lisp/php-project.el | ||
share/emacs/site-lisp/php-mode.elc \ | ||
share/emacs/site-lisp/php-project.el \ | ||
share/emacs/site-lisp/php-project.elc | ||
|
||
do-install: | ||
${INSTALL_DATA} \ | ||
${WRKSRC}/php-mode.el \ | ||
${WRKSRC}/php-mode.elc \ | ||
${WRKSRC}/php-project.el \ | ||
${WRKSRC}/php-project.elc \ | ||
${STAGEDIR}${PREFIX}/share/emacs/site-lisp/ | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1526208224 | ||
SHA256 (ejmr-php-mode-v1.19.1_GH0.tar.gz) = 23a891e989eb0466d1dddcb6cb62404d3f1c7a329d7ab6709c8fc16e1bc277c9 | ||
SIZE (ejmr-php-mode-v1.19.1_GH0.tar.gz) = 94857 | ||
TIMESTAMP = 1532599720 | ||
SHA256 (emacs-php-php-mode-v1.19.1_GH0.tar.gz) = 23a891e989eb0466d1dddcb6cb62404d3f1c7a329d7ab6709c8fc16e1bc277c9 | ||
SIZE (emacs-php-php-mode-v1.19.1_GH0.tar.gz) = 94857 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
This is a PHP mode for GNU Emacs. | ||
|
||
WWW: https://github.com/ejmr/php-mode | ||
WWW: https://github.com/emacs-php/php-mode |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
To use php-mode in Emacs/XEmacs, add the following lines to your ~/.emacs: | ||
To use php-mode in Emacs, add the following lines to your ~/.emacs: | ||
|
||
(autoload 'php-mode "php-mode" "Mode for editing PHP source files") | ||
(add-to-list 'auto-mode-alist '("\\.\\(inc\\|php[s34]?\\)" . php-mode)) |