Skip to content

Commit

Permalink
Added support for the bind12 and bind13, thanks to VVD and Amitay Isaacs
Browse files Browse the repository at this point in the history
PR:		235626
  • Loading branch information
b-a-t committed Feb 12, 2019
1 parent 736ab81 commit 7f33b01
Show file tree
Hide file tree
Showing 5 changed files with 93 additions and 42 deletions.
6 changes: 4 additions & 2 deletions net/samba48/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= ${SAMBA4_BASENAME}48
PORTVERSION= ${SAMBA4_VERSION}
PORTREVISION= 0
PORTREVISION= 1
CATEGORIES?= net
MASTER_SITES= SAMBA/samba/stable SAMBA/samba/rc
DISTNAME= ${SAMBA4_DISTNAME}
Expand Down Expand Up @@ -101,7 +101,7 @@ OPTIONS_SINGLE= GSSAPI
OPTIONS_SINGLE_GSSAPI= GSSAPI_BUILTIN GSSAPI_MIT

OPTIONS_RADIO= DNS ZEROCONF
OPTIONS_RADIO_DNS= NSUPDATE BIND911 BIND912
OPTIONS_RADIO_DNS= NSUPDATE BIND911 BIND912 BIND913
OPTIONS_RADIO_ZEROCONF= MDNSRESPONDER AVAHI
##############################################################################
AD_DC_DESC= Active Directory Domain Controller
Expand All @@ -127,6 +127,7 @@ GSSAPI_BUILTIN_DESC= GSSAPI support via bundled Heimdal

BIND911_DESC= Use Bind 9.11 as AD DC DNS server frontend
BIND912_DESC= Use Bind 9.12 as AD DC DNS server frontend
BIND913_DESC= Use Bind 9.13 as AD DC DNS server frontend
NSUPDATE_DESC= Use samba NSUPDATE utility for AD DC
##############################################################################
# XXX: Unconditional dependencies which can't be switched off(if present in
Expand Down Expand Up @@ -270,6 +271,7 @@ CONFIGURE_ARGS+= \
##############################################################################
BIND911_RUN_DEPENDS= bind911>=9.11.0.0:dns/bind911
BIND912_RUN_DEPENDS= bind912>=9.12.0.0:dns/bind912
BIND913_RUN_DEPENDS= bind913>=9.13.0.0:dns/bind913
NSUPDATE_RUN_DEPENDS= samba-nsupdate:dns/samba-nsupdate

AVAHI_CONFIGURE_ENABLE= avahi
Expand Down
87 changes: 87 additions & 0 deletions net/samba48/files/patch-bind13
Original file line number Diff line number Diff line change
@@ -0,0 +1,87 @@
--- source4/dns_server/wscript_build.orig 2018-01-14 20:41:58 UTC
+++ source4/dns_server/wscript_build
@@ -58,6 +58,26 @@
deps='samba-hostconfig samdb-common gensec popt dnsserver_common',
enabled=bld.AD_DC_BUILD_IS_ENABLED())

+bld.SAMBA_LIBRARY('dlz_bind9_12',
+ source='dlz_bind9.c',
+ cflags='-DBIND_VERSION_9_12',
+ private_library=True,
+ link_name='modules/bind9/dlz_bind9_12.so',
+ realname='dlz_bind9_12.so',
+ install_path='${MODULESDIR}/bind9',
+ deps='samba-hostconfig samdb-common gensec popt dnsserver_common',
+ enabled=bld.AD_DC_BUILD_IS_ENABLED())
+
+bld.SAMBA_LIBRARY('dlz_bind9_13',
+ source='dlz_bind9.c',
+ cflags='-DBIND_VERSION_9_13',
+ private_library=True,
+ link_name='modules/bind9/dlz_bind9_13.so',
+ realname='dlz_bind9_13.so',
+ install_path='${MODULESDIR}/bind9',
+ deps='samba-hostconfig samdb-common gensec popt dnsserver_common',
+ enabled=bld.AD_DC_BUILD_IS_ENABLED())
+
bld.SAMBA_LIBRARY('dlz_bind9_for_torture',
source='dlz_bind9.c',
cflags='-DBIND_VERSION_9_8',
--- source4/dns_server/dlz_minimal.h.orig 2018-01-14 20:41:58 UTC
+++ source4/dns_server/dlz_minimal.h
@@ -31,7 +31,7 @@
#elif defined (BIND_VERSION_9_10)
# define DLZ_DLOPEN_VERSION 3
# define DNS_CLIENTINFO_VERSION 1
-#elif defined (BIND_VERSION_9_11)
+#elif defined (BIND_VERSION_9_11) || defined (BIND_VERSION_9_12) || defined (BIND_VERSION_9_13)
# define DLZ_DLOPEN_VERSION 3
# define DNS_CLIENTINFO_VERSION 2
#else
--- source4/setup/named.conf.dlz.orig 2018-01-14 22:41:59 UTC
+++ source4/setup/named.conf.dlz
@@ -21,5 +21,11 @@ dlz "AD DNS Zone" {

# For BIND 9.11.x
${BIND9_11} database "dlopen ${MODULESDIR}/bind9/dlz_bind9_11.so";
+
+ # For BIND 9.12.x
+ ${BIND9_12} database "dlopen ${MODULESDIR}/bind9/dlz_bind9_12.so";
+
+ # For BIND 9.13.x
+ ${BIND9_13} database "dlopen ${MODULESDIR}/bind9/dlz_bind9_13.so";
};

--- python/samba/provision/sambadns.py.orig 2018-01-17 09:08:39 UTC
+++ python/samba/provision/sambadns.py
@@ -937,6 +937,8 @@ def create_named_conf(paths, realm, dnsd
bind9_9 = '#'
bind9_10 = '#'
bind9_11 = '#'
+ bind9_12 = '#'
+ bind9_13 = '#'
if bind_info.upper().find('BIND 9.8') != -1:
bind9_8 = ''
elif bind_info.upper().find('BIND 9.9') != -1:
@@ -945,6 +947,10 @@ def create_named_conf(paths, realm, dnsd
bind9_10 = ''
elif bind_info.upper().find('BIND 9.11') != -1:
bind9_11 = ''
+ elif bind_info.upper().find('BIND 9.12') != -1:
+ bind9_12 = ''
+ elif bind_info.upper().find('BIND 9.13') != -1:
+ bind9_13 = ''
elif bind_info.upper().find('BIND 9.7') != -1:
raise ProvisioningError("DLZ option incompatible with BIND 9.7.")
else:
@@ -955,7 +961,9 @@ def create_named_conf(paths, realm, dnsd
"BIND9_8" : bind9_8,
"BIND9_9" : bind9_9,
"BIND9_10" : bind9_10,
- "BIND9_11" : bind9_11
+ "BIND9_11" : bind9_11,
+ "BIND9_12" : bind9_12,
+ "BIND9_13" : bind9_13
})


29 changes: 0 additions & 29 deletions net/samba48/files/patch-python_samba_provision_sambadns.py

This file was deleted.

11 changes: 0 additions & 11 deletions net/samba48/files/patch-source4_setup_named.conf.dlz

This file was deleted.

2 changes: 2 additions & 0 deletions net/samba48/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -296,6 +296,8 @@ lib/samba4/private/libwinbind-client-samba4.so
lib/samba4/private/libxattr-tdb-samba4.so
%%AD_DC%%lib/shared-modules/bind9/dlz_bind9_10.so
%%AD_DC%%lib/shared-modules/bind9/dlz_bind9_11.so
%%AD_DC%%lib/shared-modules/bind9/dlz_bind9_12.so
%%AD_DC%%lib/shared-modules/bind9/dlz_bind9_13.so
%%AD_DC%%lib/shared-modules/bind9/dlz_bind9_9.so
%%AD_DC%%lib/shared-modules/bind9/dlz_bind9.so
%%AD_DC%%lib/shared-modules/gensec/krb5.so
Expand Down

0 comments on commit 7f33b01

Please sign in to comment.