Skip to content

Commit

Permalink
Move the rc.d scripts of the form *.sh.in to *.in
Browse files Browse the repository at this point in the history
Where necessary add $FreeBSD$ to the file

No PORTREVISION bump necessary because this is a no-op
  • Loading branch information
dougb authored and dougb committed Aug 5, 2012
1 parent 37b2a02 commit f0d9f58
Show file tree
Hide file tree
Showing 611 changed files with 407 additions and 373 deletions.
2 changes: 1 addition & 1 deletion audio/gnump3d/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@ RUN_DEPENDS= lame:${PORTSDIR}/audio/lame \
USE_BZIP2= yes
USE_PERL5_RUN= 5.8.0+
NO_BUILD= yes
USE_RC_SUBR= gnump3d.sh
USE_RC_SUBR= gnump3d
SUB_LIST+= PERL=${PERL}

MAN1= gnump3d-index.1 gnump3d-top.1 gnump3d.1 gnump3d.conf.1
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
#!/bin/sh

# $FreeBSD$
#
# PROVIDE: gnump3d
# REQUIRE: DAEMON NETWORKING LOGIN
Expand Down
2 changes: 1 addition & 1 deletion audio/icecast2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -28,7 +28,7 @@ LICENSE= GPLv2

USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_RC_SUBR= icecast2.sh
USE_RC_SUBR= icecast2
SUB_FILES+= pkg-message
CONFIGURE_ENV= OGG_PREFIX=${LOCALBASE}
CFLAGS+= -I${LOCALBASE}/include
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion audio/ices0/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@ USE_PERL5= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
LATEST_LINK= ices0
USE_RC_SUBR= ices0.sh
USE_RC_SUBR= ices0
SUB_FILES+= message message-bin
CONFIGURE_ARGS+=--program-suffix=0

Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion audio/liquidsoap/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -67,7 +67,7 @@ MAKE_JOBS_UNSAFE= yes

USE_BZIP2= yes

USE_RC_SUBR= liquidsoap.sh
USE_RC_SUBR= liquidsoap

USE_OCAML= yes
NO_OCAML_RUNDEPENDS= yes
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,7 @@
#!/bin/sh

# $FreeBSD$
#
# PROVIDE: liquidsoap
# REQUIRE: NETWORKING icecast2 shoutcast
# KEYWORD: shutdown
Expand Down
2 changes: 1 addition & 1 deletion audio/squeezeboxserver/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -77,7 +77,7 @@ RUN_DEPENDS+= shorten:${PORTSDIR}/audio/shorten
RUN_DEPENDS+= sox:${PORTSDIR}/audio/sox
.endif

USE_RC_SUBR= squeezeboxserver.sh
USE_RC_SUBR= squeezeboxserver
TMP_SLIMDIR= ${WRKDIR}/_squeezeboxserver
TMP_DOCSDIR= ${WRKDIR}/doc
DOCFILES= Changelog.html Installation.txt License.txt
Expand Down
2 changes: 1 addition & 1 deletion audio/ventrilo-server/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -25,7 +25,7 @@ IA32_BINARY_PORT= yes
NO_BUILD= yes
RESTRICTED= Redistribution of pre-compiled binaries is not permitted
INSTALL_DIR= ${PREFIX}/ventrilo-server
USE_RC_SUBR= ${PORTNAME}${PKGNAMESUFFIX}.sh
USE_RC_SUBR= ${PORTNAME}${PKGNAMESUFFIX}
VENT_USER= ${PORTNAME}
USERS= ${VENT_USER}
GROUPS= ${USERS}
Expand Down
2 changes: 1 addition & 1 deletion comms/conserver-com/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -18,7 +18,7 @@ COMMENT= Application that allows multiple users to watch serial consoles
GNU_CONFIGURE= YES
CONFIGURE_ARGS= --with-master=${DEFAULTHOST} --with-port=${DEFAULTPORT} \
--with-pam --with-libwrap --with-openssl
USE_RC_SUBR= conserver.sh
USE_RC_SUBR= conserver

MAN1= console.1
MAN5= conserver.cf.5 conserver.passwd.5
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion comms/conserver/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -30,7 +30,7 @@ DEFAULTHOST?= localhost
DEFAULTPORT?= 782
MAKE_ENV+= DEFAULTHOST="${DEFAULTHOST}" DEFAULTPORT="${DEFAULTPORT}"
#PKGMESSAGE= ${WRKDIR}/MESSAGE
USE_RC_SUBR= conserver.sh
USE_RC_SUBR= conserver

do-build:
${REINPLACE_CMD} -e 's:/usr/local/lib:${PREFIX}/etc:g' \
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion comms/hylafax/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@ MAKE_ARGS+= OPTIMIZER="" -EOPTIMIZER

PORTDOCS= RELEASENOTES-4.3.txt RELEASENOTES-4.4.txt RELEASENOTES-6.0.txt
SUB_FILES= pkg-message
USE_RC_SUBR= hylafax.sh
USE_RC_SUBR= hylafax

MAN1= edit-faxcover.1 faxalter.1 faxcover.1 faxmail.1 faxrm.1 faxstat.1 \
hylafax-client.1 sendfax.1 sendpage.1 sgi2fax.1 textfmt.1
Expand Down
Original file line number Diff line number Diff line change
@@ -1,8 +1,7 @@

#!/bin/sh
#
# $Id: hylafax.sh

# $FreeBSD$
#
# PROVIDE: hylafax
# REQUIRE: LOGIN
# KEYWORD: shutdown
Expand All @@ -25,5 +24,3 @@ procname="%%PREFIX%%/sbin/faxq"

load_rc_config $name
run_rc_command "$1"

# eof
2 changes: 1 addition & 1 deletion comms/lirc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -39,7 +39,7 @@ OPTIONS_DEFINE= MINIMAL DEBUG UARTLIRC
MINIMAL_DESC= Build with minmal dependencies
UARTLIRC_DESC= Install serial LIRC driver

USE_RC_SUBR= lircd.sh
USE_RC_SUBR= lircd
PORTDOCS= html images irxevent.keys lirc.css lirc.hwdb
PORTEXAMPLES= remotes
SUB_FILES= pkg-message lircd.conf
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion databases/drizzle/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -55,7 +55,7 @@ MAN1= drizzle.1 \

MAN8= drizzled.8

USE_RC_SUBR= drizzle-server.sh
USE_RC_SUBR= drizzle-server

.include <bsd.port.pre.mk>

Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion databases/frontbase/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@ LICENSE_PERMS= no-auto-accept # nothing else allowed either

NO_PACKAGE= license requires confirmation

USE_RC_SUBR= frontbase.sh
USE_RC_SUBR= frontbase
USE_LDCONFIG= yes
SUB_FILES+= pkg-message

Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion databases/mysql41-server/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -93,7 +93,7 @@ LATEST_LINK= mysql41-server

CONFLICTS= mysql-server-[35].* mysql-server-4.[02-9].*

USE_RC_SUBR= mysql-server.sh
USE_RC_SUBR= mysql-server

USERS= mysql
GROUPS= mysql
Expand Down
2 changes: 1 addition & 1 deletion databases/mysql50-server/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -104,7 +104,7 @@ LATEST_LINK= mysql50-server

CONFLICTS_INSTALL= mysql-server-[34].* mysql-server-5.[1-9].*

USE_RC_SUBR= mysql-server.sh
USE_RC_SUBR= mysql-server

USERS= mysql
GROUPS= mysql
Expand Down
2 changes: 1 addition & 1 deletion databases/mysql51-server/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -98,7 +98,7 @@ LATEST_LINK= mysql51-server

CONFLICTS_INSTALL= mysql-server-[34].* mysql-server-5.[02-9].*

USE_RC_SUBR= mysql-server.sh
USE_RC_SUBR= mysql-server

USERS= mysql
GROUPS= mysql
Expand Down
2 changes: 1 addition & 1 deletion databases/mysql55-server/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -63,7 +63,7 @@ LATEST_LINK= mysql55-server

CONFLICTS_INSTALL= mysql-server-[34].* mysql-server-5.[0-46-9].*

USE_RC_SUBR= mysql-server.sh
USE_RC_SUBR= mysql-server

USERS= mysql
GROUPS= mysql
Expand Down
2 changes: 1 addition & 1 deletion databases/mysqlard/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@ USE_MYSQL= yes

MYSQLARD_DIR?= ${PREFIX}/www/mysqlard

USE_RC_SUBR= mysqlard.sh
USE_RC_SUBR= mysqlard

MAN1= mysqlar_graph.1
MAN8= mysqlard.8
Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
#!/bin/sh

# $FreeBSD$
#
# $Id: mysqlard.server.sh 40 2006-01-20 20:26:11Z dewitge $
#
Expand Down
2 changes: 1 addition & 1 deletion databases/percona55-server/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -67,7 +67,7 @@ LATEST_LINK= percona55-server

CONFLICTS_INSTALL= mysql-server-[34].* mysql-server-5.[0-46-9].*

USE_RC_SUBR= mysql-server.sh
USE_RC_SUBR= mysql-server

USERS= mysql
GROUPS= mysql
Expand Down
2 changes: 1 addition & 1 deletion databases/pgbouncer/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@ PORTSCOUT= site:http://pgfoundry.org/frs/?group_id=1000258
USERS= pgbouncer
GROUPS= pgbouncer

USE_RC_SUBR= pgbouncer.sh
USE_RC_SUBR= pgbouncer
SUB_FILES= pkg-message pkg-install pkg-deinstall

GNU_CONFIGURE= yes
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion databases/slony1/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -22,7 +22,7 @@ USE_BISON= build
USE_PGSQL= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_RC_SUBR= slon.sh
USE_RC_SUBR= slon

SUB_FILES= pkg-message slon-mkservice.sh
SUB_LIST+= NAME=slon
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion databases/slony1v2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -24,7 +24,7 @@ USE_BISON= build
USE_PGSQL= yes
USE_GMAKE= yes
USE_BZIP2= yes
USE_RC_SUBR= slon.sh
USE_RC_SUBR= slon

SUB_FILES= pkg-message slon-mkservice.sh
SUB_LIST+= NAME=slon
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion databases/virtuoso/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -40,7 +40,7 @@ CPPFLAGS+= -std=gnu89 -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= PATH=${LOCALBASE}/bin:${PATH}\
ISQL=isql-vt
USE_RC_SUBR= virtuoso.sh
USE_RC_SUBR= virtuoso
ONLY_FOR_ARCHS= i386 amd64 sparc64
USERS= virtuoso
GROUPS= virtuoso
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion devel/distcc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -29,7 +29,7 @@ CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
DISTCCD_PIDFILE=/var/run/distccd.pid
USE_RC_SUBR= distccd.sh
USE_RC_SUBR= distccd
SUB_LIST= DISTCCD_PIDFILE=${DISTCCD_PIDFILE}

OPTIONS= GNOME "Build GUI monitor based on GNOME" Off \
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion devel/gearmand/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -24,7 +24,7 @@ GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack
USE_LDCONFIG= yes
USE_RC_SUBR= gearmand.sh
USE_RC_SUBR= gearmand
CONFIGURE_ARGS+=--with-lib-prefix=${LOCALBASE} --with-boost=${LOCALBASE}

OPTIONS= DRIZZLE "Enable Drizzle support for persistent queue" off \
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion devel/p4d/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@ P4LOG?= /var/log/p4d.log
SUB_LIST= P4ROOT=${P4ROOT} \
P4LOG=${P4LOG}

USE_RC_SUBR= p4d.sh
USE_RC_SUBR= p4d

.include <bsd.port.pre.mk>

Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion devel/p4ftpd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,7 @@ P4LOG?= /var/log/p4ftpd.log

SUB_LIST= P4LOG=${P4LOG}

USE_RC_SUBR= p4ftpd.sh
USE_RC_SUBR= p4ftpd

.include <bsd.port.pre.mk>

Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion devel/p4p/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@ P4LOG?= /var/log/p4p.log
SUB_LIST= P4CACHE=${P4CACHE} \
P4LOG=${P4LOG}

USE_RC_SUBR= p4p.sh
USE_RC_SUBR= p4p

.include <bsd.port.pre.mk>

Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion devel/p4web/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -32,7 +32,7 @@ P4LOG?= /var/log/p4web.log

SUB_LIST= P4LOG=${P4LOG}

USE_RC_SUBR= p4web.sh
USE_RC_SUBR= p4web

.include <bsd.port.pre.mk>

Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion devel/p5-Java/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= [email protected]
COMMENT= Perl extension for accessing a JVM remotely or locally

USE_RC_SUBR= javaserver.sh
USE_RC_SUBR= javaserver
PERL_CONFIGURE= YES
USE_JAVA= yes
JAVA_VERSION= 1.5+
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion dns/dnrd/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -14,7 +14,7 @@ MAINTAINER= [email protected]
COMMENT= A proxy DNS daemon

USE_GMAKE= yes
USE_RC_SUBR= ${PORTNAME}.sh
USE_RC_SUBR= ${PORTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS}

Expand Down
7 changes: 3 additions & 4 deletions dns/dnrd/files/dnrd.sh.in → dns/dnrd/files/dnrd.in
Original file line number Diff line number Diff line change
@@ -1,13 +1,13 @@
#! /bin/sh
#
#!/bin/sh

# $FreeBSD$
#
# PROVIDE: dnrd
# REQUIRE: DAEMON NETWORKING SERVERS
#
# Add the following line to /etc/rc.conf to enable dnrd:
#
# dnrd_enable="YES"
#

# override these variables in /etc/rc.conf
dnrd_enable=${dnrd_enable-"NO"}
Expand All @@ -31,4 +31,3 @@ case $1 in
run_rc_command "$1"
;;
esac

2 changes: 1 addition & 1 deletion dns/dns_balance/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -15,7 +15,7 @@ MAINTAINER= [email protected]
COMMENT= A dynamic load-balancing DNS server

USE_RUBY= yes
USE_RC_SUBR= dns_balance.sh
USE_RC_SUBR= dns_balance

NO_BUILD= yes

Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion dns/dnsmasq/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -71,7 +71,7 @@ CFLAGS+= -DHAVE_LUASCRIPT
USE_LUA= 5.1
.endif

USE_RC_SUBR= dnsmasq.sh
USE_RC_SUBR= dnsmasq

.include <bsd.port.pre.mk>

Expand Down
Original file line number Diff line number Diff line change
@@ -1,4 +1,6 @@
#! /bin/sh
#!/bin/sh

# $FreeBSD$
#
# PROVIDE: dnsmasq
# REQUIRE: SERVERS
Expand Down
2 changes: 1 addition & 1 deletion dns/dualserver/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@ MAINTAINER= [email protected]
COMMENT= Combined DHCP/DNS server for small LANs

USE_DOS2UNIX= yes
USE_RC_SUBR= dualserver.sh
USE_RC_SUBR= dualserver
WRKSRC= ${WRKDIR}/${PORTNAME}
PLIST_FILES= sbin/dualserver etc/dualserver.conf.sample

Expand Down
Original file line number Diff line number Diff line change
@@ -1,6 +1,7 @@
#!/bin/sh
#

# $FreeBSD$
#
# PROVIDE: dualserver
# REQUIRE: SERVERS
# BEFORE:
Expand Down
2 changes: 1 addition & 1 deletion dns/ez-ipupdate/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -16,7 +16,7 @@ MASTER_SITES= http://dyn.pl/client/UNIX/ez-ipupdate/ \
MAINTAINER= [email protected]
COMMENT= Update your host name on any dynamic DNS service

USE_RC_SUBR= ez-ipupdate.sh
USE_RC_SUBR= ez-ipupdate
GNU_CONFIGURE= yes

post-install:
Expand Down
File renamed without changes.
2 changes: 1 addition & 1 deletion dns/mydns/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -19,7 +19,7 @@ CONFIGURE_ARGS= --with-confdir=${PREFIX}/etc
USE_ICONV= yes
USE_BZIP2= yes

USE_RC_SUBR= mydns.sh
USE_RC_SUBR= mydns

SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
Expand Down
File renamed without changes.
Loading

0 comments on commit f0d9f58

Please sign in to comment.