Skip to content

Commit

Permalink
Update to 0.23.0
Browse files Browse the repository at this point in the history
- Add ALCHEMY12 option
- While I'm here:
  - Use >= instead of > for some *_DEPENDS
  - Update WWW

Changes:	https://github.com/pandas-dev/pandas/releases
		https://pandas.pydata.org/pandas-docs/version/0.23.0/whatsnew.html
PR:		228545
Submitted by:	John W. O'Brien <[email protected]> (maintainer)
  • Loading branch information
sunpoet committed Jun 3, 2018
1 parent 759aeba commit fa981ac
Show file tree
Hide file tree
Showing 5 changed files with 26 additions and 80 deletions.
34 changes: 20 additions & 14 deletions math/py-pandas/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,8 @@
# $FreeBSD$

PORTNAME= pandas
DISTVERSION= 0.22.0
PORTREVISION= 1
DISTVERSION= 0.23.0
PORTREVISION= 0
CATEGORIES= math devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
Expand All @@ -25,11 +25,13 @@ OPTIONS_GROUP_ACCEL= BTLNCK NUMEXPR
OPTIONS_GROUP_STORAGE= BOTO TABLES
OPTIONS_GROUP_HTML= LXML HTML5LIB JINJA2
OPTIONS_GROUP_EXCEL= XLRD XLWT OPENPYXL XLSX
OPTIONS_RADIO_SQL= ALCHEMY10 ALCHEMY11
OPTIONS_RADIO_SQL= ALCHEMY10 ALCHEMY11 ALCHEMY12
OPTIONS_DEFAULT= BTLNCK NUMEXPR

# Note: we cannot include math/py-statsmodels in *_DEPENDS because it
# depends upon us for BUILD and RUN.
# Note: we cannot include the following ports in *_DEPENDS because they depend
# on us for BUILD and RUN.
# devel/py-xarray
# math/py-statsmodels

MPL_DESC= Support graphical plotting output via math/py-matplotlib
SCIPY_DESC= Support various statistical functions via science/py-scipy
Expand All @@ -40,37 +42,41 @@ TABLES_DESC= Support HDF5-based storage via devel/py-tables
LXML_DESC= Parse HTML with devel/py-lxml and www/py-beautifulsoup
JINJA2_DESC= Support conditional HTML formatting with devel/py-Jinja2
HTML5LIB_DESC= Parse HTML with www/py-html5lib and www/py-beautifulsoup
OPENPYXL_DESC= Read/write MS Excel 2007+ with textproc/py-openpyxl
OPENPYXL_DESC= Write MS Excel 2007+ with textproc/py-openpyxl
XLRD_DESC= Read MS Excel with textproc/py-xlrd
XLWT_DESC= Write MS Excel with textproc/py-xlwt
XLSX_DESC= Write MS Excel with textproc/py-xlsxwriter
ALCHEMY10_DESC= Support SQL databases via databases/py-sqlalchemy10
ALCHEMY11_DESC= Support SQL databases via databases/py-sqlalchemy11
ALCHEMY12_DESC= Support SQL databases via databases/py-sqlalchemy12
ACCEL_DESC= Computation Acceleration Add-ons
STORAGE_DESC= Data Storage Add-ons
SQL_DESC= SQLAlchemy ORM Add-ons
HTML_DESC= HTML Parsing/Generation Add-ons
EXCEL_DESC= MS Excel I/O Add-ons

MPL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>1.4.3:math/py-matplotlib@${FLAVOR}
SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>0.14.0:science/py-scipy@${FLAVOR}
BTLNCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bottleneck>1.0.0:math/py-bottleneck@${FLAVOR}
MPL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}matplotlib>=1.4.3:math/py-matplotlib@${FLAVOR}
SCIPY_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}scipy>=0.14.0:science/py-scipy@${FLAVOR}
BTLNCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}bottleneck>=1.0.0:math/py-bottleneck@${FLAVOR}
NUMEXPR_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numexpr>=2.4.6:math/py-numexpr@${FLAVOR}
BOTO_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}boto>0:devel/py-boto@${FLAVOR}
TABLES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tables>=3.0.0:devel/py-tables@${FLAVOR}
TABLES_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tables>=3.2.1:devel/py-tables@${FLAVOR}

LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${FLAVOR} \
LXML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.2.1:www/py-beautifulsoup@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${FLAVOR}
HTML5LIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${FLAVOR} \
HTML5LIB_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.2.1:www/py-beautifulsoup@${FLAVOR} \
${PYTHON_PKGNAMEPREFIX}html5lib>0:www/py-html5lib@${FLAVOR}
JINJA2_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Jinja2>0:devel/py-Jinja2@${FLAVOR}
OPENPYXL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openpyxl>=2.2.0:textproc/py-openpyxl@${FLAVOR}
XLRD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlrd>0:textproc/py-xlrd@${FLAVOR}
OPENPYXL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}openpyxl>=2.4.0:textproc/py-openpyxl@${FLAVOR}
XLRD_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlrd>=0.9.0:textproc/py-xlrd@${FLAVOR}
XLWT_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}xlwt>0:textproc/py-xlwt@${FLAVOR}
XLSX_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}XlsxWriter>0:textproc/py-xlsxwriter@${FLAVOR}

ALCHEMY10_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10@${FLAVOR}
ALCHEMY11_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy11>0:databases/py-sqlalchemy11@${FLAVOR}
ALCHEMY12_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlalchemy12>0:databases/py-sqlalchemy12@${FLAVOR}

OPENPYXL_IMPLIES= XLRD

SUB_FILES= pkg-message

Expand Down
6 changes: 3 additions & 3 deletions math/py-pandas/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1516038682
SHA256 (pandas-0.22.0.tar.gz) = 44a94091dd71f05922eec661638ec1a35f26d573c119aa2fad964f10a2880e6c
SIZE (pandas-0.22.0.tar.gz) = 11297071
TIMESTAMP = 1527374327
SHA256 (pandas-0.23.0.tar.gz) = 84ab1d50590cb2d9554211f164dc1b1a216bc94da2ba922aed2690c83f248fd9
SIZE (pandas-0.23.0.tar.gz) = 13092442
61 changes: 0 additions & 61 deletions math/py-pandas/files/patch-GH18719

This file was deleted.

3 changes: 2 additions & 1 deletion math/py-pandas/files/pkg-message.in
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
===
If you wish, install math/py-statsmodels to enable parts of pandas.stats.
Install math/py-statsmodels to enable parts of pandas.stats.
Install devel/py-xarray to enable the to_xarray() function.
===
2 changes: 1 addition & 1 deletion math/py-pandas/pkg-descr
Original file line number Diff line number Diff line change
Expand Up @@ -4,4 +4,4 @@ data structures designed to make working with "relational" or
fundamental high-level building block for doing practical, real
world data analysis in Python.

WWW: http://pandas.pydata.org/
WWW: https://pandas.pydata.org/

0 comments on commit fa981ac

Please sign in to comment.