Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Dec 13, 2018
1 parent 7a831ee commit 010d58d
Show file tree
Hide file tree
Showing 120 changed files with 2,013 additions and 2,452 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,14 @@
diff --git src/lib/accerciser/accerciser.py src/lib/accerciser/accerciser.py
index fa6e5c752c2b921ab5cb324b747c0080e65f5f82..065a7fec78c62cb79acdda6fee7adc1097c586cf 100644
--- src/lib/accerciser/accerciser.py
+++ src/lib/accerciser/accerciser.py
@@ -103,7 +103,8 @@ class Main(Tools):
'''
GLib.timeout_add(200, self._pumpEvents)
try:
- pyatspi.Registry.start(async=True, gil=False)
+ # async is a reserved keyword in Python 3.7+, so we pass the args as dict
+ pyatspi.Registry.start(**{'async': True, 'gil': False})
except KeyboardInterrupt:
self._shutDown()

2 changes: 1 addition & 1 deletion archivers/upx/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= upx
DISTVERSIONPREFIX= v
DISTVERSION= 3.94
DISTVERSION= 3.95
CATEGORIES= archivers

MAINTAINER= [email protected]
Expand Down
10 changes: 5 additions & 5 deletions archivers/upx/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
TIMESTAMP = 1532707968
SHA256 (upx-upx-v3.94_GH0.tar.gz) = 2ddd9d409620b6946319bfdab6cf9d570c6057a89cd5b0b4707fc5e13cc95929
SIZE (upx-upx-v3.94_GH0.tar.gz) = 1601225
SHA256 (upx-upx-lzma-sdk-v3.94_GH0.tar.gz) = 9e9cea6112bd93fbc71c61d1ff068cc324b2d7bb7789043928b68c5d3cc0672d
SIZE (upx-upx-lzma-sdk-v3.94_GH0.tar.gz) = 109693
TIMESTAMP = 1544570151
SHA256 (upx-upx-v3.95_GH0.tar.gz) = fdb79c8238360115770e9c13bdaeb48da6fb09c813b0a461c5f9faee176d6fb9
SIZE (upx-upx-v3.95_GH0.tar.gz) = 1663470
SHA256 (upx-upx-lzma-sdk-v3.95_GH0.tar.gz) = 4932ed7b79cf47aa91fe737c068f74553e17033161c7e7e532e4b967f02f1557
SIZE (upx-upx-lzma-sdk-v3.95_GH0.tar.gz) = 109697
4 changes: 2 additions & 2 deletions audio/csound/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,8 +2,8 @@
# $FreeBSD$

PORTNAME= csound
DISTVERSION= 6.12.2
PORTREVISION= 3
DISTVERSION= 6.12.2-83
DISTVERSIONSUFFIX= -gdf2edd269
CATEGORIES= audio lang

MAINTAINER= [email protected]
Expand Down
6 changes: 3 additions & 3 deletions audio/csound/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1542488559
SHA256 (csound-csound-6.12.2_GH0.tar.gz) = 39f4872b896eb1cbbf596fcacc0f2122fd3e5ebbb5cec14a81b4207d6b8630ff
SIZE (csound-csound-6.12.2_GH0.tar.gz) = 26297850
TIMESTAMP = 1544642888
SHA256 (csound-csound-6.12.2-83-gdf2edd269_GH0.tar.gz) = e14038c44fd954bea0fcb34af994757ca5f4fe75f99c80a1e8df867d5b9e7eee
SIZE (csound-csound-6.12.2-83-gdf2edd269_GH0.tar.gz) = 26295519
12 changes: 7 additions & 5 deletions audio/csound/files/patch-CMakeLists.txt
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
--- CMakeLists.txt.orig 2018-11-07 14:05:23 UTC
--- CMakeLists.txt.orig 2018-12-12 19:23:43 UTC
+++ CMakeLists.txt
@@ -164,8 +164,8 @@ endif()

Expand Down Expand Up @@ -35,29 +35,31 @@
set(LINUX YES)
else()
set(LINUX NO)
@@ -527,15 +527,17 @@ find_package(FLTK )
@@ -527,9 +527,11 @@ find_package(FLTK )
# LIST_REPLACE(FLTK_LIBRARIES 2 "fltk_images_SHARED")
# endif()
#endif()
-find_package(FAUST)
-find_package(Java)
-find_package(JNI)
+if (BUILD_FAUST_OPCODES)
+ find_package(FAUST)
+ find_package(FAUST)
+endif()
+#find_package(Java)
+#find_package(JNI)
find_package(LIBLO)
find_package(LUAJIT)
find_package(MUSICXML)
@@ -540,7 +542,7 @@ find_package(MUSICXML)

find_package(PORTSMF)
find_package(PythonLibs 2.7)
-if(NOT STK_LOCAL)
+if(BUILD_STK_OPCODES AND NOT STK_LOCAL)
find_package(STK)
endif()
find_package(SWIG)
@@ -1245,11 +1247,11 @@ if(CURL_FOUND)
@@ -1251,11 +1253,11 @@ if(USE_CURL AND CURL_FOUND)
endif()

# Linux does not have a separate libintl, it is part of libc
Expand All @@ -71,7 +73,7 @@
list(APPEND libcsound_LIBS ${LIBINTL_LIBRARY})
endif()
list(APPEND libcsound_CFLAGS -DGNU_GETTEXT)
@@ -1269,8 +1271,8 @@ endif()
@@ -1275,8 +1277,8 @@ endif()

if(LINUX)
message(STATUS "Building on Linux.")
Expand Down
6 changes: 3 additions & 3 deletions audio/csound/files/patch-cmake_Modules_FindFAUST.cmake
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
--- cmake/Modules/FindFAUST.cmake.orig 2018-11-17 16:56:13 UTC
--- cmake/Modules/FindFAUST.cmake.orig 2018-12-12 19:23:43 UTC
+++ cmake/Modules/FindFAUST.cmake
@@ -27,7 +27,7 @@ if(FAUST_FOUND)
# This is a static build of faust, hence
Expand All @@ -7,5 +7,5 @@
- find_program(LLVM_CONFIG llvm-config HINTS /usr/bin /usr/local/bin /usr/local/opt/llvm/bin)
+ find_program(LLVM_CONFIG llvm-config${FAUST_LLVM_VERSION} HINTS /usr/bin /usr/local/bin /usr/local/opt/llvm/bin)
if(NOT LLVM_CONFIG)
message(FATAL_ERROR "Using a static Faust library requires LLVM tooling to be present in the path")
endif()
message(WARNING "Using a static Faust library requires LLVM tooling to be present in the path.")
UNSET(FAUST_FOUND)
2 changes: 1 addition & 1 deletion audio/synthv1-lv2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@

PORTNAME= synthv1
DISTVERSIONPREFIX= ${PORTNAME}_
DISTVERSION= 0_9_3
DISTVERSION= 0_9_4
CATEGORIES= audio
PKGNAMESUFFIX= -lv2

Expand Down
6 changes: 3 additions & 3 deletions audio/synthv1-lv2/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1540761275
SHA256 (rncbc-synthv1-synthv1_0_9_3_GH0.tar.gz) = 70f3e3bb5a6a828f7fb4f4225a16360f9738a3c40ffcaad6c51c4c0321c086ca
SIZE (rncbc-synthv1-synthv1_0_9_3_GH0.tar.gz) = 209305
TIMESTAMP = 1544634972
SHA256 (rncbc-synthv1-synthv1_0_9_4_GH0.tar.gz) = 236eff9062d8920271f18ea2de54793d7489489196fb52ea1f887021cad9af99
SIZE (rncbc-synthv1-synthv1_0_9_4_GH0.tar.gz) = 209063
9 changes: 2 additions & 7 deletions benchmarks/polygraph/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,22 +4,17 @@
PORTNAME= polygraph
DISTVERSION= 4.13.0
PORTREVISION= 1
DISTVERSIONSUFFIX= -src
CATEGORIES= benchmarks www
MASTER_SITES= http://www.web-polygraph.org/downloads/srcs/
EXTRACT_SUFX= -src.tgz

MAINTAINER= [email protected]
COMMENT= Benchmarking tool for Web proxies

LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE

BROKEN_SSL= openssl111
BROKEN_SSL_REASON_openssl111= configure: error: OpenSSL libraries and/or directories were not found in /usr/local

WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}

USES= gmake ncurses shebangfix tar:tgz
USES= gmake ncurses shebangfix
SHEBANG_FILES= tools/*.pl
USE_GCC= any
GNU_CONFIGURE= yes
Expand Down
3 changes: 0 additions & 3 deletions comms/trustedqsl/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -16,9 +16,6 @@ LICENSE_NAME= American Radio Relay League, Inc. All rights reserved.
LICENSE_FILE= ${WRKSRC}/LICENSE.txt
LICENSE_PERMS= dist-mirror pkg-mirror auto-accept

BROKEN_SSL= openssl111
BROKEN_SSL_REASON_openssl111= member access into incomplete type 'EVP_PKEY' (aka 'evp_pkey_st')

LIB_DEPENDS= libcurl.so:ftp/curl \
libexpat.so:textproc/expat2 \
liblmdb.so:databases/lmdb
Expand Down
3 changes: 0 additions & 3 deletions databases/pgbouncer/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -12,9 +12,6 @@ COMMENT= Lightweight connection pooler for PostgreSQL

LICENSE= BSD2CLAUSE

BROKEN_SSL= openssl111
BROKEN_SSL_REASON_openssl111= variable has incomplete type 'X509_STORE_CTX' (aka 'struct x509_store_ctx_st')

LIB_DEPENDS= libevent.so:devel/libevent
BUILD_DEPENDS+= ${LOCALBASE}/bin/gsed:textproc/gsed

Expand Down
2 changes: 1 addition & 1 deletion databases/py-python-arango/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= python-arango
DISTVERSION= 4.2.1
DISTVERSION= 4.3.0
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
Expand Down
6 changes: 3 additions & 3 deletions databases/py-python-arango/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1529257297
SHA256 (python-arango-4.2.1.tar.gz) = 3f2e98d0fb88ac31af1031ed09cf327609ba0bb110b8d615ef5566fee87e2c38
SIZE (python-arango-4.2.1.tar.gz) = 53999
TIMESTAMP = 1544635733
SHA256 (python-arango-4.3.0.tar.gz) = 9b479ea552194ecfc964021d064ec24518a8008215fb4a22e9268355d1617b63
SIZE (python-arango-4.3.0.tar.gz) = 55253
1 change: 0 additions & 1 deletion devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -434,7 +434,6 @@
SUBDIR += dbus-tcl
SUBDIR += dcd-client
SUBDIR += dcd-server
SUBDIR += dcmtk
SUBDIR += dconf
SUBDIR += dconf-editor
SUBDIR += ddd
Expand Down
2 changes: 1 addition & 1 deletion devel/binutils/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= binutils
PORTVERSION= 2.30
PORTREVISION= 6
PORTREVISION= 7
PORTEPOCH?= 1
CATEGORIES?= devel
MASTER_SITES= SOURCEWARE/binutils/releases
Expand Down
50 changes: 0 additions & 50 deletions devel/dcmtk/Makefile

This file was deleted.

2 changes: 0 additions & 2 deletions devel/dcmtk/distinfo

This file was deleted.

Loading

0 comments on commit 010d58d

Please sign in to comment.