forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
242 changed files
with
4,034 additions
and
1,504 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1491683625 | ||
SHA256 (routino-3.2.tgz) = e2a431eaffbafab630835966d342e4ae25d5edb94c8ed419200e1ffb50bc7552 | ||
SIZE (routino-3.2.tgz) = 2463662 | ||
TIMESTAMP = 1568197606 | ||
SHA256 (routino-3.3.1.tgz) = a954565ab60a5abebc47e8c6e8b496f972e8dd781810fa5548b6d7a9e3e5e135 | ||
SIZE (routino-3.3.1.tgz) = 2541830 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,22 @@ | ||
--- src/DoublePinyinContext.cc.orig 2019-09-09 19:45:16 UTC | ||
+++ src/DoublePinyinContext.cc | ||
@@ -352,7 +352,7 @@ DoublePinyinContext::isPinyin (int i) | ||
return NULL; | ||
} | ||
|
||
- char sheng = ID_TO_SHENG (i); | ||
+ signed char sheng = ID_TO_SHENG (i); | ||
|
||
if (sheng == PINYIN_ID_VOID) { | ||
return NULL; | ||
@@ -365,8 +365,8 @@ inline const Pinyin * | ||
DoublePinyinContext::isPinyin (int i, int j) | ||
{ | ||
const Pinyin *pinyin = NULL; | ||
- char sheng = ID_TO_SHENG (i); | ||
- const char *yun = ID_TO_YUNS (j); | ||
+ signed char sheng = ID_TO_SHENG (i); | ||
+ const signed char *yun = ID_TO_YUNS (j); | ||
|
||
do { | ||
if (sheng == PINYIN_ID_VOID || yun[0] == PINYIN_ID_VOID) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,121 @@ | ||
--- src/DoublePinyinTable.h.orig 2019-09-09 19:30:30 UTC | ||
+++ src/DoublePinyinTable.h | ||
@@ -26,7 +26,7 @@ | ||
|
||
#define PINYIN_ID_AEO PINYIN_ID_ZERO | ||
|
||
-static const char double_pinyin_mspy_sheng[] = { | ||
+static const signed char double_pinyin_mspy_sheng[] = { | ||
PINYIN_ID_AEO, // A | ||
PINYIN_ID_B, // B | ||
PINYIN_ID_C, // C | ||
@@ -55,7 +55,7 @@ static const char double_pinyin_mspy_sheng[] = { | ||
PINYIN_ID_Z, // Z | ||
PINYIN_ID_VOID, // ; | ||
}; | ||
-static const char double_pinyin_mspy_yun[][2] = { | ||
+static const signed char double_pinyin_mspy_yun[][2] = { | ||
{ PINYIN_ID_A, PINYIN_ID_VOID }, // A | ||
{ PINYIN_ID_OU, PINYIN_ID_VOID }, // B | ||
{ PINYIN_ID_IAO, PINYIN_ID_VOID }, // C | ||
@@ -84,7 +84,7 @@ static const char double_pinyin_mspy_yun[][2] = { | ||
{ PINYIN_ID_EI, PINYIN_ID_VOID }, // Z | ||
{ PINYIN_ID_ING, PINYIN_ID_VOID }, // ; | ||
}; | ||
-static const char double_pinyin_zrm_sheng[] = { | ||
+static const signed char double_pinyin_zrm_sheng[] = { | ||
PINYIN_ID_AEO, // A | ||
PINYIN_ID_B, // B | ||
PINYIN_ID_C, // C | ||
@@ -113,7 +113,7 @@ static const char double_pinyin_zrm_sheng[] = { | ||
PINYIN_ID_Z, // Z | ||
PINYIN_ID_VOID, // ; | ||
}; | ||
-static const char double_pinyin_zrm_yun[][2] = { | ||
+static const signed char double_pinyin_zrm_yun[][2] = { | ||
{ PINYIN_ID_A, PINYIN_ID_VOID }, // A | ||
{ PINYIN_ID_OU, PINYIN_ID_VOID }, // B | ||
{ PINYIN_ID_IAO, PINYIN_ID_VOID }, // C | ||
@@ -142,7 +142,7 @@ static const char double_pinyin_zrm_yun[][2] = { | ||
{ PINYIN_ID_EI, PINYIN_ID_VOID }, // Z | ||
{ PINYIN_ID_VOID, PINYIN_ID_VOID }, // ; | ||
}; | ||
-static const char double_pinyin_abc_sheng[] = { | ||
+static const signed char double_pinyin_abc_sheng[] = { | ||
PINYIN_ID_ZH, // A | ||
PINYIN_ID_B, // B | ||
PINYIN_ID_C, // C | ||
@@ -171,7 +171,7 @@ static const char double_pinyin_abc_sheng[] = { | ||
PINYIN_ID_Z, // Z | ||
PINYIN_ID_VOID, // ; | ||
}; | ||
-static const char double_pinyin_abc_yun[][2] = { | ||
+static const signed char double_pinyin_abc_yun[][2] = { | ||
{ PINYIN_ID_A, PINYIN_ID_VOID }, // A | ||
{ PINYIN_ID_OU, PINYIN_ID_VOID }, // B | ||
{ PINYIN_ID_IN, PINYIN_ID_UAI }, // C | ||
@@ -200,7 +200,7 @@ static const char double_pinyin_abc_yun[][2] = { | ||
{ PINYIN_ID_IAO, PINYIN_ID_VOID }, // Z | ||
{ PINYIN_ID_VOID, PINYIN_ID_VOID }, // ; | ||
}; | ||
-static const char double_pinyin_zgpy_sheng[] = { | ||
+static const signed char double_pinyin_zgpy_sheng[] = { | ||
PINYIN_ID_CH, // A | ||
PINYIN_ID_B, // B | ||
PINYIN_ID_C, // C | ||
@@ -229,7 +229,7 @@ static const char double_pinyin_zgpy_sheng[] = { | ||
PINYIN_ID_Z, // Z | ||
PINYIN_ID_VOID, // ; | ||
}; | ||
-static const char double_pinyin_zgpy_yun[][2] = { | ||
+static const signed char double_pinyin_zgpy_yun[][2] = { | ||
{ PINYIN_ID_A, PINYIN_ID_VOID }, // A | ||
{ PINYIN_ID_IAO, PINYIN_ID_VOID }, // B | ||
{ PINYIN_ID_VOID, PINYIN_ID_VOID }, // C | ||
@@ -258,7 +258,7 @@ static const char double_pinyin_zgpy_yun[][2] = { | ||
{ PINYIN_ID_OU, PINYIN_ID_VOID }, // Z | ||
{ PINYIN_ID_ING, PINYIN_ID_VOID }, // ; | ||
}; | ||
-static const char double_pinyin_pyjj_sheng[] = { | ||
+static const signed char double_pinyin_pyjj_sheng[] = { | ||
PINYIN_ID_ZERO, // A | ||
PINYIN_ID_B, // B | ||
PINYIN_ID_C, // C | ||
@@ -287,7 +287,7 @@ static const char double_pinyin_pyjj_sheng[] = { | ||
PINYIN_ID_Z, // Z | ||
PINYIN_ID_VOID, // ; | ||
}; | ||
-static const char double_pinyin_pyjj_yun[][2] = { | ||
+static const signed char double_pinyin_pyjj_yun[][2] = { | ||
{ PINYIN_ID_A, PINYIN_ID_VOID }, // A | ||
{ PINYIN_ID_IA, PINYIN_ID_UA }, // B | ||
{ PINYIN_ID_UAN, PINYIN_ID_VOID }, // C | ||
@@ -316,7 +316,7 @@ static const char double_pinyin_pyjj_yun[][2] = { | ||
{ PINYIN_ID_UN, PINYIN_ID_VOID }, // Z | ||
{ PINYIN_ID_VOID, PINYIN_ID_VOID }, // ; | ||
}; | ||
-static const char double_pinyin_xhe_sheng[] = { | ||
+static const signed char double_pinyin_xhe_sheng[] = { | ||
PINYIN_ID_AEO, // A | ||
PINYIN_ID_B, // B | ||
PINYIN_ID_C, // C | ||
@@ -345,7 +345,7 @@ static const char double_pinyin_xhe_sheng[] = { | ||
PINYIN_ID_Z, // Z | ||
PINYIN_ID_VOID, // ; | ||
}; | ||
-static const char double_pinyin_xhe_yun[][2] = { | ||
+static const signed char double_pinyin_xhe_yun[][2] = { | ||
{ PINYIN_ID_A, PINYIN_ID_VOID }, // A | ||
{ PINYIN_ID_IN, PINYIN_ID_VOID }, // B | ||
{ PINYIN_ID_AO, PINYIN_ID_VOID }, // C | ||
@@ -376,8 +376,8 @@ static const char double_pinyin_xhe_yun[][2] = { | ||
}; | ||
|
||
static const struct { | ||
- const char (&sheng)[27]; | ||
- const char (&yun)[27][2]; | ||
+ const signed char (&sheng)[27]; | ||
+ const signed char (&yun)[27][2]; | ||
} double_pinyin_map [] = { | ||
{ double_pinyin_mspy_sheng, double_pinyin_mspy_yun }, | ||
{ double_pinyin_zrm_sheng, double_pinyin_zrm_yun }, |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1565555125 | ||
SHA256 (freetds-dev.1.1.51.tar.bz2) = 38501a906c8ab641a2e1c9acbe36892702b8d88669c5a39896f6894156a9574d | ||
SIZE (freetds-dev.1.1.51.tar.bz2) = 2262275 | ||
TIMESTAMP = 1567764290 | ||
SHA256 (freetds-dev.1.1.56.tar.bz2) = a8d99201eaa32224e75d4e70d519c8a1a2b5c62b37c80c73480ee104470707b9 | ||
SIZE (freetds-dev.1.1.56.tar.bz2) = 2247109 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,71 @@ | ||
# Created by: Nicolas Embriz <[email protected]> | ||
# $FreeBSD$ | ||
|
||
PORTNAME= galera | ||
PORTVERSION= 26.4.2 | ||
DISTVERSIONPREFIX= release_ | ||
CATEGORIES= databases | ||
PKGNAMESUFFIX= 26 | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Synchronous multi-master replication engine | ||
|
||
LICENSE= GPLv2 | ||
|
||
BROKEN_aarch64= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var' | ||
BROKEN_armv6= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var' | ||
BROKEN_armv7= fails to compile: gu_int128.h: use of undeclared identifier '__bswap64_var' | ||
NOT_FOR_ARCHS= i386 | ||
# On i386 older versions of clang produce: | ||
# cannot compile this atomic library call yet ... __atomic_add_fetch | ||
# whereas newer ones generate a call to __atomic_add_fetch which ends up with | ||
# undefined reference at link time: | ||
# undefined reference to `__atomic_fetch_add_8' | ||
# https://bugs.llvm.org//show_bug.cgi?id=23262 | ||
# https://bugs.llvm.org//show_bug.cgi?id=24908 | ||
# https://tracker.crystax.net/issues/1263 | ||
NOT_FOR_ARCHS_REASON_i386=Uses 64 bit atomics that clang cannot generate on i386 | ||
|
||
BUILD_DEPENDS= checkmk:devel/check \ | ||
${LOCALBASE}/include/boost/shared_ptr.hpp:devel/boost-libs | ||
LIB_DEPENDS= libboost_date_time.so:devel/boost-libs | ||
|
||
USES= compiler:c++11-lang python:build scons ssl | ||
|
||
USE_LDCONFIG= yes | ||
|
||
USE_GITHUB= yes | ||
GH_TUPLE?= codership:galera:${DISTVERSIONPREFIX}${PORTVERSION}${DISTVERSIONSUFFIX} \ | ||
codership:wsrep-API:75a5f452f2ba07b0f4a3a9a94825fccc71b27398:dummy/wsrep/src | ||
|
||
LDFLAGS+= -lboost_program_options -lboost_system | ||
MAKE_ARGS+= revno=${GH_TAGNAME} system_asio=0 tests=0 | ||
|
||
USE_RC_SUBR= garb.sh | ||
|
||
# Abuse TEST_TARGET to append tests=1 (which is not a target, strictly | ||
# speaking) at the end of the "scons ..." command so that it overrides | ||
# tests=0 from ${MAKE_ARGS}. To rerun the tests a second time, remove | ||
# all *.passed files: find ./work -name *.passed -print -delete | ||
TEST_TARGET= deterministic_tests=1 tests=1 | ||
|
||
PLIST_FILES= bin/garbd \ | ||
lib/libgalera.so \ | ||
lib/libgalera_smm.so | ||
|
||
OPTIONS_DEFINE= BOOSTPOOL BPOSTATIC DEBUG | ||
|
||
BOOSTPOOL_DESC= Use boost pool allocator | ||
BPOSTATIC_DESC= Use static boost_program_options | ||
|
||
BOOSTPOOL_MAKE_ARGS= boost_pool=1 | ||
BPOSTATIC_MAKE_ARGS= bpostatic=${LOCALBASE}/lib/libboost_program_options.a | ||
DEBUG_MAKE_ARGS= debug=0 | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/garb/garbd ${STAGEDIR}${PREFIX}/bin/ | ||
${INSTALL_LIB} ${WRKSRC}/libgalera_smm.so ${STAGEDIR}${PREFIX}/lib/ | ||
@(cd ${STAGEDIR}${PREFIX}/lib && ${LN} -sf libgalera_smm.so \ | ||
libgalera.so) | ||
|
||
.include <bsd.port.mk> |
Oops, something went wrong.