Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Sep 27, 2019
1 parent 387e5e9 commit 057dbde
Show file tree
Hide file tree
Showing 259 changed files with 1,101 additions and 2,076 deletions.
2 changes: 1 addition & 1 deletion benchmarks/phoronix-test-suite/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= phoronix-test-suite
DISTVERSIONPREFIX= v
DISTVERSION= 8.8.1
DISTVERSION= 9.0.0
CATEGORIES= benchmarks
PKGNAMESUFFIX= ${PHP_PKGNAMESUFFIX}

Expand Down
6 changes: 3 additions & 3 deletions benchmarks/phoronix-test-suite/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1560783124
SHA256 (phoronix-test-suite-phoronix-test-suite-v8.8.1_GH0.tar.gz) = d51a0749c8d93767686e36a93214d66cd1657c189b68fd61f4dff84fdce2fd5e
SIZE (phoronix-test-suite-phoronix-test-suite-v8.8.1_GH0.tar.gz) = 890982
TIMESTAMP = 1569412239
SHA256 (phoronix-test-suite-phoronix-test-suite-v9.0.0_GH0.tar.gz) = 041aebe9e3828bb41dfd51c57446a5d215b38a7cd1830bee8154a73a0d384129
SIZE (phoronix-test-suite-phoronix-test-suite-v9.0.0_GH0.tar.gz) = 1261557
1 change: 1 addition & 0 deletions biology/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -158,6 +158,7 @@
SUBDIR += tRNAscan-SE
SUBDIR += t_coffee
SUBDIR += tabixpp
SUBDIR += tophat
SUBDIR += treekin
SUBDIR += treepuzzle
SUBDIR += trimadap
Expand Down
34 changes: 34 additions & 0 deletions biology/tophat/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# $FreeBSD$

PORTNAME= tophat
DISTVERSION= 2.1.1
CATEGORIES= biology python
MASTER_SITES= http://ccb.jhu.edu/software/tophat/downloads/

MAINTAINER= [email protected]
COMMENT= Fast splice junction mapper for RNA-Seq reads

LICENSE= BSL
LICENSE_FILE= ${WRKSRC}/LICENSE

LIB_DEPENDS= libboost_iostreams.so:devel/boost-libs
RUN_DEPENDS= bowtie2:biology/bowtie2

USES= gmake python:2.7 shebangfix

SHEBANG_FILES= src/contig_to_chr_coords \
src/bed_to_juncs \
src/sra_to_solid \
src/tophat-fusion-post \
src/tophat.py \
src/tophat2.sh

GNU_CONFIGURE= yes
CFLAGS+= -Wno-unused
INSTALL_TARGET= install-strip
MAKE_JOBS_UNSAFE= yes

post-install:
${INSTALL_SCRIPT} ${FILESDIR}/tophat-test ${STAGEDIR}${PREFIX}/bin

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions biology/tophat/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1522620646
SHA256 (tophat-2.1.1.tar.gz) = 37840b96f3219630082b15642c47f5ef95d14f6ee99c06a369b08b3d05684da5
SIZE (tophat-2.1.1.tar.gz) = 2259554
22 changes: 22 additions & 0 deletions biology/tophat/files/patch-configure
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
--- configure.orig 2016-02-24 02:55:11 UTC
+++ configure
@@ -6886,7 +6886,7 @@ case $host_os in *\ *) host_os=`echo "$h
# set CFLAGS and CXXFLAGS
#user_CFLAGS="${CXXFLAGS}"
user_CFLAGS=${CFLAGS}
-generic_CFLAGS="-Wall -Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized"
+generic_CFLAGS="-Wno-strict-aliasing -g -gdwarf-2 -Wuninitialized"
ext_CFLAGS=""
debug_CFLAGS=""
user_LDFLAGS="$LDFLAGS"
@@ -6922,8 +6922,8 @@ else
fi

CFLAGS="${generic_CFLAGS} ${ext_CFLAGS} ${user_CFLAGS} ${debug_CFLAGS}"
-CXXFLAGS="$CFLAGS"
-CXXFLAGS="$CXXFLAGS $BAM_CPPFLAGS $BOOST_CPPFLAGS -I./SeqAn-1.4.2"
+CXXFLAGS="-std=gnu++98 $CFLAGS"
+CXXFLAGS="-I./SeqAn-1.4.2 $CXXFLAGS $BAM_CPPFLAGS $BOOST_CPPFLAGS"
LDFLAGS="$BAM_LDFLAGS $BOOST_LDFLAGS $user_LDFLAGS"

if test "`cd $srcdir && pwd`" != "`pwd`"; then
25 changes: 25 additions & 0 deletions biology/tophat/files/patch-src-samtools-0.1.18-Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
--- src/samtools-0.1.18/Makefile.orig 2016-02-14 18:21:17 UTC
+++ src/samtools-0.1.18/Makefile
@@ -1,5 +1,10 @@
-CC= gcc
-CFLAGS= -g -Wall -O2 #-m64 #-arch ppc
+CC?= gcc
+CFLAGS?= -g -Wall -O2 #-m64 #-arch ppc
+CC?= gcc
+CFLAGS?= -g -Wall -O2
+# Link fails with clang on inlined functions with no -O
+CFLAGS+= -O
+RANLIB?= /usr/bin/ranlib
DFLAGS= -D_FILE_OFFSET_BITS=64 -D_LARGEFILE64_SOURCE -D_USE_KNETFILE -D_CURSES_LIB=0
KNETFILE_O= knetfile.o
LOBJS= bgzf.o kstring.o bam_aux.o bam.o bam_import.o sam.o bam_index.o \
@@ -38,7 +43,8 @@ all:$(PROG)
lib:libbam.a

libbam.a:$(LOBJS)
- $(AR) -csru $@ $(LOBJS)
+ $(AR) cr $@ $(LOBJS)
+ $(RANLIB) $@

samtools_0.1.18:lib-recur $(AOBJS)
$(CC) $(CFLAGS) -o $@ $(AOBJS) -Lbcftools $(LIBPATH) libbam.a -lbcf -lm -lz #$(LIBCURSES)
51 changes: 51 additions & 0 deletions biology/tophat/files/patch-src_Makefile.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
--- src/Makefile.in.orig 2016-02-24 03:08:32 UTC
+++ src/Makefile.in
@@ -1207,10 +1207,15 @@ libgc.a: $(libgc_a_OBJECTS) $(libgc_a_DE
-rm -f libgc.a
$(libgc_a_AR) libgc.a $(libgc_a_OBJECTS) $(libgc_a_LIBADD)
$(RANLIB) libgc.a
+
+# $(SAMLIB) and $(SAMPROG) are being mysteriously deleted sometime after they
+# are copied to src. The cp below is a hack to allow the port to build.
libtophat.a: $(libtophat_a_OBJECTS) $(libtophat_a_DEPENDENCIES) $(EXTRA_libtophat_a_DEPENDENCIES)
-rm -f libtophat.a
$(libtophat_a_AR) libtophat.a $(libtophat_a_OBJECTS) $(libtophat_a_LIBADD)
$(RANLIB) libtophat.a
+ cp $(SAMDIR)/$(SAMLIB) $(SAMDIR)/$(SAMPROG) .
+
install-binPROGRAMS: $(bin_PROGRAMS)
@$(NORMAL_INSTALL)
@list='$(bin_PROGRAMS)'; test -n "$(bindir)" || list=; \
@@ -1281,9 +1286,11 @@ prep_reads$(EXEEXT): $(prep_reads_OBJECT
sam_juncs$(EXEEXT): $(sam_juncs_OBJECTS) $(sam_juncs_DEPENDENCIES) $(EXTRA_sam_juncs_DEPENDENCIES)
@rm -f sam_juncs$(EXEEXT)
$(sam_juncs_LINK) $(sam_juncs_OBJECTS) $(sam_juncs_LDADD) $(LIBS)
+
samtools_0.1.18$(EXEEXT): $(samtools_0_1_18_OBJECTS) $(samtools_0_1_18_DEPENDENCIES) $(EXTRA_samtools_0_1_18_DEPENDENCIES)
- @rm -f samtools_0.1.18$(EXEEXT)
- $(LINK) $(samtools_0_1_18_OBJECTS) $(samtools_0_1_18_LDADD) $(LIBS)
+ #rm -f samtools_0.1.18$(EXEEXT)
+ #$(LINK) $(samtools_0_1_18_OBJECTS) $(samtools_0_1_18_LDADD) $(LIBS)
+
segment_juncs$(EXEEXT): $(segment_juncs_OBJECTS) $(segment_juncs_DEPENDENCIES) $(EXTRA_segment_juncs_DEPENDENCIES)
@rm -f segment_juncs$(EXEEXT)
$(segment_juncs_LINK) $(segment_juncs_OBJECTS) $(segment_juncs_LDADD) $(LIBS)
@@ -1658,7 +1665,7 @@ uninstall-am: uninstall-binPROGRAMS unin


clean-local:
- cd $(SAMDIR) && make clean
+ cd $(SAMDIR) && ${MAKE} clean

tophat2: tophat2.sh
cp tophat2.sh tophat2 && chmod 755 tophat2
@@ -1669,7 +1676,8 @@ tophat: tophat.py
$(SAMPROG): $(SAMLIB)

$(SAMLIB):
- cd $(SAMDIR) && make $(SAMPROG) && cp $(SAMLIB) $(SAMPROG) ..
+ cd $(SAMDIR) && ${MAKE} $(SAMPROG)
+ cp $(SAMDIR)/$(SAMLIB) $(SAMDIR)/$(SAMPROG) .

install-data-hook:
cp -r intervaltree sortedcontainers $(DESTDIR)$(bindir)
16 changes: 16 additions & 0 deletions biology/tophat/files/tophat-test
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
#!/bin/sh -e

if [ ! -e test_data.tar.gz ]; then
fetch https://ccb.jhu.edu/software/tophat/downloads/test_data.tar.gz
fi
if [ -e test_data ]; then
cat << EOM
test_data already exists. Remove it or run $0 from a different directory.
EOM
exit 1
fi
tar zxvf test_data.tar.gz
cd test_data
tophat -r 20 test_ref reads_1.fq reads_2.fq
11 changes: 11 additions & 0 deletions biology/tophat/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
TopHat is a fast splice junction mapper for RNA-Seq reads. It aligns RNA-Seq
reads to mammalian-sized genomes using the ultra high-throughput short read
aligner Bowtie, and then analyzes the mapping results to identify splice
junctions between exons.

Note:

TopHat has been Superseded by HISAT2 and is no longer maintained upstream.
This port is provided mainly for revisiting old studies where TopHat was used.

WWW: http://ccb.jhu.edu/software/tophat/index.shtml
29 changes: 29 additions & 0 deletions biology/tophat/pkg-plist
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
bin/bam2fastx
bin/bam_merge
bin/bed_to_juncs
bin/contig_to_chr_coords
bin/fix_map_ordering
bin/gtf_juncs
bin/gtf_to_fasta
bin/intervaltree/__init__.py
bin/intervaltree/interval.py
bin/intervaltree/intervaltree.py
bin/intervaltree/node.py
bin/juncs_db
bin/long_spanning_reads
bin/map2gtf
bin/prep_reads
bin/sam_juncs
bin/samtools_0.1.18
bin/segment_juncs
bin/sortedcontainers/__init__.py
bin/sortedcontainers/sorteddict.py
bin/sortedcontainers/sortedlist.py
bin/sortedcontainers/sortedlistwithkey.py
bin/sortedcontainers/sortedset.py
bin/sra_to_solid
bin/tophat
bin/tophat-fusion-post
bin/tophat-test
bin/tophat2
bin/tophat_reports
2 changes: 1 addition & 1 deletion chinese/librime/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
PORTNAME= librime
PORTVERSION= 1.2.9
DISTVERSIONPREFIX= rime-
PORTREVISION= 18
PORTREVISION= 19
CATEGORIES= chinese textproc

MAINTAINER= [email protected]
Expand Down
1 change: 1 addition & 0 deletions comms/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -39,6 +39,7 @@
SUBDIR += dump1090
SUBDIR += ebook2cw
SUBDIR += ebook2cwgui
SUBDIR += ebusd
SUBDIR += echolinux
SUBDIR += efax
SUBDIR += ems-flasher
Expand Down
47 changes: 47 additions & 0 deletions comms/ebusd/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,47 @@
# $FreeBSD$

PORTNAME= ebusd
PORTVERSION= 3.3
CATEGORIES= comms

MAINTAINER= [email protected]
COMMENT= Daemon for communication with eBUS heating systems

LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/LICENSE

LIB_DEPENDS= libargp.so:devel/argp-standalone

USES= autoreconf localbase:ldflags

OPTIONS_DEFINE= MQTT
OPTIONS_DEFAULT=MQTT
MQTT_DESC= MQTT protocol support

USE_GITHUB= yes
GH_ACCOUNT= john30
GH_TAGNAME= v${PORTVERSION}

USE_RC_SUBR= ebusd

USERS= ebusd
GROUPS= ebusd

LOGDIR= /var/log/${PORTNAME}
RUNDIR= /var/run/${PORTNAME}
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes

PLIST_SUB= USER=${USERS} GROUP=${GROUPS} \
LOGDIR=${LOGDIR} \
RUNDIR=${RUNDIR}

MQTT_CONFIGURE_WITH= mqtt
MQTT_LIB_DEPENDS= libmosquitto.so:net/mosquitto
MQTT_VARS= LIBS+=-lmosquitto

post-install:
${MKDIR} ${STAGEDIR}${LOGDIR}
${MKDIR} ${STAGEDIR}${RUNDIR}

.include <bsd.port.mk>
3 changes: 3 additions & 0 deletions comms/ebusd/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
TIMESTAMP = 1565559816
SHA256 (john30-ebusd-3.3-v3.3_GH0.tar.gz) = 48669140cfafbe060c765b4530018b30f07e1b074dbce00b205a8f2a22dee573
SIZE (john30-ebusd-3.3-v3.3_GH0.tar.gz) = 696172
37 changes: 37 additions & 0 deletions comms/ebusd/files/ebusd.in
Original file line number Diff line number Diff line change
@@ -0,0 +1,37 @@
#!/bin/sh

# $FreeBSD$
#
# PROVIDE: ebusd
# REQUIRE: LOGIN cleanvar
# KEYWORD: shutdown

#
# Add the following lines to /etc/rc.conf to enable ebusd:
#
#ebusd_enable (bool): set to "YES" to start domotics at boot
#ebusd_user (str): Default to ebusd, user for starting ebusd
#ebusd_group (str): Default to ebusd, group for stating ebusd
#ebusd_pidfile (str): Custum PID file path and name
# Default to "/var/run/ebusd/${hostname}.pid".
#ebusd_args (str): Custom additional arguments to be passed
# Default to "-d /dev/ttyU0 --scanconfig --localhost"

. /etc/rc.subr

name="ebusd"
rcvar="ebusd_enable"

load_rc_config $name

: ${ebusd_user:=ebusd}
: ${ebusd_group:=ebusd}
: ${ebusd_enable:=NO}
: ${ebusd_args:="-d /dev/ttyU0 --scanconfig --localhost"}

pidfile=${ebusd_pidfile:-"/var/run/ebusd/${hostname}.pid"}

command="%%PREFIX%%/bin/ebusd"
command_args="--pidfile ${pidfile} ${ebusd_args}"

run_rc_command "$1"
19 changes: 19 additions & 0 deletions comms/ebusd/files/patch-configure.ac
Original file line number Diff line number Diff line change
@@ -0,0 +1,19 @@
--- configure.ac.orig 2018-12-26 15:38:15 UTC
+++ configure.ac
@@ -36,6 +36,7 @@ AC_SUBST(EXTRA_LIBS)
AC_CHECK_FUNC([pselect], [AC_DEFINE(HAVE_PSELECT, [1], [Defined if pselect() is available.])])
AC_CHECK_FUNC([ppoll], [AC_DEFINE(HAVE_PPOLL, [1], [Defined if ppoll() is available.])])
AC_CHECK_HEADER([linux/serial.h], [AC_DEFINE(HAVE_LINUX_SERIAL, [1], [Defined if linux/serial.h is available.])])
+AC_CHECK_HEADER([dev/usb/uftdiio.h], [AC_DEFINE(HAVE_FREEBSD_UFTDI, [1], [Defined if dev/usb/uftdiio.h is available.])])

AC_ARG_ENABLE(coverage, AS_HELP_STRING([--enable-coverage], [enable code coverage tracking]), [CXXFLAGS+=" -coverage -O0"], [])
AC_ARG_WITH(contrib, AS_HELP_STRING([--without-contrib], [disable inclusion of contributed sources]), [], [with_contrib=yes])
@@ -118,7 +119,7 @@ AM_COND_IF([CONTRIB], [AC_CONFIG_FILES([
])])

AC_DEFINE_UNQUOTED(PACKAGE_PIDFILE, LOCALSTATEDIR "/run/" PACKAGE ".pid", [The path and name of the PID file.])
-AC_DEFINE_UNQUOTED(PACKAGE_LOGFILE, LOCALSTATEDIR "/log/" PACKAGE ".log", [The path and name of the log file.])
+AC_DEFINE_UNQUOTED(PACKAGE_LOGFILE, LOCALSTATEDIR "/log/" PACKAGE "/" PACKAGE ".log", [The path and name of the log file.])
AC_DEFINE(SCAN_VERSION, "[m4_esyscmd_s([sed -e 's#^\([0-9]*\.[0-9]*\).*#\1#' -e 's#\.\([0-9]\)$#0\1#' -e 's#\.##' VERSION])]", [The version of the package formatted for the scan result.])
AC_DEFINE(REVISION, "[m4_esyscmd_s([git describe --always 2>/dev/null || (date +p%Y%m%d)])]", [The revision of the package.])

Loading

0 comments on commit 057dbde

Please sign in to comment.