Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: FreeBSD
  • Loading branch information
fichtner committed Sep 26, 2015
1 parent e11f8f9 commit 0a597f6
Show file tree
Hide file tree
Showing 362 changed files with 3,257 additions and 1,547 deletions.
9 changes: 2 additions & 7 deletions archivers/gtar/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -36,13 +36,8 @@ NLS_CONFIGURE_ENABLE= nls
STATIC_LDFLAGS= -static
STATIC_CONFIGURE_ENV= SHLIBEXT=""

.include <bsd.port.options.mk>

.if ${PORT_OPTIONS:MSTATIC}
STATIC_ARGS= build
.else
STATIC_ARGS= lib
.endif
STATIC_VARS= STATIC_ARGS=build
STATIC_VARS_OFF= STATIC_ARGS=lib

# Tests 161 163 are known to fail because path resolution of ".."
# in a removed directory fails.
Expand Down
10 changes: 4 additions & 6 deletions audio/qmpdclient/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -32,18 +32,16 @@ DBUS_USE= QT4=dbus

DEBUG_QMAKE_ON= CONFIG+=debug

.include <bsd.port.options.mk>

post-patch:
.if ! ${PORT_OPTIONS:MNLS}
@${REINPLACE_CMD} -e '/INSTALLS += translations/d' \
${WRKSRC}/${PORTNAME}.pro
.endif
@${REINPLACE_CMD} -e 's|/usr/local|${PREFIX}|' \
-e 's|lupdate|lupdate-qt4|' \
-e 's|lrelease|lrelease-qt4|' \
${WRKSRC}/${PORTNAME}.pro
@${REINPLACE_CMD} -e 's|/usr|${PREFIX}|' \
${WRKSRC}/src/notifications_dbus.cpp

post-patch-NLS-off:
@${REINPLACE_CMD} -e '/INSTALLS += translations/d' \
${WRKSRC}/${PORTNAME}.pro

.include <bsd.port.mk>
1 change: 1 addition & 0 deletions benchmarks/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -70,6 +70,7 @@
SUBDIR += smhasher
SUBDIR += spp
SUBDIR += stream
SUBDIR += stress-ng
SUBDIR += super-smack
SUBDIR += sysbench
SUBDIR += tcpblast
Expand Down
29 changes: 29 additions & 0 deletions benchmarks/stress-ng/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,29 @@
# $FreeBSD$

PORTNAME= stress-ng
PORTVERSION= 0.04.20
CATEGORIES= benchmarks
MASTER_SITES= http://kernel.ubuntu.com/~cking/tarballs/stress-ng/

MAINTAINER= [email protected]
COMMENT= Stress test benchmarks

LICENSE= GPLv2 # or later
LICENSE_FILE= ${WRKSRC}/COPYING

ALL_TARGET= # empty

PLIST_FILES= bin/stress-ng man/man1/stress-ng.1.gz

.include <bsd.port.pre.mk>

.if ${OSVERSION} < 1000000
EXTRA_PATCHES+= ${FILESDIR}/extrapatch-stress-cpu.c \
${FILESDIR}/extrapatch-Makefile
.endif

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/stress-ng ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/stress-ng.1 ${STAGEDIR}${MANDIRS}/man1

.include <bsd.port.post.mk>
2 changes: 2 additions & 0 deletions benchmarks/stress-ng/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (stress-ng-0.04.20.tar.gz) = 5b00c23325e46236466e598a977c8ebcd4f786cc0c2e15118004a0462bb6f47f
SIZE (stress-ng-0.04.20.tar.gz) = 236074
11 changes: 11 additions & 0 deletions benchmarks/stress-ng/files/extrapatch-Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- Makefile.orig 2015-09-25 10:15:45 UTC
+++ Makefile
@@ -165,7 +165,7 @@ OBJS = $(SRC:.c=.o)
@$(CC) $(CFLAGS) -c -o $@ $<

stress-ng: $(OBJS)
- $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm -pthread -lrt -lcrypt -o $@ $(LDFLAGS)
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm -pthread -lrt -lcrypt -lstdc++ -o $@ $(LDFLAGS)

stress-cpu.o: stress-cpu.c
@echo $(CC) $(CFLAGS) -c -o $@ $<
10 changes: 10 additions & 0 deletions benchmarks/stress-ng/files/extrapatch-stress-cpu.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
--- stress-cpu.c.orig 2015-09-18 14:50:12 UTC
+++ stress-cpu.c
@@ -23,6 +23,7 @@
*
*/
#define _GNU_SOURCE
+#define _DECLARE_C99_LDBL_MATH 1

#include <stdio.h>
#include <stdlib.h>
38 changes: 38 additions & 0 deletions benchmarks/stress-ng/files/patch-stress-cpu.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,38 @@
--- stress-cpu.c.orig 2015-09-18 14:50:12 UTC
+++ stress-cpu.c
@@ -57,7 +58,6 @@
#define ccosl ccos
#define csinl csin
#define cpow pow
-#define powl pow
#endif

/*
@@ -866,6 +866,7 @@ stress_cpu_fp(_Decimal128, decimal128, s
/* Append floating point literal specifier to literal value */
#define FP(val, ltype) val ## ltype

+#if defined(__STDC_IEC_559_COMPLEX__)
/*
* Generic complex stressor macro
*/
@@ -891,6 +892,7 @@ static void HOT OPTIMIZE3 stress_cpu_ ##
stress_cpu_complex(complex float, f, complex_float, csinf, ccosf)
stress_cpu_complex(complex double, , complex_double, csin, ccos)
stress_cpu_complex(complex long double, l, complex_long_double, csinl, ccosl)
+#endif /* __STDC_IEC_559_COMPLEX__ */

#define int_float_ops(_ftype, flt_a, flt_b, flt_c, flt_d, \
_sin, _cos, int_a, int_b, _c1, _c2, _c3) \
@@ -2058,9 +2060,11 @@ static stress_cpu_stressor_info_t cpu_me
{ "ackermann", stress_cpu_ackermann },
{ "bitops", stress_cpu_bitops },
{ "callfunc", stress_cpu_callfunc },
+#if defined(__STDC_IEC_559_COMPLEX__)
{ "cdouble", stress_cpu_complex_double },
{ "cfloat", stress_cpu_complex_float },
{ "clongdouble", stress_cpu_complex_long_double },
+#endif /* __STDC_IEC_559_COMPLEX__ */
{ "correlate", stress_cpu_correlate },
{ "crc16", stress_cpu_crc16 },
#if defined(STRESS_FLOAT_DECIMAL)
5 changes: 5 additions & 0 deletions benchmarks/stress-ng/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
This stress test suite will stress a computer system in various selectable ways
It was designed to exercise various physical subsystems of a computer as well
as various operating system kernel interfaces.

WWW: http://kernel.ubuntu.com/~cking/stress-ng/
6 changes: 6 additions & 0 deletions biology/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -11,7 +11,9 @@
SUBDIR += biococoa
SUBDIR += biojava
SUBDIR += blat
SUBDIR += bwa
SUBDIR += cd-hit
SUBDIR += cdbfasta
SUBDIR += chemeq
SUBDIR += clustalw
SUBDIR += consed
Expand All @@ -20,6 +22,9 @@
SUBDIR += fasta
SUBDIR += fasta3
SUBDIR += fastdnaml
SUBDIR += fastool
SUBDIR += fasttree
SUBDIR += fastx-toolkit
SUBDIR += fluctuate
SUBDIR += garlic
SUBDIR += gff2ps
Expand All @@ -32,6 +37,7 @@
SUBDIR += jalview
SUBDIR += lagan
SUBDIR += lamarc
SUBDIR += libgtextutils
SUBDIR += libsbml
SUBDIR += linux-foldingathome
SUBDIR += mafft
Expand Down
28 changes: 28 additions & 0 deletions biology/bwa/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,28 @@
# Created by: Jason Bacon <[email protected]>
# $FreeBSD$

PORTNAME= bwa
PORTVERSION= 0.7.9a
CATEGORIES= biology
MASTER_SITES= SF/bio-bwa/

MAINTAINER= [email protected]
COMMENT= Burrows-Wheeler sequence aligner

LICENSE= GPLv3

USES= perl5 shebangfix tar:bzip2
SHEBANG_FILES= qualfa2fq.pl xa2multi.pl
USE_PERL5= run

PLIST_FILES= bin/bwa bin/qualfa2fq.pl bin/xa2multi.pl man/man1/bwa.1.gz

# Avoid #error in emmintrin.h
CFLAGS+= -msse2

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bwa ${STAGEDIR}${PREFIX}/bin
${INSTALL_SCRIPT} ${WRKSRC}/*.pl ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/*.1 ${STAGEDIR}${MAN1PREFIX}/man/man1

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions biology/bwa/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (bwa-0.7.9a.tar.bz2) = f5ad30e4e5ea86a8dcd6febcb6f620a75c82b03024f64a572017c295a962eadc
SIZE (bwa-0.7.9a.tar.bz2) = 166193
11 changes: 11 additions & 0 deletions biology/bwa/files/patch-Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- Makefile.orig 2014-05-19 13:11:41 UTC
+++ Makefile
@@ -1,6 +1,6 @@
-CC= gcc
+CC?= gcc
#CC= clang --analyze
-CFLAGS= -g -Wall -Wno-unused-function -O2
+CFLAGS?= -g -Wall -Wno-unused-function -O2
WRAP_MALLOC=-DUSE_MALLOC_WRAPPERS
AR= ar
DFLAGS= -DHAVE_PTHREAD $(WRAP_MALLOC)
11 changes: 11 additions & 0 deletions biology/bwa/files/patch-bwt_lite.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- bwt_lite.c.orig 2014-05-19 13:11:41 UTC
+++ bwt_lite.c
@@ -48,7 +48,7 @@ bwtl_t *bwtl_seq2bwtl(int len, const uin
}
{ // generate cnt_table
for (i = 0; i != 256; ++i) {
- u_int32_t j, x = 0;
+ uint32_t j, x = 0;
for (j = 0; j != 4; ++j)
x |= (((i&3) == j) + ((i>>2&3) == j) + ((i>>4&3) == j) + (i>>6 == j)) << (j<<3);
b->cnt_table[i] = x;
11 changes: 11 additions & 0 deletions biology/bwa/files/patch-bwtgap.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- bwtgap.c.orig 2014-02-25 21:20:01 UTC
+++ bwtgap.c
@@ -58,7 +58,7 @@ static inline void gap_push(gap_stack_t
q->stack = (gap_entry_t*)realloc(q->stack, sizeof(gap_entry_t) * q->m_entries);
}
p = q->stack + q->n_entries;
- p->info = (u_int32_t)score<<21 | i; p->k = k; p->l = l;
+ p->info = (uint32_t)score<<21 | i; p->k = k; p->l = l;
p->n_mm = n_mm; p->n_gapo = n_gapo; p->n_gape = n_gape;
p->n_ins = n_ins; p->n_del = n_del;
p->state = state;
15 changes: 15 additions & 0 deletions biology/bwa/files/patch-bwtgap.h
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
--- bwtgap.h.orig 2014-02-25 21:20:01 UTC
+++ bwtgap.h
@@ -5,9 +5,9 @@
#include "bwtaln.h"

typedef struct { // recursion stack
- u_int32_t info; // score<<21 | i
- u_int32_t n_mm:8, n_gapo:8, n_gape:8, state:2, n_seed_mm:6;
- u_int32_t n_ins:16, n_del:16;
+ uint32_t info; // score<<21 | i
+ uint32_t n_mm:8, n_gapo:8, n_gape:8, state:2, n_seed_mm:6;
+ uint32_t n_ins:16, n_del:16;
int last_diff_pos;
bwtint_t k, l; // (k,l) is the SA region of [i,n-1]
} gap_entry_t;
5 changes: 5 additions & 0 deletions biology/bwa/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,5 @@
BWA is a program for aligning sequencing reads against a large reference
genome (e.g. human genome). It has two major components, one for read shorter
than 150bp and the other for longer reads.

WWW: http://sourceforge.net/projects/bio-bwa/
25 changes: 25 additions & 0 deletions biology/cdbfasta/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,25 @@
# Created by: Dan Siercks <[email protected]>
# $FreeBSD$

PORTNAME= cdbfasta
PORTVERSION= 2010.07.22
CATEGORIES= biology
MASTER_SITES= http://acadix.biz/Ports/distfiles/ \
http://personalpages.tds.net/~jwbacon/Ports/distfiles/

MAINTAINER= [email protected]
COMMENT= Fast indexing and retrieval of FASTA records from flat file databases

# LICENSE= unspecified

WRKSRC= ${WRKDIR}/${PORTNAME}

USES= gmake

PLIST_FILES= bin/cdbfasta bin/cdbyank

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/cdbfasta ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/cdbyank ${STAGEDIR}${PREFIX}/bin

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions biology/cdbfasta/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (cdbfasta-2010.07.22.tar.gz) = 68767e8b2fb9de5a6d68ee16df73293f65e02f05cf2f747a9dd6b8854766722c
SIZE (cdbfasta-2010.07.22.tar.gz) = 59735
54 changes: 54 additions & 0 deletions biology/cdbfasta/files/patch-Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
--- Makefile.orig 2009-12-03 20:17:51 UTC
+++ Makefile
@@ -18,7 +18,10 @@ else
MARCH =
endif

-CC := g++
+# Use the correct compiler (CXX, not CC) and respect the environment
+# by using ?=
+CXX ?= g++
+
BASEFLAGS = -Wall ${SEARCHDIRS} $(MARCH) -DENABLE_COMPRESSION=0 -D_FILE_OFFSET_BITS=64 \
-D_LARGEFILE_SOURCE -fno-exceptions -fno-rtti -fno-strict-aliasing \
-D_REENTRANT
@@ -33,30 +36,30 @@ else
endif

ifeq ($(findstring nommap,$(MAKECMDGOALS)),)
- CFLAGS = $(DBGFLAGS) $(BASEFLAGS)
+ CXXFLAGS = $(DBGFLAGS) $(BASEFLAGS)
else
- CFLAGS = $(DBGFLAGS) $(BASEFLAGS) -DNO_MMAP
+ CXXFLAGS = $(DBGFLAGS) $(BASEFLAGS) -DNO_MMAP
endif

%.o : %.c
- ${CC} ${CFLAGS} -c $< -o $@
+ ${CXX} ${CXXFLAGS} -c $< -o $@

%.o : %.cc
- ${CC} ${CFLAGS} -c $< -o $@
+ ${CXX} ${CXXFLAGS} -c $< -o $@

%.o : %.C
- ${CC} ${CFLAGS} -c $< -o $@
+ ${CXX} ${CXXFLAGS} -c $< -o $@

%.o : %.cpp
- ${CC} ${CFLAGS} -c $< -o $@
+ ${CXX} ${CXXFLAGS} -c $< -o $@

%.o : %.cxx
- ${CC} ${CFLAGS} -c $< -o $@
+ ${CXX} ${CXXFLAGS} -c $< -o $@

# C/C++ linker

-LINKER := g++
-LDFLAGS = -lz
+LINKER := ${CXX}
+LDFLAGS = -lz
#if ENABLE_COMPRESSION is not needed,
# LDFLAGS =

3 changes: 3 additions & 0 deletions biology/cdbfasta/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
Fast indexing and retrieval of FASTA records from flat file data bases.

WWW: http://sourceforge.net/projects/cdbfasta/
33 changes: 33 additions & 0 deletions biology/fastool/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,33 @@
# Created by: Jason Bacon <[email protected]>
# $FreeBSD$

PORTNAME= fastool
PORTVERSION= 0.1.4
CATEGORIES= biology

MAINTAINER= [email protected]
COMMENT= Simple and quick FastQ and FastA tool for file reading and conversion

LICENSE= BSD2CLAUSE

USE_GITHUB= yes
GH_ACCOUNT= fstrozzi
GH_PROJECT= Fastool

WRKSRC= ${WRKDIR}/Fastool-${PORTVERSION}

PLIST_FILES= bin/fastool

CFLAGS+= -std=c99

post-patch:
${REINPLACE_CMD} \
-e 's|CC *=|CC ?=|g' \
-e 's|CFLAGS *=|CFLAGS ?=|g' \
${WRKSRC}/Makefile

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/fastool \
${STAGEDIR}${PREFIX}/bin

.include <bsd.port.mk>
2 changes: 2 additions & 0 deletions biology/fastool/distinfo
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
SHA256 (fstrozzi-Fastool-0.1.4_GH0.tar.gz) = f86f02fced9479b77d6d27a442b66e66f0c55d40d5ad2ddd91a752de57024540
SIZE (fstrozzi-Fastool-0.1.4_GH0.tar.gz) = 6346
3 changes: 3 additions & 0 deletions biology/fastool/pkg-descr
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
Simple and quick FastQ and FastA tool for file reading and conversion.

WWW: https://github.com/fstrozzi/Fastool
Loading

0 comments on commit 0a597f6

Please sign in to comment.