forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
171 changed files
with
70,158 additions
and
2,708 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
https://github.com/cmus/cmus/commit/b595b8cd7fee | ||
|
||
--- ip/ffmpeg.c.orig 2016-11-20 12:29:46 UTC | ||
+++ ip/ffmpeg.c | ||
@@ -252,8 +252,8 @@ static int ffmpeg_open(struct input_plugin_data *ip_da | ||
break; | ||
} | ||
|
||
- if (codec->capabilities & CODEC_CAP_TRUNCATED) | ||
- cc->flags |= CODEC_FLAG_TRUNCATED; | ||
+ if (codec->capabilities & AV_CODEC_CAP_TRUNCATED) | ||
+ cc->flags |= AV_CODEC_FLAG_TRUNCATED; | ||
|
||
#if (LIBAVCODEC_VERSION_INT < ((53<<16)+(8<<8)+0)) | ||
if (avcodec_open(cc, codec) < 0) { |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,32 @@ | ||
ffmpeg.c:996:34: error: use of undeclared identifier 'CODEC_CAP_TRUNCATED' | ||
if (data->codec->capabilities & CODEC_CAP_TRUNCATED) | ||
^ | ||
ffmpeg.c:997:23: error: use of undeclared identifier 'CODEC_FLAG_TRUNCATED' | ||
data->enc->flags |= CODEC_FLAG_TRUNCATED; | ||
^ | ||
ffmpeg.c:1028:34: error: use of undeclared identifier 'CODEC_CAP_DELAY' | ||
if (data->codec->capabilities & CODEC_CAP_DELAY) | ||
^ | ||
|
||
--- decoder_plugins/ffmpeg/ffmpeg.c.orig 2016-11-16 00:54:37 UTC | ||
+++ decoder_plugins/ffmpeg/ffmpeg.c | ||
@@ -993,8 +993,8 @@ static void *ffmpeg_open (const char *file) | ||
#endif | ||
|
||
set_downmixing (data); | ||
- if (data->codec->capabilities & CODEC_CAP_TRUNCATED) | ||
- data->enc->flags |= CODEC_FLAG_TRUNCATED; | ||
+ if (data->codec->capabilities & AV_CODEC_CAP_TRUNCATED) | ||
+ data->enc->flags |= AV_CODEC_FLAG_TRUNCATED; | ||
|
||
#ifdef HAVE_AVCODEC_OPEN2 | ||
if (avcodec_open2 (data->enc, data->codec, NULL) < 0) | ||
@@ -1025,7 +1025,7 @@ static void *ffmpeg_open (const char *file) | ||
|
||
data->sample_width = sfmt_Bps (data->fmt); | ||
|
||
- if (data->codec->capabilities & CODEC_CAP_DELAY) | ||
+ if (data->codec->capabilities & AV_CODEC_CAP_DELAY) | ||
data->delay = true; | ||
data->seek_broken = is_seek_broken (data); | ||
data->timing_broken = is_timing_broken (data->ic); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -6,6 +6,9 @@ PORTVERSION= 2017.08.30 | |
CATEGORIES= audio | ||
MASTER_SITES= https://6xq.net/${PORTNAME}/ | ||
|
||
PATCH_SITES= https://github.com/PromyLOPh/${PORTNAME}/commit/ | ||
PATCHFILES= 38b16f9957a7.patch:-p1 | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Command-line Pandora online radio player | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,5 @@ | ||
TIMESTAMP = 1504104262 | ||
SHA256 (pianobar-2017.08.30.tar.bz2) = ec14db6cf1a7dbc1d8190b5ca0d256021e970587bcdaeb23904d4bca71a04674 | ||
SIZE (pianobar-2017.08.30.tar.bz2) = 46664 | ||
SHA256 (38b16f9957a7.patch) = cc90b0f0cd7b02a1a5470af2cb60e5dc6f45bcbc2302faba6502f2f6c9e73bf0 | ||
SIZE (38b16f9957a7.patch) = 1040 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1514962318 | ||
SHA256 (seaview_4.6.3.tar.gz) = 36361f0f2950b9ec438823bbd7fc8ae67619837673fe3220b6dca97b7afad1bf | ||
SIZE (seaview_4.6.3.tar.gz) = 435155 | ||
TIMESTAMP = 1524512448 | ||
SHA256 (seaview_4.6.5.tar.gz) = 9663f4488ac32d8db27922923f525ad7ac8f650d4987e6e874567723f4713164 | ||
SIZE (seaview_4.6.5.tar.gz) = 429108 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,40 @@ | ||
# $FreeBSD$ | ||
|
||
PORTNAME= unanimity | ||
DISTVERSION= g20180307 | ||
CATEGORIES= biology | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Pacific Biosciences consensus library and applications | ||
|
||
LICENSE= BSD3CLAUSE | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
|
||
# Sensitive to dependency versions, use latest commit for everything | ||
BUILD_DEPENDS= pbseqan==g20171002:biology/pbseqan \ | ||
pbbam==g20180416:biology/pbbam \ | ||
pbcopper==g20180413:biology/pbcopper | ||
LIB_DEPENDS= libhts.so:biology/htslib \ | ||
libboost_regex.so:devel/boost-libs | ||
|
||
USES= cmake pkgconfig python | ||
USE_GITHUB= yes | ||
GH_ACCOUNT= PacificBiosciences | ||
GH_TAGNAME= 6f11a13e1472b8c00337ba8c5e94bf83bdab31d6 | ||
|
||
CMAKE_ARGS+= -DHTSLIB_INCLUDE_DIRS:STRING=${LOCALBASE}/include/htslib \ | ||
-DHTSLIB_LIBRARIES:STRING="-L${LOCALBASE}/lib -lhts" \ | ||
-DPacBioBAM_INCLUDE_DIRS:STRING=${LOCALBASE}/include/pbbam \ | ||
-DPacBioBAM_LIBRARIES:STRING="-L${LOCALBASE}/lib -lpbbam" \ | ||
-DSEQAN_INCLUDE_DIRS:STRING=${LOCALBASE}/include/PacBio \ | ||
-Dpbcopper_INCLUDE_DIRS=${LOCALBASE}/include \ | ||
-Dpbcopper_LIBRARIES="-L${LOCALBASE}/lib -lpbcopper" | ||
CFLAGS_i386= -msse2 -Wno-c++11-narrowing | ||
|
||
PLIST_FILES= bin/arrow bin/ccs bin/gcpp lib/libcc2.a lib/libunanimity.a | ||
|
||
post-install: | ||
${INSTALL_DATA} ${WRKSRC}/src/libcc2.a ${WRKSRC}/src/libunanimity.a \ | ||
${STAGEDIR}${PREFIX}/lib | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
TIMESTAMP = 1524324354 | ||
SHA256 (PacificBiosciences-unanimity-g20180307-6f11a13e1472b8c00337ba8c5e94bf83bdab31d6_GH0.tar.gz) = 20ed61c46afcfe86403a564136b96f909149208c51fde16f608e924ad4c59e38 | ||
SIZE (PacificBiosciences-unanimity-g20180307-6f11a13e1472b8c00337ba8c5e94bf83bdab31d6_GH0.tar.gz) = 6492231 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- CMakeLists.txt.orig 2018-03-07 23:10:34 UTC | ||
+++ CMakeLists.txt | ||
@@ -37,7 +37,7 @@ include(uny-ccache) | ||
include(uny-releasewithassert) | ||
include(uny-dependencies) | ||
include(uny-compilerflags) | ||
-include(uny-gitsha1) | ||
+# include(uny-gitsha1) | ||
include(uny-config) | ||
|
||
# Build library |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,10 @@ | ||
--- cmake/uny-config.cmake.orig 2016-09-12 19:55:43 UTC | ||
+++ cmake/uny-config.cmake | ||
@@ -1,6 +1,6 @@ | ||
# Config generation | ||
|
||
-find_git_sha1(UNANIMITY_GIT_SHA1) | ||
+# find_git_sha1(UNANIMITY_GIT_SHA1) | ||
|
||
file (STRINGS "${UNY_RootDir}/CHANGELOG.md" UNANIMITY_CHANGELOG) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- cmake/uny-gitsha1.cmake.orig 2018-03-07 23:10:34 UTC | ||
+++ cmake/uny-gitsha1.cmake | ||
@@ -7,7 +7,7 @@ set(__find_git_sha1 YES) | ||
function(find_git_sha1 _GIT_SHA1) | ||
find_package(Git QUIET REQUIRED) | ||
execute_process(COMMAND | ||
- "${GIT_EXECUTABLE}" "describe" "--always" "--dirty=-dirty" | ||
+ echo 6f11a13e1472b8c00337ba8c5e94bf83bdab31d6 | ||
WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}" | ||
RESULT_VARIABLE res | ||
OUTPUT_VARIABLE out |
16 changes: 16 additions & 0 deletions
16
biology/unanimity/files/patch-include_pacbio_genomicconsensus_Input.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
--- include/pacbio/genomicconsensus/Input.h.orig 2018-03-07 23:10:34 UTC | ||
+++ include/pacbio/genomicconsensus/Input.h | ||
@@ -25,7 +25,12 @@ namespace GenomicConsensus { | ||
class Input | ||
{ | ||
public: | ||
- explicit Input(const Settings& settings) : settings_{settings} {} | ||
+ // Original | ||
+ //explicit Input(const Settings& settings) : settings_{settings} {} | ||
+ // Probably OK | ||
+ //explicit Input(const Settings& settings) { settings_ = settings; } | ||
+ // https://forums.freebsd.org/threads/compile-error-with-clang-3-4.65595/#post-385293 | ||
+ explicit Input(const Settings& settings) : settings_(settings) {} | ||
|
||
Input() = delete; | ||
Input(const Input&) = delete; |
19 changes: 19 additions & 0 deletions
19
biology/unanimity/files/patch-include_pacbio_genomicconsensus_Output.h
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
--- include/pacbio/genomicconsensus/Output.h.orig 2018-03-07 23:10:34 UTC | ||
+++ include/pacbio/genomicconsensus/Output.h | ||
@@ -80,8 +80,15 @@ inline void PrintVcfLite(const Variant& | ||
<< "\tPASS\n"; | ||
} | ||
|
||
-inline Output::Output(const Settings& settings) : settings_{settings} | ||
+// Original | ||
+//inline Output::Output(const Settings& settings) : settings_{settings} | ||
+// Probably OK patch | ||
+//inline Output::Output(const Settings& settings) | ||
+// https://forums.freebsd.org/threads/compile-error-with-clang-3-4.65595/#post-385293 | ||
+inline Output::Output(const Settings& settings) : settings_(settings) | ||
{ | ||
+ // Probably OK patch | ||
+ //settings_ = settings; | ||
// initialize maps | ||
PacBio::BAM::FastaSequenceQuery fasta{settings_.referenceFilename}; | ||
for (const auto& seq : fasta) { |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,15 @@ | ||
--- src/CMakeLists.txt.orig 2018-03-07 23:10:34 UTC | ||
+++ src/CMakeLists.txt | ||
@@ -53,11 +53,11 @@ configure_file( | ||
|
||
# includes | ||
set(UNY_INCLUDE_DIRS | ||
+ ${SEQAN_INCLUDE_DIRS} | ||
${UNY_IncludeDir} | ||
${CMAKE_BINARY_DIR}/generated | ||
${Boost_INCLUDE_DIRS} | ||
${HTSLIB_INCLUDE_DIRS} | ||
- ${SEQAN_INCLUDE_DIRS} | ||
${CPPOPTPARSE_IncludeDir} | ||
${PacBioBAM_INCLUDE_DIRS} | ||
${pbcopper_INCLUDE_DIRS} |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
# Type mismatch on 11.0 i386 | ||
--- src/Recursor.h.orig 2018-03-07 23:10:34 UTC | ||
+++ src/Recursor.h | ||
@@ -708,7 +708,7 @@ size_t Recursor<Derived>::FillAlphaBeta( | ||
size_t J = tpl.Length(); | ||
int flipflops = 0; | ||
size_t maxSize = | ||
- std::max(100ul, static_cast<size_t>(0.5 + REBANDING_THRESHOLD * (I + 1) * (J + 1))); | ||
+ std::max(100ul, static_cast<unsigned long>(0.5 + REBANDING_THRESHOLD * (I + 1) * (J + 1))); | ||
|
||
// if we use too much space, do at least one more round | ||
// to take advantage of rebanding |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
Unanimity is a C++ library + applications to generate and process accurate | ||
consensus sequences from Pacific Biosciences sequence data. | ||
|
||
The core binary, CCS (circular consensus calling) takes multiple reads of the | ||
same SMRTbell sequence and combines them, employing a statistical model, to | ||
produce one high quality consensus sequence. | ||
|
||
WWW: https://github.com/PacificBiosciences/unanimity |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
# $FreeBSD$ | ||
|
||
PORTNAME= abc | ||
DISTVERSION= g20180420 | ||
CATEGORIES= cad | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= System for sequential synthesis and verification | ||
|
||
LICENSE= MIT | ||
LICENSE_FILE= ${WRKSRC}/copyright.txt | ||
|
||
USES= gmake localbase:ldflags | ||
USE_GITHUB= yes | ||
GH_ACCOUNT= berkeley-abc | ||
GH_TAGNAME= 0e15e4d | ||
USE_LDCONFIG= yes | ||
|
||
MAKE_ENV= ABC_USE_STDINT_H=1 ABC_MAKE_VERBOSE=1 | ||
CFLAGS+= -fPIC | ||
CXXFLAGS+= -fPIC | ||
|
||
PLIST_FILES= bin/${PORTNAME} lib/lib${PORTNAME}.so | ||
|
||
OPTIONS_DEFINE= DEBUG DOCS READLINE THREADS | ||
OPTIONS_DEFAULT= READLINE THREADS | ||
|
||
READLINE_USES= readline | ||
READLINE_MAKE_ENV= ABC_READLINE_LIBRARIES="-L${LOCALBASE}/lib -lreadline" | ||
READLINE_MAKE_ENV_OFF= ABC_USE_NO_READLINE=1 | ||
|
||
THREADS_MAKE_ENV_OFF= ABC_USE_NO_PTHREADS=1 | ||
|
||
PORTDOCS= README.md readmeaig | ||
|
||
post-build: | ||
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ABC_USE_PIC=1 lib${PORTNAME}.so | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin | ||
${INSTALL_PROGRAM} ${WRKSRC}/lib${PORTNAME}.so ${STAGEDIR}${PREFIX}/lib | ||
|
||
do-install-DOCS-on: | ||
@${MKDIR} ${STAGEDIR}${DOCSDIR} | ||
${INSTALL_DATA} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR} | ||
${INSTALL_DATA} ${WRKSRC}/readmeaig ${STAGEDIR}${DOCSDIR} | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
TIMESTAMP = 1524554306 | ||
SHA256 (berkeley-abc-abc-g20180420-0e15e4d_GH0.tar.gz) = ec291913390100d8b91264cba754fdf00274516d5f81d8b6ae2838d4489d0384 | ||
SIZE (berkeley-abc-abc-g20180420-0e15e4d_GH0.tar.gz) = 5591634 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
--- Makefile.orig 2018-03-30 08:04:05 UTC | ||
+++ Makefile | ||
@@ -1,6 +1,4 @@ | ||
|
||
-CC := gcc | ||
-CXX := g++ | ||
LD := $(CXX) | ||
|
||
MSG_PREFIX ?= | ||
@@ -52,8 +50,6 @@ endif | ||
|
||
ARCHFLAGS := $(ARCHFLAGS) | ||
|
||
-OPTFLAGS ?= -g -O | ||
- | ||
CFLAGS += -Wall -Wno-unused-function -Wno-write-strings -Wno-sign-compare $(ARCHFLAGS) | ||
ifneq ($(findstring arm,$(shell uname -m)),) | ||
CFLAGS += -DABC_MEMALIGN=4 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
--- src/misc/util/abc_global.h.orig 2018-04-10 14:33:45 UTC | ||
+++ src/misc/util/abc_global.h | ||
@@ -97,6 +97,15 @@ ABC_NAMESPACE_HEADER_START | ||
//////////////////////////////////////////////////////////////////////// | ||
|
||
#ifdef ABC_USE_STDINT_H | ||
+ | ||
+#ifndef __STDC_LIMIT_MACROS | ||
+ #define __STDC_LIMIT_MACROS | ||
+#endif | ||
+ | ||
+#ifndef __STDC_CONSTANT_MACROS | ||
+ #define __STDC_CONSTANT_MACROS | ||
+#endif | ||
+ | ||
// If there is stdint.h, assume this is a reasonably-modern platform that | ||
// would also have stddef.h and limits.h | ||
#include <limits.h> |
Oops, something went wrong.