Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Feb 2, 2018
1 parent aac78e9 commit 1a5cd6c
Show file tree
Hide file tree
Showing 80 changed files with 2,932 additions and 221 deletions.
5 changes: 4 additions & 1 deletion archivers/pbzip2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -17,8 +17,11 @@ PLIST_FILES= bin/pbzip2 bin/pbunzip2 \
man/man1/pbzip2.1.gz man/man1/pbunzip2.1.gz

post-patch:
@${REINPLACE_CMD} -e 's,PRI[iu]MAX, & ,g' ${WRKSRC}/pbzip2.cpp \
${WRKSRC}/BZ2StreamScanner.cpp
# Spell target sources to be understood by both BSD and GNU make(1)
@${REINPLACE_CMD} -e 's,$$^,$$>&,' ${WRKSRC}/Makefile
@${REINPLACE_CMD} -e '/-O2/s,^,#, ; s,$$^,$$>&,' \
${WRKSRC}/Makefile

do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
Expand Down
10 changes: 4 additions & 6 deletions audio/lastfm-desktop/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -21,8 +21,8 @@ LIB_DEPENDS= liblastfm.so:audio/liblastfm \
USE_GITHUB= yes
GH_ACCOUNT= lastfm

USES= gettext pkgconfig qmake tar:bzip2 gmake
USE_QT4= corelib gui linguist_build moc_build network phonon \
USES= gettext pkgconfig qmake gmake
USE_QT4= corelib dbus gui linguist_build moc_build network phonon \
rcc_build sql uic_build webkit xml
SUB_FILES= lastfm-desktop.sh

Expand All @@ -37,12 +37,10 @@ OPTIONS_SINGLE= PHONON
OPTIONS_SINGLE_PHONON= GSTREAMER VLC
OPTIONS_DEFAULT= VLC
GSTREAMER_DESC= Multimedia via Phonon-GStreamer
GSTREAMER_USE= QT4=dbus,phonon-gst_run GNOME=gdkpixbuf2,glib20
GSTREAMER_USE= QT4=phonon-gst_run
VLC_DESC= Multimedia via Phonon-VLC
VLC_RUN_DEPENDS= phonon-vlc>=0.6.1:multimedia/phonon-vlc

.include <bsd.port.pre.mk>

do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_SCRIPT} ${WRKDIR}/lastfm-desktop.sh ${STAGEDIR}${PREFIX}/bin/lastfm-desktop
Expand All @@ -52,4 +50,4 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/app/client/audioscrobbler.ico ${STAGEDIR}${PREFIX}/share/pixmaps/
(cd ${WRKSRC}/app/client && ${COPYTREE_SHARE} qrc ${STAGEDIR}${DATADIR})

.include <bsd.port.post.mk>
.include <bsd.port.mk>
11 changes: 11 additions & 0 deletions audio/lastfm-desktop/files/patch-admin_include.qmake
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- admin/include.qmake.orig 2013-09-03 12:19:10 UTC
+++ admin/include.qmake
@@ -45,8 +45,6 @@ unix:!mac {
#default install target
target.path = $$INSTALL_DIR/lib

-CONFIG += silent
-
macx:CONFIG( app_bundle ): contains( TEMPLATE, app ) {
DISTDIR = $$ROOT_DIR/admin/dist/mac
BUNDLE_DIR = $$DESTDIR/$$TARGET$$quote(.app)
4 changes: 4 additions & 0 deletions cad/stepcode/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,10 @@ CMAKE_ARGS+= -DSC_INSTALL_PREFIX=${PREFIX} \

MANDIRS= ${PREFIX}/man

post-patch:
@${REINPLACE_CMD} -e 's,( JudyValue ) 0,nullptr,' \
${WRKSRC}/src/base/judy/src/judy*Array.h

post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/schema_scanner
@(cd ${STAGEDIR}${PREFIX} ; \
Expand Down
52 changes: 27 additions & 25 deletions comms/lirc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= lirc
PORTVERSION= 0.9.0
PORTREVISION= 7
PORTREVISION= 8
PORTEPOCH= 1
CATEGORIES= comms
MASTER_SITES= SF/${PORTNAME}/LIRC/${PORTVERSION}
Expand All @@ -13,58 +13,60 @@ COMMENT= Linux Infrared Remote Control

BUILD_DEPENDS= v4l_compat>=1.0.20110603:multimedia/v4l_compat

INSTALL_TARGET= install-strip
USES= alias autoreconf gmake libtool python tar:bzip2
USE_XORG= sm x11
USES= alias autoreconf gmake libtool localbase python tar:bzip2
USE_XORG= sm x11 ice
USE_CSTD= gnu89
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes

GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-sandboxed --with-devdir=/var/run/lirc \
--sysconfdir=${PREFIX}/etc
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib

OPTIONS_DEFINE= MINIMAL DEBUG UARTLIRC DOCS EXAMPLES

MINIMAL_DESC= Build with minmal dependencies
UARTLIRC_DESC= Install serial LIRC driver

USE_RC_SUBR= lircd
PORTDOCS= html images irxevent.keys lirc.css lirc.hwdb
PORTEXAMPLES= remotes
SUB_FILES= pkg-message lircd.conf

.if exists(${LOCALBASE}/lib/libvga.so.1)
LIB_DEPENDS+= libvga.so:graphics/svgalib
PLIST_SUB+= SMODE2=
.else
PLIST_SUB+= SMODE2="@comment "
.endif
OPTIONS_DEFINE= MINIMAL DEBUG UARTLIRC DOCS EXAMPLES
OPTIONS_DEFINE_i386= SMODE2 # requires svgalib which is...
OPTIONS_DEFINE_amd64= SMODE2 # ...only available on x86
OPTIONS_SUB= yes

MINIMAL_DESC= Build with minimal dependencies
UARTLIRC_DESC= Install serial LIRC driver
SMODE2_DESC= Build smode2 (shows signal waveform), requires svgalib

MINIMAL_LIB_DEPENDS_OFF= libftdi.so:devel/libftdi \
MINIMAL_LIB_DEPENDS_OFF=libftdi.so:devel/libftdi \
libirman.so:comms/libirman
MINIMAL_CONFIGURE_OFF= --with-driver=userspace
MINIMAL_CONFIGURE_ON= --with-driver=dvico

DEBUG_CONFIGURE_ENABLE= debug

UARTLIRC_RUN_DEPENDS= uartlirc>=0.3:comms/uartlirc
SMODE2_LIB_DEPENDS= libvga.so:graphics/svgalib

UARTLIRC_RUN_DEPENDS= uartlirc>=0.3:comms/uartlirc

post-patch:
@${REINPLACE_CMD} \
-e 's/`$${LIBUSB_CONFIG} --libs`/-lusb/' \
-e 's/`$${LIBUSB_CONFIG} --cflags`//' \
${WRKSRC}/configure.ac

post-install:
${INSTALL_DATA} ${WRKDIR}/lircd.conf ${STAGEDIR}${PREFIX}/etc/lircd.conf.sample
@${MKDIR} ${STAGEDIR}/var/run/lirc

post-install-MINIMAL-on:
# bacause --with-driver is specified, it installs remotes/dvico/lircd.conf.fusionHDTV to etc/lircd/
# remove to not break the plist, but remote configs handling should probably be fixed...
@${RM} -r ${STAGEDIR}${PREFIX}/etc/lirc

post-install-DOCS-on:
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR}/)
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} images ${STAGEDIR}${DOCSDIR}/)
@(cd ${WRKSRC}/doc && ${INSTALL_DATA} irxevent.keys lirc.css lirc.hwdb ${STAGEDIR}${DOCSDIR}/)
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} "html images irxevent.keys lirc.css lirc.hwdb" ${STAGEDIR}${DOCSDIR}/)

post-install-EXAMPLES-on:
@(cd ${WRKSRC} && ${COPYTREE_SHARE} remotes ${STAGEDIR}${EXAMPLESDIR}/)
post-install:
@${INSTALL_DATA} ${WRKDIR}/lircd.conf ${STAGEDIR}${PREFIX}/etc/lircd.conf.sample
@${MKDIR} ${STAGEDIR}/var/run/lirc

.include <bsd.port.mk>
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Drop unnecessary use of boost::make_optional
https://jira.mongodb.org/browse/SERVER-32516
https://github.com/mongodb/mongo/commit/3c34eda8d8a3

--- src/mongo/db/repl/oplog_fetcher.cpp.orig 2017-09-07 19:28:48 UTC
+++ src/mongo/db/repl/oplog_fetcher.cpp
Expand All @@ -8,7 +8,7 @@ Drop unnecessary use of boost::make_optional
return metadataResult.getStatus();
}
- oqMetadata = boost::make_optional<rpc::OplogQueryMetadata>(metadataResult.getValue());
+ oqMetadata = metadataResult.getValue();
+ oqMetadata = boost::make_optional(metadataResult.getValue());
}
return oqMetadata;
}
2 changes: 1 addition & 1 deletion databases/mongodb34/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@
PORTNAME= mongodb
DISTVERSIONPREFIX= r
DISTVERSION= 3.4.9
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= databases net
MASTER_SITES= https://fastdl.mongodb.org/src/ \
http://fastdl.mongodb.org/src/ \
Expand Down
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
Drop unnecessary use of boost::make_optional
https://jira.mongodb.org/browse/SERVER-32516
https://github.com/mongodb/mongo/commit/3c34eda8d8a3

--- src/mongo/db/repl/oplog_fetcher.cpp.orig 2017-09-07 19:28:48 UTC
+++ src/mongo/db/repl/oplog_fetcher.cpp
Expand All @@ -8,7 +8,7 @@ Drop unnecessary use of boost::make_optional
return metadataResult.getStatus();
}
- oqMetadata = boost::make_optional<rpc::OplogQueryMetadata>(metadataResult.getValue());
+ oqMetadata = metadataResult.getValue();
+ oqMetadata = boost::make_optional(metadataResult.getValue());
}
return oqMetadata;
}
16 changes: 12 additions & 4 deletions deskutils/calcurse/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,28 +2,36 @@
# $FreeBSD$

PORTNAME= calcurse
PORTVERSION= 4.2.2
PORTVERSION= 4.3.0
CATEGORIES= deskutils
MASTER_SITES= http://calcurse.org/files/

MAINTAINER= [email protected]
COMMENT= Text-based calendar and scheduling application

LICENSE= BSD2CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING

OPTIONS_DEFINE= DOCS NLS
OPTIONS_DEFINE= CALDAV DOCS NLS
OPTIONS_DEFAULT=CALDAV
OPTIONS_SUB= yes

USES= gmake ncurses shebangfix
SHEBANG_LANG= python3
SHEBANG_FILES= contrib/caldav/calcurse-caldav.py
SHEBANG_FILES= contrib/caldav/calcurse-caldav \
contrib/caldav/calcurse-caldav.py
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-asciidoc

DOCS_CONFIGURE_ENABLE= docs
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext

CALDAV_DESC= Support Calendaring Extensions to WebDAV
CALDAV_USES= python:3.4+
CALDAV_USES_OFF= python:3.4+,env
CALDAV_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}httplib2>=0:www/py-httplib2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}oauth2client>=0:security/py-oauth2client@${PY_FLAVOR}

post-patch:
@${REINPLACE_CMD} -e 's|^docdir = .*|docdir = ${DOCSDIR}|' ${WRKSRC}/doc/Makefile.in
@${REINPLACE_CMD} -e 's|-R$$found_dir||' ${WRKSRC}/configure
Expand Down
6 changes: 3 additions & 3 deletions deskutils/calcurse/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1501159906
SHA256 (calcurse-4.2.2.tar.gz) = c6881ddbd1cc7fbd02898187ac0fb4c6d8ac4c2715909b1cf00fb7a90cf08046
SIZE (calcurse-4.2.2.tar.gz) = 612456
TIMESTAMP = 1517490109
SHA256 (calcurse-4.3.0.tar.gz) = 31ecc3dc09e1e561502b4c94f965ed6b167c03e9418438c4a7ad5bad2c785f9a
SIZE (calcurse-4.3.0.tar.gz) = 597490
2 changes: 1 addition & 1 deletion deskutils/fbreader/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -27,7 +27,7 @@ STATUS= debug
STATUS= release
.endif

USES= compiler gmake iconv localbase pkgconfig sqlite tar:tgz
USES= compiler gmake iconv localbase pkgconfig sqlite
USE_LDCONFIG= yes

INSTALL_TARGET= do_install
Expand Down
1 change: 1 addition & 0 deletions devel/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5952,6 +5952,7 @@
SUBDIR += sysconftool
SUBDIR += sysfsutils
SUBDIR += t1lib
SUBDIR += tablist
SUBDIR += ta-lib
SUBDIR += tailor
SUBDIR += talloc
Expand Down
13 changes: 4 additions & 9 deletions devel/arpc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -21,8 +21,9 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pyPEG2>=2.15.2:textproc/py-pyPEG2@${PY_FLAVO
BROKEN_armv6= fails to build: *** Signal 11
BROKEN_armv7= fails to build: *** Signal 11

USES= cmake localbase:ldflags python:3.4+ shebangfix tar:xz
python_OLD_CMD= "/usr/bin/env python3"
IGNORE_FreeBSD_10= requires various C++17 features

USES= cmake localbase:ldflags python:3.4+ shebangfix
SHEBANG_FILES= scripts/aprotoc.py
USE_LDCONFIG= yes
USE_GITHUB= yes
Expand All @@ -31,14 +32,8 @@ GH_ACCOUNT= NuxiNL
PLIST_FILES= bin/aprotoc include/arpc++/arpc++.h \
lib/libarpc.so lib/libarpc.so.1

.include <bsd.port.pre.mk>

.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1100511
IGNORE= requires various C++17 features
.endif

# Require the unit tests to pass prior to installing.
post-build:
@trap '' PIPE && ${WRKSRC}/arpc_tests

.include <bsd.port.post.mk>
.include <bsd.port.mk>
5 changes: 3 additions & 2 deletions devel/babeltrace/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= babeltrace
PORTVERSION= 1.5.3
PORTVERSION= 1.5.4
DISTVERSIONPREFIX= v
CATEGORIES= devel

Expand All @@ -19,10 +19,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libpopt.so:devel/popt \
libuuid.so:misc/e2fsprogs-libuuid

USES= autoreconf:build bison gmake libtool pathfix pkgconfig

USE_GITHUB= yes
GH_ACCOUNT= efficios

USES= autoreconf:build bison gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-debug-info
USE_GNOME= glib20
Expand Down
6 changes: 3 additions & 3 deletions devel/babeltrace/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1502909561
SHA256 (efficios-babeltrace-v1.5.3_GH0.tar.gz) = 568d52a266828f2d673484757ecc025fee456efc1b15c2105092427ac51506f0
SIZE (efficios-babeltrace-v1.5.3_GH0.tar.gz) = 839678
TIMESTAMP = 1517489116
SHA256 (efficios-babeltrace-v1.5.4_GH0.tar.gz) = a4e3cc46da022bc4640a2c50bb065d39a4e96468931f9df196810ed7fa8d5290
SIZE (efficios-babeltrace-v1.5.4_GH0.tar.gz) = 841428
1 change: 1 addition & 0 deletions devel/babeltrace/pkg-plist
Original file line number Diff line number Diff line change
Expand Up @@ -20,6 +20,7 @@ include/babeltrace/ctf-writer/writer.h
include/babeltrace/ctf/callbacks.h
include/babeltrace/ctf/events.h
include/babeltrace/ctf/iterator.h
include/babeltrace/error.h
include/babeltrace/format.h
include/babeltrace/iterator.h
include/babeltrace/list.h
Expand Down
2 changes: 1 addition & 1 deletion devel/elixir-msgpax/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= msgpax
PORTVERSION= 2.1.0
PORTVERSION= 2.1.1
DISTVERSIONPREFIX= v
CATEGORIES= devel
PKGNAMEPREFIX= elixir-
Expand Down
6 changes: 3 additions & 3 deletions devel/elixir-msgpax/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1512703153
SHA256 (lexmag-msgpax-v2.1.0_GH0.tar.gz) = 420a9083d2d09dbf489b28a151962a7a8d3b17c7a765b2b66501a6d6b05a3946
SIZE (lexmag-msgpax-v2.1.0_GH0.tar.gz) = 13516
TIMESTAMP = 1517589328
SHA256 (lexmag-msgpax-v2.1.1_GH0.tar.gz) = 25ac538876d17fa495dbeffc1dfbe3cbd2df7eb48f6a035309554b9e34d10c39
SIZE (lexmag-msgpax-v2.1.1_GH0.tar.gz) = 13533
2 changes: 1 addition & 1 deletion devel/elixir-swarm/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $FreeBSD$

PORTNAME= swarm
DISTVERSION= 3.2.0
DISTVERSION= 3.2.1
CATEGORIES= devel
PKGNAMEPREFIX= elixir-

Expand Down
6 changes: 3 additions & 3 deletions devel/elixir-swarm/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1517492348
SHA256 (bitwalker-swarm-3.2.0_GH0.tar.gz) = 7fd44ee8620b32d81e6b530f582cb526024ec25615ef2122e19d282685233f26
SIZE (bitwalker-swarm-3.2.0_GH0.tar.gz) = 36153
TIMESTAMP = 1517555554
SHA256 (bitwalker-swarm-3.2.1_GH0.tar.gz) = 450cd0612ac052d3b93991d032b1653c02a7ae9cddc797176b2c9368370f77d6
SIZE (bitwalker-swarm-3.2.1_GH0.tar.gz) = 35874
2 changes: 1 addition & 1 deletion devel/fpc-fcl-pdf/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -5,7 +5,7 @@ PKGNAMESUFFIX= -fcl-pdf

COMMENT= Free Pascal pdf (FCL)

USE_FPC= fcl-base fcl-image fcl-res pasjpeg rtl-objpas
USE_FPC= fcl-base fcl-image fcl-res fcl-xml pasjpeg rtl-objpas

MASTERDIR= ${.CURDIR}/../../lang/fpc
WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
Expand Down
2 changes: 1 addition & 1 deletion devel/libversion/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= libversion
PORTVERSION= 2.4.0
PORTVERSION= 2.5.0
CATEGORIES= devel

MAINTAINER= [email protected]
Expand Down
6 changes: 3 additions & 3 deletions devel/libversion/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1516392743
SHA256 (repology-libversion-2.4.0_GH0.tar.gz) = b4fca4f8a166f8f60a6e7b47c2d39171a7a6d512b7b2c76aa2aa3966cf1b601c
SIZE (repology-libversion-2.4.0_GH0.tar.gz) = 13188
TIMESTAMP = 1517571849
SHA256 (repology-libversion-2.5.0_GH0.tar.gz) = 19c027eb44153439e2ed0af639703d5230f489b2cbe85d59a218f3e0572a8ab9
SIZE (repology-libversion-2.5.0_GH0.tar.gz) = 13531
2 changes: 1 addition & 1 deletion devel/py-grpcio-tools/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= grpcio-tools
PORTVERSION= 1.8.6
PORTVERSION= 1.9.0
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
Expand Down
Loading

0 comments on commit 1a5cd6c

Please sign in to comment.