Skip to content

Commit

Permalink
*/*: sync with upstream
Browse files Browse the repository at this point in the history
Taken from: HardenedBSD
  • Loading branch information
fichtner committed Nov 15, 2019
1 parent dbb7f81 commit 20dbb75
Show file tree
Hide file tree
Showing 212 changed files with 740 additions and 691 deletions.
1 change: 1 addition & 0 deletions audio/adplay/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -37,6 +37,7 @@ ALSA_CONFIGURE_OFF= --disable-output-alsa
ALSA_CFLAGS+= `pkg-config --cflags alsa`

SDL_CONFIGURE_OFF= --disable-output-sdl
SDL_USES= sdl
SDL_USE= SDL=sdl,mixer

PLIST_FILES= bin/adplay %%DATADIR%%/adplug.db man/man1/adplay.1.gz
Expand Down
1 change: 1 addition & 0 deletions audio/aumix/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -39,6 +39,7 @@ NLS_CONFIGURE_OFF= --disable-nls
NLS_PLIST_FILES+= share/locale/${ii}/LC_MESSAGES/aumix.mo
.endfor

GTK2_USES= gnome
GTK2_USE= GNOME=gtk20
GTK2_CONFIGURE_OFF=--without-gtk

Expand Down
1 change: 1 addition & 0 deletions audio/baresip/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -76,6 +76,7 @@ PORT_OPTIONS+= PULSE
.endif

.if ${PORT_OPTIONS:MSDL}
USES+= sdl
USE_SDL= sdl sound
.endif

Expand Down
1 change: 1 addition & 0 deletions audio/clementine-player/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -32,6 +32,7 @@ USES= cmake \
qt:5 \
sqlite \
gl \
gnome \
xorg

USE_CXXSTD= c++11
Expand Down
1 change: 1 addition & 0 deletions audio/kmix/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -30,6 +30,7 @@ OPTIONS_DEFINE= PULSEAUDIO DOCS

PULSEAUDIO_LIB_DEPENDS= libcanberra.so:audio/libcanberra \
libpulse.so:audio/pulseaudio
PULSEAUDIO_USES= gnome
PULSEAUDIO_USE= GNOME=glib20
PULSEAUDIO_CMAKE_BOOL_OFF= CMAKE_DISABLE_FIND_PACKAGE_Canberra \
CMAKE_DISABLE_FIND_PACKAGE_PulseAudio
Expand Down
1 change: 1 addition & 0 deletions audio/lmms/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -56,6 +56,7 @@ PORTAUDIO_CMAKE_BOOL= WANT_PORTAUDIO
PORTAUDIO_LIB_DEPENDS= libportaudio.so:audio/portaudio

SDL_CMAKE_OFF= WANT_SDL
SDL_USES= sdl
SDL_USE= SDL=sdl

SNDIO_CMAKE_BOOL= WANT_SNDIO
Expand Down
1 change: 1 addition & 0 deletions audio/mhwaveedit/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -47,6 +47,7 @@ PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
PULSEAUDIO_CONFIGURE_WITH= pulse
SAMPLERATE_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
SAMPLERATE_CONFIGURE_WITH= libsamplerate
SDL_USES= sdl
SDL_USE= sdl=sdl
SDL_CONFIGURE_WITH= sdl
SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
Expand Down
1 change: 1 addition & 0 deletions audio/xmms2/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -137,6 +137,7 @@ SPEEX_CONFIGURE_OFF= --without-plugins="speex"
TREMOR_LIB_DEPENDS= libvorbisidec.so:audio/libtremor
TREMOR_CONFIGURE_OFF= --without-plugins="tremor"

VISUAL_USES= sdl
VISUAL_USE= SDL=sdl
VISUAL_LIB_DEPENDS= libvisual-0.4.so:graphics/libvisual04
VISUAL_CONFIGURE_OFF= --without-optionals="vistest"
Expand Down
21 changes: 17 additions & 4 deletions cad/openvsp/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@

PORTNAME= openvsp
DISTVERSIONPREFIX= ${GH_PROJECT}_
DISTVERSION= 3.18.0
DISTVERSION= 3.19.0
CATEGORIES= cad

MAINTAINER= [email protected]
Expand Down Expand Up @@ -51,15 +51,28 @@ USE_GNOME= libxml2

.include <bsd.port.options.mk>

.include <bsd.port.pre.mk>

# See https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=230888
.if ${OPSYS} == FreeBSD
.if (${OSVERSION} < 1200000 || ${OSVERSION} >=1300000)
BROKEN= undefined reference to __atomic_load
.endif
.endif

BUILD_PREFIX= OpenVSP-prefix/src/OpenVSP-build/_CPack_Packages/FreeBSD/ZIP/OpenVSP-${DISTVERSION}-FreeBSD

do-install:
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${BUILD_PREFIX}/vsp* ${STAGEDIR}${PREFIX}/bin
@${STRIP_CMD} ${STAGEDIR}/${PREFIX}/vsp*
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_DATA} ${BUILD_WRKSRC}/${BUILD_PREFIX}/vspIcon.png ${STAGEDIR}${DATADIR}
${RM} ${STAGEDIR}${PREFIX}/vspIcon.png ${BUILD_WRKSRC}/${BUILD_PREFIX}/vspIcon.png
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/${BUILD_PREFIX}/vsp* ${STAGEDIR}${PREFIX}/bin
${RM} ${STAGEDIR}${PREFIX}/vsp*
.for d in CustomScripts airfoil matlab scripts textures
(cd ${BUILD_WRKSRC}/${BUILD_PREFIX}/${d} && ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR})
${RM} -rf ${STAGEDIR}${PREFIX}/${d}
.endfor
${CP} ${BUILD_WRKSRC}/${BUILD_PREFIX}/LICENSE ${STAGEDIR}${DATADIR}
${RM} ${STAGEDIR}${PREFIX}/LICENSE

.include <bsd.port.mk>
.include <bsd.port.post.mk>
6 changes: 3 additions & 3 deletions cad/openvsp/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1567610562
SHA256 (OpenVSP-OpenVSP-OpenVSP_3.18.0_GH0.tar.gz) = 0d1b15e3532ae1fe7893fd3cfdfbea89065379032957ab8cc37fbbe6019889e6
SIZE (OpenVSP-OpenVSP-OpenVSP_3.18.0_GH0.tar.gz) = 110268961
TIMESTAMP = 1573426703
SHA256 (OpenVSP-OpenVSP-OpenVSP_3.19.0_GH0.tar.gz) = e6fe666875b7442c5717f66610cd6f7262f7d51473028edde5b0f7ab1e026445
SIZE (OpenVSP-OpenVSP-OpenVSP_3.19.0_GH0.tar.gz) = 110506891
79 changes: 3 additions & 76 deletions cad/openvsp/pkg-plist
Original file line number Diff line number Diff line change
@@ -1,70 +1,9 @@
CustomScripts/Box.vsppart
CustomScripts/BoxGroup.vsppart
CustomScripts/Cone.vsppart
CustomScripts/Disk.vsppart
CustomScripts/Duct.vsppart
CustomScripts/OnOffExample.vsppart
CustomScripts/PodMan.vsppart
CustomScripts/Seat.vsppart
CustomScripts/SeatGroup.vsppart
CustomScripts/TransportFuse.vsppart
LICENSE
README.md
airfoil/23015.af
airfoil/Hershey_AR10.avl
airfoil/Hershey_AR10_AVL.dat
airfoil/N0012_VSP.af
airfoil/N0012_VSP_sym.af
airfoil/VKT_e0.1_k0.1_t10.dat
airfoil/XFoil_VKT_CpDist.txt
airfoil/b737a.af
airfoil/b737b.af
airfoil/b737c.af
airfoil/b737d.af
airfoil/clarky_Lednicer.dat
airfoil/e205_Selig.dat
airfoil/n0012.dat
airfoil/sc2_0404.af
bin/vsp
bin/vspaero
bin/vspscript
bin/vspslicer
bin/vspviewer
matlab/BezierAirfoilExample.m
matlab/BezierCtrlToCoordPnts.m
matlab/OpenVSPParasiteDragPlotData.m
matlab/plotDegenPlate.m
matlab/plotDegenStick.m
matlab/plotDegenSurf.m
scripts/AirfoilExport.vspscript
scripts/CFDMesh.vspscript
scripts/CpSlicer.vspscript
scripts/CreateEditGeom.vspscript
scripts/DegenGeom.vspscript
scripts/DumpResults.vspscript
scripts/FEAMesh.vspscript
scripts/Fuselage.vspscript
scripts/Master_VSP_VV_Script.vspscript
scripts/ParasiteDragScriptTest.vspscript
scripts/SingleAirfoilExport.vspscript
scripts/SnapToDemo.vspscript
scripts/Stack.vspscript
scripts/StructuresParmContainerTest.vspscript
scripts/SubSurface.vspscript
scripts/TestAll.vspscript
scripts/TestAnalysis.vspscript
scripts/TestAnalysisVSPAERO.vspscript
scripts/testanimate.vspscript
scripts/TestAreaProj.vspscript
scripts/TestDXF.vspscript
scripts/TestFacet.vspscript
scripts/TestMassProperties.vspscript
scripts/TestMeasure.vspscript
scripts/TestSVG.vspscript
scripts/TestSaveLoad.vspscript
scripts/TestSurfQuery.vspscript
scripts/VKTAirfoil.vspscript
scripts/Wing.vspscript
%%DATADIR%%/23015.af
%%DATADIR%%/AirfoilExport.vspscript
%%DATADIR%%/BezierAirfoilExample.m
Expand All @@ -79,6 +18,7 @@ scripts/Wing.vspscript
%%DATADIR%%/Disk.vsppart
%%DATADIR%%/Duct.vsppart
%%DATADIR%%/DumpResults.vspscript
%%DATADIR%%/EditCurveXSec.vspscript
%%DATADIR%%/FEAMesh.vspscript
%%DATADIR%%/Fuselage.vspscript
%%DATADIR%%/Hershey_AR10.avl
Expand All @@ -102,7 +42,6 @@ scripts/Wing.vspscript
%%DATADIR%%/TestAll.vspscript
%%DATADIR%%/TestAnalysis.vspscript
%%DATADIR%%/TestAnalysisVSPAERO.vspscript
%%DATADIR%%/testanimate.vspscript
%%DATADIR%%/TestAreaProj.vspscript
%%DATADIR%%/TestDXF.vspscript
%%DATADIR%%/TestFacet.vspscript
Expand Down Expand Up @@ -134,18 +73,6 @@ scripts/Wing.vspscript
%%DATADIR%%/plotDegenSurf.m
%%DATADIR%%/redbluearrow.tga
%%DATADIR%%/sc2_0404.af
%%DATADIR%%/testanimate.vspscript
%%DATADIR%%/vspIcon.png
%%DATADIR%%/window.tga
textures/SharkTeeth.tga
textures/VSPBoxXSec.PNG
textures/VSPCircXSec.PNG
textures/VSPIXSec.PNG
textures/VSPPipeXSec.PNG
textures/VSPRectXSec.PNG
textures/nasa-logo.tga
textures/redbluearrow.tga
textures/window.tga
vsp
vspaero
vspscript
vspslicer
vspviewer
1 change: 1 addition & 0 deletions chinese/libtabe/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -30,6 +30,7 @@ MAKE_JOBS_UNSAFE= yes

OPTIONS_DEFINE= DOCS X11
OPTIONS_SUB= yes
X11_USES= xorg
X11_USE= XORG=x11
X11_CONFIGURE_WITH= x

Expand Down
1 change: 1 addition & 0 deletions databases/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -978,6 +978,7 @@
SUBDIR += rubygem-memcache-client
SUBDIR += rubygem-mysql
SUBDIR += rubygem-mysql2
SUBDIR += rubygem-mysql204
SUBDIR += rubygem-openid-redis-store
SUBDIR += rubygem-paranoia
SUBDIR += rubygem-peek-mysql2-rails5
Expand Down
2 changes: 1 addition & 1 deletion databases/libiodbc/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -29,7 +29,7 @@ OPTIONS_DEFINE= GTK2 DOCS EXAMPLES
OPTIONS_SUB= yes

GTK2_USE= GNOME=cairo,gdkpixbuf2,gtk20
GTK2_USES= gettext-runtime
GTK2_USES= gettext-runtime gnome
GTK2_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2

Expand Down
4 changes: 2 additions & 2 deletions databases/postgresql10-server/Makefile
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Created by: Marc G. Fournier <[email protected]>
# $FreeBSD$

DISTVERSION?= 10.10
DISTVERSION?= 10.11
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
PORTREVISION?= 1
PORTREVISION?= 0
PKGNAMESUFFIX?= ${DISTVERSION:R:S/.//}${COMPONENT}

MAINTAINER?= [email protected]
Expand Down
6 changes: 3 additions & 3 deletions databases/postgresql10-server/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1565174246
SHA256 (postgresql/postgresql-10.10.tar.bz2) = ad4f9b8575f98ed6091bf9bb2cb16f0e52795a5f66546c1f499ca5c69b21f253
SIZE (postgresql/postgresql-10.10.tar.bz2) = 19012049
TIMESTAMP = 1573552509
SHA256 (postgresql/postgresql-10.11.tar.bz2) = 0d5d14ff6b075655f4421038fbde3a5d7b418c26a249a187a4175600d7aecc09
SIZE (postgresql/postgresql-10.11.tar.bz2) = 19017947
4 changes: 2 additions & 2 deletions databases/postgresql12-server/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME?= postgresql
DISTVERSION?= 12.0
DISTVERSION?= 12.1
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
PORTREVISION?= 0
Expand Down Expand Up @@ -110,7 +110,7 @@ USES+= pkgconfig
# (requires dump/restore if modified.)
OPTIONS_DEFINE+= INTDATE
INTDATE_DESC= Builds with 64-bit date/time type
OPTIONS_DEFAULT+= TZDATA INTDATE
OPTIONS_DEFAULT+= INTDATE
.endif

.if !defined(SLAVE_ONLY)
Expand Down
6 changes: 3 additions & 3 deletions databases/postgresql12-server/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1569942321
SHA256 (postgresql/postgresql-12.0.tar.bz2) = cda2397215f758b793f741c86be05468257b0e6bcb1a6113882ab5d0df0855c6
SIZE (postgresql/postgresql-12.0.tar.bz2) = 20177458
TIMESTAMP = 1573552509
SHA256 (postgresql/postgresql-12.1.tar.bz2) = a09bf3abbaf6763980d0f8acbb943b7629a8b20073de18d867aecdb7988483ed
SIZE (postgresql/postgresql-12.1.tar.bz2) = 20213711
2 changes: 1 addition & 1 deletion databases/postgresql94-server/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Created by: Marc G. Fournier <[email protected]>
# $FreeBSD$

DISTVERSION?= 9.4.24
DISTVERSION?= 9.4.25
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
PORTREVISION?= 0
Expand Down
6 changes: 3 additions & 3 deletions databases/postgresql94-server/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
TIMESTAMP = 1565174268
SHA256 (postgresql/postgresql-9.4.24.tar.bz2) = 52253d67dd46a7463a9d7c5e82bf959931fa4c11ec56293150210fa82a0f9429
SIZE (postgresql/postgresql-9.4.24.tar.bz2) = 16842941
TIMESTAMP = 1573552509
SHA256 (postgresql/postgresql-9.4.25.tar.bz2) = cb98afaef4748de76c13202c14198e3e4717adde49fd9c90fdc81da877520928
SIZE (postgresql/postgresql-9.4.25.tar.bz2) = 16849015
SHA256 (postgresql/pg-949-icu-2016-10-02.diff.gz) = 34612e685a79874db04bc6b66c700bfc6412042840c532eef0da7832d1f70d43
SIZE (postgresql/pg-949-icu-2016-10-02.diff.gz) = 5289
2 changes: 1 addition & 1 deletion databases/postgresql95-server/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# Created by: Marc G. Fournier <[email protected]>
# $FreeBSD$

DISTVERSION?= 9.5.19
DISTVERSION?= 9.5.20
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
PORTREVISION?= 0
Expand Down
6 changes: 3 additions & 3 deletions databases/postgresql95-server/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
TIMESTAMP = 1565174279
SHA256 (postgresql/postgresql-9.5.19.tar.bz2) = 960caa26612bca8a3791d1c0bdc5c6d24b3d15841becb617470424edbc5e1bb3
SIZE (postgresql/postgresql-9.5.19.tar.bz2) = 17571998
TIMESTAMP = 1573552509
SHA256 (postgresql/postgresql-9.5.20.tar.bz2) = 925751b375cf975bebbe79753fbcb5fe85d7a62abe516d4c56861a6b877dde0d
SIZE (postgresql/postgresql-9.5.20.tar.bz2) = 17610134
SHA256 (postgresql/pg-954-icu-2016-08-10.diff.gz) = 5fa083ec38087d6a0961642208f012e902221270708b919b92e9eedaa755e365
SIZE (postgresql/pg-954-icu-2016-08-10.diff.gz) = 5952
4 changes: 2 additions & 2 deletions databases/postgresql96-server/Makefile
Original file line number Diff line number Diff line change
@@ -1,10 +1,10 @@
# Created by: Marc G. Fournier <[email protected]>
# $FreeBSD$

DISTVERSION?= 9.6.15
DISTVERSION?= 9.6.16
# PORTREVISION must be ?= otherwise, all slave ports get this PORTREVISION and
# not their own. Probably best to keep it at ?=0 when reset here too.
PORTREVISION?= 1
PORTREVISION?= 0
PKGNAMESUFFIX?= ${PORTVERSION:R:S/.//}${COMPONENT}

MAINTAINER?= [email protected]
Expand Down
6 changes: 3 additions & 3 deletions databases/postgresql96-server/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
TIMESTAMP = 1565174281
SHA256 (postgresql/postgresql-9.6.15.tar.bz2) = 3cd9fe9af247167f863030842c1a57f58bdf3e5d50a94997d34a802b6032170a
SIZE (postgresql/postgresql-9.6.15.tar.bz2) = 18799121
TIMESTAMP = 1573552509
SHA256 (postgresql/postgresql-9.6.16.tar.bz2) = 5c6cba9cc0df70ba2b128c4a87d0babfce7c0e2b888f70a9c8485745f66b22e7
SIZE (postgresql/postgresql-9.6.16.tar.bz2) = 18806372
SHA256 (postgresql/pg-96b4-icu-2016-10-02.diff.gz) = 85f81baa0fc8f692bcf802c8645196d9e3afdef4f760cef712d940b87655486e
SIZE (postgresql/pg-96b4-icu-2016-10-02.diff.gz) = 5998
2 changes: 1 addition & 1 deletion databases/proftpd-mod_sql_tds/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

PORTNAME= mod_sql_tds
DISTVERSION= 4.13
PORTREVISION= 0
PORTREVISION= 1
CATEGORIES= databases ftp
PKGNAMEPREFIX= proftpd-

Expand Down
6 changes: 3 additions & 3 deletions databases/proftpd-mod_sql_tds/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
TIMESTAMP = 1552950955
SHA256 (proftpd-1.3.6.tar.gz) = 91ef74b143495d5ff97c4d4770c6804072a8c8eb1ad1ecc8cc541b40e152ecaf
SIZE (proftpd-1.3.6.tar.gz) = 20251898
TIMESTAMP = 1573760277
SHA256 (proftpd-1.3.6b.tar.gz) = fe5baf6c469a2b0b7f0e2611561b6fd5414300e32a76b96adb2ccfe05b5efb60
SIZE (proftpd-1.3.6b.tar.gz) = 20260731
SHA256 (mod_sql_tds-4.13.tar.gz) = 9d9fb6c4b9a952739a84e166ed8b0d93f539c7bcf73e32923318e00cbd7eea08
SIZE (mod_sql_tds-4.13.tar.gz) = 11688
2 changes: 1 addition & 1 deletion databases/py-tiledb/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
# $FreeBSD$

PORTNAME= tiledb
PORTVERSION= 0.4.4
PORTVERSION= 0.5.0
CATEGORIES= databases python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
Expand Down
6 changes: 3 additions & 3 deletions databases/py-tiledb/distinfo
Original file line number Diff line number Diff line change
@@ -1,3 +1,3 @@
TIMESTAMP = 1571671543
SHA256 (tiledb-0.4.4.tar.gz) = ec8c9e07804af34e4db0a23503d0f58635b05e71252aff4a528560bebbb5bee4
SIZE (tiledb-0.4.4.tar.gz) = 86395
TIMESTAMP = 1573740249
SHA256 (tiledb-0.5.0.tar.gz) = d76226bef676275b310ba48192f82f24b85160456ddf808d8fd4db5c11414931
SIZE (tiledb-0.5.0.tar.gz) = 95856
8 changes: 0 additions & 8 deletions databases/py-tiledb/files/patch-tiledb-libtiledb.pyd

This file was deleted.

Loading

0 comments on commit 20dbb75

Please sign in to comment.