forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
315 changed files
with
3,020 additions
and
5,636 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- configure.orig 2018-03-31 02:06:04 UTC | ||
+++ configure | ||
@@ -18871,7 +18871,7 @@ return ID3Tag_Link (); | ||
return 0; | ||
} | ||
_ACEOF | ||
-for ac_lib in '' "id3" "id3 -lstdc++" "id3 -lz" "id3 -lz -lstdc++"; do | ||
+for ac_lib in "id3 -lstdc++" "id3 -lz -lstdc++"; do | ||
if test -z "$ac_lib"; then | ||
ac_res="none required" | ||
else |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
# $FreeBSD$ | ||
|
||
PORTNAME= stacks | ||
DISTVERSION= 1.48 | ||
CATEGORIES= biology | ||
MASTER_SITES= http://catchenlab.life.illinois.edu/stacks/source/ | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Software pipeline for building loci from short-read sequences | ||
|
||
LICENSE= GPLv2 | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
|
||
USES= gmake python shebangfix | ||
SHEBANG_FILES= scripts/*.pl scripts/*.py | ||
GNU_CONFIGURE= yes | ||
|
||
LDFLAGS+= -lpthread | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,3 @@ | ||
TIMESTAMP = 1520376299 | ||
SHA256 (stacks-1.48.tar.gz) = e9f6251f5f609f9dd0bb1de17a51f69ce1a9af531548c4d2456a89783b1dcd1e | ||
SIZE (stacks-1.48.tar.gz) = 895195 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,20 @@ | ||
--- htslib/Makefile.orig 2016-09-16 15:40:03 UTC | ||
+++ htslib/Makefile | ||
@@ -22,13 +22,13 @@ | ||
# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER | ||
# DEALINGS IN THE SOFTWARE. | ||
|
||
-CC = gcc | ||
-AR = ar | ||
-RANLIB = ranlib | ||
+CC ?= gcc | ||
+AR ?= ar | ||
+RANLIB ?= ranlib | ||
|
||
CPPFLAGS = | ||
# TODO: probably update cram code to make it compile cleanly with -Wc++-compat | ||
-CFLAGS = -g -Wall -O2 | ||
+CFLAGS ?= -g -Wall -O2 | ||
EXTRA_CFLAGS_PIC = -fpic | ||
LDFLAGS = | ||
LIBS = |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,6 @@ | ||
Stacks is a software pipeline for building loci from short-read sequences, such | ||
as those generated on the Illumina platform. Stacks was developed to work with | ||
restriction enzyme-based data, such as RAD-seq, for the purpose of building | ||
genetic maps and conducting population genomics and phylogeography. | ||
|
||
WWW: http://catchenlab.life.illinois.edu/stacks/ |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,16 @@ | ||
=== | ||
|
||
If you would like to use the stacks web interface, follow the instructions at: | ||
|
||
http://catchenlab.life.illinois.edu/stacks/manual-v1/#install | ||
|
||
You will need to install databases/p5-DBD-mysql to allow the optional | ||
wrapper scripts to interact with the database server. | ||
|
||
To set up the web server, you will need an apache server such as www/apache24, | ||
MySQL server and client packages such as databases/mysql56-client and | ||
databases/mysql56-server, and PHP interface modules such as | ||
databases/php56-mysql (php56 will be automatically installed as a dependency), | ||
and lastly textproc/p5-Spreadsheet-WriteExcel. | ||
|
||
=== |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,70 @@ | ||
bin/clone_filter | ||
bin/count_fixed_catalog_snps.py | ||
bin/cstacks | ||
bin/denovo_map.pl | ||
bin/exec_velvet.pl | ||
bin/export_sql.pl | ||
bin/genotypes | ||
bin/index_radtags.pl | ||
bin/integrate_alignments.py | ||
bin/kmer_filter | ||
bin/load_radtags.pl | ||
bin/load_sequences.pl | ||
bin/phasedstacks | ||
bin/populations | ||
bin/process_radtags | ||
bin/process_shortreads | ||
bin/pstacks | ||
bin/ref_map.pl | ||
bin/rxstacks | ||
bin/sort_read_pairs.pl | ||
bin/sstacks | ||
bin/stacks_export_notify.pl | ||
bin/ustacks | ||
%%DATADIR%%/php/CatalogClass.php | ||
%%DATADIR%%/php/Locus.php | ||
%%DATADIR%%/php/ajax.js | ||
%%DATADIR%%/php/annotate.js | ||
%%DATADIR%%/php/annotate_marker.php | ||
%%DATADIR%%/php/catalog.php | ||
%%DATADIR%%/php/catalog_genotypes.php | ||
%%DATADIR%%/php/constants.php.dist | ||
%%DATADIR%%/php/correct_genotype.php | ||
%%DATADIR%%/php/correct_genotypes.php | ||
%%DATADIR%%/php/db_functions.php | ||
%%DATADIR%%/php/export.js | ||
%%DATADIR%%/php/export_batch.php | ||
%%DATADIR%%/php/fst_view.php | ||
%%DATADIR%%/php/hapstat_view.php | ||
%%DATADIR%%/php/header.php | ||
%%DATADIR%%/php/images/caret-d.png | ||
%%DATADIR%%/php/images/caret-u.png | ||
%%DATADIR%%/php/images/excel_icon.png | ||
%%DATADIR%%/php/images/l-arrow-disabled.png | ||
%%DATADIR%%/php/images/l-arrow.png | ||
%%DATADIR%%/php/images/r-arrow-disabled.png | ||
%%DATADIR%%/php/images/r-arrow.png | ||
%%DATADIR%%/php/images/stacks_bg.png | ||
%%DATADIR%%/php/images/stacks_logo_rev_small.png | ||
%%DATADIR%%/php/index.php | ||
%%DATADIR%%/php/last_modified.php | ||
%%DATADIR%%/php/phist_view.php | ||
%%DATADIR%%/php/pop_view.php | ||
%%DATADIR%%/php/population_view.js | ||
%%DATADIR%%/php/samples.php | ||
%%DATADIR%%/php/sequence_blast.php | ||
%%DATADIR%%/php/stack_view.php | ||
%%DATADIR%%/php/stacks.css | ||
%%DATADIR%%/php/stacks.js | ||
%%DATADIR%%/php/stacks_functions.php | ||
%%DATADIR%%/php/sumstat_view.php | ||
%%DATADIR%%/php/tag.php | ||
%%DATADIR%%/php/tags.php | ||
%%DATADIR%%/php/version.php | ||
%%DATADIR%%/php/view_sequence.php | ||
%%DATADIR%%/sql/catalog_index.sql | ||
%%DATADIR%%/sql/chr_index.sql | ||
%%DATADIR%%/sql/mysql.cnf.dist | ||
%%DATADIR%%/sql/stacks.sql | ||
%%DATADIR%%/sql/tag_index.sql | ||
@dir %%DATADIR%%/php/export |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -10,6 +10,9 @@ PKGNAMEPREFIX= p5- | |
MAINTAINER= [email protected] | ||
COMMENT= Perl5 modules to handle various Unicode issues | ||
|
||
LICENSE= ART10 GPLv1+ | ||
LICENSE_COMB= dual | ||
|
||
USES= perl5 | ||
USE_PERL5= configure | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1519944014 | ||
SHA256 (memcached-1.5.6.tar.gz) = 9675ee859d7d81f7a950f190a6812720b26f08228d356044ec517d4d5af25f03 | ||
SIZE (memcached-1.5.6.tar.gz) = 452038 | ||
TIMESTAMP = 1522358405 | ||
SHA256 (memcached-1.5.7.tar.gz) = 5bb706a8fc7ae7461a6788eaddd85e4a4e84e952d3a80c21926342c2838f4e46 | ||
SIZE (memcached-1.5.7.tar.gz) = 458062 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1466507621 | ||
SHA256 (DBD-CSV-0.49.tgz) = 86fcea010571a6f774344c920c23619c899f8aee30d2961fe2716306a95e9a80 | ||
SIZE (DBD-CSV-0.49.tgz) = 39271 | ||
TIMESTAMP = 1522513695 | ||
SHA256 (DBD-CSV-0.51.tgz) = 603d9756a07e9fc0483d45ef92601319f71dffc7ec490d79680f756dfdc73a08 | ||
SIZE (DBD-CSV-0.51.tgz) = 39260 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,7 +2,7 @@ | |
# $FreeBSD$ | ||
|
||
PORTNAME= pglogical | ||
PORTVERSION= 2.1.1 | ||
PORTVERSION= 2.2.0 | ||
CATEGORIES= databases | ||
|
||
MAINTAINER= [email protected] | ||
|
@@ -16,7 +16,7 @@ WANT_PGSQL= client server | |
USE_GITHUB= yes | ||
GH_ACCOUNT= 2ndQuadrant | ||
GH_PROJECT= pglogical pglogical_dump:dump | ||
GH_TAGNAME= REL2_1_1 9f3b0b1:dump | ||
GH_TAGNAME= REL2_2_0 f66606d:dump | ||
GH_SUBDIR= pglogical_dump:dump | ||
|
||
MAKE_ARGS= USE_PGXS=1 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,5 @@ | ||
TIMESTAMP = 1515711146 | ||
SHA256 (2ndQuadrant-pglogical-2.1.1-REL2_1_1_GH0.tar.gz) = 5f9f9059d36bebb57d567c108a33aa8273d3525dd9e755ac44c71f249c33785f | ||
SIZE (2ndQuadrant-pglogical-2.1.1-REL2_1_1_GH0.tar.gz) = 244676 | ||
SHA256 (2ndQuadrant-pglogical_dump-9f3b0b1_GH0.tar.gz) = 915250bf63f3b309228c5a2bbd9bfc7df3e1e5e2b54e89f3c52e722797b7b8aa | ||
SIZE (2ndQuadrant-pglogical_dump-9f3b0b1_GH0.tar.gz) = 206704 | ||
TIMESTAMP = 1521278458 | ||
SHA256 (2ndQuadrant-pglogical-2.2.0-REL2_2_0_GH0.tar.gz) = 47c5091f18194899abea70b902bbbd38f7ac18192cf618b90faa618f013d8d4b | ||
SIZE (2ndQuadrant-pglogical-2.2.0-REL2_2_0_GH0.tar.gz) = 251121 | ||
SHA256 (2ndQuadrant-pglogical_dump-f66606d_GH0.tar.gz) = 09666d5927fe071c9a2ef64eb7028f793cfea10510a3d17e8ef4335349291e63 | ||
SIZE (2ndQuadrant-pglogical_dump-f66606d_GH0.tar.gz) = 206722 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,11 @@ | ||
--- pglogical_fe.c.orig 2018-03-17 09:48:56 UTC | ||
+++ pglogical_fe.c | ||
@@ -10,6 +10,8 @@ | ||
* | ||
*------------------------------------------------------------------------- | ||
*/ | ||
+#include <sys/wait.h> | ||
+ | ||
#include "postgres_fe.h" | ||
|
||
#include "pglogical_fe.h" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -2,7 +2,7 @@ | |
|
||
PORTNAME= ga | ||
DISTVERSIONPREFIX= v | ||
DISTVERSION= 5.6.4 | ||
DISTVERSION= 5.6.5 | ||
CATEGORIES= devel | ||
|
||
MAINTAINER= [email protected] | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1522000478 | ||
SHA256 (GlobalArrays-ga-v5.6.4_GH0.tar.gz) = f1e2e92e0ab76f58d7f8afde633b7614dc120f35a99b6880e7320b1dd7e8e652 | ||
SIZE (GlobalArrays-ga-v5.6.4_GH0.tar.gz) = 4958446 | ||
TIMESTAMP = 1522394877 | ||
SHA256 (GlobalArrays-ga-v5.6.5_GH0.tar.gz) = abeb6e105e1a39e9ceb092c5d301f0cb6fa9bf5ce480bd5dd54ac87d86a20346 | ||
SIZE (GlobalArrays-ga-v5.6.5_GH0.tar.gz) = 4963339 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -46,4 +46,4 @@ lib/libcomex.so.0 | |
lib/libcomex.so.0.0.0 | ||
lib/libga.so | ||
lib/libga.so.1 | ||
lib/libga.so.1.0.4 | ||
lib/libga.so.1.0.5 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1521523660 | ||
SHA256 (jenkins/2.112/jenkins.war) = 085f597edeb0d49d54d7653f3742ba31ed72b8a1a2b053d2eb23fd806c6a5393 | ||
SIZE (jenkins/2.112/jenkins.war) = 74601396 | ||
TIMESTAMP = 1522421016 | ||
SHA256 (jenkins/2.113/jenkins.war) = 3c443d9aeb178058287d12bb5b81b330e78e83ea949069b82c780257ce301390 | ||
SIZE (jenkins/2.113/jenkins.war) = 74584533 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.