forked from opnsense/ports
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Taken from: HardenedBSD
- Loading branch information
Showing
355 changed files
with
2,387 additions
and
1,203 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
Obtained from: https://gitlab.xiph.org/xiph/icecast-libshout/commit/0ac7ed9e84c3871d4427acc1ce59dca5e4af21ef | ||
|
||
--- include/shout/shout.h.in.orig 2019-05-22 09:05:32 UTC | ||
+++ include/shout/shout.h.in | ||
@@ -85,6 +85,11 @@ extern "C" { | ||
#define SHOUT_TLS_RFC2818 ( 11) /* Use TLS for transport layer like HTTPS [RFC2818] does. */ | ||
#define SHOUT_TLS_RFC2817 ( 12) /* Use TLS via HTTP Upgrade:-header [RFC2817]. */ | ||
|
||
+/* Possible values for blocking */ | ||
+#define SHOUT_BLOCKING_DEFAULT (255) /* Use the default blocking setting. */ | ||
+#define SHOUT_BLOCKING_FULL ( 0) /* Block in all I/O related functions */ | ||
+#define SHOUT_BLOCKING_NONE ( 1) /* Do not block in I/O related functions */ | ||
+ | ||
#define SHOUT_AI_BITRATE "bitrate" | ||
#define SHOUT_AI_SAMPLERATE "samplerate" | ||
#define SHOUT_AI_CHANNELS "channels" | ||
@@ -244,7 +249,8 @@ int shout_set_protocol(shout_t *self, un | ||
unsigned int shout_get_protocol(shout_t *self); | ||
|
||
/* Instructs libshout to use nonblocking I/O. Must be called before | ||
- * shout_open (no switching back and forth midstream at the moment). */ | ||
+ * shout_open (no switching back and forth midstream at the moment). | ||
+ * nonblocking is one of SHOUT_BLOCKING_xxx. */ | ||
int shout_set_nonblocking(shout_t* self, unsigned int nonblocking); | ||
unsigned int shout_get_nonblocking(shout_t *self); | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,59 @@ | ||
Obtained from: https://gitlab.xiph.org/xiph/icecast-libshout/commit/0ac7ed9e84c3871d4427acc1ce59dca5e4af21ef | ||
https://gitlab.xiph.org/xiph/icecast-libshout/commit/b807c1e2550718bdc73d65ac1b05255d18f45c54 | ||
|
||
--- src/connection.c.orig 2019-05-20 19:32:59 UTC | ||
+++ src/connection.c | ||
@@ -118,7 +118,7 @@ static struct timeval shout_connection_i | ||
.tv_usec = (timeout % 1000) * 1000 | ||
}; | ||
return tv; | ||
- } else if (con->nonblocking) { | ||
+ } else if (con->nonblocking == SHOUT_BLOCKING_NONE) { | ||
return tv_nonblocking; | ||
} else { | ||
return tv_blocking; | ||
@@ -167,7 +167,7 @@ static shout_connection_return_state_t s | ||
} | ||
break; | ||
case SHOUT_SOCKSTATE_CONNECTING: | ||
- if (con->nonblocking) { | ||
+ if (con->nonblocking == SHOUT_BLOCKING_NONE) { | ||
ret = shout_connection_iter__wait_for_io(con, shout, 1, 1, 0); | ||
if (ret != SHOUT_RS_DONE) { | ||
return ret; | ||
@@ -460,7 +460,7 @@ int shout_connection_ite | ||
break; \ | ||
case SHOUT_RS_TIMEOUT: \ | ||
case SHOUT_RS_NOTNOW: \ | ||
- if (con->nonblocking) \ | ||
+ if (con->nonblocking == SHOUT_BLOCKING_NONE) \ | ||
return SHOUTERR_RETRY; \ | ||
retry = 1; \ | ||
break; \ | ||
@@ -518,7 +518,7 @@ int shout_connection_sel | ||
} | ||
int shout_connection_set_nonblocking(shout_connection_t *con, unsigned int nonblocking) | ||
{ | ||
- if (!con) | ||
+ if (!con || (nonblocking != SHOUT_BLOCKING_DEFAULT && nonblocking != SHOUT_BLOCKING_FULL && nonblocking != SHOUT_BLOCKING_NONE)) | ||
return SHOUTERR_INSANE; | ||
|
||
if (con->socket != SOCK_ERROR) | ||
@@ -563,13 +563,14 @@ int shout_connection_con | ||
if (con->socket != SOCK_ERROR || con->current_socket_state != SHOUT_SOCKSTATE_UNCONNECTED) | ||
return SHOUTERR_BUSY; | ||
|
||
- shout_connection_set_nonblocking(con, shout_get_nonblocking(shout)); | ||
+ if (con->nonblocking == SHOUT_BLOCKING_DEFAULT) | ||
+ shout_connection_set_nonblocking(con, shout_get_nonblocking(shout)); | ||
|
||
port = shout->port; | ||
- if (shout_get_protocol(shout) == SHOUT_PROTOCOL_ICY) | ||
+ if (con->impl == shout_icy_impl) | ||
port++; | ||
|
||
- if (con->nonblocking) { | ||
+ if (con->nonblocking == SHOUT_BLOCKING_NONE) { | ||
con->socket = sock_connect_non_blocking(shout->host, port); | ||
} else { | ||
con->socket = sock_connect(shout->host, port); |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,25 @@ | ||
Obtained from: https://gitlab.xiph.org/xiph/icecast-libshout/commit/0ac7ed9e84c3871d4427acc1ce59dca5e4af21ef | ||
|
||
--- src/shout.c.orig 2019-05-22 09:05:32 UTC | ||
+++ src/shout.c | ||
@@ -417,7 +417,7 @@ int shout_set_metadata(shout_t *self, sh | ||
#ifdef HAVE_OPENSSL | ||
shout_connection_select_tlsmode(connection, self->tls_mode); | ||
#endif | ||
- shout_connection_set_nonblocking(connection, 0); | ||
+ shout_connection_set_nonblocking(connection, SHOUT_BLOCKING_FULL); | ||
|
||
connection->target_message_state = SHOUT_MSGSTATE_PARSED_FINAL; | ||
|
||
@@ -989,7 +989,10 @@ unsigned int shout_get_protocol(shout_t | ||
|
||
int shout_set_nonblocking(shout_t *self, unsigned int nonblocking) | ||
{ | ||
- if (!self || (nonblocking != 0 && nonblocking != 1)) | ||
+ if (nonblocking == SHOUT_BLOCKING_DEFAULT) | ||
+ nonblocking = SHOUT_BLOCKING_FULL; | ||
+ | ||
+ if (!self || (nonblocking != SHOUT_BLOCKING_FULL && nonblocking != SHOUT_BLOCKING_NONE)) | ||
return SHOUTERR_INSANE; | ||
|
||
if (self->connection) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -4,15 +4,14 @@ | |
PORTNAME= openal-soft | ||
PORTVERSION= 1.16.0 | ||
DISTVERSIONSUFFIX= -3.el7 | ||
PORTREVISION= 2 | ||
PORTREVISION= 3 | ||
CATEGORIES= audio linux | ||
MASTER_SITES= EPEL7/o | ||
MASTER_SITES= EPEL7/o \ | ||
https://harbottle.gitlab.io/wine32/7/i386/:i386 | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= 3D positional spatialized sound library (Linux CentOS ${LINUX_DIST_VER}) | ||
|
||
ONLY_FOR_ARCHS= amd64 | ||
|
||
USES= linux:c7 | ||
USE_LDCONFIG= yes | ||
USE_LINUX= alsalib | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,8 @@ | ||
etc/openal/alsoft.conf | ||
usr/bin/openal-info | ||
usr/lib/libopenal.so.1 | ||
usr/lib/libopenal.so.1.16.0 | ||
%%PORTDOCS%%%%DOCSDIR%%/COPYING | ||
usr/share/openal/alsoftrc.sample | ||
usr/share/openal/hrtf/default-44100.mhr | ||
usr/share/openal/hrtf/default-48000.mhr |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -4,7 +4,7 @@ | |
PORTNAME= mixxx | ||
DISTVERSIONPREFIX= release- | ||
DISTVERSION= 2.2.2 | ||
PORTREVISION= 1 | ||
PORTREVISION= 2 | ||
CATEGORIES= audio | ||
|
||
MAINTAINER= [email protected] | ||
|
@@ -47,22 +47,25 @@ USE_QT= buildtools concurrent core dbus gui network opengl script scripttools \ | |
CONFLICTS= mixxx20* mixxx21* | ||
|
||
MAKE_ARGS= qtdir="${PREFIX}" install_root="${PREFIX}" \ | ||
build=release optimize=off ${GUI} battery=0 vamp=1 modplug=1 | ||
build=release optimize=off ${GUI} battery=0 vamp=1 modplug=1 mad=1 | ||
LATE_INSTALL_ARGS= --install-sandbox=${STAGEDIR} | ||
|
||
GUI= qt5=1 | ||
|
||
PORTDATA= * | ||
PORTDOCS= * | ||
|
||
OPTIONS_DEFINE= DOCS FAAD GPERFTOOLS HID LAME OPUS SHOUTCAST WAVPACK | ||
OPTIONS_DEFAULT= FAAD HID SHOUTCAST OPUS WAVPACK | ||
OPTIONS_DEFINE= DOCS FAAD FFMPEG GPERFTOOLS HID LAME OPUS SHOUTCAST WAVPACK | ||
OPTIONS_DEFAULT= FAAD FFMPEG HID SHOUTCAST OPUS WAVPACK | ||
OPTIONS_SUB= yes | ||
|
||
FAAD_LIB_DEPENDS= libfaad.so:audio/faad \ | ||
libmp4v2.so:multimedia/mp4v2 | ||
FAAD_MAKE_ARGS= faad=1 | ||
FAAD_MAKE_ARGS_OFF= faad=0 | ||
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg | ||
FFMPEG_MAKE_ARGS= ffmpeg=1 | ||
FFMPEG_MAKE_ARGS_OFF= ffmpeg=0 | ||
GPERFTOOLS_LIB_DEPENDS= libtcmalloc.so:devel/google-perftools | ||
GPERFTOOLS_MAKE_ARGS= perftools=1 | ||
GPERFTOOLS_MAKE_ARGS_OFF= perftools=0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1564587441 | ||
SHA256 (KDE/plasma/5.16.4/plasma-pa-5.16.4.tar.xz) = 9b166e11f7115576181c17f0ced51b9a7ec689334d4b15ebb55d4e6e7ff6cbd4 | ||
SIZE (KDE/plasma/5.16.4/plasma-pa-5.16.4.tar.xz) = 100748 | ||
TIMESTAMP = 1567529834 | ||
SHA256 (KDE/plasma/5.16.5/plasma-pa-5.16.5.tar.xz) = e029563d50cc6266a4a3e22574c33fef4670e1aaab18630eb30769e2167acc96 | ||
SIZE (KDE/plasma/5.16.5/plasma-pa-5.16.5.tar.xz) = 101100 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,20 +1,27 @@ | ||
# $FreeBSD$ | ||
|
||
PORTNAME= text-unidecode | ||
DISTVERSION= 1.2 | ||
DISTVERSION= 1.3 | ||
CATEGORIES= converters python | ||
MASTER_SITES= CHEESESHOP | ||
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX} | ||
|
||
MAINTAINER= [email protected] | ||
COMMENT= Most basic port of Perl's Text::Unidecode module | ||
|
||
LICENSE= ART10 | ||
LICENSE_FILE= ${WRKSRC}/LICENSE | ||
LICENSE= ART10 GPLv1+ | ||
LICENSE_COMB= dual | ||
LICENSE_FILE_ART10= ${WRKSRC}/LICENSE | ||
LICENSE_FILE_GPLv1= ${WRKSRC}/LICENSE | ||
|
||
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>0:devel/py-pytest@${PY_FLAVOR} | ||
|
||
USES= python | ||
USE_PYTHON= distutils autoplist | ||
|
||
NO_ARCH= yes | ||
|
||
do-test: | ||
@cd ${WRKSRC} && ${PYTHON_CMD} -m pytest -rs -v | ||
|
||
.include <bsd.port.mk> |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1530183792 | ||
SHA256 (text-unidecode-1.2.tar.gz) = 5a1375bb2ba7968740508ae38d92e1f889a0832913cb1c447d5e2046061a396d | ||
SIZE (text-unidecode-1.2.tar.gz) = 76872 | ||
TIMESTAMP = 1567451164 | ||
SHA256 (text-unidecode-1.3.tar.gz) = bad6603bb14d279193107714b288be206cac565dfa49aa5b105294dd5c4aab93 | ||
SIZE (text-unidecode-1.3.tar.gz) = 76885 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,3 +1,3 @@ | ||
TIMESTAMP = 1564157951 | ||
SHA256 (rubygem/json-ld-preloaded-3.0.3.gem) = d3af9499870fbbeb4e17c2f69531bed12cfaa04ea1caf646bdb6795c1cadb853 | ||
SIZE (rubygem/json-ld-preloaded-3.0.3.gem) = 107008 | ||
TIMESTAMP = 1567510044 | ||
SHA256 (rubygem/json-ld-preloaded-3.0.4.gem) = 316980ac5faf4c863946012b3d40ed96680a5da8c8204c72ed7169e4bdfb6442 | ||
SIZE (rubygem/json-ld-preloaded-3.0.4.gem) = 116224 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
# $FreeBSD$ | ||
|
||
PORTREVISION= 3 | ||
PORTREVISION= 4 | ||
CATEGORIES= databases lang | ||
PKGNAMESUFFIX= -fpindexer | ||
|
||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,6 +1,6 @@ | ||
# $FreeBSD$ | ||
|
||
PORTREVISION= 2 | ||
PORTREVISION= 3 | ||
CATEGORIES= databases lang | ||
PKGNAMESUFFIX= -gdbm | ||
|
||
|
Oops, something went wrong.